Re: [Mesa-dev] [PATCH 1/2] st/nine: Fix issue with surface and volume dtors and csmt

2017-03-23 Thread Emil Velikov
On 15 March 2017 at 21:56, Axel Davy wrote: > Surfaces and Volumes can be freed in the worker thread. > > This fixes these dtor. > Especially if they were freed by nine_context_box_upload, > the counter was decremented after the destructions, which > lead to deadlock. > Humble

Re: [Mesa-dev] [RFC 00/12] anv: A first pass at VK_KHX_multiview

2017-03-23 Thread Iago Toral
The proposed implementation makes sense to me, I looked through patches 1-8 and they all look good as well, so those are: Reviewed-by: Iago Toral Quiroga I still have to look into the actual meat of the implementation (patches 9-12), I'll do that tomorrow if nobody else beats

Re: [Mesa-dev] [PATCH] mesa/marshal: add custom BufferData/BufferSubData marshalling

2017-03-23 Thread Nicolai Hähnle
On 23.03.2017 14:07, Timothy Arceri wrote: On 23/03/17 23:51, Nicolai Hähnle wrote: On 23.03.2017 13:41, Timothy Arceri wrote: On 23/03/17 23:19, Nicolai Hähnle wrote: On 23.03.2017 13:06, Timothy Arceri wrote: On 23/03/17 22:52, Nicolai Hähnle wrote: On 23.03.2017 07:32, Timothy

Re: [Mesa-dev] [PATCH 5/5] [v2] gbm: Export a per plane getter for offset

2017-03-23 Thread Daniel Stone
Hi, On 8 March 2017 at 05:31, Ben Widawsky wrote: > Unlike stride, there was no previous offset getter, so it can be right > on the first try. > > v2: Return EINVAL when plane is greater than total planes to make it > match the similar APIs. > Avoid leak after fromPlanar

Re: [Mesa-dev] [PATCH] mesa/marshal: add custom BufferData/BufferSubData marshalling

2017-03-23 Thread Timothy Arceri
On 23/03/17 23:51, Nicolai Hähnle wrote: On 23.03.2017 13:41, Timothy Arceri wrote: On 23/03/17 23:19, Nicolai Hähnle wrote: On 23.03.2017 13:06, Timothy Arceri wrote: On 23/03/17 22:52, Nicolai Hähnle wrote: On 23.03.2017 07:32, Timothy Arceri wrote: +void GLAPIENTRY

[Mesa-dev] [PATCH 2/3] anv/pipeline: add a sample_shading_enable field to anv_pipeline

2017-03-23 Thread Iago Toral Quiroga
We need to know if sample shading has been requested during shader compilation since that affects the way fragment coordinates are computed. Notice that the semantics of fragment coordinates only depend on whether sample shading has been requested, not on whether more than one sample will

[Mesa-dev] [PATCH 1/3] nir/lower_wpos_center: support adding sample position to fragment coordinate

2017-03-23 Thread Iago Toral Quiroga
According to section 14.6 of the Vulkan specification: "When sample shading is enabled, the x and y components of FragCoord reflect the location of the sample corresponding to the shader invocation." So add a boolean parameter to the lowering pass to select this behavior when we need

[Mesa-dev] [PATCH 3/3] anv/pipeline: make FragCoord include sample positions when sample shading

2017-03-23 Thread Iago Toral Quiroga
Because this setting affects the code we generate for the shader, we also need to include it in the WM prog key. Notice we don't need to alter the OpenGL code because it doesn't ever use this behavior, so they key's value is always false (the default). Fixes:

Re: [Mesa-dev] [PATCH] mesa/marshal: add custom BufferData/BufferSubData marshalling

2017-03-23 Thread Nicolai Hähnle
On 23.03.2017 13:41, Timothy Arceri wrote: On 23/03/17 23:19, Nicolai Hähnle wrote: On 23.03.2017 13:06, Timothy Arceri wrote: On 23/03/17 22:52, Nicolai Hähnle wrote: On 23.03.2017 07:32, Timothy Arceri wrote: +void GLAPIENTRY +_mesa_marshal_BufferData(GLenum target, GLsizeiptr size,

Re: [Mesa-dev] [PATCH] mesa/marshal: add custom BufferData/BufferSubData marshalling

2017-03-23 Thread Timothy Arceri
On 23/03/17 23:19, Nicolai Hähnle wrote: On 23.03.2017 13:06, Timothy Arceri wrote: On 23/03/17 22:52, Nicolai Hähnle wrote: On 23.03.2017 07:32, Timothy Arceri wrote: GL_AMD_pinned_memory requires memory to be aligned correctly, so we skip marshalling in this case. Also copying the data

Re: [Mesa-dev] [RFC libdrm 0/2] Replace the build system with meson

2017-03-23 Thread Jonathan Gray
On Tue, Mar 21, 2017 at 04:00:37PM +1100, Jonathan Gray wrote: > On Tue, Mar 21, 2017 at 08:28:22AM +1100, Timothy Arceri wrote: > > > > > > On 21/03/17 06:39, Emil Velikov wrote: > > > On 20 March 2017 at 18:30, Matt Turner wrote: > > > > On Mon, Mar 20, 2017 at 6:55 AM,

Re: [Mesa-dev] [PATCH] mesa/marshal: add custom BufferData/BufferSubData marshalling

2017-03-23 Thread Nicolai Hähnle
On 23.03.2017 13:06, Timothy Arceri wrote: On 23/03/17 22:52, Nicolai Hähnle wrote: On 23.03.2017 07:32, Timothy Arceri wrote: GL_AMD_pinned_memory requires memory to be aligned correctly, so we skip marshalling in this case. Also copying the data defeats the purpose of

Re: [Mesa-dev] [PATCH v4 2/3] util/disk_cache: hash pointer size and gpu name into cache keys

2017-03-23 Thread Nicolai Hähnle
On 22.03.2017 09:56, Timothy Arceri wrote: From: Grazvydas Ignotas This allows to get rid of the arch and gpu name directories. v2: (Timothy Arceri) don't use an opaque data type to store pointer size and gpu name. v3: (Timothy Arceri) use blob to store driver keys

Re: [Mesa-dev] [PATCH] mesa/marshal: add custom BufferData/BufferSubData marshalling

2017-03-23 Thread Timothy Arceri
On 23/03/17 22:52, Nicolai Hähnle wrote: On 23.03.2017 07:32, Timothy Arceri wrote: GL_AMD_pinned_memory requires memory to be aligned correctly, so we skip marshalling in this case. Also copying the data defeats the purpose of EXTERNAL_VIRTUAL_MEMORY_BUFFER_AMD. Fixes GL_AMD_pinned_memory

Re: [Mesa-dev] [PATCH] intel: move gen_decoder.* to DECODER_FILES

2017-03-23 Thread Emil Velikov
On 23 March 2017 at 07:15, Tapani Pälli wrote: > patch adds DECODER_FILES for libintel_common, this is so that platforms > such as Android not currently using this functionality can opt out. > > Fixes: 7d84bb3 ("intel: Move tools/decoder.[ch] to common/gen_decoder.[ch].")

Re: [Mesa-dev] [PATCH] android: fix vulkan build issues with anv_entrypoints

2017-03-23 Thread Emil Velikov
On 23 March 2017 at 11:50, Tapani Pälli wrote: > @@ -179,11 +180,11 @@ LOCAL_WHOLE_STATIC_LIBRARIES := \ > > LOCAL_GENERATED_SOURCES += $(intermediates)/vulkan/anv_entrypoints.c > > -$(intermediates)/vulknan/anv_entrypoints.c: Please add a note vaguely like below: #

Re: [Mesa-dev] [PATCH] mesa/marshal: add custom BufferData/BufferSubData marshalling

2017-03-23 Thread Nicolai Hähnle
On 23.03.2017 07:32, Timothy Arceri wrote: GL_AMD_pinned_memory requires memory to be aligned correctly, so we skip marshalling in this case. Also copying the data defeats the purpose of EXTERNAL_VIRTUAL_MEMORY_BUFFER_AMD. Fixes GL_AMD_pinned_memory piglit tests when glthread is enabled. ---

[Mesa-dev] [PATCH] android: fix vulkan build issues with anv_entrypoints

2017-03-23 Thread Tapani Pälli
Patch fixes entrypoint generation for libmesa_anv_entrypoints that still used old style of calling generator script. Also small fixes to libmesa_vulkan_common where there was a typo in target name (vulknan) and files were generated to wrong folder. Fixes: 8211e3e6 ("anv: Generate anv_entrypoints

Re: [Mesa-dev] [PATCH v2] util/rand_xor: seed with getentropy when available

2017-03-23 Thread Nicolai Hähnle
On 23.03.2017 05:53, Jonathan Gray wrote: On Thu, Mar 23, 2017 at 03:24:16PM +1100, Jonathan Gray wrote: Instead of using using /dev/urandom on Linux and time(NULL) elsewhere for a seed first use getentropy() for systems that have a kernel interface to get a seed such as OpenBSD. This

Re: [Mesa-dev] [PATCH v2] util/rand_xor: seed with getentropy when available

2017-03-23 Thread Nicolai Hähnle
On 23.03.2017 07:19, Jonathan Gray wrote: On Thu, Mar 23, 2017 at 03:24:16PM +1100, Jonathan Gray wrote: Instead of using using /dev/urandom on Linux and time(NULL) elsewhere for a seed first use getentropy() for systems that have a kernel interface to get a seed such as OpenBSD. This

Re: [Mesa-dev] [RFC 04/12] anv/nir: Delete the apply_dynamic_offsets prototype

2017-03-23 Thread tournier.elie
Reviewed-by: Elie Tournier On 23 March 2017 at 04:01, Jason Ekstrand wrote: > That pass hasn't existed since dd4db84640bbb694f180dd50850c3388f67228be > but the prototype stuck around for no reason. > --- > src/intel/vulkan/anv_nir.h | 3 --- >

Re: [Mesa-dev] [PATCH] radeonsi: disable sinking common instructions down to the end block

2017-03-23 Thread Samuel Pitoiset
On 03/23/2017 12:38 PM, Nicolai Hähnle wrote: On 22.03.2017 21:00, Andy Furniss wrote: Samuel Pitoiset wrote: This patch has a minor issue for me using radeonsi on tonga. ffmpeg vaapi hwdecode by cli or via mpv now produces the message mesa: for the -simplifycfg-sink-common option: may

Re: [Mesa-dev] [RFC libdrm 0/2] Replace the build system with meson

2017-03-23 Thread Emil Velikov
On 22 March 2017 at 20:10, Dylan Baker wrote: > On Wed, Mar 22, 2017 at 12:40 PM, Alex Deucher wrote: >> I guess I'm a little late to the party here, but I haven't had time to >> really let all of this sink in and actually look at meson. It doesn't >>

Re: [Mesa-dev] [PATCH] radeonsi: disable sinking common instructions down to the end block

2017-03-23 Thread Nicolai Hähnle
On 22.03.2017 21:00, Andy Furniss wrote: Samuel Pitoiset wrote: This patch has a minor issue for me using radeonsi on tonga. ffmpeg vaapi hwdecode by cli or via mpv now produces the message mesa: for the -simplifycfg-sink-common option: may only occur zero or one times! I guess that setup

Re: [Mesa-dev] [PATCH mesa] docs/submittingpatches: add mention about legal disclaimers

2017-03-23 Thread Nicolai Hähnle
On 22.03.2017 16:56, Eric Engestrom wrote: Signed-off-by: Eric Engestrom --- docs/submittingpatches.html | 10 ++ 1 file changed, 10 insertions(+) diff --git a/docs/submittingpatches.html b/docs/submittingpatches.html index 7910ae98f7..5310b1d8c1 100644 ---

[Mesa-dev] [PATCH] anv: enable sampling from fast-cleared images on SKL

2017-03-23 Thread Samuel Iglesias Gonsálvez
A resolve is not needed on Skylake in this case. We were forcing a resolve because we set the input_aux_usage to ISL_AUX_USAGE_NONE. Signed-off-by: Samuel Iglesias Gonsálvez --- This doesn't fix the problem with BDW but I found it while reviewing the code.

[Mesa-dev] [PATCH 3/3] anv: return VK_ERROR_DEVICE_LOST immeditely when device is known to be lost

2017-03-23 Thread Iago Toral Quiroga
If we know the device has been lost we should return this error code for any command that can report it before we attempt to do anything with the device. --- src/intel/vulkan/anv_device.c | 22 +- src/intel/vulkan/genX_query.c | 3 +++ 2 files changed, 24 insertions(+), 1

[Mesa-dev] [PATCH 2/3] anv/device: keep track of 'device lost' state

2017-03-23 Thread Iago Toral Quiroga
The Vulkan specs say: "A logical device may become lost because of hardware errors, execution timeouts, power management events and/or platform-specific events. This may cause pending and future command execution to fail and cause hardware resources to be corrupted. When this

[Mesa-dev] [PATCH 1/3] anv/device: return VK_ERROR_DEVICE_LOST for errors during queue submissions

2017-03-23 Thread Iago Toral Quiroga
So that we don't have to do things like rolling back address relocations in case that we ran into OOM after computing them, etc Also, make sure that if the queue submission comes with a fence, we set it up correctly so it behaves according to the spec after returning VK_ERROR_DEVICE_LOST. ---

Re: [Mesa-dev] [PATCH] st/dri: wait for thread to finish before unbinding context

2017-03-23 Thread Michel Dänzer
On 20/03/17 06:40 AM, Timothy Arceri wrote: > On 17/03/17 18:38, Michel Dänzer wrote: >> On 17/03/17 09:02 AM, Timothy Arceri wrote: >>> Fixes a bunch of piglit crashes that hit an assert() when trying >>> to delete the framebuffer. The assert() was triggered because >>> WinSysDrawBuffer was set

Re: [Mesa-dev] [RFC libdrm 0/2] Replace the build system with meson

2017-03-23 Thread Jani Nikula
On Wed, 22 Mar 2017, Dylan Baker wrote: > Quoting Jani Nikula (2017-03-22 01:24:19) >> Right. That helps avoid many of the issues e.g. Sphinx has with the >> configuration files being pure python. > > Yes, sphinx's configuration files are awful for just that reason. Of

Re: [Mesa-dev] [PATCH v4 07/28] i965/fs: generalize the legalization d2x pass

2017-03-23 Thread Samuel Iglesias Gonsálvez
On Thu, 2017-03-23 at 08:59 +0100, Samuel Iglesias Gonsálvez wrote: > On Wed, 2017-03-22 at 15:47 -0700, Francisco Jerez wrote: > > Samuel Iglesias Gonsálvez writes: > > > > > Generalize it to lower any unsupported narrower conversion. > > > > > > v2 (Curro): > > > - Add

Re: [Mesa-dev] [PATCH v4 19/28] i965/vec4: fix SIMD-width lowering for VEC4_OPCODE_FROM_DOUBLE

2017-03-23 Thread Samuel Iglesias Gonsálvez
On Wed, 2017-03-22 at 15:55 -0700, Francisco Jerez wrote: > Samuel Iglesias Gonsálvez writes: > > > Now the VEC4_OPCODE_FROM_DOUBLE's destination data is written with > > stride 2. We need to take into account this when doing the split > > so we don't overwrite data. > > >

Re: [Mesa-dev] [PATCH v4 08/28] i965/fs: rename lower_d2x to lower_narrow_conversions

2017-03-23 Thread Samuel Iglesias Gonsálvez
On Wed, 2017-03-22 at 15:49 -0700, Francisco Jerez wrote: > I'd rename this to lower_conversions instead since after your > previous > patch it's going to take care of handling unsupported conversions > which > aren't necessarily to a narrower type. > OK. Does this patch get your R-b then? Sam

Re: [Mesa-dev] [PATCH v4 07/28] i965/fs: generalize the legalization d2x pass

2017-03-23 Thread Samuel Iglesias Gonsálvez
On Wed, 2017-03-22 at 15:47 -0700, Francisco Jerez wrote: > Samuel Iglesias Gonsálvez writes: > > > Generalize it to lower any unsupported narrower conversion. > > > > v2 (Curro): > > - Add supports_type_conversion() > > - Reuse existing intruction instead of cloning it. >

Re: [Mesa-dev] [PATCH] intel: move gen_decoder.* to DECODER_FILES

2017-03-23 Thread Kenneth Graunke
On Thursday, March 23, 2017 12:15:54 AM PDT Tapani Pälli wrote: > patch adds DECODER_FILES for libintel_common, this is so that platforms > such as Android not currently using this functionality can opt out. > > Fixes: 7d84bb3 ("intel: Move tools/decoder.[ch] to common/gen_decoder.[ch].") >

[Mesa-dev] [PATCH] intel: move gen_decoder.* to DECODER_FILES

2017-03-23 Thread Tapani Pälli
patch adds DECODER_FILES for libintel_common, this is so that platforms such as Android not currently using this functionality can opt out. Fixes: 7d84bb3 ("intel: Move tools/decoder.[ch] to common/gen_decoder.[ch].") Signed-off-by: Tapani Pälli ---

[Mesa-dev] [Bug 100236] Undefined symbols for architecture x86_64: "typeinfo for llvm::RTDyldMemoryManager"

2017-03-23 Thread bugzilla-daemon
https://bugs.freedesktop.org/show_bug.cgi?id=100236 Vinson Lee changed: What|Removed |Added Resolution|--- |FIXED

Re: [Mesa-dev] [PATCH] mesa/marshal: add custom BufferData/BufferSubData marshalling

2017-03-23 Thread Edward O'Callaghan
Acked-by: Edward O'Callaghan On 03/23/2017 05:32 PM, Timothy Arceri wrote: > GL_AMD_pinned_memory requires memory to be aligned correctly, so > we skip marshalling in this case. Also copying the data defeats > the purpose of EXTERNAL_VIRTUAL_MEMORY_BUFFER_AMD. > >

[Mesa-dev] [PATCH] mesa/marshal: add custom BufferData/BufferSubData marshalling

2017-03-23 Thread Timothy Arceri
GL_AMD_pinned_memory requires memory to be aligned correctly, so we skip marshalling in this case. Also copying the data defeats the purpose of EXTERNAL_VIRTUAL_MEMORY_BUFFER_AMD. Fixes GL_AMD_pinned_memory piglit tests when glthread is enabled. --- src/mapi/glapi/gen/gl_API.xml | 4 +-

Re: [Mesa-dev] [PATCH] i965: Don't leak gen_spec from INTEL_DEBUG=bat handling.

2017-03-23 Thread Kenneth Graunke
On Wednesday, March 22, 2017 10:35:50 PM PDT Jason Ekstrand wrote: > Is the whole spec really a flat thing you an free with a single free()? If > not, maybe we should consider pulling in ralloc to help out. You're right, this patch is totally bogus. ralloc sounds appropriate. signature.asc

[Mesa-dev] [PATCH 2/2] i965: Stop calling drm_intel_bufmgr_gem_enable_fenced_relocs().

2017-03-23 Thread Kenneth Graunke
This does nothing on Gen4+, which is the only hardware we support. Signed-off-by: Kenneth Graunke --- src/mesa/drivers/dri/i965/intel_screen.c | 2 -- 1 file changed, 2 deletions(-) diff --git a/src/mesa/drivers/dri/i965/intel_screen.c

[Mesa-dev] [PATCH 1/2] i965: Stop using legacy dri_bufmgr_* and intel_* names.

2017-03-23 Thread Kenneth Graunke
Eric renamed these from dri_bufmgr_* and intel_bufmgr_* to drm_intel_* in libdrm commit 4b9826408f65976a1a13387beda748b65e03ec52, circa 2008, but we've been using the legacy names this whole time. Signed-off-by: Kenneth Graunke --- src/mesa/drivers/dri/i965/brw_compute.c

Re: [Mesa-dev] [PATCH v2] util/rand_xor: seed with getentropy when available

2017-03-23 Thread Jonathan Gray
On Thu, Mar 23, 2017 at 03:24:16PM +1100, Jonathan Gray wrote: > Instead of using using /dev/urandom on Linux and time(NULL) elsewhere > for a seed first use getentropy() for systems that have a kernel > interface to get a seed such as OpenBSD. This interface is also > present in other systems

<    1   2