Re: [Mesa-dev] [PATCH] radeonsi/nir: add nir_intrinsic_load_sample_mask_in to ir scan

2018-01-22 Thread Nicolai Hähnle
On 19.01.2018 12:03, Timothy Arceri wrote: Fixes a bunch of ARB_sample_shading piglit tests. Reviewed-by: Nicolai Hähnle --- src/gallium/drivers/radeonsi/si_shader_nir.c | 3 +++ 1 file changed, 3 insertions(+) diff --git

Re: [Mesa-dev] [PATCH] ac: image size builtin for GLSL_SAMPLER_DIM_3D

2018-01-22 Thread Nicolai Hähnle
On 18.01.2018 08:17, Timothy Arceri wrote: This is what radeonsi does. Fixes remaing piglit subtest in: ./bin/arb_shader_image_size-builtin --quick -auto -fbo Reviewed-by: Nicolai Hähnle --- src/amd/common/ac_nir_to_llvm.c | 3 ++- 1 file changed, 2

Re: [Mesa-dev] [PATCH 2/2] glsl: add image and sampler (un)packing support to glsl to nir

2018-01-22 Thread Nicolai Hähnle
Both patches: Reviewed-by: Nicolai Hähnle On 19.01.2018 05:12, Timothy Arceri wrote: This is needed for ARB_bindless_texture support. --- src/compiler/glsl/glsl_to_nir.cpp | 4 1 file changed, 4 insertions(+) diff --git a/src/compiler/glsl/glsl_to_nir.cpp

Re: [Mesa-dev] [PATCH] radeonsi: don't ignore pitch for imported textures

2018-01-22 Thread Nicolai Hähnle
On 10.01.2018 20:49, Marek Olšák wrote: From: Marek Olšák Please add a bug report or reference to what fails without it. It does make sense though, so Reviewed-by: Nicolai Hähnle Cc: 17.2 17.3 ---

Re: [Mesa-dev] [PATCH 10/10] gallium/u_threaded: don't run out of memory with staging uploads

2018-01-22 Thread Nicolai Hähnle
On 10.01.2018 20:49, Marek Olšák wrote: From: Marek Olšák Cc: 17.2 17.3 --- src/gallium/auxiliary/util/u_threaded_context.c | 13 + src/gallium/auxiliary/util/u_threaded_context.h | 8 2 files changed, 21

Re: [Mesa-dev] [PATCH 3/3] amd/common: only load used channels when sampling buffer views

2018-01-22 Thread Nicolai Hähnle
For the series: Reviewed-by: Nicolai Hähnle On 10.01.2018 20:12, Samuel Pitoiset wrote: This allows to reduce the number of dwords that are loaded with buffer_load_format_xyzw. For example, when the only used channel is 1, the driver will emit buffer_load_format_x

[Mesa-dev] [PATCH v2 4/5] disk cache: add callback functionality

2018-01-22 Thread Tapani Pälli
v2: add disk_cache_has_key, disk_cache_put_key support using blob cache (Nicolai, Jordan) Signed-off-by: Tapani Pälli --- src/util/disk_cache.c | 49 + src/util/disk_cache.h | 19 +++ 2 files changed, 68

[Mesa-dev] [PATCH 5/5] i965: add __DRI2_BLOB support and set cache functions

2018-01-22 Thread Tapani Pälli
Signed-off-by: Tapani Pälli --- src/mesa/drivers/dri/i965/intel_screen.c | 21 + 1 file changed, 21 insertions(+) diff --git a/src/mesa/drivers/dri/i965/intel_screen.c b/src/mesa/drivers/dri/i965/intel_screen.c index a4e34e9f2c..84009382c6 100644 ---

[Mesa-dev] [PATCH 3/5] disk cache: initialize cache path and index only when used

2018-01-22 Thread Tapani Pälli
This patch makes disk_cache initialize path and index lazily so that we can utilize disk_cache without a path using callback functionality introduced by next patch. Signed-off-by: Tapani Pälli --- src/util/disk_cache.c | 114

[Mesa-dev] [PATCH 1/5] dri: add interface for EGL_ANDROID_blob_cache extension

2018-01-22 Thread Tapani Pälli
Signed-off-by: Tapani Pälli --- include/GL/internal/dri_interface.h | 26 +- 1 file changed, 25 insertions(+), 1 deletion(-) diff --git a/include/GL/internal/dri_interface.h b/include/GL/internal/dri_interface.h index 34a5c9fb01..de367d8f77

[Mesa-dev] [PATCH v2 2/5] egl: add support for EGL_ANDROID_blob_cache

2018-01-22 Thread Tapani Pälli
v2: cleanup, move callbacks to _egl_display struct (Emil Velikov) Signed-off-by: Tapani Pälli --- src/egl/drivers/dri2/egl_dri2.c | 39 +++ src/egl/drivers/dri2/egl_dri2.h | 1 + src/egl/main/eglapi.c | 30

[Mesa-dev] [PATCH 0/5] EGL_ANDROID_blob_cache

2018-01-22 Thread Tapani Pälli
Another go at EGL_ANDROID_blob_cache, some patches are re-sent but I thought it would be easier to read when sending all patches at once. Most important change here is that I've done refactoring to disk cache so that it can live without path/index. Path will get generated only when cache is

Re: [Mesa-dev] [PATCH] radeonsi/nir: fix fs output index

2018-01-22 Thread Nicolai Hähnle
On 22.01.2018 04:57, Timothy Arceri wrote: Fixes the following piglit tests: arb_blend_func_extended-fbo-extended-blend arb_blend_func_extended-fbo-extended-blend-explicit arb_blend_func_extended-fbo-extended-blend-explicit_gles3 arb_blend_func_extended-fbo-extended-blend-pattern

Re: [Mesa-dev] [PATCH] ac/nir/radeonsi: add ARB_shader_ballot support

2018-01-22 Thread Nicolai Hähnle
On 22.01.2018 02:54, Timothy Arceri wrote: --- src/amd/common/ac_nir_to_llvm.c | 38 src/gallium/drivers/radeonsi/si_shader_nir.c | 9 +++ 2 files changed, 47 insertions(+) diff --git a/src/amd/common/ac_nir_to_llvm.c

Re: [Mesa-dev] [PATCH] ac/nir: add ARB_shader_group_vote support

2018-01-22 Thread Nicolai Hähnle
Reviewed-by: Nicolai Hähnle On 22.01.2018 00:52, Timothy Arceri wrote: --- src/amd/common/ac_nir_to_llvm.c | 15 +++ 1 file changed, 15 insertions(+) diff --git a/src/amd/common/ac_nir_to_llvm.c b/src/amd/common/ac_nir_to_llvm.c index

Re: [Mesa-dev] [PATCH] ac: add support for gl_HelperInvocation

2018-01-22 Thread Nicolai Hähnle
Reviewed-by: Nicolai Hähnle On 19.01.2018 00:05, Timothy Arceri wrote: --- src/amd/common/ac_nir_to_llvm.c | 14 ++ 1 file changed, 14 insertions(+) diff --git a/src/amd/common/ac_nir_to_llvm.c b/src/amd/common/ac_nir_to_llvm.c index

Re: [Mesa-dev] [PATCH 1/3] ac: add stream handling to visit_end_primitive()

2018-01-22 Thread Nicolai Hähnle
Why hasn't this been noticed before? Does Vulkan not have multiple streams? Anyway, series is: Reviewed-by: Nicolai Hähnle On 18.01.2018 23:26, Timothy Arceri wrote: --- src/amd/common/ac_nir_to_llvm.c | 7 +++ 1 file changed, 3 insertions(+), 4 deletions(-)

Re: [Mesa-dev] [PATCH 2/3] i965: use context priority definitions from gen_defines.h

2018-01-22 Thread Chris Wilson
Quoting Tapani Pälli (2018-01-22 12:29:31) > Signed-off-by: Tapani Pälli 1&2 Reviewed-by: Chris Wilson -Chris ___ mesa-dev mailing list mesa-dev@lists.freedesktop.org

Re: [Mesa-dev] [GSOC] DriConf Replacement

2018-01-22 Thread Nicolai Hähnle
Hi Jean, thanks for the interest :) On 17.01.2018 21:50, Jean Hertel wrote: Hello Michel, Hello Nicolai, I have spent some more time reading the Mesa source code and trying to figure out how the prime configuration works. If i understood correctly the driconf XML format should have an option

[Mesa-dev] [PATCH 1/3] intel: add new common header gen_defines.h

2018-01-22 Thread Tapani Pälli
Signed-off-by: Tapani Pälli --- src/intel/common/gen_defines.h | 52 ++ 1 file changed, 52 insertions(+) create mode 100644 src/intel/common/gen_defines.h diff --git a/src/intel/common/gen_defines.h

[Mesa-dev] [PATCH 2/3] i965: use context priority definitions from gen_defines.h

2018-01-22 Thread Tapani Pälli
Signed-off-by: Tapani Pälli --- src/mesa/drivers/dri/i965/brw_bufmgr.h | 4 src/mesa/drivers/dri/i965/brw_context.c | 8 +--- src/mesa/drivers/dri/i965/intel_screen.c | 8 +--- 3 files changed, 10 insertions(+), 10 deletions(-) diff --git

[Mesa-dev] [PATCH v3 3/3] anv: implement VK_EXT_global_priority extension

2018-01-22 Thread Tapani Pälli
v2: add ANV_CONTEXT_REALTIME_PRIORITY (Chris) use unreachable with unknown priority (Samuel) v3: add stubs in gem_stubs.c (Emil) use priority defines from gen_defines.h Signed-off-by: Tapani Pälli Reviewed-by: Samuel Iglesias Gonsálvez (v2)

Re: [Mesa-dev] [PATCH] ac: fix visit_ssa_undef() for doubles

2018-01-22 Thread Nicolai Hähnle
Reviewed-by: Nicolai Hähnle On 18.01.2018 02:03, Timothy Arceri wrote: Fixes: f4e499ec7914 "radv: add initial non-conformant radv vulkan driver" --- src/amd/common/ac_nir_to_llvm.c | 5 +++-- 1 file changed, 3 insertions(+), 2 deletions(-) diff --git

Re: [Mesa-dev] [PATCH v2 1/2] ac/nir: Use correct 32-bit component writemask for 64-bit SSBO stores.

2018-01-22 Thread Nicolai Hähnle
On 18.01.2018 00:48, Bas Nieuwenhuizen wrote: Fixes: 91074bb11bda "radv/ac: Implement Float64 SSBO stores." --- src/amd/common/ac_nir_to_llvm.c | 22 +- 1 file changed, 13 insertions(+), 9 deletions(-) diff --git a/src/amd/common/ac_nir_to_llvm.c

[Mesa-dev] [PATCH] clover: add functions up to 2.2 to ICD dispatch table

2018-01-22 Thread Karol Herbst
using void* for functions we need newer CL headers for. Signed-off-by: Karol Herbst --- src/gallium/state_trackers/clover/api/dispatch.cpp | 29 +- src/gallium/state_trackers/clover/api/dispatch.hpp | 116 + 2 files changed, 144 insertions(+), 1

Re: [Mesa-dev] [RFC PATCH 1/2] r600/sb: Set flags for GROUP_BARRIER instruction and force it into slot X

2018-01-22 Thread Nicolai Hähnle
On 11.01.2018 12:22, Ilia Mirkin wrote: On Thu, Jan 11, 2018 at 3:51 AM, Gert Wollny wrote: Am Donnerstag, den 11.01.2018, 08:09 +0100 schrieb Gert Wollny: Am Mittwoch, den 10.01.2018, 15:27 -0500 schrieb Ilia Mirkin: [...] If your hardware executes all the vertices in

Re: [Mesa-dev] [PATCH] i965: Accept CONTEXT_ATTRIB_PRIORITY for brwCreateContext

2018-01-22 Thread Emil Velikov
On 22 January 2018 at 10:27, Chris Wilson wrote: > Quoting Jason Ekstrand (2018-01-22 09:45:55) >> On Mon, Jan 22, 2018 at 1:22 AM, Chris Wilson >> wrote: >> >> Quoting Tapani Pälli (2018-01-22 08:26:15) >> > Reviewed-by: Tapani Pälli

Re: [Mesa-dev] [PATCH] i965: Accept CONTEXT_ATTRIB_PRIORITY for brwCreateContext

2018-01-22 Thread Chris Wilson
Quoting Jason Ekstrand (2018-01-22 09:45:55) > On Mon, Jan 22, 2018 at 1:22 AM, Chris Wilson > wrote: > > Quoting Tapani Pälli (2018-01-22 08:26:15) > > Reviewed-by: Tapani Pälli > > > > On 01/20/2018 02:29 AM, Chris Wilson

Re: [Mesa-dev] [PATCH v2 19/24] anv/cmd_buffer: Move the mi_alu helper higher up

2018-01-22 Thread Pohjolainen, Topi
On Fri, Jan 19, 2018 at 03:47:36PM -0800, Jason Ekstrand wrote: > --- > src/intel/vulkan/genX_cmd_buffer.c | 34 +++--- > 1 file changed, 19 insertions(+), 15 deletions(-) > > diff --git a/src/intel/vulkan/genX_cmd_buffer.c > b/src/intel/vulkan/genX_cmd_buffer.c >

Re: [Mesa-dev] [PATCH v2 18/24] anv/image: Simplify some verbose commennts

2018-01-22 Thread Pohjolainen, Topi
On Fri, Jan 19, 2018 at 03:47:35PM -0800, Jason Ekstrand wrote: > --- > src/intel/vulkan/anv_image.c | 13 +++-- > 1 file changed, 3 insertions(+), 10 deletions(-) Reviewed-by: Topi Pohjolainen > > diff --git a/src/intel/vulkan/anv_image.c

Re: [Mesa-dev] [PATCH v2 17/24] anv: Use blorp_ccs_ambiguate instead of fast-clears

2018-01-22 Thread Pohjolainen, Topi
On Fri, Jan 19, 2018 at 03:47:34PM -0800, Jason Ekstrand wrote: > Even though the blorp pass looks a bit on the sketchy side, the end > result in the Vulkan driver is very nice. Instead of having this weird > case where you do a fast clear and then maybe have to resolve, we just > do the

Re: [Mesa-dev] [PATCH v2 16/24] anv/cmd_buffer: Re-arrange the logic around UNDEFINED fast-clears

2018-01-22 Thread Pohjolainen, Topi
On Fri, Jan 19, 2018 at 03:47:33PM -0800, Jason Ekstrand wrote: > --- > src/intel/vulkan/genX_cmd_buffer.c | 31 ++- > 1 file changed, 14 insertions(+), 17 deletions(-) Reviewed-by: Topi Pohjolainen > > diff --git

Re: [Mesa-dev] [PATCH v2 15/24] anv/cmd_buffer: Pull the undefined layout condition into the if

2018-01-22 Thread Pohjolainen, Topi
On Fri, Jan 19, 2018 at 03:47:32PM -0800, Jason Ekstrand wrote: > Now that this isn't a multi-case if and it's just the one case, it's a > bit clearer if the condition is just part of the if instead of being > pulled out into a boolean variable. Reviewed-by: Topi Pohjolainen

Re: [Mesa-dev] [PATCH] i965: Accept CONTEXT_ATTRIB_PRIORITY for brwCreateContext

2018-01-22 Thread Jason Ekstrand
On Mon, Jan 22, 2018 at 1:22 AM, Chris Wilson wrote: > Quoting Tapani Pälli (2018-01-22 08:26:15) > > Reviewed-by: Tapani Pälli > > > > On 01/20/2018 02:29 AM, Chris Wilson wrote: > > > The forward port of commit 6d87500fe12e ("dri: Change > > >

Re: [Mesa-dev] [PATCH 2/6] st/omx/tizonia: Add --enable-omx-tizonia flag and build files

2018-01-22 Thread Gurkirpal Singh
Since patch 1 was rejected this time around for being too large I've also sent the series directly to Leo and Julien. On Sat, Jan 20, 2018 at 8:01 AM, Gurkirpal Singh wrote: > I've added the right patches as a reply. > > Sry again for the inconvenience > > On Sat, Jan

Re: [Mesa-dev] [PATCH] i965: Accept CONTEXT_ATTRIB_PRIORITY for brwCreateContext

2018-01-22 Thread Chris Wilson
Quoting Tapani Pälli (2018-01-22 08:26:15) > Reviewed-by: Tapani Pälli > > On 01/20/2018 02:29 AM, Chris Wilson wrote: > > The forward port of commit 6d87500fe12e ("dri: Change > > __DriverApiRec::CreateContext to take a struct for attribs") failed to > > adapt the set of

Re: [Mesa-dev] [PATCH v2 12/24] anv/cmd_buffer: Add a mark_image_written helper

2018-01-22 Thread Pohjolainen, Topi
On Fri, Jan 19, 2018 at 03:47:29PM -0800, Jason Ekstrand wrote: > Currently, this helper does nothing but we call it every place where an > image is written through the render pipeline. This will allow us to > properly mark the aux state so that we can handle resolves correctly. I can't tell

Re: [Mesa-dev] [PATCH 00/21] anv: Follow the rules for vkGet*ProcAddr

2018-01-22 Thread Jason Ekstrand
I don't think they're blocked by mailman decided to give up over the week-end so it may have gotten lost. Here's a branch: https://cgit.freedesktop.org/~jekstrand/mesa/log/?h=wip/anv-proc-addr On Mon, Jan 22, 2018 at 1:03 AM, Samuel Iglesias Gonsálvez < sigles...@igalia.com> wrote: > I don't

[Mesa-dev] [AppVeyor] mesa master #6664 completed

2018-01-22 Thread AppVeyor
Build mesa 6664 completed Commit 005375717b by Matthew Nicholls on 1/19/2018 2:11 PM: radv: restore previous stencil reference after depth-stencil clear\n\nCc: mesa-sta...@lists.freedesktop.org\nReviewed-by: Samuel Pitoiset

Re: [Mesa-dev] [PATCH 00/21] anv: Follow the rules for vkGet*ProcAddr

2018-01-22 Thread Samuel Iglesias Gonsálvez
I don't see patches 4, 8, 9 and 18 in the mailing list. Are they blocked? Sam On 20/01/18 20:11, Jason Ekstrand wrote: > Our previous scheme for Get*ProcAddr was to just return what we could and > not care about the details. This meant that GetInstanceProcAddr returned > all anv_ entrypoints

Re: [Mesa-dev] [PATCH 5/7] report.py: Add option to only display measurements that have changes

2018-01-22 Thread Ian Romanick
On 01/13/2018 04:23 AM, Dylan Baker wrote: > Quoting Ian Romanick (2018-01-12 12:06:59) >> From: Ian Romanick >> >> This is useful for preparing data to go in a Mesa commit message. >> >> Signed-off-by: Ian Romanick >> --- >> report.py | 53

Re: [Mesa-dev] [PATCH v2 09/24] anv/cmd_buffer: Generalize transition_color_buffer

2018-01-22 Thread Pohjolainen, Topi
On Mon, Jan 22, 2018 at 12:30:30AM -0800, Jason Ekstrand wrote: > On Mon, Jan 22, 2018 at 12:17 AM, Pohjolainen, Topi < > topi.pohjolai...@gmail.com> wrote: > > > On Fri, Jan 19, 2018 at 03:47:26PM -0800, Jason Ekstrand wrote: > > > This moves it to being based on layout_to_aux_usage instead of

Re: [Mesa-dev] [PATCH 2/2] i965: Set tiling on BOs imported with modifiers

2018-01-22 Thread Jason Ekstrand
Note to back-porters: I forgot to add a "fixes" tag but these and the other two I pushed with them should go into 17.3 as they fix the modifiers support we landed there. On Sun, Jan 21, 2018 at 8:05 PM, Jason Ekstrand wrote: > We need this to ensure that GTT maps work on

[Mesa-dev] [AppVeyor] mesa master #6663 failed

2018-01-22 Thread AppVeyor
Build mesa 6663 failed Commit 5048572352 by Jason Ekstrand on 1/12/2018 1:33 AM: i965: Set tiling on BOs imported with modifiers\n\nWe need this to ensure that GTT maps work on buffers we get from Vulkan\non the off chance that someone does a readpixels or

Re: [Mesa-dev] [PATCH v2 11/24] anv/blorp: Add src/dst_level helper variables in CmdCopyImage

2018-01-22 Thread Pohjolainen, Topi
On Fri, Jan 19, 2018 at 03:47:28PM -0800, Jason Ekstrand wrote: > --- > src/intel/vulkan/anv_blorp.c | 14 ++ > 1 file changed, 6 insertions(+), 8 deletions(-) Reviewed-by: Topi Pohjolainen > > diff --git a/src/intel/vulkan/anv_blorp.c

Re: [Mesa-dev] [PATCH v2 09/24] anv/cmd_buffer: Generalize transition_color_buffer

2018-01-22 Thread Jason Ekstrand
On Mon, Jan 22, 2018 at 12:17 AM, Pohjolainen, Topi < topi.pohjolai...@gmail.com> wrote: > On Fri, Jan 19, 2018 at 03:47:26PM -0800, Jason Ekstrand wrote: > > This moves it to being based on layout_to_aux_usage instead of being > > hard-coded based on bits of a priori knowledge of how transitions

Re: [Mesa-dev] [PATCH] i965: Accept CONTEXT_ATTRIB_PRIORITY for brwCreateContext

2018-01-22 Thread Tapani Pälli
Reviewed-by: Tapani Pälli On 01/20/2018 02:29 AM, Chris Wilson wrote: The forward port of commit 6d87500fe12e ("dri: Change __DriverApiRec::CreateContext to take a struct for attribs") failed to adapt the set of allowed attributes for the earlier introduction of context

Re: [Mesa-dev] [PATCH v2 07/24] anv/image: Support color aspects in layout_to_aux_usage

2018-01-22 Thread Jason Ekstrand
On Mon, Jan 22, 2018 at 12:07 AM, Pohjolainen, Topi < topi.pohjolai...@gmail.com> wrote: > On Fri, Jan 19, 2018 at 03:47:24PM -0800, Jason Ekstrand wrote: > > Reviewed-by: Nanley Chery > > --- > > src/intel/vulkan/anv_image.c | 48 ++ >

[Mesa-dev] [PATCH v3 06/24] anv/image: Add a helper for determining when fast clears are supported

2018-01-22 Thread Jason Ekstrand
v2 (Jason Ekstrand): - Return an enum instead of a boolean v3 (Jason Ekstrand): - Return ANV_FAST_CLEAR_NONE instead of false (Topi) - Rename ANV_FAST_CLEAR_ANY to ANV_FAST_CLEAR_DEFAULT_VALUE - Add documentation for the enum values Reviewed-by: Topi Pohjolainen

Re: [Mesa-dev] [PATCH v2 09/24] anv/cmd_buffer: Generalize transition_color_buffer

2018-01-22 Thread Pohjolainen, Topi
On Fri, Jan 19, 2018 at 03:47:26PM -0800, Jason Ekstrand wrote: > This moves it to being based on layout_to_aux_usage instead of being > hard-coded based on bits of a priori knowledge of how transitions > interact with layouts. This conceptually simplifies things because > we're now using

Re: [Mesa-dev] [PATCH v2 07/24] anv/image: Support color aspects in layout_to_aux_usage

2018-01-22 Thread Pohjolainen, Topi
On Fri, Jan 19, 2018 at 03:47:24PM -0800, Jason Ekstrand wrote: > Reviewed-by: Nanley Chery > --- > src/intel/vulkan/anv_image.c | 48 > ++-- > 1 file changed, 29 insertions(+), 19 deletions(-) > > diff --git

[Mesa-dev] [PATCH] ac/nir: Use instance_rate_inputs per attribute, not per variable.

2018-01-22 Thread Bas Nieuwenhuizen
This did the wrong thing if we had e.g. an array for which only some of the attributes use the instance index. Tripped up some new CTS tests. CC: --- src/amd/common/ac_nir_to_llvm.c | 27 +-- 1 file changed, 13 insertions(+), 14

<    1   2