Re: Question about getaddrinfo in Inet4AddressImpl.c

2011-11-11 Thread Mike Duigou
Some comments: Inet4AddressImpl.c: - why use bzero rather than posix memset? - MAXHOSTNAMELEN is used. Shouldn't this be NI_MAXHOST as in the Inet6 version? Mike On Nov 11 2011, at 06:53 , Neil Richards wrote: > On Wed, 2011-11-09 at 12:19 +0800, Charles Lee wrote: >> On 11/09/2011 03:25 AM,

Re: Code Review Request: 7107020: java.net.PlainSocketImpl.socketSetOption() calls itself

2011-11-11 Thread Alan Bateman
On 11/11/2011 18:57, Kurchi Hazra wrote: Hi, As specified in the CR description, this is a bug in src/windows/java/net/PlainSocketImpl.java and impl.socketSetOption() should be called instead of socketSetOption(). This bug did not create a problem yet since setOption() is usually called f

Code Review Request: 7107020: java.net.PlainSocketImpl.socketSetOption() calls itself

2011-11-11 Thread Kurchi Hazra
Hi, As specified in the CR description, this is a bug in src/windows/java/net/PlainSocketImpl.java and impl.socketSetOption() should be called instead of socketSetOption(). This bug did not create a problem yet since setOption() is usually called for setting socket options. Submitting hg d

Re: Question about getaddrinfo in Inet4AddressImpl.c

2011-11-11 Thread Neil Richards
On Wed, 2011-11-09 at 12:19 +0800, Charles Lee wrote: > On 11/09/2011 03:25 AM, Chris Hegarty wrote: > > Charles, > > > > Is it possible to fix up the style issues, etc that Neil pointed out, > > and have the webrev updated? > > > Hi Chris, > > Here it is. (attached) > And here it is, in webre

hg: jdk8/tl/corba: 7091388: Regular unexplained npe's from corba libs after system has been running for days

2011-11-11 Thread sean . coffey
Changeset: 44c269731425 Author:coffeys Date: 2011-11-11 10:16 + URL: http://hg.openjdk.java.net/jdk8/tl/corba/rev/44c269731425 7091388: Regular unexplained npe's from corba libs after system has been running for days Reviewed-by: alanb ! src/share/classes/com/sun/corba/se/impl

hg: jdk8/tl/jdk: 7105952: Improve finalisation for FileInputStream/FileOutputStream/RandomAccessFile

2011-11-11 Thread sean . coffey
Changeset: 9dd994f319ee Author:coffeys Date: 2011-11-11 10:08 + URL: http://hg.openjdk.java.net/jdk8/tl/jdk/rev/9dd994f319ee 7105952: Improve finalisation for FileInputStream/FileOutputStream/RandomAccessFile Reviewed-by: alanb ! src/share/classes/java/io/FileInputStream.java