Re: RFR: 8282917: Remove InetAddressImplFactory from InetAddress [v3]

2022-03-16 Thread Jaikiran Pai
On Wed, 16 Mar 2022 17:47:15 GMT, Aleksei Efimov wrote: >> Thanks for noticing that Jaikiran! >> >> Both `ipv4_available()` and `ipv6_available()` are defined to return `jint` >> so the implementation in `Java_java_net_InetAddress_isIPv6Supported` is >> arguably the more correct (provided that

Re: RFR: 8282917: Remove InetAddressImplFactory from InetAddress [v3]

2022-03-16 Thread Jaikiran Pai
On Wed, 16 Mar 2022 17:51:17 GMT, Aleksei Efimov wrote: >> Hi, >> >> This cleanup change removes `InetAddressImplFactory` class from >> `InetAddress`. The list of changes: >> - Remove `InetAddressImplFactory` from `InetAddress` >> - Since `isIPv6Supported` native code is identical for Windows a

Re: RFR: 8280400: JDK 19 L10n resource files update - msgdrop 10 [v4]

2022-03-16 Thread Naoto Sato
On Wed, 16 Mar 2022 18:31:55 GMT, Alisen Chung wrote: >> msg drop for jdk19, Mar 9, 2022 > > Alisen Chung has updated the pull request incrementally with one additional > commit since the last revision: > > removed incorrect translation of compiler configuration file LGTM. Thanks for the cha

Re: RFR: 8280400: JDK 19 L10n resource files update - msgdrop 10 [v4]

2022-03-16 Thread Alisen Chung
> msg drop for jdk19, Mar 9, 2022 Alisen Chung has updated the pull request incrementally with one additional commit since the last revision: removed incorrect translation of compiler configuration file - Changes: - all: https://git.openjdk.java.net/jdk/pull/7765/files - new:

Re: RFR: 8282917: Remove InetAddressImplFactory from InetAddress [v3]

2022-03-16 Thread Daniel Fuchs
On Wed, 16 Mar 2022 17:51:17 GMT, Aleksei Efimov wrote: >> Hi, >> >> This cleanup change removes `InetAddressImplFactory` class from >> `InetAddress`. The list of changes: >> - Remove `InetAddressImplFactory` from `InetAddress` >> - Since `isIPv6Supported` native code is identical for Windows a

Re: RFR: 8282917: Remove InetAddressImplFactory from InetAddress [v3]

2022-03-16 Thread Aleksei Efimov
On Wed, 16 Mar 2022 14:34:49 GMT, Daniel Fuchs wrote: >> I agree that it could be simplified to match >> `Java_java_net_InetAddress_isIPv4Available`. Changed in >> 49fdd576cade2e97639f827f9db6d0f1e31101e2 > > Thanks for noticing that Jaikiran! > > Both `ipv4_available()` and `ipv6_available()`

Re: RFR: 8282917: Remove InetAddressImplFactory from InetAddress [v3]

2022-03-16 Thread Aleksei Efimov
> Hi, > > This cleanup change removes `InetAddressImplFactory` class from > `InetAddress`. The list of changes: > - Remove `InetAddressImplFactory` from `InetAddress` > - Since `isIPv6Supported` native code is identical for Windows and Unix > implementations it was moved to the libnet's `InetAdd

Re: RFR: 8282917: Remove InetAddressImplFactory from InetAddress [v2]

2022-03-16 Thread Daniel Fuchs
On Wed, 16 Mar 2022 14:25:44 GMT, Aleksei Efimov wrote: >> src/java.base/share/native/libnet/InetAddress.c line 96: >> >>> 94: } else { >>> 95: return JNI_FALSE; >>> 96: } >> >> I don't have knowledge of C or JNI, but the >> `Java_java_net_InetAddress_isIPv4Available` currently

Re: RFR: 8282917: Remove InetAddressImplFactory from InetAddress [v2]

2022-03-16 Thread Aleksei Efimov
> Hi, > > This cleanup change removes `InetAddressImplFactory` class from > `InetAddress`. The list of changes: > - Remove `InetAddressImplFactory` from `InetAddress` > - Since `isIPv6Supported` native code is identical for Windows and Unix > implementations it was moved to the libnet's `InetAdd

Re: RFR: 8282917: Remove InetAddressImplFactory from InetAddress [v2]

2022-03-16 Thread Aleksei Efimov
On Wed, 16 Mar 2022 13:49:39 GMT, Jaikiran Pai wrote: >> Aleksei Efimov has updated the pull request incrementally with one >> additional commit since the last revision: >> >> Address review comments > > src/java.base/share/native/libnet/InetAddress.c line 88: > >> 86: * Class: java_net

Re: RFR: 8282917: Remove InetAddressImplFactory from InetAddress

2022-03-16 Thread Jaikiran Pai
On Wed, 16 Mar 2022 13:26:36 GMT, Aleksei Efimov wrote: > Hi, > > This cleanup change removes `InetAddressImplFactory` class from > `InetAddress`. The list of changes: > - Remove `InetAddressImplFactory` from `InetAddress` > - Since `isIPv6Supported` native code is identical for Windows and Uni

Re: RFR: 8282917: Remove InetAddressImplFactory from InetAddress

2022-03-16 Thread Jaikiran Pai
On Wed, 16 Mar 2022 13:26:36 GMT, Aleksei Efimov wrote: > Hi, > > This cleanup change removes `InetAddressImplFactory` class from > `InetAddress`. The list of changes: > - Remove `InetAddressImplFactory` from `InetAddress` > - Since `isIPv6Supported` native code is identical for Windows and Uni

RFR: 8282917: Remove InetAddressImplFactory from InetAddress

2022-03-16 Thread Aleksei Efimov
Hi, This cleanup change removes `InetAddressImplFactory` class from `InetAddress`. The list of changes: - Remove `InetAddressImplFactory` from `InetAddress` - Since `isIPv6Supported` native code is identical for Windows and Unix implementations it was moved to the libnet's `InetAddress.c`. - `In

Re: RFR: 8282536: java.net.InetAddress should be a sealed class [v3]

2022-03-16 Thread Aleksei Efimov
> The following fix seals the `java.net.InetAddress` class and permits only two > implementations - `java.net.Inet4Address` and `java.net.Inet6Address`. > > No issues have been detected by regression and JCK tests. > > Links: [JBS](https://bugs.openjdk.java.net/browse/JDK-8282536) > [CSR](http