Re: RFR: 8282917: Remove InetAddressImplFactory from InetAddress [v4]

2022-03-23 Thread Aleksei Efimov
> Hi, > > This cleanup change removes `InetAddressImplFactory` class from > `InetAddress`. The list of changes: > - Remove `InetAddressImplFactory` from `InetAddress` > - Since `isIPv6Supported` native code is identical for Windows and Unix > implementations it was moved to the libnet's

Re: RFR: 8282917: Remove InetAddressImplFactory from InetAddress [v3]

2022-03-16 Thread Jaikiran Pai
On Wed, 16 Mar 2022 17:47:15 GMT, Aleksei Efimov wrote: >> Thanks for noticing that Jaikiran! >> >> Both `ipv4_available()` and `ipv6_available()` are defined to return `jint` >> so the implementation in `Java_java_net_InetAddress_isIPv6Supported` is >> arguably the more correct (provided

Re: RFR: 8282917: Remove InetAddressImplFactory from InetAddress [v3]

2022-03-16 Thread Jaikiran Pai
On Wed, 16 Mar 2022 17:51:17 GMT, Aleksei Efimov wrote: >> Hi, >> >> This cleanup change removes `InetAddressImplFactory` class from >> `InetAddress`. The list of changes: >> - Remove `InetAddressImplFactory` from `InetAddress` >> - Since `isIPv6Supported` native code is identical for Windows

Re: RFR: 8282917: Remove InetAddressImplFactory from InetAddress [v3]

2022-03-16 Thread Daniel Fuchs
On Wed, 16 Mar 2022 17:51:17 GMT, Aleksei Efimov wrote: >> Hi, >> >> This cleanup change removes `InetAddressImplFactory` class from >> `InetAddress`. The list of changes: >> - Remove `InetAddressImplFactory` from `InetAddress` >> - Since `isIPv6Supported` native code is identical for Windows

Re: RFR: 8282917: Remove InetAddressImplFactory from InetAddress [v3]

2022-03-16 Thread Aleksei Efimov
On Wed, 16 Mar 2022 14:34:49 GMT, Daniel Fuchs wrote: >> I agree that it could be simplified to match >> `Java_java_net_InetAddress_isIPv4Available`. Changed in >> 49fdd576cade2e97639f827f9db6d0f1e31101e2 > > Thanks for noticing that Jaikiran! > > Both `ipv4_available()` and

Re: RFR: 8282917: Remove InetAddressImplFactory from InetAddress [v3]

2022-03-16 Thread Aleksei Efimov
> Hi, > > This cleanup change removes `InetAddressImplFactory` class from > `InetAddress`. The list of changes: > - Remove `InetAddressImplFactory` from `InetAddress` > - Since `isIPv6Supported` native code is identical for Windows and Unix > implementations it was moved to the libnet's

Re: RFR: 8282917: Remove InetAddressImplFactory from InetAddress [v2]

2022-03-16 Thread Daniel Fuchs
On Wed, 16 Mar 2022 14:25:44 GMT, Aleksei Efimov wrote: >> src/java.base/share/native/libnet/InetAddress.c line 96: >> >>> 94: } else { >>> 95: return JNI_FALSE; >>> 96: } >> >> I don't have knowledge of C or JNI, but the >> `Java_java_net_InetAddress_isIPv4Available`

Re: RFR: 8282917: Remove InetAddressImplFactory from InetAddress [v2]

2022-03-16 Thread Aleksei Efimov
> Hi, > > This cleanup change removes `InetAddressImplFactory` class from > `InetAddress`. The list of changes: > - Remove `InetAddressImplFactory` from `InetAddress` > - Since `isIPv6Supported` native code is identical for Windows and Unix > implementations it was moved to the libnet's

Re: RFR: 8282917: Remove InetAddressImplFactory from InetAddress [v2]

2022-03-16 Thread Aleksei Efimov
On Wed, 16 Mar 2022 13:49:39 GMT, Jaikiran Pai wrote: >> Aleksei Efimov has updated the pull request incrementally with one >> additional commit since the last revision: >> >> Address review comments > > src/java.base/share/native/libnet/InetAddress.c line 88: > >> 86: * Class:

Re: RFR: 8282917: Remove InetAddressImplFactory from InetAddress

2022-03-16 Thread Jaikiran Pai
On Wed, 16 Mar 2022 13:26:36 GMT, Aleksei Efimov wrote: > Hi, > > This cleanup change removes `InetAddressImplFactory` class from > `InetAddress`. The list of changes: > - Remove `InetAddressImplFactory` from `InetAddress` > - Since `isIPv6Supported` native code is identical for Windows and

Re: RFR: 8282917: Remove InetAddressImplFactory from InetAddress

2022-03-16 Thread Jaikiran Pai
On Wed, 16 Mar 2022 13:26:36 GMT, Aleksei Efimov wrote: > Hi, > > This cleanup change removes `InetAddressImplFactory` class from > `InetAddress`. The list of changes: > - Remove `InetAddressImplFactory` from `InetAddress` > - Since `isIPv6Supported` native code is identical for Windows and

RFR: 8282917: Remove InetAddressImplFactory from InetAddress

2022-03-16 Thread Aleksei Efimov
Hi, This cleanup change removes `InetAddressImplFactory` class from `InetAddress`. The list of changes: - Remove `InetAddressImplFactory` from `InetAddress` - Since `isIPv6Supported` native code is identical for Windows and Unix implementations it was moved to the libnet's `InetAddress.c`. -