In 2.4.21, arp code uses gc_timer to check for stale arp cache
entries. In 2.6, each entry has its own timer to check for stale arp
cache. 2.4.29 to 2.4.32 kernels (atleast) use neither of these timers.
This causes problems in environments where IPs or MACs are reassigned
- saw this problem on load
Roland> Is forcedeth ever used with a discrete ethernet
Roland> controller? I thought that nforce NICs are always
Roland> intergrated in the chipset, and hence the entire scope for
Roland> MSI problems is within a single chip. However, I don't
Roland> know if there are devices
Jesse Brandeburg wrote:
On 1/28/06, Mattia Dongili <[EMAIL PROTECTED]> wrote:
On Thu, Jan 26, 2006 at 08:02:37PM +0100, Stefan Seyfried wrote:
On Wed, Jan 25, 2006 at 04:28:48PM -0800, Jesse Brandeburg wrote:
Okay I reproduced the issue on 2.6.15.1 (with S1 sleep) and was able
to show that
On Tuesday 07 February 2006 01:32, Carlos Martín wrote:
> Hi,
>
> The attached patch changes the acx_ioctl_{get,set}_encode functions to use
> the 80211 stack in the kernel, so they become mere wrappers.
>
> Signed-off-by: Carlos Martin <[EMAIL PROTECTED]>
>
>cmn
Applied, thanks!
--
vda
-
Dave,
please apply.
--
Horms
Hello,
This patch against the latest GIT HEAD reduces the includes to the
necessary ones. I've compile-tested it against following (and s/y/m/)
configuration on x86:
CONFIG_IP_VS=y
CONFIG_IP_VS_DEBUG=y
CONFIG_IP_VS_TAB_BITS=12
CONFIG_IP_VS_PROTO_TCP=y
CONFIG_IP_
In gmane.comp.linux.lvs.user Roberto Nibali <[EMAIL PROTECTED]> wrote:
CONFIG_IP_VS=m
# CONFIG_IP_VS_DEBUG is not set
CONFIG_IP_VS_TAB_BITS=12
CONFIG_IP_VS_PROTO_TCP=y
CONFIG_IP_VS_PROTO_UDP=y
CONFIG_IP_VS_PROTO_ESP=y
CONFIG_IP_VS_PROTO_AH=y
>
> These 'y' caused
David S. Miller <[EMAIL PROTECTED]> wrote:
.
> But, thinking about this some more, it might actually be best to just
> add them anyways to "TcpExt: " and get netstat's limitation fixed.
>
> Any other opinions?
Use netlink?
--
Visit Openswan at http://www.openswan.org/
Email: Herbert Xu ~{PmV>HI
David S. Miller <[EMAIL PROTECTED]> wrote:
> From: David Carlton <[EMAIL PROTECTED]>
> Date: Mon, 06 Feb 2006 14:38:10 -0800
>
>> I'm working on an application that we're trying to switch from a 2.4
>> kernel to a 2.6 kernel. (I believe we're using 2.6.9.) One part of
>> the program periodically
Network device API cleanup for 2.6.17 (and put in -rcX-mm please).
Get rid of the old __dev_put macro that is just a hold over
from pre 2.6 kernel. And turn dev_hold into an inline instead
of a macro.
Signed-off-by: Stephen Hemminger <[EMAIL PROTECTED]>
--- br-2.6.orig/drivers/net/e1000/e1000_mai
From: David Carlton <[EMAIL PROTECTED]>
Date: Mon, 06 Feb 2006 14:38:10 -0800
> I'm working on an application that we're trying to switch from a 2.4
> kernel to a 2.6 kernel. (I believe we're using 2.6.9.) One part of
> the program periodically sends out chunks of data (whose size is just
> over
Patch to 2.6.15 stable kernel to fix race conditions on device
removal. These are reproducible by doing delif while packets are
in flight.
Signed-off-by: Stephen Hemminger <[EMAIL PROTECTED]>
--- linux-2.6.15.2.orig/net/bridge/br_if.c
+++ linux-2.6.15.2/net/bridge/br_if.c
@@ -99,7 +99,6 @@ stat
Fix bridge netfilter to handle case where interface is deleted
from bridge while packet is being processed (on other CPU).
Fixes: http://bugzilla.kernel.org/show_bug.cgi?id=5803
Signed-off-by: Stephen Hemminger <[EMAIL PROTECTED]>
Index: linux-2.6.15.2/net/bridge/br_netfilter.c
=
Hi,
The attached patch changes the acx_ioctl_{get,set}_encode functions to use
the 80211 stack in the kernel, so they become mere wrappers.
Signed-off-by: Carlos Martin <[EMAIL PROTECTED]>
cmn
--
Carlos Martín http://www.cmartin.tk
"Erdbeben? Sicherlich etwas, das mit Erdberen zu tu
A couple of small optimizations in bridge code for 2.6.17
Can use kcalloc and kzalloc. Also the bridge device's
netdev_priv area is already zeroed.
Signed-off-by: Stephen Hemminger <[EMAIL PROTECTED]>
--- br-2.6.orig/net/bridge/br_if.c
+++ br-2.6/net/bridge/br_if.c
@@ -208,7 +208,6 @@ static str
Fix the VLAN macros in bridge netfilter code. Macros should
not depend on magic variables. Also, __constant_htons() should
only be for initailizers.
Signed-off-by: Stephen Hemminger <[EMAIL PROTECTED]>
--- br-2.6.orig/net/bridge/br_netfilter.c
+++ br-2.6/net/bridge/br_netfilter.c
@@ -61,15 +61,2
Move nf_bridge_alloc from header file to the one place it is
used and optimize it.
Signed-off-by: Stephen Hemminger <[EMAIL PROTECTED]>
--- br-2.6.orig/include/linux/netfilter_bridge.h
+++ br-2.6/include/linux/netfilter_bridge.h
@@ -47,22 +47,6 @@ enum nf_br_hook_priorities {
#define BRNF_BRIDG
This applies after the RCU fix patches; it can be held until 2.6.17.
Run br_netfilter through Lindent to fix whitespace.
Signed-off-by: Stephen Hemminger <[EMAIL PROTECTED]>
--- br-2.6.orig/net/bridge/br_netfilter.c
+++ br-2.6/net/bridge/br_netfilter.c
@@ -135,7 +135,7 @@ static void __br_dnat_c
Change Bridge receive path to correctly handle RCU removal of device
from bridge. Also fixes deadlock between carrier_check and del_nbp.
This replaces the previous deleted flag fix.
Signed-off-by: Stephen Hemminger <[EMAIL PROTECTED]>
--- br-2.6.orig/net/bridge/br_input.c
+++ br-2.6/net/bridge/
Bridge netfilter code needs to handle the case where device is
removed from bridge while packet in process. In these cases the
bridge_parent can be come null while processing.
This should fix: http://bugzilla.kernel.org/show_bug.cgi?id=5803
Signed-off-by: Stephen Hemminger <[EMAIL PROTECTED]>
--
Fix a number of issues relating to deleting a device from
a bridge while work is in progress. Passes the usual func/stress tests.
-
To unsubscribe from this list: send the line "unsubscribe netdev" in
the body of a message to [EMAIL PROTECTED]
More majordomo info at http://vger.kernel.org/majordo
Refactor how the bridge code interacts with kobject system.
It should still use kobjects even if not using sysfs.
Fix the error unwind handling in br_add_if.
Signed-off-by: Stephen Hemminger <[EMAIL PROTECTED]>
--- br-2.6.orig/net/bridge/br_if.c
+++ br-2.6/net/bridge/br_if.c
@@ -106,6 +106,20 @@
On Mon, 2006-02-06 at 21:23 +0100, matthieu castet wrote:
> Hi,
>
> Dan Williams wrote:
> > I can help out with the mpi350 if you'd like. However, most of the code
> > for the MPI350 should be exactly the same as with the PCMCIA version of
> > the card. They share just about everything except fo
On Mon, 6 Feb 2006, Catherine Zhang wrote:
>
> Hi,
>
> Updated as per James' comment.
Looks good to me.
Acked-by: James Morris <[EMAIL PROTECTED]>
--
James Morris
<[EMAIL PROTECTED]>
-
To unsubscribe from this list: send the line "unsubscribe netdev" in
the body of a message to [EMAIL PRO
Hi,
Dan Williams wrote:
I can help out with the mpi350 if you'd like. However, most of the code
for the MPI350 should be exactly the same as with the PCMCIA version of
the card. They share just about everything except for the bus type.
(unless I'm wrong?)
There are some differences for RX and
Stephen> Since many motherboards and chipsets don't handle MSI
Stephen> properly, it is probably better to do a test interrupt
Stephen> before fully using MSI. See tg3 for an example.
Is forcedeth ever used with a discrete ethernet controller? I thought
that nforce NICs are always int
On Mon, 2006-02-06 at 19:06 +0100, matthieu castet wrote:
> Hi,
>
> matthieu castet wrote:
> > Hi,
> >
> > I have a working linux airo driver that support WPA-PSK, but it is very
> > ugly.
> > It only support one card, and don't support MPI350. Also it only works
> > with WPA.
> >
> > Current
On Mon, 2006-02-06 at 19:06 +0100, matthieu castet wrote:
> Hi,
>
> matthieu castet wrote:
> > Hi,
> >
> > I have a working linux airo driver that support WPA-PSK, but it is very
> > ugly.
> > It only support one card, and don't support MPI350. Also it only works
> > with WPA.
> >
> > Current
Hi,
Updated as per James' comment.
Catherine
---
From: [EMAIL PROTECTED]
This patch implements an application of the LSM-IPSec networking
controls whereby an application can determine the label of the
security association its TCP or UDP sockets are currently connected to
via getsockopt and th
Hi,
matthieu castet wrote:
Hi,
I have a working linux airo driver that support WPA-PSK, but it is very
ugly.
It only support one card, and don't support MPI350. Also it only works
with WPA.
Currently the RX and TX key are set only for set_tx=1 key. The card
should report valid mic key wit
On Sat, 04 Feb 2006 13:13:31 -0500
Ayaz Abdulla <[EMAIL PROTECTED]> wrote:
> This forcedeth patch adds support for MSI/MSIX interrupts.
>
> Signed-off-By: Ayaz Abdulla <[EMAIL PROTECTED]>
>
Since many motherboards and chipsets don't handle MSI properly, it is
probably better to do a test interr
Users report problems w/ auto-negotiation disabled and the link set
to 100/Half or 10/Half. Problems range from poor performance to no
link at all.
The current sky2 code does not set things properly on link up if
autonegotiation is disabled. Plus it does not contemplate a 10Mbit
setting at all.
On Monday 06 February 2006 15:59, Jiri Benc wrote:
> Subject: [PATCH] d80211: rename ieee80211_rx to __ieee80211_rx
>
> This patch fix the problem reported by Michael Buesch <[EMAIL PROTECTED]>:
>
> net/ieee80211/built-in.o: In function `ieee80211_rx':
> : multiple definition of `ieee80211_rx'
>
On Thu, 2 Feb 2006 20:36:26 +0100, Michael Buesch wrote:
> Maybe people always compile the stacks as modules, so this does
> only appear on insmod time... .
That's my case. I've also never inserted both modules together.
> But how to solve it? I suggest to change all dscape function prefixes
> fr
>>> CONFIG_IP_VS=m
>>> # CONFIG_IP_VS_DEBUG is not set
>>> CONFIG_IP_VS_TAB_BITS=12
>>> CONFIG_IP_VS_PROTO_TCP=y
>>> CONFIG_IP_VS_PROTO_UDP=y
>>> CONFIG_IP_VS_PROTO_ESP=y
>>> CONFIG_IP_VS_PROTO_AH=y
These 'y' caused me to think that it wasn't modular.
>>> CONFIG_IP_VS_RR=m
>>> CONFIG_IP_VS_WRR=m
In gmane.comp.linux.lvs.user Roberto Nibali <[EMAIL PROTECTED]> wrote:
>> Hi Rats,
>>
>> I'm all for this patch, but I get horrible breakage with the following
>> config (I can give the rest if you need it).
>
> Darn!
>
>> CONFIG_IP_VS=m
>> # CONFIG_IP_VS_DEBUG is not set
>> CONFIG_IP_VS_TAB_BI
> Hi Rats,
>
> I'm all for this patch, but I get horrible breakage with the following
> config (I can give the rest if you need it).
Darn!
> CONFIG_IP_VS=m
> # CONFIG_IP_VS_DEBUG is not set
> CONFIG_IP_VS_TAB_BITS=12
> CONFIG_IP_VS_PROTO_TCP=y
> CONFIG_IP_VS_PROTO_UDP=y
> CONFIG_IP_VS_PROTO_ESP
On Mon, Feb 06, 2006 at 01:48:33AM +0100, Roberto Nibali wrote:
> Hello,
>
> This patch against the latest GIT HEAD reduces the includes to the
> necessary ones. I've compile-tested it against following (and s/y/m/)
> configuration on x86:
>
> CONFIG_IP_VS=y
> CONFIG_IP_VS_DEBUG=y
> CONFIG_IP_V
37 matches
Mail list logo