Please pull from 'upstream-linus' branch of
master.kernel.org:/pub/scm/linux/kernel/git/jgarzik/netdev-2.6.git
to receive the following updates:
drivers/net/forcedeth.c | 312 +++-
drivers/net/pcmcia/axnet_cs.c | 13 -
drivers/net/skg
On Fri, May 19, 2006 at 07:53:08PM -0700, Chris Wedgwood wrote:
> A lot of people use MPPE and I'm not aware of too many complaints with
> this. Remove it's EXPERIMENTAL status.
>
>
> Signed-off-by: Chris Wedgwood <[EMAIL PROTECTED]>
Acked-by: Matt Domsch <[EMAIL PROTECTED]>
Thanks Chris!
-Mat
A lot of people use MPPE and I'm not aware of too many complaints with
this. Remove it's EXPERIMENTAL status.
Signed-off-by: Chris Wedgwood <[EMAIL PROTECTED]>
diff --git a/drivers/net/Kconfig b/drivers/net/Kconfig
index aa633fa..2c56a95 100644
--- a/drivers/net/Kconfig
+++ b/drivers/net/Kconfi
Apparently IP_ROUTE_MULTIPATH_CACHED isn't entirely safe to use and
will oops the kernel "sooner or later". The Kconfig comment says
EXPERIMENTAL but it's not.
Let's go further and mark it BROKEN for now (leaving the comment as-is
though). If nobody steps up to resurrect this code we can discuss
Signed-off-by: Alexey Dobriyan <[EMAIL PROTECTED]>
---
include/linux/atmbr2684.h |4 ++--
include/linux/atmmpc.h|8
net/atm/br2684.c |2 +-
net/atm/clip.c|4 ++--
net/atm/lec.c |2 +-
net/atm/mpc.c | 20 ++
> We have tried :) But there is no nice way to split this code. So I guess
> we will have to keep it like this.
You could shorten the #define names a bit (s/MYRI10GE_MCP_ETHER_/MCP_/) Then
everything
will fit better.
-Andi
-
To unsubscribe from this list: send the line "unsubscribe netdev" in
Arnd Bergmann wrote:
>> +static int myri10ge_open(struct net_device *dev)
>>
>
> This function is too long to read easily.
>
Ok we have split it a little bit.
>> +/* allocate the host shadow rings */
>> +
>> +bytes = 8 + (MYRI10GE_MCP_ETHER_MAX_SEND_DESC_TSO + 4)
>> +* siz
From: Sridhar Samudrala <[EMAIL PROTECTED]>
Date: Fri, 19 May 2006 15:24:58 -0700
> Please pull the following SCTP updates from
>master.kernel.org:/pub/scm/linux/kernel/git/sridhar/lksctp-2.6.git
Pulled, thanks a lot Sridhar.
-
To unsubscribe from this list: send the line "unsubscribe netdev"
Dave,
Please pull the following SCTP updates from
master.kernel.org:/pub/scm/linux/kernel/git/sridhar/lksctp-2.6.git
Thanks
Sridhar
include/net/sctp/command.h |1
include/net/sctp/sctp.h|6 +-
net/sctp/input.c | 144 +---
net/sc
On Fri, May 19, 2006 at 03:03:11PM -0400, Michael Wu wrote:
> On Friday 19 May 2006 14:06, John W. Linville wrote:
> > Are we satisfied w/ this patch? If so, please repost the patch after
> > cleaning-up the changelog according to the rules here:
> >
> > http://linux.yyz.us/patch-format.html
>
On Friday 19 May 2006 14:06, John W. Linville wrote:
> Are we satisfied w/ this patch? If so, please repost the patch after
> cleaning-up the changelog according to the rules here:
>
> http://linux.yyz.us/patch-format.html
>
I was going to after getting a response, but Jiri Benc already pull
I have updated the wireless-dev tree w/ some patches posted over the
last couple of weeks. Please update your repositories!
John
---
The following changes since commit b3783fbd3cc23106a21995b1bebde396047b2759:
John W. Linville:
Merge branch 'from-linus'
are found in the git repositor
Francois Romieu wrote:
Jeff Kirsher <[EMAIL PROTECTED]> :
@@ -486,8 +495,7 @@ ixgb_probe(struct pci_dev *pdev,
netif_carrier_off(netdev);
netif_stop_queue(netdev);
- printk(KERN_INFO "%s: Intel(R) PRO/10GbE Network Connection\n",
- netdev->name);
+ DPRIN
On Friday 19 May 2006 20:44, you wrote:
> John W. Linville wrote:
> > Do you intend for this to be merged? Given recent miscommunication,
> > I figured I should ask... :-)
>
> Nobody has tested it yet, so no, but thanks for asking.
>
> I figure it will be easier to find testers once the base pat
John W. Linville wrote:
Do you intend for this to be merged? Given recent miscommunication,
I figured I should ask... :-)
Nobody has tested it yet, so no, but thanks for asking.
I figure it will be easier to find testers once the base patch (softmac
suggest txrate) has been pushed by you int
On Sat, May 06, 2006 at 10:16:51AM +0100, Daniel Drake wrote:
> Can a bcm43xx user please test this. It uses the new txrate stuff found in
> the wireless-dev tree.
Daniel,
Do you intend for this to be merged? Given recent miscommunication,
I figured I should ask... :-)
John
--
John W. Linville
On Thu, May 04, 2006 at 02:36:56PM +0200, Johannes Berg wrote:
> On Thu, 2006-05-04 at 14:33 +0200, Jiri Benc wrote:
>
> > TSF is set to a value sent by an AP. Is there anything that prevents
> > that AP to send you e.g. 0xf0?
>
> Ah, good point, I didn't think of stupid APs. Yeah, it
On Mon, May 15, 2006 at 01:19:23PM -0400, Michael Wu wrote:
> On Monday 15 May 2006 07:37, Jiri Benc wrote:
> > This issue can be easily solved by not masking hw_modes by
> > valid_hw_modes in ieee80211_ioctl_prism2_param and
> > ieee80211_precalc_modes. Just check (hw_modes & valid_hw_modes) inste
On Wed, 17 May 2006 15:45:14 -0700
"Haruki Dai-r35557" <[EMAIL PROTECTED]> wrote:
> This patch improves the IP forwarding throughput of
> the Freescale TSEC/eTSEC Gianfar driver. By recycling
> the Socket buffer and Data buffer, reduce the unnecessary
> memory allocation and de-allocation in the f
I've found that when increasing the sky2 interface MTU beyond
somewhere around 6000-7500, packets can get truncated.
The interface is the internal interface on a NAT router - I've been
able to reproduce this with 2.6.16 and 2.6.17-rc4 when say sending an
email from gmail (via the web interface).
Allow for PCI-E core to be considered as PCI core. Allow revision 10 of
wireless core.
Signed-off-by: Stefano Brivio <[EMAIL PROTECTED]>
Index: wireless-dev/drivers/net/wireless/bcm43xx/bcm43xx_main.c
===
--- wireless-dev.orig/drive
Can somebody with a bcm4311 or bcm4312 board please test this. This
patchset adds support for PCI-E devices and includes as well some minor
fixes to powercontrol, wireless core management, PCI core management.
--
Ciao
Stefano
-
To unsubscribe from this list: send the line "unsubscribe netdev" in
Add read and write functions for PCI-E registers
Add write function for MDIO slaves.
Signed-off-by: Stefano Brivio <[EMAIL PROTECTED]>
Index: wireless-dev/drivers/net/wireless/bcm43xx/bcm43xx_main.c
===
--- wireless-dev.orig/drivers/
Fix reading core ID and revision from sb_id_hi.
Signed-off-by: Stefano Brivio <[EMAIL PROTECTED]>
Index: wireless-dev/drivers/net/wireless/bcm43xx/bcm43xx_main.c
===
--- wireless-dev.orig/drivers/net/wireless/bcm43xx/bcm43xx_main.c
+
Allow a GPHY to have revision 8. Issue a warning instead of giving up when
dealing with an unknown core revision.
Signed-off-by: Stefano Brivio <[EMAIL PROTECTED]>
Index: wireless-dev/drivers/net/wireless/bcm43xx/bcm43xx_main.c
===
-
Trivial change in specs related to bcm43xx_wireless_core_mark_inactive.
Signed-off-by: Stefano Brivio <[EMAIL PROTECTED]>
Index: wireless-dev/drivers/net/wireless/bcm43xx/bcm43xx_main.c
===
--- wireless-dev.orig/drivers/net/wireless/
Add powercontrol support for PCI-E devices.
Signed-off-by: Stefano Brivio <[EMAIL PROTECTED]>
Index: wireless-dev/drivers/net/wireless/bcm43xx/bcm43xx.h
===
--- wireless-dev.orig/drivers/net/wireless/bcm43xx/bcm43xx.h
+++ wireless-de
Backplane setup for PCI-E devices and PCI devices with PCI Core ID > 10.
Use chipcommon if possible while broadcasting PCI settings.
Signed-off-by: Stefano Brivio <[EMAIL PROTECTED]>
Index: wireless-dev/drivers/net/wireless/bcm43xx/bcm43xx.h
==
Andi Kleen wrote:
> On Friday 19 May 2006 12:00, Arnd Bergmann wrote:
>
>> On Friday 19 May 2006 04:25, Brice Goglin wrote:
>>
>>> dev_mc_upload() from net/core/dev_mcast.c does
>>>
>>> spin_lock_bh(&dev->xmit_lock);
>>> __dev_mc_upload(dev);
>>>
>>> which calls dev->set_multicast_list(), w
Add core ID for PCI-E core.
Signed-off-by: Stefano Brivio <[EMAIL PROTECTED]>
Index: wireless-dev/drivers/net/wireless/bcm43xx/bcm43xx.h
===
--- wireless-dev.orig/drivers/net/wireless/bcm43xx/bcm43xx.h
+++ wireless-dev/drivers/net/wi
Add PCI ID for bcm4311 PCI-E device.
Signed-off-by: Stefano Brivio <[EMAIL PROTECTED]>
Index: wireless-dev/drivers/net/wireless/bcm43xx/bcm43xx_main.c
===
--- wireless-dev.orig/drivers/net/wireless/bcm43xx/bcm43xx_main.c
+++ wireless
Fix wireless core initialization in order to work with PCI-E devices.
Signed-off-by: Stefano Brivio <[EMAIL PROTECTED]>
Index: wireless-dev/drivers/net/wireless/bcm43xx/bcm43xx_main.c
===
--- wireless-dev.orig/drivers/net/wireless/bc
Revert previous patch with subject "change mdelay to msleep and remove
from ISR path". This patch seems to have caused bigger problems than
it solved, and it didn't solve much of a problem to begin with...
Signed-off-by: John W. Linville <[EMAIL PROTECTED]
---
Use this one, it applies w/o fuzz...
Revert previous patch with subject "change mdelay to msleep and remove
from ISR path". This patch seems to have caused bigger problems than
it solved, and it didn't solve much of a problem to begin with...
Signed-off-by: John W. Linville <[EMAIL PROTECTED]
---
Discussion about backing-out this pa
> dev_err?
>
[...]
> Could probably use dev_printk.
>
When the interface name is known, we prefer having the message look like
"myri10ge: eth2: something" since it might be easier to read than
""myri10ge: 5:000e: something". The administrator usually knows the
name of the network inter
Signed-off-by: Alexey Dobriyan <[EMAIL PROTECTED]>
---
drivers/ieee1394/eth1394.c |6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
--- a/drivers/ieee1394/eth1394.c
+++ 1/drivers/ieee1394/eth1394.c
@@ -935,7 +935,7 @@ static inline u16 ether1394_parse_encap(
*(u32*)a
Christian Schmid <[EMAIL PROTECTED]> wrote:
Since this seems to be an undocumented feature How is this equal-cost multipath supposed to
work? I just want to send outgoing traffic over two gateways. I tried this:
ip route replace default scope global nexthop via 192.168.0.1 dev eth1 weight
Signed-off-by: Alexey Dobriyan <[EMAIL PROTECTED]>
---
--- a/include/net/irda/irlmp.h
+++ 1/include/net/irda/irlmp.h
@@ -112,7 +112,7 @@ struct lsap_cb {
struct timer_list watchdog_timer;
- IRLMP_STATE lsap_state; /* Connection state */
+ LSAP_STATE lsap_state; /
Signed-off-by: Alexey Dobriyan <[EMAIL PROTECTED]>
---
--- a/net/irda/iriap.c
+++ 1/net/irda/iriap.c
@@ -544,7 +544,8 @@ static void iriap_getvaluebyclass_respon
{
struct sk_buff *tx_skb;
int n;
- __u32 tmp_be32, tmp_be16;
+ __u32 tmp_be32;
+ __be16 tmp_be16;
On Friday 19 May 2006 12:00, Arnd Bergmann wrote:
> On Friday 19 May 2006 04:25, Brice Goglin wrote:
> > dev_mc_upload() from net/core/dev_mcast.c does
> >
> > spin_lock_bh(&dev->xmit_lock);
> > __dev_mc_upload(dev);
> >
> > which calls dev->set_multicast_list(), which is
> > myri10ge_set_multica
On Friday 19 May 2006 04:25, Brice Goglin wrote:
> dev_mc_upload() from net/core/dev_mcast.c does
>
> spin_lock_bh(&dev->xmit_lock);
> __dev_mc_upload(dev);
>
> which calls dev->set_multicast_list(), which is
> myri10ge_set_multicast_list()
>
> which calls myri10ge_change_promisc
>
> which call
41 matches
Mail list logo