The ibmvnic driver keeps its statistics in net_device->stats, so the
net_stats member in struct ibmvnic_adapter is unused. Remove it.
Signed-off-by: Tobias Klauser
---
drivers/net/ethernet/ibm/ibmvnic.h | 1 -
1 file changed, 1 deletion(-)
diff --git a/drivers/net/ethernet/ibm/ibmvnic.h
b/driv
The ibmveth driver keeps its statistics in net_device->stats, so the
stats member in struct ibmveth_adapter is unused. Remove it.
Signed-off-by: Tobias Klauser
---
drivers/net/ethernet/ibm/ibmveth.h | 1 -
1 file changed, 1 deletion(-)
diff --git a/drivers/net/ethernet/ibm/ibmveth.h
b/drivers/
The bfin_mac driver keeps its statistics in net_device->stats, so the
stats member in struct bfin_mac_local is unused. Remove it, as well as
the accompanying comment.
Cc: adi-buildroot-de...@lists.sourceforge.net
Signed-off-by: Tobias Klauser
---
drivers/net/ethernet/adi/bfin_mac.h | 7 ---
On Sat, Mar 25, 2017 at 7:52 AM, Marcelo Ricardo Leitner
wrote:
> On Tue, Mar 21, 2017 at 01:44:32PM +0800, Xin Long wrote:
>> On Tue, Mar 21, 2017 at 2:04 AM, Marcelo Ricardo Leitner
>> wrote:
>> > On Fri, Mar 10, 2017 at 12:11:07PM +0800, Xin Long wrote:
>> >> This patch is to implement Receive
David Ahern writes:
> Number of nexthops and number of alive nexthops are tracked using an
> unsigned int. A route should never have more than 255 nexthops so
> convert both to u8. Update all references and intermediate variables
> to consistently use u8 as well.
>
> Shrinks the size of mpls_rout
Hi Arushi,
[auto build test ERROR on nf-next/master]
[also build test ERROR on v4.11-rc4 next-20170324]
[if your patch is applied to the wrong git tree, please drop us a note to help
improve the system]
url:
https://github.com/0day-ci/linux/commits/Arushi-Singhal/net-netfilters-Remove-typede
> -Original Message-
> From: Colin King [mailto:colin.k...@canonical.com]
> Sent: Saturday, March 25, 2017 10:17 AM
> To: KY Srinivasan ; Haiyang Zhang
> ; Stephen Hemminger ;
> de...@linuxdriverproject.org; netdev@vger.kernel.org
> Cc: kernel-janit...@vger.kernel.org; linux-ker...@vger.k
> -Original Message-
> From: Colin King [mailto:colin.k...@canonical.com]
> Sent: Saturday, March 25, 2017 10:27 AM
> To: KY Srinivasan ; Haiyang Zhang
> ; Stephen Hemminger ;
> de...@linuxdriverproject.org; netdev@vger.kernel.org
> Cc: kernel-janit...@vger.kernel.org; linux-ker...@vger.k
Hi all,
Today's linux-next merge of the gfs2 tree got a conflict in:
net/core/secure_seq.c
between commit:
28ee1b746f49 ("secure_seq: downgrade to per-host timestamp offsets")
from the net tree and commit:
a30aad50c26c ("tcp: rename *_sequence_number() to *_seq_and_tsoff()")
from the g
Hi all,
Today's linux-next merge of the gfs2 tree got a conflict in:
drivers/net/usb/r8152.c
between commit:
2f25abe6bac5 ("r8152: prevent the driver from transmitting packets with
carrier off")
from the net tree and commit:
ce594e9824ab ("r8152: simply the arguments")
from the gfs2 a
The 0-day builder identified some issues with the four RFC patches I
sent out before the weekend, I'll be sending v2 tomorrow. Sorry for
the noise.
--
RMK's Patch system: http://www.armlinux.org.uk/developer/patches/
FTTC broadband for 0.8mile line: currently at 9.6Mbps down 400kbps up
according
On Sun, 2017-03-26 at 10:55 -0700, John Fastabend wrote:
> On 17-03-26 03:11 AM, Benjamin Herrenschmidt wrote:
> > Hi !
> >
> > It's not 100% clear to me looking at various drivers what is
> > considered "rx_pause" and what is "tx_pause" (from the ethtool
> > terminology).
> >
> > Is "rx_pause" a
The ethtool api {get|set}_settings is deprecated.
We move this driver to new api {get|set}_link_ksettings.
As I don't have the hardware, I'd be very pleased if
someone may test this patch.
Signed-off-by: Philippe Reynes
---
drivers/net/ethernet/tehuti/tehuti.c | 43 ++-
The series is aimed at replacing struct timespec which is not
y2038 safe with y2038 safe struct timespec64 for k_clock interfaces.
The series also replaces struct itimerspec which uses struct timespec
internally with struct itimerspec64 for the k_clock interfaces.
The series does not change the sy
While generating PDFs from the man pages, I saw the warning below from
several files. Compared the tc-matchall.8 with bridge.8 and used .RI
instead of .R. It should have no effect on the man page rendering.
`R' is a string (producing the registered sign), not a macro.
Signed-off-by: Alexander
struct timespec is not y2038 safe on 32 bit machines.
The posix clocks apis use struct timespec directly and
through struct itimerspec.
Replace the posix clock interfaces to use
struct timespec64 and struct itimerspec64 instead.
Also fix up their implementations accordingly.
Note that the clock_
On 3/24/17, 3:21 PM, David Ahern wrote:
> If the device for a nexthop in a multipath route is deleted, the nexthop
> is effectively removed from the route. Currently, a route dump still
> returns the nexhop though without the device set:
>
> $ ip -f mpls ro ls
> 100
> nexthopvia inet 10.11.1.
On 17-03-26 03:11 AM, Benjamin Herrenschmidt wrote:
> Hi !
>
> It's not 100% clear to me looking at various drivers what is
> considered "rx_pause" and what is "tx_pause" (from the ethtool
> terminology).
>
> Is "rx_pause" about receiving pause frame to throttle the transmitter
> or is it about s
On 3/24/17, 3:21 PM, David Ahern wrote:
> When all devices for all nexthops in a route have been deleted, the
> route is effectively dead, so remove it.
>
> Signed-off-by: David Ahern
>
Acked-by: Roopa Prabhu
David Laight noticed the support for MSG_MORE with datamsg->force_delay
didn't really work as we expected, as the first msg with MSG_MORE set
would always block the following chunks' dequeuing.
This Patch is to rewrite it by saving the MSG_MORE flag into assoc as
David Laight suggested.
asoc->for
On Wed, 2017-03-22 at 21:22 +0200, Andy Shevchenko wrote:
> In some cases nfc_dbg() is useful. Add such macro to a header.
>
I think we may drop this, since the idea is to get rid of such macros
(as I read back in 2011 in commit message of change that removed
nfc_dbg() one).
I will re-do depende
I've got a few other races in padata, I think, that I'm working on
fixing. If these pan out, I'll submit them exclusively to -crypto
instead of -netdev, to avoid this confusion next time. Of course, if
I'm able to fix these, then I'll probably be bald from pulling my hair
out during this insane deb
On 26/03/2017 00:50, Jakub Kicinski wrote:
> On Wed, 8 Mar 2017 16:03:51 +0200, Gal Pressman wrote:
>> This ethtool patch adds support to set and get the current RSS hash
>> function for the device through the new hfunc mask field in the
>> ethtool_rxfh struct. Kernel supported hash function names
On 26/03/2017 11:21 AM, Tariq Toukan wrote:
On 23/03/2017 4:51 PM, Mel Gorman wrote:
On Thu, Mar 23, 2017 at 02:43:47PM +0100, Jesper Dangaard Brouer wrote:
On Wed, 22 Mar 2017 23:40:04 +
Mel Gorman wrote:
On Wed, Mar 22, 2017 at 07:39:17PM +0200, Tariq Toukan wrote:
This modificati
Hi !
It's not 100% clear to me looking at various drivers what is
considered "rx_pause" and what is "tx_pause" (from the ethtool
terminology).
Is "rx_pause" about receiving pause frame to throttle the transmitter
or is it about sending pause frames when the receiver gets full ?
Thanks,
Ben.
On Sat, Mar 25, 2017 at 6:54 PM, Tom Herbert wrote:
> On Fri, Mar 24, 2017 at 2:52 PM, Saeed Mahameed wrote:
>> Hi Dave,
>>
>> This series provides some preformancee optimizations for mlx5e
>> driver, especially for XDP TX flows.
>>
>> 1st patch is a simple change of rmb to dma_rmb in CQE fetch r
On 23/03/2017 4:51 PM, Mel Gorman wrote:
On Thu, Mar 23, 2017 at 02:43:47PM +0100, Jesper Dangaard Brouer wrote:
On Wed, 22 Mar 2017 23:40:04 +
Mel Gorman wrote:
On Wed, Mar 22, 2017 at 07:39:17PM +0200, Tariq Toukan wrote:
This modification may slow allocations from IRQ context slight
27 matches
Mail list logo