Re: [PATCH net] multicast: remove useless parameter for group add

2018-07-21 Thread David Miller
From: Hangbin Liu Date: Fri, 20 Jul 2018 14:07:42 +0800 > Remove the mode parameter for igmp/igmp6_group_added as we can get it > from first parameter. > > Fixes: 6e2059b53f988 (ipv4/igmp: init group mode as INCLUDE when join source > group) > Fixes: c7ea20c9da5b9 (ipv6/mcast: init as INCLUDE

Re: [PATCH] net: dsa: mv88e6xxx: fix races between lock and irq freeing

2018-07-21 Thread David Miller
From: Uwe Kleine-König Date: Fri, 20 Jul 2018 11:53:15 +0200 > free_irq() waits until all handlers for this IRQ have completed. As the > relevant handler (mv88e6xxx_g1_irq_thread_fn()) takes the chip's reg_lock > it might never return if the thread calling free_irq() holds this lock. > > For

[PATCH net] ipv6: use fib6_info_hold_safe() when necessary

2018-07-21 Thread Wei Wang
From: Wei Wang In the code path where only rcu read lock is held, e.g. in the route lookup code path, it is not safe to directly call fib6_info_hold() because the fib6_info may already have been deleted but still exists in the rcu grace period. Holding reference to it could cause double free and

Re: [PATCH 4/4] net: dsa: Add Lantiq / Intel DSA driver for vrx200

2018-07-21 Thread David Miller
From: Hauke Mehrtens Date: Sat, 21 Jul 2018 21:13:58 +0200 > + // start the table access: Please stick to C-style comments, except perhaps in the SPDX identifiers. Thank you.

Re: [PATCH net] net: skb_segment() should not return NULL

2018-07-21 Thread David Miller
From: Eric Dumazet Date: Thu, 19 Jul 2018 16:04:38 -0700 > syzbot caught a NULL deref [1], caused by skb_segment() > > skb_segment() has many "goto err;" that assume the @err variable > contains -ENOMEM. > > A successful call to __skb_linearize() should not clear @err, > otherwise a subsequent

Re: [PATCH net] net/ipv6: Fix linklocal to global address with VRF

2018-07-21 Thread David Miller
From: dsah...@kernel.org Date: Thu, 19 Jul 2018 12:41:18 -0700 > From: David Ahern > > Example setup: > host: ip -6 addr add dev eth1 2001:db8:104::4 >where eth1 is enslaved to a VRF > > switch: ip -6 ro add 2001:db8:104::4/128 dev br1 > where br1 only has an

Re: [net-next v5 3/3] net/tls: Remove redundant array allocation.

2018-07-21 Thread David Miller
From: Vakul Garg Date: Thu, 19 Jul 2018 21:56:13 +0530 > In function decrypt_skb(), array allocation in case when sgout is NULL > is unnecessary. Instead, local variable sgin_arr[] can be used. > > Signed-off-by: Vakul Garg Hmmm... Dave, can you take a look at this? Do you think there might

Re: [PATCH net-next 4/4] act_mirred: use ACT_MIRRED when possible

2018-07-21 Thread David Miller
From: Paolo Abeni Date: Thu, 19 Jul 2018 15:02:29 +0200 > kernel openswitch datapath. ^^ "openvswitch"

Re: [PATCH net] net: phy: consider PHY_IGNORE_INTERRUPT in phy_start_aneg_priv

2018-07-21 Thread David Miller
From: Heiner Kallweit Date: Thu, 19 Jul 2018 08:15:16 +0200 > The situation described in the comment can occur also with > PHY_IGNORE_INTERRUPT, therefore change the condition to include it. > > Signed-off-by: Heiner Kallweit Applied and queued up for -stable, thanks.

Re: [PATCH net 0/3] qed: Fix series II.

2018-07-21 Thread David Miller
From: Sudarsana Reddy Kalluru Date: Wed, 18 Jul 2018 22:50:01 -0700 > The patch series fixes few issues in the qed driver. > > Please consider applying it to 'net' branch. Series applied, thanks.

Re: [PATCH 3/4] net: lantiq: Add Lantiq / Intel vrx200 Ethernet driver

2018-07-21 Thread Hauke Mehrtens
On 07/21/2018 10:25 PM, John Crispin wrote: > > > On 21/07/18 21:13, Hauke Mehrtens wrote: >> + * Copyright (C) 2012 John Crispin > that is not my mail addr :-) >     John Thanks for the information, I fixed your mail address. Hauke

Re: [PATCH 3/4] net: lantiq: Add Lantiq / Intel vrx200 Ethernet driver

2018-07-21 Thread John Crispin
On 21/07/18 21:13, Hauke Mehrtens wrote: + * Copyright (C) 2012 John Crispin that is not my mail addr :-)     John

[PATCH 4/4] net: dsa: Add Lantiq / Intel DSA driver for vrx200

2018-07-21 Thread Hauke Mehrtens
This adds the DSA driver for the GSWIP Switch found in the VRX200 SoC. This switch is integrated in the DSL SoC, this SoC uses a GSWIP version 2.0, there are other SoCs using different versions of this IP block, but this driver was only tested with the version found in the VRX200. Currently only

[PATCH 3/4] net: lantiq: Add Lantiq / Intel vrx200 Ethernet driver

2018-07-21 Thread Hauke Mehrtens
This drives the PMAC between the GSWIP Switch and the CPU in the VRX200 SoC. This is currently only the very basic version of the Ethernet driver. Signed-off-by: Hauke Mehrtens --- MAINTAINERS | 2 + arch/mips/lantiq/xway/sysctrl.c | 2 +-

[PATCH 0/4] net: Add support for Lantiq / Intel vrx200 network

2018-07-21 Thread Hauke Mehrtens
This adds basic support for the GSWIP (Gigabit Switch) found in the VRX200 SoC. There are different versions of this IP core used in different SoCs, but this driver was currently only tested on the VRX200 SoC line, for other SoCs this driver probably need some adoptions to work. I also plan to

[PATCH 2/4] net: dsa: Add Lantiq / Intel GSWIP tag support

2018-07-21 Thread Hauke Mehrtens
This handles the tag added by the PMAC on the VRX200 SoC line. The GSWIP uses internally a GSWIP special tag which is located after the Ethernet header. The PMAC which connects the GSWIP to the CPU converts this special tag used by the GSWIP into the PMAC special tag which is added in front of

[PATCH 1/4] MIPS: lantiq: Do not enable IRQs in dma open

2018-07-21 Thread Hauke Mehrtens
When a DMA channel is opened the IRQ should not get activated automatically, this allows it to pull data out manually without the help of interrupts. This is needed for a workaround in the vrx200 Ethernet driver. Signed-off-by: Hauke Mehrtens --- arch/mips/lantiq/xway/dma.c| 1 -

[PATCH v2 bpf 0/3] Introduce BPF_ANNOTATE_KV_PAIR

2018-07-21 Thread Martin KaFai Lau
The series allows the BPF loader to figure out the btf_key_id and btf_value_id from a map's name by using BPF_ANNOTATE_KV_PAIR. It also removes the old 'typedef' way which requires two separate typedefs (one for the key and one for the value). By doing this, iproute2 and libbpf have one

[PATCH v2 bpf 2/3] bpf: Replace [u]int32_t and [u]int64_t in libbpf

2018-07-21 Thread Martin KaFai Lau
This patch replaces [u]int32_t and [u]int64_t usage with __[su]32 and __[su]64. The same change goes for [u]int16_t and [u]int8_t. Fixes: 8a138aed4a80 ("bpf: btf: Add BTF support to libbpf") Signed-off-by: Martin KaFai Lau --- tools/lib/bpf/btf.c| 28 +---

[PATCH v2 bpf 3/3] bpf: Introduce BPF_ANNOTATE_KV_PAIR

2018-07-21 Thread Martin KaFai Lau
This patch introduces BPF_ANNOTATE_KV_PAIR to signal the bpf loader about the btf key_type and value_type of a bpf map. Please refer to the changes in test_btf_haskv.c for its usage. Both iproute2 and libbpf loader will then have the same convention to find out the map's btf_key_type_id and

[PATCH v2 bpf 1/3] bpf: btf: Sync uapi btf.h to tools

2018-07-21 Thread Martin KaFai Lau
This patch sync the uapi btf.h to tools/ Fixes: 36fc3c8c282c bpf: btf: Clean up BTF_INT_BITS() in uapi btf.h Signed-off-by: Martin KaFai Lau --- tools/include/uapi/linux/btf.h | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/tools/include/uapi/linux/btf.h

Re: [pull request][net 0/8] Mellanox, mlx5 fixes 2018-07-18

2018-07-21 Thread David Miller
From: Saeed Mahameed Date: Wed, 18 Jul 2018 18:26:04 -0700 > The following series provides fixes to mlx5 core and net device driver. > > Please pull and let me know if there's any problem. Pulled, thanks Saeed. Based upon the thread with Or, it would be useful to do some auditing and make

Re: [PATCH net-next 00/11] s390/qeth: updates 2018-07-19

2018-07-21 Thread David Miller
From: Julian Wiedmann Date: Thu, 19 Jul 2018 12:43:47 +0200 > please apply one more round of qeth patches to net-next. > This brings additional performance improvements for the transmit code, > and some refactoring to pave the way for using netdev_priv. > Also, two minor fixes for rare corner

Re: [PATCH bpf 3/3] bpf: Introduce BPF_ANNOTATE_KV_PAIR

2018-07-21 Thread Martin KaFai Lau
On Fri, Jul 20, 2018 at 06:39:33PM -0700, Martin KaFai Lau wrote: > This patch introduces BPF_ANNOTATE_KV_PAIR to signal the > bpf loader about the btf key_type and value_type of a bpf map. > Please refer to the changes in test_btf_haskv.c for its usage. > Both iproute2 and libbpf loader will then

RE: MY NAME IS MRS BELLA YOSTIN MOHAMMAD

2018-07-21 Thread Mrs Bella Yostin Mohammad
Hello Dear. My Name is Mrs. Bella Yostin Mohammad, I got your contact from a business directory search and I decided to contact you directly. well am originally from South Africa, but based in London, i am searching for a reliable and honest and understanding person to go into partnership in

[PATCH net-next 2/2] net: phy: use helper phy_polling_mode

2018-07-21 Thread Heiner Kallweit
Make use of new helper phy_polling_mode(). Signed-off-by: Heiner Kallweit --- drivers/net/phy/phy.c | 8 1 file changed, 4 insertions(+), 4 deletions(-) diff --git a/drivers/net/phy/phy.c b/drivers/net/phy/phy.c index 914fe8e6..7ade22a7 100644 --- a/drivers/net/phy/phy.c +++

[PATCH v2 net-next] net: phy: add GBit master / slave error detection

2018-07-21 Thread Heiner Kallweit
Certain PHY's have issues when operating in GBit slave mode and can be forced to master mode. Examples are RTL8211C, also the Micrel PHY driver has a DT setting to force master mode. If two such chips are link partners the autonegotiation will fail. Standard defines a self-clearing on read,

[PATCH net-next 1/2] net: phy: add helper phy_polling_mode

2018-07-21 Thread Heiner Kallweit
Add a helper for checking whether polling is used to detect PHY status changes. Signed-off-by: Heiner Kallweit --- include/linux/phy.h | 10 ++ 1 file changed, 10 insertions(+) diff --git a/include/linux/phy.h b/include/linux/phy.h index 075c2f77..cd6f637c 100644 ---

Re: [PATCH bpf] xdp: add NULL pointer check in __xdp_return()

2018-07-21 Thread Taehee Yoo
2018-07-21 2:18 GMT+09:00 Martin KaFai Lau : > On Sat, Jul 21, 2018 at 01:04:45AM +0900, Taehee Yoo wrote: >> rhashtable_lookup() can return NULL. so that NULL pointer >> check routine should be added. >> >> Fixes: 02b55e5657c3 ("xdp: add MEM_TYPE_ZERO_COPY") >> Signed-off-by: Taehee Yoo >> ---

Re: pull-request: bpf-next 2018-07-20

2018-07-21 Thread David Miller
From: Daniel Borkmann Date: Sat, 21 Jul 2018 00:01:10 +0200 > The following pull-request contains BPF updates for your *net-next* tree. > > The main changes are: > > 1) Add sharing of BPF objects within one ASIC: this allows for reuse of >the same program on multiple ports of a device, and

Re: pull-request: bpf 2018-07-20

2018-07-21 Thread David Miller
From: Daniel Borkmann Date: Fri, 20 Jul 2018 23:24:43 +0200 > The following pull-request contains BPF updates for your *net* tree. > > The main changes are: > > 1) Fix in BPF Makefile to detect llvm-objcopy in a more robust way which is >needed for pahole's BTF converter and minor UAPI

[PATCH] net: Init backlog NAPI's gro_hash.

2018-07-21 Thread David Miller
Based upon a patch by Sean Tranchetti. Fixes: d4546c2509b1 ("net: Convert GRO SKB handling to list_head.") Signed-off-by: David S. Miller --- net/core/dev.c | 18 -- 1 file changed, 12 insertions(+), 6 deletions(-) diff --git a/net/core/dev.c b/net/core/dev.c index

Re: [PATCH net-next] net: gro: Initialize backlog NAPI's gro_list

2018-07-21 Thread David Miller
From: Sean Tranchetti Date: Fri, 20 Jul 2018 17:53:23 -0600 > @@ -9556,6 +9556,7 @@ static int __init net_dev_init(void) > > sd->backlog.poll = process_backlog; > sd->backlog.weight = weight_p; > + INIT_LIST_HEAD(>backlog.gro_list); > } > >