[PATCH] bonding: Fix time comparison

2007-12-05 Thread David Sterba
bonding: Fix time comparison Use macros for comparing jiffies. Jiffies' wrap caused missed events and hangs. Module reinsert was needed to make bonding work again. Signed-off-by: David Sterba <[EMAIL PROTECTED]> --- drivers/net/bonding/bond_main.c | 25 +--

Re: [PATCH 10/10] fs:btrfs: return -ENOMEM on allocation failure.

2017-09-13 Thread David Sterba
On Wed, Sep 13, 2017 at 01:02:19PM +0530, Allen Pais wrote: > Signed-off-by: Allen Pais > --- > fs/btrfs/check-integrity.c | 2 +- > 1 file changed, 1 insertion(+), 1 deletion(-) > > diff --git a/fs/btrfs/check-integrity.c b/fs/btrfs/check-integrity.c > index 7d5a9b5..efa4c23 100644 > --- a/fs/b

Re: [PATCH 3/8] fs: btrfs: remove unused hardirq.h

2017-11-20 Thread David Sterba
is Mason > Cc: Josef Bacik > Cc: David Sterba > Cc: linux-bt...@vger.kernel.org Acked-by: David Sterba

Re: [PATCH 3/3] btrfs: tree-checker: Avoid accidental stack VLA

2018-03-08 Thread David Sterba
rg/lkml/2018/3/7/621 > > Signed-off-by: Kees Cook Acked-by: David Sterba for whatever name you decide for the max macro.

Re: get_user_pages returning 0 (was Re: kernel BUG at drivers/vhost/vhost.c:LINE!)

2018-03-19 Thread David Sterba
On Mon, Mar 19, 2018 at 05:09:28PM +0200, Michael S. Tsirkin wrote: > Hello! > The following code triggered by syzbot > > r = get_user_pages_fast(log, 1, 1, &page); > if (r < 0) > return r; > BUG_ON(r != 1); > > Just looking at get_user_pages_fast's docu

Re: [kernel-hardening] Re: [RFC v4 02/18] bpf: Move u64_to_ptr() to BPF headers and inline it

2016-10-26 Thread David Sterba
On Wed, Oct 26, 2016 at 09:19:08AM +0200, Arnd Bergmann wrote: > On Wednesday, October 26, 2016 8:56:38 AM CEST Mickaël Salaün wrote: > > include/linux/bpf.h | 6 ++ > > kernel/bpf/syscall.c | 6 -- > > 2 files changed, 6 insertions(+), 6 deletions(-) > > > > diff --git a/include/linux/b

Re: [PATCH 5/6] treewide: use kv[mz]alloc* rather than opencoded variants

2017-01-12 Thread David Sterba
ven when the memory allocator would > succeed after several more reclaim/compaction attempts previously. There > is no guarantee something like that happens though. > > This patch converts many of those places to kv[mz]alloc* helpers because > they are more conservative. For the btrfs bits, Acked-by: David Sterba

Re: [PATCH 07/12] fs: btrfs: Use ktime_get_real_ts for root ctime

2017-04-12 Thread David Sterba
are used for vfs inode times as well. These can be > transitioned to using timespec64 when btrfs internally > changes to use timespec64 as well. > > Signed-off-by: Deepa Dinamani > Acked-by: David Sterba > Reviewed-by: Arnd Bergmann I'm going to add the patch to my 4.12 queue and will let Andrew know.

Re: KASAN: use-after-free Write in hci_conn_del

2020-08-10 Thread David Sterba
On Mon, Aug 10, 2020 at 08:35:08PM -0700, syzbot wrote: > syzbot has bisected this issue to: > > commit 6a3c7f5c87854e948c3c234e5f5e745c7c553722 > Author: Nikolay Borisov > Date: Thu May 28 08:05:13 2020 + > > btrfs: don't balance btree inode pages from buffered write path This does n

Re: [PATCH] net: ethernet: mscc: fix missing brace warning for old compilers

2020-11-02 Thread David Sterba
On Mon, Nov 02, 2020 at 01:56:55PM +, Vladimir Oltean wrote: > On Mon, Nov 02, 2020 at 09:41:36PM +0800, Pujin Shi wrote: > > For older versions of gcc, the array = {0}; will cause warnings: > > > > drivers/net/ethernet/mscc/ocelot_vcap.c: In function 'is1_entry_set': > > drivers/net/ethernet/

Re: [PATCH v4 3/3] btrfs: Use kfree() in btrfs_ioctl_get_subvol_info()

2020-06-16 Thread David Sterba
On Mon, Jun 15, 2020 at 09:57:18PM -0400, Waiman Long wrote: > In btrfs_ioctl_get_subvol_info(), there is a classic case where kzalloc() > was incorrectly paired with kzfree(). According to David Sterba, there > isn't any sensitive information in the subvol_info that needs to be &g

Re: [PATCH v4 0/3] mm, treewide: Rename kzfree() to kfree_sensitive()

2020-06-16 Thread David Sterba
On Tue, Jun 16, 2020 at 11:53:50AM -0700, Joe Perches wrote: > On Mon, 2020-06-15 at 21:57 -0400, Waiman Long wrote: > > v4: > > - Break out the memzero_explicit() change as suggested by Dan Carpenter > > so that it can be backported to stable. > > - Drop the "crypto: Remove unnecessary me