Re: [PATCH] net/mlx4_core: Use min_t instead of if for consistency

2017-05-11 Thread Johannes Thumshirn
n2_), \ x, y) Did you compile this patch? -- Johannes Thumshirn Storage jthumsh...@suse.de+49 911 74053 689 SUSE LINUX GmbH, Maxfeldstr. 5, 90409 Nürnberg GF: Felix Imendörffer, Jane Smithard, Graham Norton HRB 21

Re: [PATCHv2 3/5] rds: ib: remove redundant ib_dealloc_fmr

2017-03-09 Thread Johannes Thumshirn
On 03/09/2017 10:20 AM, Zhu Yanjun wrote: > The function ib_dealloc_fmr will never be called. As such, it should > be removed. > > Cc: Joe Jin <joe@oracle.com> > Cc: Junxiao Bi <junxiao...@oracle.com> > Signed-off-by: Zhu Yanjun <yanjun@oracle.com> &g

Re: [PATCH 22/29] drivers, scsi: convert iscsi_task.refcount from atomic_t to refcount_t

2017-03-09 Thread Johannes Thumshirn
> This looks OK to me. >>>> >>>> Acked-by: Chris Leech <cle...@redhat.com> >>> >>> Thank you for review! Do you have a tree that can take this change? >> >> Hi Elena, >> >> iscsi like fcoe should go via the SCSI tree. > > Tha

Re: [PATCH 22/29] drivers, scsi: convert iscsi_task.refcount from atomic_t to refcount_t

2017-03-09 Thread Johannes Thumshirn
gned-off-by: Kees Cook <keesc...@chromium.org> >>> Signed-off-by: David Windsor <dwind...@gmail.com> >> >> This looks OK to me. >> >> Acked-by: Chris Leech <cle...@redhat.com> > > Thank you for review! Do you have a tree that can take this change

Re: [PATCH 3/5] rds: ib: remove redundant ib_dealloc_fmr

2017-03-09 Thread Johannes Thumshirn
a NULL check (see http://lxr.free-electrons.com/source/mm/slab.c#L3811) so no need to do it here. -- Johannes Thumshirn Storage jthumsh...@suse.de+49 911 74053 689 SUSE LINUX GmbH, Maxfeldstr. 5, 90409 Nürnberg GF: Felix Im

Re: [PATCH 21/29] drivers, s390: convert fc_fcp_pkt.ref_cnt from atomic_t to refcount_t

2017-03-08 Thread Johannes Thumshirn
-after-free situations. The subject is wrong, should be something like "scsi: libfc convert fc_fcp_pkt.ref_cnt from atomic_t to refcount_t" but not s390. Other than that Acked-by: Johannes Thumshirn <j...@kernel.org> Turns out that it is better that all these patches go throug

Re: [PATCH 21/29] drivers, s390: convert fc_fcp_pkt.ref_cnt from atomic_t to refcount_t

2017-03-06 Thread Johannes Thumshirn
s. The subject is wrong, should be something like "scsi: libfc convert fc_fcp_pkt.ref_cnt from atomic_t to refcount_t" but not s390. Other than that Acked-by: Johannes Thumshirn <j...@kernel.org> -- Johannes Thumshirn

Re: [PATCHv1] net-next: treewide use is_vlan_dev() helper function.

2017-02-05 Thread Johannes Thumshirn
For drivers/scsi/fcoe/fcoe.c: Acked-by: Johannes Thumshirn <j...@kernel.org>

Re: [PATCH net] qed: fix old-style function definition

2016-12-16 Thread Johannes Thumshirn
old-style > function definition [-Wold-style-definition] > > This makes it a proper prototype. > > Fixes: fc831825f99e ("qed: Add support for hardware offloaded iSCSI.") > Signed-off-by: Arnd Bergmann <a...@arndb.de> > --- Looks good, Reviewed-by: Joha

Re: [RFC 1/6] qed: Add support for hardware offloaded iSCSI.

2016-10-20 Thread Johannes Thumshirn
you do not have strong > objections, I would like to keep it this way. No strong objections, I just don't think these lengthy blocks are readable, but I don't want to do too much bikeshedding about it. Thanks, Johannes -- Johannes Thumshirn Stora

Re: [RFC 2/6] qed: Add iSCSI out of order packet handling.

2016-10-19 Thread Johannes Thumshirn
qed_ooo_put_free_buffer(p_hwfn, p_hwfn->p_ooo_info, > + p_buffer); > + break; > + } > } > + > + /* Submit Tx buffers here */ > + while ((p_buffer = qed_ooo_get_ready_buffer(p_hwfn, > +

Re: [RFC 5/6] qedi: Add support for iSCSI session management.

2016-10-19 Thread Johannes Thumshirn
msecs_to_jiffies(timeout_ms)); Maybe: #define QEDI_OLDCON_STATE(q) ((q)->state == EP_STATE_OFLDCONN_FAILED || \ (q)->state == EP_STATE_OFLDCONN_COMPL) ret = wait_event_interruptible_timeout(qedi_ep->ofld_wait,

Re: [RFC 1/6] qed: Add support for hardware offloaded iSCSI.

2016-10-19 Thread Johannes Thumshirn
E(cdev, "Failed to gather task information\n"); > + qed_iscsi_stop(cdev); > + kfree(tid_info); > + return rc; > + } > + > + /* Fill task information */ > + tasks->size = tid_info->ti

Re: [RFC 3/6] qedi: Add QLogic FastLinQ offload iSCSI driver framework.

2016-10-19 Thread Johannes Thumshirn
quot;Unable to start tmf thread!\n"); > + rc = -ENODEV; > + goto free_cid_que; > + } > + > + sprintf(host_buf, "qedi_ofld%d", qedi->shost->host_no); > + qedi->offload_thread = create_work

Re: [PATCH 1/3] cw1200: Don't leak memory if krealloc failes

2016-09-30 Thread Johannes Thumshirn
On Fri, Sep 30, 2016 at 03:56:45PM +0300, Sergei Shtylyov wrote: > Hello. > > On 9/30/2016 3:11 PM, Johannes Thumshirn wrote: > > > The call to krealloc() in wsm_buf_reserve() directly assigns the newly > > returned memory to buf->begin. This is all fine except wh

[PATCH v2] cw1200: Don't leak memory if krealloc failes

2016-09-30 Thread Johannes Thumshirn
assign the memory to it we can mitigate the memory leak. Signed-off-by: Johannes Thumshirn <jthumsh...@suse.de> Cc: Johannes Berg <johan...@sipsolutions.net> --- drivers/net/wireless/st/cw1200/wsm.c | 16 +--- 1 file changed, 9 insertions(+), 7 deletions(-) Changes from v1: * Do

Re: [PATCH 1/3] cw1200: Don't leak memory if krealloc failes

2016-09-30 Thread Johannes Thumshirn
On Fri, Sep 30, 2016 at 02:29:39PM +0200, Johannes Berg wrote: > > > + tmp = krealloc(buf->begin, size, GFP_KERNEL | GFP_DMA); > > + if (tmp) { > > > I think that check is inverted? > > johannes Fu.. you're right, of cause it's !tmp. I'll resend. Thank

[PATCH 1/3] cw1200: Don't leak memory if krealloc failes

2016-09-30 Thread Johannes Thumshirn
assign the memory to it we can mitigate the memory leak. Signed-off-by: Johannes Thumshirn <jthumsh...@suse.de> --- drivers/net/wireless/st/cw1200/wsm.c | 16 +--- 1 file changed, 9 insertions(+), 7 deletions(-) diff --git a/drivers/net/wireless/st/cw1200/wsm.c b/drivers/net/wireless/st/

Re: [PATCH v3 0/6] Introduce pci_(request|release)_(mem|io)_regions

2016-06-08 Thread Johannes Thumshirn
On Tue, Jun 07, 2016 at 09:44:00AM +0200, Johannes Thumshirn wrote: > The first patch in this series introduces the following 4 helper functions to > the PCI core: > > * pci_request_mem_regions() > * pci_request_io_regions() > * pci_release_mem_regions() > * pci_release_io

[PATCH v3 0/6] Introduce pci_(request|release)_(mem|io)_regions

2016-06-07 Thread Johannes Thumshirn
, one for Atheros and one for Intel drivers. * Correctly named lpfc patch. * Converted init-path of lpfc driver as well. * Added Reviewed-by tags were appropriate. Johannes Thumshirn (6): PCI: Add helpers to request/release memory and I/O regions NVMe: Use pci_(request|release)_mem_regions lpfc

[PATCH v3 6/6] alx: Use pci_(request|release)_mem_regions

2016-06-07 Thread Johannes Thumshirn
Now that we do have pci_request_mem_regions() and pci_release_mem_regions() at hand, use it in the ethernet drivers. Suggested-by: Christoph Hellwig <h...@infradead.org> Signed-off-by: Johannes Thumshirn <jthumsh...@suse.de> Cc: Jay Cliburn <jclib...@gmail.com> Cc: Chr

[PATCH v3 5/6] ethernet/intel: Use pci_(request|release)_mem_regions

2016-06-07 Thread Johannes Thumshirn
Now that we do have pci_request_mem_regions() and pci_release_mem_regions() at hand, use it in the Intel ethernet drivers. Suggested-by: Christoph Hellwig <h...@infradead.org> Signed-off-by: Johannes Thumshirn <jthumsh...@suse.de> Cc: Jeff Kirsher <jeffrey.t.kirs...@intel.com> C

[PATCH v2 5/6] ethernet/intel: Use pci_(request|release)_mem_regions

2016-06-02 Thread Johannes Thumshirn
Now that we do have pci_request_mem_regions() and pci_release_mem_regions() at hand, use it in the Intel ethernet drivers. Suggested-by: Christoph Hellwig <h...@infradead.org> Signed-off-by: Johannes Thumshirn <jthumsh...@suse.de> Cc: Jeff Kirsher <jeffrey.t.kirs...@intel.com> C

[PATCH v2 6/6] alx: Use pci_(request|release)_mem_regions

2016-06-02 Thread Johannes Thumshirn
Now that we do have pci_request_mem_regions() and pci_release_mem_regions() at hand, use it in the ethernet drivers. Suggested-by: Christoph Hellwig <h...@infradead.org> Signed-off-by: Johannes Thumshirn <jthumsh...@suse.de> Cc: Jay Cliburn <jclib...@gmail.com> Cc: Chr

[PATCH v2 0/6] Introduce pci_(request|release)_(mem|io)_regions

2016-06-02 Thread Johannes Thumshirn
); Changes since v1: * Fixed indendatoin in pci.h patch to not cross the 80 chars boundary. * Split Ethernet patches into two, one for Atheros and one for Intel drivers. * Correctly named lpfc patch. * Converted init-path of lpfc driver as well. * Added Reviewed-by tags were appropriate. Johannes

Re: [PATCH 5/5] ethernet: Use pci_(request|release)_mem_regions

2016-06-01 Thread Johannes Thumshirn
On Wed, Jun 01, 2016 at 07:56:45AM -0700, Jeff Kirsher wrote: > On Wed, 2016-06-01 at 10:51 +0200, Johannes Thumshirn wrote: > > On Wed, Jun 01, 2016 at 12:59:56AM -0700, Christoph Hellwig wrote: > > > On Tue, May 31, 2016 at 02:05:13PM +0200, Johannes Thumshirn wrote: > >

Re: [PATCH 5/5] ethernet: Use pci_(request|release)_mem_regions

2016-06-01 Thread Johannes Thumshirn
On Wed, Jun 01, 2016 at 12:59:56AM -0700, Christoph Hellwig wrote: > On Tue, May 31, 2016 at 02:05:13PM +0200, Johannes Thumshirn wrote: > > Now that we do have pci_request_mem_regions() and pci_release_mem_regions() > > at > > hand, use it in the ethernet drivers. >

[PATCH 5/5] ethernet: Use pci_(request|release)_mem_regions

2016-05-31 Thread Johannes Thumshirn
Now that we do have pci_request_mem_regions() and pci_release_mem_regions() at hand, use it in the ethernet drivers. Suggested-by: Christoph Hellwig <h...@infradead.org> Signed-off-by: Johannes Thumshirn <jthumsh...@suse.de> Cc: Jay Cliburn <jclib...@gmail.com> Cc: Chr

[PATCH 0/5] Introduce pci_(request|release)_(mem|io)_regions

2016-05-31 Thread Johannes Thumshirn
); Johannes Thumshirn (5): PCI: Add helpers to request/release memory and I/O regions NVMe: Use pci_(request|release)_mem_regions scsi: Use pci_(request|release)_mem_regions GenWQE: Use pci_(request|release)_mem_regions ethernet: Use pci_(request|release)_mem_regions drivers/misc/genwqe

[PATCH] macvtap: Destroy minor_idr on module_exit

2015-07-08 Thread Johannes Thumshirn
; @@ exit(void) { ... idr_destroy(idr); ... } @ missing_module_idr_destroy depends on declares_idr defines_module_exit !on_exit_calls_destroy @ identifier declares_idr.idr, defines_module_exit.exit; @@ exit(void) { ... +idr_destroy(idr); } /SmPL Signed-off-by: Johannes Thumshirn jthumsh