[WIP 2/2] cli: search: multithread

2012-03-20 Thread Mark Walters
--- notmuch-search.c | 19 +++ 1 files changed, 19 insertions(+), 0 deletions(-) diff --git a/notmuch-search.c b/notmuch-search.c index f6061e4..2fa4231 100644 --- a/notmuch-search.c +++ b/notmuch-search.c @@ -436,6 +436,9 @@ notmuch_search_command (void *ctx, int argc, char *ar

[WIP 1/2] lib: multithread

2012-03-20 Thread Mark Walters
--- lib/notmuch.h | 12 lib/query.cc | 46 +- 2 files changed, 57 insertions(+), 1 deletions(-) diff --git a/lib/notmuch.h b/lib/notmuch.h index babd208..22dd69e 100644 --- a/lib/notmuch.h +++ b/lib/notmuch.h @@ -445,6 +445,18 @@ typed

[WIP 0/2] Thread based searching

2012-03-20 Thread Mark Walters
This is very definitely only a work in progress but there have been several requests for this or something similar on irc. It implements a very crude form of thread based search: the user can ask for all the threads that have a message matching the primary query and have a (possibly different) mes

Re: [PATCH v2 5/6] emacs: simplify `notmuch-show-get-messages-ids{, -search}'

2012-03-20 Thread Mark Walters
On Fri, 24 Feb 2012 23:30:39 +0100, Pieter Praet wrote: > * emacs/notmuch-show.el > > (notmuch-show-get-messages-ids): > If provided with optional arg SEPARATOR, return a string consisting > of all Message-Id's, separated by SEPARATOR. Also improve original > docstring wrt default

Re: [PATCH v2 5/6] emacs: simplify `notmuch-show-get-messages-ids{, -search}'

2012-03-20 Thread Mark Walters
On Fri, 24 Feb 2012 23:30:39 +0100, Pieter Praet wrote: > * emacs/notmuch-show.el > > (notmuch-show-get-messages-ids): > If provided with optional arg SEPARATOR, return a string consisting > of all Message-Id's, separated by SEPARATOR. Also improve original > docstring wrt default

Re: [PATCH v2 4/6] emacs: add optional predicate arg to `notmuch-show-mapc'

2012-03-20 Thread Mark Walters
On Fri, 24 Feb 2012 23:30:38 +0100, Pieter Praet wrote: > * emacs/notmuch-show.el (notmuch-show-mapc): > > If provided with optional argument PREDICATE, only call > FUNCTION if calling PREDICATE returns non-nil. > > Also correct original docstring: 's/thread/buffer/'. > --- > emacs/notmuc

Re: [PATCH v2 1/6] test: emacs: new tests "notmuch-show: {add, remove} multiple tags {to, from} single message"

2012-03-20 Thread Mark Walters
Hi > * test/emacs: > > - Rename subtests "{Add,Remove} tag from notmuch-show view" to > "notmuch-show: {add,remove} single tag {to,from} single message" > to be consistent with the following tests. > > - New subtest "notmuch-show: add multiple tags to single message": > `notmuch

[PATCH 7/7] python: wrap and use notmuch_database_destroy as destructor

2012-03-20 Thread Justus Winter
Adapt the go bindings to the notmuch_database_close split. Signed-off-by: Justus Winter <4win...@informatik.uni-hamburg.de> --- bindings/python/notmuch/database.py | 17 +++-- 1 files changed, 15 insertions(+), 2 deletions(-) diff --git a/bindings/python/notmuch/database.py b/bind

[PATCH 6/7] ruby: Use notmuch_database_destroy instead of notmuch_database_close

2012-03-20 Thread Justus Winter
Adapt the ruby bindings to the notmuch_database_close split. Signed-off-by: Justus Winter <4win...@informatik.uni-hamburg.de> --- bindings/ruby/database.c |2 +- 1 files changed, 1 insertions(+), 1 deletions(-) diff --git a/bindings/ruby/database.c b/bindings/ruby/database.c index 982fd59..b

[PATCH 5/7] go: Use notmuch_database_destroy instead of notmuch_database_close

2012-03-20 Thread Justus Winter
Adapt the go bindings to the notmuch_database_close split. Signed-off-by: Justus Winter <4win...@informatik.uni-hamburg.de> --- bindings/go/pkg/notmuch.go |4 ++-- 1 files changed, 2 insertions(+), 2 deletions(-) diff --git a/bindings/go/pkg/notmuch.go b/bindings/go/pkg/notmuch.go index c684

[PATCH 4/7] Use notmuch_database_destroy instead of notmuch_database_close

2012-03-20 Thread Justus Winter
Adapt notmuch-deliver to the notmuch_database_close split. Signed-off-by: Justus Winter <4win...@informatik.uni-hamburg.de> --- contrib/notmuch-deliver/src/main.c |2 +- 1 files changed, 1 insertions(+), 1 deletions(-) diff --git a/contrib/notmuch-deliver/src/main.c b/contrib/notmuch-delive

[PATCH 1/7] Split notmuch_database_close into two functions

2012-03-20 Thread Justus Winter
Formerly notmuch_database_close closed the xapian database and destroyed the talloc structure associated with the notmuch database object. Split notmuch_database_close into notmuch_database_close and notmuch_database_destroy. This makes it possible for long running programs to close the xapian dat

[PATCH 3/7] Use notmuch_database_destroy instead of notmuch_database_close

2012-03-20 Thread Justus Winter
Adapt the notmuch binaries source to the notmuch_database_close split. Signed-off-by: Justus Winter <4win...@informatik.uni-hamburg.de> --- notmuch-count.c |2 +- notmuch-dump.c|2 +- notmuch-new.c |2 +- notmuch-reply.c |2 +- notmuch-restore.c |2 +- notmuch-sear

[PATCH 2/7] NEWS: Document the notmuch_database_close split

2012-03-20 Thread Justus Winter
Signed-off-by: Justus Winter <4win...@informatik.uni-hamburg.de> --- NEWS | 12 1 files changed, 12 insertions(+), 0 deletions(-) diff --git a/NEWS b/NEWS index ed5e3c5..26fce67 100644 --- a/NEWS +++ b/NEWS @@ -52,6 +52,18 @@ Reply improvement using the JSON format reply body, a

[RFC] Split notmuch_database_close into two functions

2012-03-20 Thread Justus Winter
I propose to split the function notmuch_database_close into notmuch_database_close and notmuch_database_destroy so that long running processes like alot can close the database while still using data obtained from queries to that database. I've updated the tools, the go, ruby and python bindings to

[alot] announcing v0.3

2012-03-20 Thread Patrick Totzke
Hi everyone! I have just released version 0.3 of my terminal GUI `alot`; You can get a tarball here [0]. This release features many bugfixes, a revised config syntax and a fairly complete user and API manual [1]. Detailed usage updates since v0.21: * revised config syntax! * config file validat

[PATCH 2/2] man: Document 'config list' command

2012-03-20 Thread Peter Wang
Document the 'config list' command and its output. --- man/man1/notmuch-config.1 | 12 1 files changed, 12 insertions(+), 0 deletions(-) diff --git a/man/man1/notmuch-config.1 b/man/man1/notmuch-config.1 index 395cb9c..b9f81a5 100644 --- a/man/man1/notmuch-config.1 +++ b/man/man1/n

[PATCH 1/2] config: Add 'config list' command

2012-03-20 Thread Peter Wang
Add a command to list all keys in a given configuration section. One use is as follows: a MUA may prefer to store data in a central notmuch configuration file so that the data is accessible across different machines, e.g. an addressbook. The list command helps to implement features such as tab co

[PATCH 1/2] configure: add empty line after each missing component message

2012-03-20 Thread Tomi Ollila
Currently whenever message about missing GMime, Glib or talloc is printed the message is 2 lines, component info and its http location in next line. In the future the amount of lines will vary. To ease reading in these cases newline is added after each message. --- configure |4 +++- 1 files c

[PATCH 2/2] configure: print info about required gmime 2.4 or 2.6 versions

2012-03-20 Thread Tomi Ollila
In case required gmime (2.4 or 2.6) version if not found print information about both alternatives (and currently minimal 2.6 version that is needed). --- I'm not entirely happy about the implementation but I would be less happy to write static message that has the same spesific version informatio

[WIP 2/2] cli: search: multithread

2012-03-20 Thread Mark Walters
--- notmuch-search.c | 19 +++ 1 files changed, 19 insertions(+), 0 deletions(-) diff --git a/notmuch-search.c b/notmuch-search.c index f6061e4..2fa4231 100644 --- a/notmuch-search.c +++ b/notmuch-search.c @@ -436,6 +436,9 @@ notmuch_search_command (void *ctx, int argc, char *ar

[WIP 1/2] lib: multithread

2012-03-20 Thread Mark Walters
--- lib/notmuch.h | 12 lib/query.cc | 46 +- 2 files changed, 57 insertions(+), 1 deletions(-) diff --git a/lib/notmuch.h b/lib/notmuch.h index babd208..22dd69e 100644 --- a/lib/notmuch.h +++ b/lib/notmuch.h @@ -445,6 +445,18 @@ typed

[WIP 0/2] Thread based searching

2012-03-20 Thread Mark Walters
This is very definitely only a work in progress but there have been several requests for this or something similar on irc. It implements a very crude form of thread based search: the user can ask for all the threads that have a message matching the primary query and have a (possibly different) mes

[alot] announcing v0.3

2012-03-20 Thread Patrick Totzke
Hi everyone! I have just released version 0.3 of my terminal GUI `alot`; You can get a tarball here [0]. This release features many bugfixes, a revised config syntax and a fairly complete user and API manual [1]. Detailed usage updates since v0.21: * revised config syntax! * config file validat

[PATCH 1/2] Add GNU as a valid platform

2012-03-20 Thread David Bremner
On Mon, 5 Mar 2012 11:23:43 +0100, Justus Winter <4winter at informatik.uni-hamburg.de> wrote: > Signed-off-by: Justus Winter <4winter at informatik.uni-hamburg.de> > --- > configure |6 +++--- > 1 files changed, 3 insertions(+), 3 deletions(-) pushed both. d

[PATCH 1/2] configure: store $IFS to $DEFAULT_IFS readonly variable

2012-03-20 Thread David Bremner
On Wed, 14 Mar 2012 16:59:59 +0200, Tomi Ollila wrote: > In the future, IFS value needs to be changed in a few places > in configure -- and then restored. Store the original value > to $DEFAULT_IFS for easy restoration. pushed both, d

notmuch release 0.12 now available

2012-03-20 Thread David Bremner
For compatibility with GMime 2.4's tolerance of "From " headers we require GMime 2.6 >= 2.6.7. What is notmuch === Notmuch is a system for indexing, searching, reading, and tagging large collections of email messages in maildir or mh format. It uses the Xapian lib

Re: [PATCH 1/2] Add GNU as a valid platform

2012-03-20 Thread David Bremner
On Mon, 5 Mar 2012 11:23:43 +0100, Justus Winter <4win...@informatik.uni-hamburg.de> wrote: > Signed-off-by: Justus Winter <4win...@informatik.uni-hamburg.de> > --- > configure |6 +++--- > 1 files changed, 3 insertions(+), 3 deletions(-) pushed both. d

Re: [PATCH 1/2] configure: store $IFS to $DEFAULT_IFS readonly variable

2012-03-20 Thread David Bremner
On Wed, 14 Mar 2012 16:59:59 +0200, Tomi Ollila wrote: > In the future, IFS value needs to be changed in a few places > in configure -- and then restored. Store the original value > to $DEFAULT_IFS for easy restoration. pushed both, d ___ notmuch mail

notmuch release 0.12 now available

2012-03-20 Thread David Bremner
Where to obtain notmuch 0.12 === http://notmuchmail.org/releases/notmuch-0.12.tar.gz Which can be verified with: http://notmuchmail.org/releases/notmuch-0.12.tar.gz.sha1 93effc7f8993c7b29b854adf8a2662b50a187819 notmuch-0.12.tar.gz http://notmuchmail.org/releases