[Nouveau] [PATCH] gk20a: add LTC device

2014-08-12 Thread Alexandre Courbot
LTC device is now required for PGRAPH to work, add it. Signed-off-by: Alexandre Courbot --- nvkm/engine/device/nve0.c | 1 + 1 file changed, 1 insertion(+) diff --git a/nvkm/engine/device/nve0.c b/nvkm/engine/device/nve0.c index 54ec53bc6252..cdf9147f32a1 100644 --- a/nvkm/engine/device/nve0.c

[Nouveau] [PATCH] platform: fix compilation error

2014-08-12 Thread Alexandre Courbot
nouveau_platform.c was still using the old nouveau_dev() macro, triggering a compilation error. Fix this. Signed-off-by: Alexandre Courbot --- Hi Ben, This one should probably go for 3.17 as Linus' tree currently does not compile if NOUVEAU_PLATFORM is selected. :( drm/nouveau_platform.c | 3 +

[Nouveau] [Bug 82527] xset dpms force {off, standby, suspend} returns after ~20 seconds (GeForce 8400 GS)

2014-08-12 Thread bugzilla-daemon
https://bugs.freedesktop.org/show_bug.cgi?id=82527 --- Comment #1 from Ilia Mirkin --- The bug you reference was about DP. But display stuff got a substantial rework in 3.16 (with an eye to DP) and even more changes are queued for 3.17. Would you mind giving the linux-3.17 branch a shot (http://c

[Nouveau] [Bug 82527] New: xset dpms force {off, standby, suspend} returns after ~20 seconds (GeForce 8400 GS)

2014-08-12 Thread bugzilla-daemon
https://bugs.freedesktop.org/show_bug.cgi?id=82527 Priority: medium Bug ID: 82527 Assignee: nouveau@lists.freedesktop.org Summary: xset dpms force {off,standby,suspend} returns after ~20 seconds (GeForce 8400 GS) QA Contact: xo

Re: [Nouveau] [PATCH 3/4] drm/nouveau: Replaced copy-pasted nv_wait with nv50_wait_dpms_ctrl helper

2014-08-12 Thread Ilia Mirkin
On Tue, Aug 12, 2014 at 5:05 AM, Joel Holdsworth wrote: > --- > drivers/gpu/drm/nouveau/core/engine/disp/dacnv50.c | 14 ++ > 1 file changed, 10 insertions(+), 4 deletions(-) > > diff --git a/drivers/gpu/drm/nouveau/core/engine/disp/dacnv50.c > b/drivers/gpu/drm/nouveau/core/engine/d

Re: [Nouveau] [PATCH 2/4] drm/nouveau: Replaced magic numbers with defines from nouveau_reg

2014-08-12 Thread Ilia Mirkin
As you've no doubt noticed, using "magic" numbers is the convention used throughout the driver (except dispnv04 which is in a world of its own), rather than the (occasional) macros. It's a trade-off, since the magic numbers are a little harder to read, but they're much easier to match up in traces.

Re: [Nouveau] Some initial tidy-ups and refactoring

2014-08-12 Thread Martin Peres
Le 12/08/2014 11:07, Joel Holdsworth a écrit : Ok just resubmitted. The reason for doing it this way is that my SMTP server seems not to be compatible with get send-mail SSL or TLS. I resubmitted via my work SMTP, so hopefully it works for you now. It went through ;) Thanks, it will be easier

Re: [Nouveau] Some initial tidy-ups and refactoring

2014-08-12 Thread Joel Holdsworth
On 12/08/14 00:55, Ilia Mirkin wrote: Please send these one email per patch, inlined. git send-email will generally do the right thing, but you can do it manually too (just be careful about preserving tabs, not wrapping, etc... most mail clients mess it up one way or another) On Mon, Aug 11, 201

[Nouveau] [PATCH 2/4] drm/nouveau: Replaced magic numbers with defines from nouveau_reg

2014-08-12 Thread Joel Holdsworth
--- drivers/gpu/drm/nouveau/core/engine/disp/dacnv50.c | 27 +- 1 file changed, 16 insertions(+), 11 deletions(-) diff --git a/drivers/gpu/drm/nouveau/core/engine/disp/dacnv50.c b/drivers/gpu/drm/nouveau/core/engine/disp/dacnv50.c index b36addf..61e29d6 100644 --- a/drivers/g

[Nouveau] [PATCH 0/4] Some initial tidy-ups and refactoring

2014-08-12 Thread Joel Holdsworth
The patches contain some tidy-up work, and refactoring that has arisen as a by-product of my initial work on adding TV support to nv50. Joel Holdsworth (4): drm/nouveau: Removed unneeded include in nvc0_fence.c drm/nouveau: Replaced magic numbers with defines from nouveau_reg drm/nouveau: Re

[Nouveau] [PATCH 3/4] drm/nouveau: Replaced copy-pasted nv_wait with nv50_wait_dpms_ctrl helper

2014-08-12 Thread Joel Holdsworth
--- drivers/gpu/drm/nouveau/core/engine/disp/dacnv50.c | 14 ++ 1 file changed, 10 insertions(+), 4 deletions(-) diff --git a/drivers/gpu/drm/nouveau/core/engine/disp/dacnv50.c b/drivers/gpu/drm/nouveau/core/engine/disp/dacnv50.c index 61e29d6..98bded6 100644 --- a/drivers/gpu/drm/no

[Nouveau] [PATCH 4/4] drm/nouveau: Refactored encoder create functions into common nv50_encoder_create helper

2014-08-12 Thread Joel Holdsworth
--- drivers/gpu/drm/nouveau/nv50_display.c | 178 + 1 file changed, 71 insertions(+), 107 deletions(-) diff --git a/drivers/gpu/drm/nouveau/nv50_display.c b/drivers/gpu/drm/nouveau/nv50_display.c index 03949ea..048e03e 100644 --- a/drivers/gpu/drm/nouveau/nv50_dis

[Nouveau] [PATCH 1/4] drm/nouveau: Removed unneeded include in nvc0_fence.c

2014-08-12 Thread Joel Holdsworth
--- drivers/gpu/drm/nouveau/nvc0_fence.c | 2 -- 1 file changed, 2 deletions(-) diff --git a/drivers/gpu/drm/nouveau/nvc0_fence.c b/drivers/gpu/drm/nouveau/nvc0_fence.c index becf19a..c9fc6f7 100644 --- a/drivers/gpu/drm/nouveau/nvc0_fence.c +++ b/drivers/gpu/drm/nouveau/nvc0_fence.c @@ -26,8 +2