[Nouveau] [Bug 92438] Segfault in pushbuf_kref when running the android emulator (qemu) on nv50

2015-10-13 Thread bugzilla-daemon
https://bugs.freedesktop.org/show_bug.cgi?id=92438 --- Comment #6 from Pierre Moreau --- FYI, latest Mesa release is 11.0.3. 10.4 was branched out in December 2014 (though it did receive some additional fixes up to March 2015), so you might want to try at least 10.6.x, or

[Nouveau] [Bug 92438] Segfault in pushbuf_kref when running the android emulator (qemu) on nv50

2015-10-13 Thread bugzilla-daemon
https://bugs.freedesktop.org/show_bug.cgi?id=92438 --- Comment #5 from Gabriele Svelto --- Still repros on mesa 10.4.6 and libdrm 2.4.65. -- You are receiving this mail because: You are the QA Contact for the bug. You are the assignee for the bug.

[Nouveau] [Bug 92438] Segfault in pushbuf_kref when running the android emulator (qemu) on nv50

2015-10-13 Thread bugzilla-daemon
https://bugs.freedesktop.org/show_bug.cgi?id=92438 --- Comment #4 from Gabriele Svelto --- I've started testing with different versions of mesa and libdrm. On my first try I could still repro with mesa 10.4.6 and libdrm 2.4.59. -- You are receiving this mail because:

[Nouveau] [PATCH v2 5/9] pci: implement pcie speed change on Fermi

2015-10-13 Thread Karol Herbst
v2: rename functions and simplify code a little Signed-off-by: Karol Herbst --- drm/nouveau/nvkm/subdev/pci/gf100.c | 59 + drm/nouveau/nvkm/subdev/pci/gf106.c | 5 drm/nouveau/nvkm/subdev/pci/gk104.c | 3 ++

[Nouveau] [PATCH v2 1/9] pci: add gk104 variant

2015-10-13 Thread Karol Herbst
v2: change email used in header Signed-off-by: Karol Herbst --- drm/nouveau/include/nvkm/subdev/pci.h | 1 + drm/nouveau/nvkm/engine/device/base.c | 20 +- drm/nouveau/nvkm/subdev/pci/Kbuild| 1 + drm/nouveau/nvkm/subdev/pci/gk104.c | 38

[Nouveau] [PATCH v2 7/9] bios/perf: parse the pci speed from the bios for tesla and newer cards

2015-10-13 Thread Karol Herbst
Signed-off-by: Karol Herbst --- drm/nouveau/include/nvkm/subdev/bios/perf.h | 2 ++ drm/nouveau/nvkm/subdev/bios/perf.c | 16 2 files changed, 18 insertions(+) diff --git a/drm/nouveau/include/nvkm/subdev/bios/perf.h

[Nouveau] [PATCH v2 8/9] perf: add fields for pci speed and width and use it for the pstates

2015-10-13 Thread Karol Herbst
Signed-off-by: Karol Herbst --- drm/nouveau/include/nvkm/subdev/clk.h | 3 +++ drm/nouveau/nvkm/subdev/clk/base.c| 2 ++ 2 files changed, 5 insertions(+) diff --git a/drm/nouveau/include/nvkm/subdev/clk.h b/drm/nouveau/include/nvkm/subdev/clk.h index

[Nouveau] [PATCH v2 2/9] pci: add gf106 variant

2015-10-13 Thread Karol Herbst
v2: change email used in header Signed-off-by: Karol Herbst --- drm/nouveau/include/nvkm/subdev/pci.h | 1 + drm/nouveau/nvkm/engine/device/base.c | 10 - drm/nouveau/nvkm/subdev/pci/Kbuild| 1 + drm/nouveau/nvkm/subdev/pci/gf106.c | 38

[Nouveau] [PATCH v2 3/9] pci: implement generic code for PCIe speed change

2015-10-13 Thread Karol Herbst
v2: rename and group functions Signed-off-by: Karol Herbst --- drm/nouveau/include/nvkm/subdev/pci.h | 14 +++ drm/nouveau/nvkm/subdev/pci/Kbuild| 1 + drm/nouveau/nvkm/subdev/pci/base.c| 5 ++ drm/nouveau/nvkm/subdev/pci/pcie.c| 165

[Nouveau] [PATCH v2 0/9] PCIEs speed change

2015-10-13 Thread Karol Herbst
overall the same as the old stuff, but with better namings and tirivialy improved code here and there Karol Herbst (9): pci: add gk104 variant pci: add gf106 variant pci: implement generic code for PCIe speed change pci: implement pcie speed change for tesla pci: implement pcie speed

[Nouveau] [PATCH v2 6/9] pci: implement PCIe speed change for kepler+

2015-10-13 Thread Karol Herbst
v2: rename functions Signed-off-by: Karol Herbst --- drm/nouveau/nvkm/subdev/pci/gk104.c | 196 1 file changed, 196 insertions(+) diff --git a/drm/nouveau/nvkm/subdev/pci/gk104.c b/drm/nouveau/nvkm/subdev/pci/gk104.c index

[Nouveau] [PATCH v2 4/9] pci: implement pcie speed change for tesla

2015-10-13 Thread Karol Herbst
v2: rename functions and simplify init Signed-off-by: Karol Herbst --- drm/nouveau/nvkm/subdev/pci/g84.c | 105 drm/nouveau/nvkm/subdev/pci/g94.c | 10 drm/nouveau/nvkm/subdev/pci/gf100.c | 5 ++

[Nouveau] [PATCH v2 9/9] perf: change pcie speed on pstate change

2015-10-13 Thread Karol Herbst
v2: remove error and only set link for pcie devices Signed-off-by: Karol Herbst --- drm/nouveau/nvkm/subdev/clk/base.c | 4 1 file changed, 4 insertions(+) diff --git a/drm/nouveau/nvkm/subdev/clk/base.c b/drm/nouveau/nvkm/subdev/clk/base.c index 7ae4f26..137e06f

[Nouveau] [PATCH 3/6] debugfs: we need a ctrl object for debugfs

2015-10-13 Thread Karol Herbst
Signed-off-by: Karol Herbst --- drm/nouveau/nouveau_debugfs.c | 30 ++ drm/nouveau/nouveau_debugfs.h | 26 ++ drm/nouveau/nouveau_drm.c | 2 ++ drm/nouveau/nouveau_drm.h | 1 + 4 files changed, 59 insertions(+)

[Nouveau] [PATCH 6/6] sysfs: remove pstate options and remove files

2015-10-13 Thread Karol Herbst
Signed-off-by: Karol Herbst --- drm/nouveau/Kbuild | 1 - drm/nouveau/nouveau_drm.c | 2 -- drm/nouveau/nouveau_sysfs.c | 33 - drm/nouveau/nouveau_sysfs.h | 8 4 files changed, 44 deletions(-) delete mode 100644

[Nouveau] [PATCH 4/6] debugfs: add copy of sysfs pstate interface ported to debugfs

2015-10-13 Thread Karol Herbst
Signed-off-by: Karol Herbst --- drm/nouveau/nouveau_debugfs.c | 144 +- 1 file changed, 142 insertions(+), 2 deletions(-) diff --git a/drm/nouveau/nouveau_debugfs.c b/drm/nouveau/nouveau_debugfs.c index 53d2233..d024ffa 100644 ---

[Nouveau] [PATCH 0/6] move pstate interface to debugfs

2015-10-13 Thread Karol Herbst
exposing the pstate interface through sysfs might make sense with no dynamic reclocking, we shouldn't expose it as sysfs interface, because we actually want to dynamic reclock the card later on. Doing it in debugfs on the other hand should be fine, also we need something like that later on, when

[Nouveau] [PATCH 1/6] debugfs: add infrastructure to add files with other fops than only read

2015-10-13 Thread Karol Herbst
this is somehow copied from i915 Signed-off-by: Karol Herbst --- drm/nouveau/nouveau_debugfs.c | 56 +-- 1 file changed, 54 insertions(+), 2 deletions(-) diff --git a/drm/nouveau/nouveau_debugfs.c b/drm/nouveau/nouveau_debugfs.c

[Nouveau] [PATCH 2/6] debugfs: rename functions to indicate they are used inside drm

2015-10-13 Thread Karol Herbst
we will need our own debugfs_init and cleanup functions, because nouveau_drm isn't ready while the drm ones are called by drm Signed-off-by: Karol Herbst --- drm/nouveau/nouveau_debugfs.c | 4 ++-- drm/nouveau/nouveau_debugfs.h | 9 + drm/nouveau/nouveau_drm.c

[Nouveau] [Bug 92438] Segfault in pushbuf_kref when running the android emulator (qemu) on nv50

2015-10-13 Thread bugzilla-daemon
https://bugs.freedesktop.org/show_bug.cgi?id=92438 --- Comment #7 from Gabriele Svelto --- After some fiddling with the various dependency I'm now testing on mesa 11.0.3. I haven't hit the bug just yet but I want to run the emulator for a while to be sure it's not just

[Nouveau] [PATCH 5/6] sysfs: remove sysfs interface

2015-10-13 Thread Karol Herbst
Signed-off-by: Karol Herbst --- drm/nouveau/nouveau_drm.c | 2 - drm/nouveau/nouveau_drm.h | 1 - drm/nouveau/nouveau_sysfs.c | 165 drm/nouveau/nouveau_sysfs.h | 13 4 files changed, 181 deletions(-) diff --git

[Nouveau] [Bug 92438] Segfault in pushbuf_kref when running the android emulator (qemu) on nv50

2015-10-13 Thread bugzilla-daemon
https://bugs.freedesktop.org/show_bug.cgi?id=92438 --- Comment #11 from Gabriele Svelto --- Created attachment 118860 --> https://bugs.freedesktop.org/attachment.cgi?id=118860=edit X log -- You are receiving this mail because: You are the QA Contact for the bug.

[Nouveau] [Bug 92438] Segfault in pushbuf_kref when running the android emulator (qemu) on nv50

2015-10-13 Thread bugzilla-daemon
https://bugs.freedesktop.org/show_bug.cgi?id=92438 --- Comment #9 from Gabriele Svelto --- I'm attaching a new dmesg/Xorg.0.log couple taken just after I hit the bug, they'll be probably easier to parse than the previous one. Especially the dmesg output has some

[Nouveau] [Bug 92438] Segfault in pushbuf_kref when running the android emulator (qemu) on nv50

2015-10-13 Thread bugzilla-daemon
https://bugs.freedesktop.org/show_bug.cgi?id=92438 Gabriele Svelto changed: What|Removed |Added Attachment #118838|0 |1

[Nouveau] [Bug 92438] Segfault in pushbuf_kref when running the android emulator (qemu) on nv50

2015-10-13 Thread bugzilla-daemon
https://bugs.freedesktop.org/show_bug.cgi?id=92438 --- Comment #8 from Gabriele Svelto --- I can still reproduce on mesa 11.0.3 / libdrm 2.4.65 though it takes longer to trigger the bug (a few minutes of usage). This is the backtrace when using these versions of mesa

[Nouveau] [PATCH v3 3/9] pci: implement generic code for PCIe speed change

2015-10-13 Thread Karol Herbst
v2: rename and group functions Signed-off-by: Karol Herbst --- drm/nouveau/include/nvkm/subdev/pci.h | 14 +++ drm/nouveau/nvkm/subdev/pci/Kbuild| 1 + drm/nouveau/nvkm/subdev/pci/base.c| 5 ++ drm/nouveau/nvkm/subdev/pci/pcie.c| 165

[Nouveau] [PATCH v3 7/9] bios/perf: parse the pci speed from the bios for tesla and newer cards

2015-10-13 Thread Karol Herbst
Signed-off-by: Karol Herbst --- drm/nouveau/include/nvkm/subdev/bios/perf.h | 2 ++ drm/nouveau/nvkm/subdev/bios/perf.c | 16 2 files changed, 18 insertions(+) diff --git a/drm/nouveau/include/nvkm/subdev/bios/perf.h

[Nouveau] [PATCH v3 6/9] pci: implement PCIe speed change for kepler+

2015-10-13 Thread Karol Herbst
v2: rename functions v3: remove pcie2 accessors Signed-off-by: Karol Herbst --- drm/nouveau/nvkm/subdev/pci/gk104.c | 186 1 file changed, 186 insertions(+) diff --git a/drm/nouveau/nvkm/subdev/pci/gk104.c

[Nouveau] [PATCH v3 8/9] perf: add fields for pci speed and width and use it for the pstates

2015-10-13 Thread Karol Herbst
Signed-off-by: Karol Herbst --- drm/nouveau/include/nvkm/subdev/clk.h | 3 +++ drm/nouveau/nvkm/subdev/clk/base.c| 2 ++ 2 files changed, 5 insertions(+) diff --git a/drm/nouveau/include/nvkm/subdev/clk.h b/drm/nouveau/include/nvkm/subdev/clk.h index

[Nouveau] [PATCH v3 4/9] pci: implement pcie speed change for tesla

2015-10-13 Thread Karol Herbst
v2: rename functions and simplify init v3: give g84/6 their own implementation Signed-off-by: Karol Herbst --- drm/nouveau/nvkm/subdev/pci/g84.c | 97 + drm/nouveau/nvkm/subdev/pci/g94.c | 18 +++

[Nouveau] [PATCH v3 1/9] pci: add gk104 variant

2015-10-13 Thread Karol Herbst
v2: change email used in header Signed-off-by: Karol Herbst --- drm/nouveau/include/nvkm/subdev/pci.h | 1 + drm/nouveau/nvkm/engine/device/base.c | 20 +- drm/nouveau/nvkm/subdev/pci/Kbuild| 1 + drm/nouveau/nvkm/subdev/pci/gk104.c | 38

[Nouveau] [PATCH v3 5/9] pci: implement pcie speed change on Fermi

2015-10-13 Thread Karol Herbst
v2: rename functions and simplify code a little Signed-off-by: Karol Herbst --- drm/nouveau/nvkm/subdev/pci/gf100.c | 59 + drm/nouveau/nvkm/subdev/pci/gf106.c | 5 drm/nouveau/nvkm/subdev/pci/gk104.c | 3 ++

[Nouveau] [PATCH v3 2/9] pci: add gf106 variant

2015-10-13 Thread Karol Herbst
v2: change email used in header Signed-off-by: Karol Herbst --- drm/nouveau/include/nvkm/subdev/pci.h | 1 + drm/nouveau/nvkm/engine/device/base.c | 10 - drm/nouveau/nvkm/subdev/pci/Kbuild| 1 + drm/nouveau/nvkm/subdev/pci/gf106.c | 38

[Nouveau] [PATCH v3 0/9] PCIEs speed change

2015-10-13 Thread Karol Herbst
I hope now the final revison of that patch series. I've taken care of 2 out of 3 comments from ben. I left the set_link and set_version name this way, because I can't figure any better name and because they are always used with pcie. in front, so they should fit in nice Ben: if you are strong

[Nouveau] [PATCH v3 9/9] perf: change pcie speed on pstate change

2015-10-13 Thread Karol Herbst
v2: remove error and only set link for pcie devices Signed-off-by: Karol Herbst --- drm/nouveau/nvkm/subdev/clk/base.c | 4 1 file changed, 4 insertions(+) diff --git a/drm/nouveau/nvkm/subdev/clk/base.c b/drm/nouveau/nvkm/subdev/clk/base.c index 7ae4f26..137e06f

[Nouveau] [Bug 92307] G98: WARNING: ... at include/drm/drm_crtc.h:1577 drm_helper_choose_encoder_dpms+0x8a/0x90 [drm_kms_helper]()

2015-10-13 Thread bugzilla-daemon
https://bugs.freedesktop.org/show_bug.cgi?id=92307 --- Comment #5 from poma --- Created attachment 118863 --> https://bugs.freedesktop.org/attachment.cgi?id=118863=edit dmesg 4.3.0-0.rc5.git0.1.fc24.x86_64+debug & nouveau git on G98 -- You are receiving this mail

[Nouveau] [PATCH v2] pll/gk104: fix PLL instability due to bad configuration with gddr5

2015-10-13 Thread Karol Herbst
this patch uses an approach closer to the nvidia driver to configure both PLLs for high gddr5 memory clocks (usually above 2400MHz) previously nouveau used the one PLL as it was used for the lower clocks and just adjusted the second PLL to get as close as possible to the requested clock. This

[Nouveau] [Bug 92307] NV50: WARNING: ... at include/drm/drm_crtc.h:1577 drm_helper_choose_encoder_dpms+0x8a/0x90 [drm_kms_helper]()

2015-10-13 Thread bugzilla-daemon
https://bugs.freedesktop.org/show_bug.cgi?id=92307 --- Comment #4 from poma --- (In reply to Stefan Huehner from comment #3) > Seeing same here when 'switching off' and 'on' again hdmi display connected > to a gm206 Goes - both, S3 RESUME and disable/enable the

[Nouveau] [Bug 92307] G98: WARNING: ... at include/drm/drm_crtc.h:1577 drm_helper_choose_encoder_dpms+0x8a/0x90 [drm_kms_helper]()

2015-10-13 Thread bugzilla-daemon
https://bugs.freedesktop.org/show_bug.cgi?id=92307 poma changed: What|Removed |Added Summary|NV50: WARNING: ... at |G98: WARNING: ... at

Re: [Nouveau] [PATCH] pll/gk104: fix PLL instability due to bad configuration with gddr5

2015-10-13 Thread Ben Skeggs
-BEGIN PGP SIGNED MESSAGE- Hash: SHA256 On 10/13/2015 06:18 AM, Karol Herbst wrote: > this patch uses an approach closer to the nvidia driver to > configure both PLLs for high gddr5 memory clocks (usually above > 2400MHz) > > previously nouveau used the one PLL as it was used for the

Re: [Nouveau] [PATCH v2 3/9] pci: implement generic code for PCIe speed change

2015-10-13 Thread Ben Skeggs
-BEGIN PGP SIGNED MESSAGE- Hash: SHA256 On 10/13/2015 07:44 PM, Karol Herbst wrote: > v2: rename and group functions > > Signed-off-by: Karol Herbst --- > drm/nouveau/include/nvkm/subdev/pci.h | 14 +++ > drm/nouveau/nvkm/subdev/pci/Kbuild| 1 + >

Re: [Nouveau] [PATCH v2 4/9] pci: implement pcie speed change for tesla

2015-10-13 Thread Ben Skeggs
-BEGIN PGP SIGNED MESSAGE- Hash: SHA256 On 10/13/2015 07:44 PM, Karol Herbst wrote: > v2: rename functions and simplify init > > Signed-off-by: Karol Herbst --- > drm/nouveau/nvkm/subdev/pci/g84.c | 105 > >

Re: [Nouveau] [PATCH v2 6/9] pci: implement PCIe speed change for kepler+

2015-10-13 Thread Ben Skeggs
-BEGIN PGP SIGNED MESSAGE- Hash: SHA256 On 10/13/2015 07:44 PM, Karol Herbst wrote: > v2: rename functions > > Signed-off-by: Karol Herbst --- > drm/nouveau/nvkm/subdev/pci/gk104.c | 196 > 1 file changed, 196 > insertions(+)

[Nouveau] [Bug 92306] GL Excess demo renders incorrectly on nv43

2015-10-13 Thread bugzilla-daemon
https://bugs.freedesktop.org/show_bug.cgi?id=92306 --- Comment #17 from Ben Skeggs --- (In reply to Ilia Mirkin from comment #14) > (In reply to Andrew Randrianasulu from comment #13) > > (In reply to Ilia Mirkin from comment #12) > > > (In reply to Andrew Randrianasulu from