Re: [Nouveau] [PATCH] x86: mmiotrace: Use cpumask_available for cpumask_var_t variables

2020-04-24 Thread Sedat Dilek
On Wed, Apr 8, 2020 at 11:36 PM Sedat Dilek wrote: [ ... ] > Feel free to add appropriate credits: > >Tested-by: Sedat Dilek > Re-tested with Linux v5.7-rc1 which shows this warning - with GCC v9.3 and LLVM/Clang v10.0.0 (and snapshot/pre-release of v10.0.1) on Debian/testing AMD64. - Sed

Re: [Nouveau] [PATCH 2/2] mm/thp: Rename pmd_mknotpresent() as pmd_mknotvalid()

2020-04-24 Thread Anshuman Khandual
On 04/21/2020 02:33 AM, Will Deacon wrote: > On Fri, Mar 20, 2020 at 10:24:17AM +0530, Anshuman Khandual wrote: >> pmd_present() is expected to test positive after pmdp_mknotpresent() as the >> PMD entry still points to a valid huge page in memory. pmdp_mknotpresent() >> implies that given PMD e

[Nouveau] [PATCH] x86: mmiotrace: Use cpumask_available for cpumask_var_t variables

2020-04-24 Thread Nathan Chancellor
When building with Clang + -Wtautological-compare and CONFIG_CPUMASK_OFFSTACK unset: arch/x86/mm/mmio-mod.c:375:6: warning: comparison of array 'downed_cpus' equal to a null pointer is always false [-Wtautological-pointer-compare] if (downed_cpus == NULL && ^~~

[Nouveau] [RFC v3 00/11] drm/nouveau: Introduce CRC support for gf119+

2020-04-24 Thread Lyude Paul
Nvidia released some documentation on how CRC support works on their GPUs, hooray! So: this patch series implements said CRC support in nouveau, along with adding some special debugfs interfaces for some relevant igt-gpu-tools tests that we'll be sending in just a short bit. This additionally add

Re: [Nouveau] [PATCH v2 03/17] drm: Nuke mode->vrefresh

2020-04-24 Thread Jani Nikula
On Fri, 03 Apr 2020, abhin...@codeaurora.org wrote: > On 2020-04-03 13:39, Ville Syrjala wrote: >> diff --git a/drivers/gpu/drm/drm_modes.c b/drivers/gpu/drm/drm_modes.c >> index fec1c33b3045..e3d5f011f7bd 100644 >> --- a/drivers/gpu/drm/drm_modes.c >> +++ b/drivers/gpu/drm/drm_modes.c >> @@ -759,9

Re: [Nouveau] [PATCH v2 03/17] drm: Nuke mode->vrefresh

2020-04-24 Thread Laurent Pinchart
Hi Ville, Thank you for the patch. On Fri, Apr 03, 2020 at 11:39:54PM +0300, Ville Syrjala wrote: > From: Ville Syrjälä > > Get rid of mode->vrefresh and just calculate it on demand. Saves > a bit of space and avoids the cached value getting out of sync > with reality. > > Mostly done with coc

[Nouveau] [PATCH 1/1] drm/nouveau: Use generic helper to check _PR3 presence

2020-04-24 Thread Kai-Heng Feng
Replace nouveau_pr3_present() in favor of a more generic one, pci_pr3_present(). Also the presence of upstream bridge _PR3 doesn't need to go hand in hand with device's _DSM, so check _PR3 before _DSM. Signed-off-by: Kai-Heng Feng --- drivers/gpu/drm/nouveau/nouveau_acpi.c | 44 ++--

Re: [Nouveau] [PATCH] x86: mmiotrace: Use cpumask_available for cpumask_var_t variables

2020-04-24 Thread Sedat Dilek
On Wed, Apr 8, 2020 at 10:53 PM Nathan Chancellor wrote: > > When building with Clang + -Wtautological-compare and > CONFIG_CPUMASK_OFFSTACK unset: > Hi Nathan, thanks for the quick patch. I can confirm I have no CONFIG_CPUMASK_OFFSTACK set. Regards, - Sedat - > arch/x86/mm/mmio-mod.c:375:6:

[Nouveau] [PATCH V2 0/2] mm/thp: Rename pmd_mknotpresent() as pmd_mkinvalid()

2020-04-24 Thread Anshuman Khandual
This series renames pmd_mknotpresent() as pmd_mkinvalid(). Before that it drops an existing pmd_mknotpresent() definition from powerpc platform which was never required as it defines it's pmdp_invalidate() through subscribing __HAVE_ARCH_PMDP_INVALIDATE. This does not create any functional change.

[Nouveau] [PATCH 3/5] drm/nouveau: utilize subconnector property for DP

2020-04-24 Thread Jeevan B
From: Oleg Vasilev Since DP-specific information is stored in driver's structures, every driver needs to implement subconnector property by itself. v2: rebase Cc: Ben Skeggs Cc: nouveau@lists.freedesktop.org Signed-off-by: Jeevan B Signed-off-by: Oleg Vasilev Reviewed-by: Emil Velikov ---

[Nouveau] [PATCH V2 2/2] mm/thp: Rename pmd_mknotpresent() as pmd_mkinvalid()

2020-04-24 Thread Anshuman Khandual
pmd_present() is expected to test positive after pmdp_mknotpresent() as the PMD entry still points to a valid huge page in memory. pmdp_mknotpresent() implies that given PMD entry is just invalidated from MMU perspective while still holding on to pmd_page() referred valid huge page thus also cleari

Re: [Nouveau] [PATCH 2/2] mm/thp: Rename pmd_mknotpresent() as pmd_mknotvalid()

2020-04-24 Thread Anshuman Khandual
On 04/21/2020 12:37 PM, Will Deacon wrote: > On Tue, Apr 21, 2020 at 04:57:26AM +0530, Anshuman Khandual wrote: >> >> >> On 04/21/2020 02:33 AM, Will Deacon wrote: >>> On Fri, Mar 20, 2020 at 10:24:17AM +0530, Anshuman Khandual wrote: pmd_present() is expected to test positive after pmdp_mk

Re: [Nouveau] [PATCH v2 03/17] drm: Nuke mode->vrefresh

2020-04-24 Thread abhinavk
Hi Jani On 2020-04-06 01:32, Jani Nikula wrote: On Fri, 03 Apr 2020, abhin...@codeaurora.org wrote: On 2020-04-03 13:39, Ville Syrjala wrote: diff --git a/drivers/gpu/drm/drm_modes.c b/drivers/gpu/drm/drm_modes.c index fec1c33b3045..e3d5f011f7bd 100644 --- a/drivers/gpu/drm/drm_modes.c +++ b/

[Nouveau] [PATCH 3/5] drm/nouveau: utilize subconnector property for DP

2020-04-24 Thread Jeevan B
From: Oleg Vasilev Since DP-specific information is stored in driver's structures, every driver needs to implement subconnector property by itself. v2: rebase Cc: Ben Skeggs Cc: nouveau@lists.freedesktop.org Signed-off-by: Jeevan B Signed-off-by: Oleg Vasilev Reviewed-by: Emil Velikov Link:

Re: [Nouveau] [PATCH] x86: mmiotrace: Use cpumask_available for cpumask_var_t variables

2020-04-24 Thread Sedat Dilek
On Wed, Apr 8, 2020 at 11:12 PM Sedat Dilek wrote: > > On Wed, Apr 8, 2020 at 10:53 PM Nathan Chancellor > wrote: > > > > When building with Clang + -Wtautological-compare and > > CONFIG_CPUMASK_OFFSTACK unset: > > > > Hi Nathan, > > thanks for the quick patch. > > I can confirm I have no CONFIG_

Re: [Nouveau] [PATCH 2/2] mm/thp: Rename pmd_mknotpresent() as pmd_mknotvalid()

2020-04-24 Thread Will Deacon
On Fri, Mar 20, 2020 at 10:24:17AM +0530, Anshuman Khandual wrote: > pmd_present() is expected to test positive after pmdp_mknotpresent() as the > PMD entry still points to a valid huge page in memory. pmdp_mknotpresent() > implies that given PMD entry is just invalidated from MMU perspective while

Re: [Nouveau] [PATCH 0/2] mm/thp: Rename pmd_mknotpresent() as pmd_mknotvalid()

2020-04-24 Thread Andrew Morton
On Sun, 29 Mar 2020 19:12:35 +0530 Anshuman Khandual wrote: > > > On 03/20/2020 10:24 AM, Anshuman Khandual wrote: > > This series renames pmd_mknotpresent() as pmd_mknotvalid(). Before that it > > drops an existing pmd_mknotpresent() definition from powerpc platform which > > was never requir

[Nouveau] gp104: regression on Linux 5.6

2020-04-24 Thread Alexey Dobriyan
gp104 refuses to switch to "graphic" mode and show anything past this line: fb0: switching to nouveaufb from EFI VGA Machine is fine, as it I can press Ctrl+Alt+Delete and reboot it normally. 5.5 is OK. 5.6 is broken. Bisecting is kinda painful with miscompilation and init/main.c breakag

[Nouveau] [PATCH -next] drm/nouveau/acr: Use kmemdup instead of kmalloc and memcpy

2020-04-24 Thread Zou Wei
Fixes coccicheck warning: drivers/gpu/drm/nouveau/nvkm/subdev/acr/hsfw.c:103:23-30: WARNING opportunity for kmemdup drivers/gpu/drm/nouveau/nvkm/subdev/acr/hsfw.c:113:22-29: WARNING opportunity for kmemdup Fixes: 22dcda45a3d1 ("drm/nouveau/acr: implement new subdev to replace "secure boot"") R

[Nouveau] Reproducable Crashes in Nouveau with GM204 [GeForce GTX 980]

2020-04-24 Thread Geoffrey Allott
Greetings, I hope this bug report is in the right place; the documentation at  https://nouveau.freedesktop.org/wiki/Bugs/ links to a defunct bugzilla page. I'm running an NVIDIA Corporation GM204  [GeForce GTX 980] graphics card in an EVGA X99 classified motherboar

Re: [Nouveau] [PATCH 2/2] mm/thp: Rename pmd_mknotpresent() as pmd_mknotvalid()

2020-04-24 Thread Will Deacon
On Tue, Apr 21, 2020 at 04:57:26AM +0530, Anshuman Khandual wrote: > > > On 04/21/2020 02:33 AM, Will Deacon wrote: > > On Fri, Mar 20, 2020 at 10:24:17AM +0530, Anshuman Khandual wrote: > >> pmd_present() is expected to test positive after pmdp_mknotpresent() as the > >> PMD entry still points t

[Nouveau] [PATCH 3/5] drm/nouveau: utilize subconnector property for DP

2020-04-24 Thread Jeevan B
Since DP-specific information is stored in driver's structures, every driver needs to implement subconnector property by itself. Reviewed-by: Emil Velikov Signed-off-by: Oleg Vasilev Cc: Ben Skeggs Cc: nouveau@lists.freedesktop.org Signed-off-by: Jeevan B Link: https://patchwork.freedesktop.o

Re: [Nouveau] [RFC v3 00/11] drm/nouveau: Introduce CRC support for gf119+

2020-04-24 Thread Ben Skeggs
On Sat, 18 Apr 2020 at 05:42, Lyude Paul wrote: > > Nvidia released some documentation on how CRC support works on their > GPUs, hooray! > > So: this patch series implements said CRC support in nouveau, along with > adding some special debugfs interfaces for some relevant igt-gpu-tools > tests tha

[Nouveau] [PATCH] drm/nouveau/mmu: Remove unneeded semicolon

2020-04-24 Thread Zheng Bin
Fixes coccicheck warning: drivers/gpu/drm/nouveau/nvkm/subdev/mmu/vmm.h:307:2-3: Unneeded semicolon drivers/gpu/drm/nouveau/nvkm/subdev/mmu/vmm.c:583:2-3: Unneeded semicolon Reported-by: Hulk Robot Signed-off-by: Zheng Bin --- drivers/gpu/drm/nouveau/nvkm/subdev/mmu/vmm.c | 2 +- drivers/gpu/d