[PATCH 5/5] drm/amdgpu: use GTT only as fallback for VRAM|GTT

2024-01-08 Thread Christian König
Try to fill up VRAM as well by setting the busy flag on GTT allocations. This fixes the issue that when VRAM was evacuated for suspend it's never filled up again unless the application is restarted. Signed-off-by: Christian König --- drivers/gpu/drm/amd/amdgpu/amdgpu_object.c | 6 ++ 1 file

[PATCH 2/5] drm/ttm: return ENOSPC from ttm_bo_mem_space

2024-01-08 Thread Christian König
Only convert it to ENOMEM in ttm_bo_validate. Signed-off-by: Christian König --- drivers/gpu/drm/ttm/ttm_bo.c | 5 - 1 file changed, 4 insertions(+), 1 deletion(-) diff --git a/drivers/gpu/drm/ttm/ttm_bo.c b/drivers/gpu/drm/ttm/ttm_bo.c index edf10618fe2b..8c1eaa74fa21 100644 --- a/drivers/

[PATCH 4/5] drm/ttm: improve idle/busy handling v2

2024-01-08 Thread Christian König
Previously we would never try to move a BO into the preferred placements when it ever landed in a busy placement since those were considered compatible. Rework the whole handling and finally unify the idle and busy handling. ttm_bo_validate() is now responsible to try idle placement first and then

[PATCH 3/5] drm/ttm: replace busy placement with flags v5

2024-01-08 Thread Christian König
From: Somalapuram Amaranath Instead of a list of separate busy placement add flags which indicate that a placement should only be used when there is room or if we need to evict. v2: add missing TTM_PL_FLAG_IDLE for i915 v3: fix auto build test ERROR on drm-tip/drm-tip v4: fix some typos pointed

Rework TTMs busy handling

2024-01-08 Thread Christian König
Hi guys, I'm trying to make this functionality a bit more useful for years now since we multiple reports that behavior of drivers can be suboptimal when multiple placements be given. So basically instead of hacking around the TTM behavior in the driver once more I've gone ahead and changed the id

[PATCH 1/5] drm/vmwgfx: remove vmw_vram_gmr_placement

2024-01-08 Thread Christian König
Seems to be unused. Signed-off-by: Christian König --- drivers/gpu/drm/vmwgfx/vmwgfx_drv.h| 1 - drivers/gpu/drm/vmwgfx/vmwgfx_ttm_buffer.c | 28 -- 2 files changed, 29 deletions(-) diff --git a/drivers/gpu/drm/vmwgfx/vmwgfx_drv.h b/drivers/gpu/drm/vmwgfx/vmwgfx_dr

Re: [PATCH AUTOSEL 6.1 5/5] nouveau: fix disp disabling with GSP

2024-01-08 Thread David Airlie
NAK for backporting this to anything, it is just a fix for 6.7 On Mon, Jan 8, 2024 at 10:28 PM Sasha Levin wrote: > > From: Dave Airlie > > [ Upstream commit 7854ea0e408d7f2e8faaada1773f3ddf9cb538f5 ] > > This func ptr here is normally static allocation, but gsp r535 > uses a dynamic pointer, s

Re: [PATCH -next] drm/nouveau: uapi: fix kerneldoc warnings

2024-01-08 Thread Danilo Krummrich
On 12/25/23 07:51, Vegard Nossum wrote: As of commit b77fdd6a48e6 ("scripts/kernel-doc: restore warning for Excess struct/union"), we see the following warnings when running 'make htmldocs': ./include/uapi/drm/nouveau_drm.h:292: warning: Excess struct member 'DRM_NOUVEAU_VM_BIND_OP_MAP' desc

Re: [PATCH 1/3] drm/nouveau: include drm/drm_edid.h only where needed

2024-01-08 Thread Danilo Krummrich
On 1/4/24 21:16, Jani Nikula wrote: Including drm_edid.h from nouveau_connector.h causes the rebuild of 15 files when drm_edid.h is modified, while there are only a few files that actually need to include drm_edid.h. Cc: Karol Herbst Cc: Lyude Paul Cc: Danilo Krummrich Cc: nouveau@lists.freed

Re: [PATCH 1/4] drm/nouveau/disp: don't misuse kernel-doc comments

2024-01-08 Thread Danilo Krummrich
On 1/1/24 00:36, Randy Dunlap wrote: Change kernel-doc "/**" comments to common "/*" comments to prevent kernel-doc warnings: crtc.c:453: warning: This comment starts with '/**', but isn't a kernel-doc comment. Refer Documentation/doc-guide/kernel-doc.rst * Sets up registers for the given mod

Re: [PATCH] drm/nouveau/bios/init: drop kernel-doc notation

2024-01-08 Thread Danilo Krummrich
On 12/16/23 21:11, Randy Dunlap wrote: The "/**" comments in this file are not kernel-doc comments. They are used on static functions which can have kernel-doc comments, but that is not the primary focus of kernel-doc comments. Since these comments are incomplete for kernel-doc notation, remove t

Re: [PATCH] drm/nouveau/fifo: remove duplicated including

2024-01-08 Thread Danilo Krummrich
Hi Wang, there is another patch [1] to fix this, which already made it upstream. - Danilo [1] https://patchwork.freedesktop.org/patch/msgid/20231122004926.84933-1-yang@linux.alibaba.com On 12/15/23 11:02, Wang Jinchao wrote: rm second including of chid.h Signed-off-by: Wang Jinchao ---

Re: [PATCH linux-next] drm/nouveau/disp: switch to use kmemdup() helper

2024-01-08 Thread Danilo Krummrich
Hi Yang, On 12/14/23 13:03, yang.gua...@zte.com.cn wrote: From: Yang Guang Use kmemdup() helper instead of open-coding to simplify the code. Signed-off-by: Chen Haonan Please add your "Signed-off-by" tag to this patch. If the above is intended to indicate that Chan was involved in creatin

[PATCH AUTOSEL 6.1 5/5] nouveau: fix disp disabling with GSP

2024-01-08 Thread Sasha Levin
From: Dave Airlie [ Upstream commit 7854ea0e408d7f2e8faaada1773f3ddf9cb538f5 ] This func ptr here is normally static allocation, but gsp r535 uses a dynamic pointer, so we need to handle that better. This fixes a crash with GSP when you use config=disp=0 to avoid disp problems. Signed-off-by:

[PATCH AUTOSEL 6.6 8/8] nouveau: fix disp disabling with GSP

2024-01-08 Thread Sasha Levin
From: Dave Airlie [ Upstream commit 7854ea0e408d7f2e8faaada1773f3ddf9cb538f5 ] This func ptr here is normally static allocation, but gsp r535 uses a dynamic pointer, so we need to handle that better. This fixes a crash with GSP when you use config=disp=0 to avoid disp problems. Signed-off-by: