Re: [PATCH] drm/nouveau/nvif: Avoid build error due to potential integer overflows

2024-05-18 Thread Joe Perches
On Sat, 2024-05-18 at 11:23 -0700, Guenter Roeck wrote: > On 5/18/24 10:32, Kees Cook wrote: > [] > > I think the INT_MAX test is actually better in this case because > > nvif_object_ioctl()'s size argument is u32: > > > > ret = nvif_object_ioctl(object, args, sizeof(*args) + size, NULL); > >

Re: [Nouveau] [PATCH] drm/nouveau/mmu: Fix a typo

2022-06-21 Thread Joe Perches
On Wed, 2022-06-22 at 09:52 +0800, Zhang Jiaming wrote: > There is a typo in comments. Change 'neeed' to 'need'. [] > diff --git a/drivers/gpu/drm/nouveau/nvkm/subdev/mmu/vmm.c > b/drivers/gpu/drm/nouveau/nvkm/subdev/mmu/vmm.c [] > @@ -280,7 +280,7 @@ nvkm_vmm_unref_ptes(struct nvkm_vmm_iter *it,

Re: [Nouveau] Hardware decoding in video playback with Nvidia GT 218 (NVA8)

2022-05-30 Thread Joe
. Otherwise I'll give up and re-switch to nvidia closed drivers. Thanks again! On Mon, May 30, 2022 at 1:26 AM Ilia Mirkin wrote: > > Hi Joe, > > On Sun, May 29, 2022 at 6:58 PM Joe wrote: > > > > Hi all, I'm trying to make running hardware acceleration deco

[Nouveau] Hardware decoding in video playback with Nvidia GT 218 (NVA8)

2022-05-29 Thread Joe
Hi all, I'm trying to make running hardware acceleration decoding on my old GeForce 210 (AKA GT-218, or NVA8 / NV-50 Tesla family). -- 02:00.0 VGA compatible controller [0300]: NVIDIA Corporation GT218 [GeForce 210] [10de:0a65] (rev a2) --

Re: [Nouveau] [PATCH 1/6] drivers: usb: remove usage of list iterator past the loop body

2022-02-28 Thread Joe Perches
On Mon, 2022-02-28 at 14:24 +0300, Dan Carpenter wrote: > a multi-line indent gets curly braces for readability even though > it's not required by C. And then both sides would get curly braces. That's more your personal preference than a coding style guideline.

Re: [Nouveau] [PATCH 1/3] lib/string_helpers: Consolidate yesno() implementation

2022-01-20 Thread Joe Perches
On Wed, 2022-01-19 at 16:00 -0500, Steven Rostedt wrote: > On Wed, 19 Jan 2022 21:25:08 +0200 > Andy Shevchenko wrote: > > > > I say keep it one line! > > > > > > Reviewed-by: Steven Rostedt (Google) > > > > I believe Sakari strongly follows the 80 rule, which means... > > Checkpatch says "

Re: [Nouveau] [PATCH 000/141] Fix fall-through warnings for Clang

2020-11-23 Thread Joe Perches
On Mon, 2020-11-23 at 07:58 -0800, James Bottomley wrote: > We're also complaining about the inability to recruit maintainers: > > https://www.theregister.com/2020/06/30/hard_to_find_linux_maintainers_says_torvalds/ > > And burn out: > > http://antirez.com/news/129 https://www.wired.com/story/o

Re: [Nouveau] [PATCH 000/141] Fix fall-through warnings for Clang

2020-11-23 Thread Joe Perches
On Tue, 2020-11-24 at 11:58 +1100, Finn Thain wrote: > it's not for me to prove that such patches don't affect code > generation. That's for the patch author and (unfortunately) for reviewers. Ideally, that proof would be provided by the compilation system itself and not patch authors nor reviewe

Re: [Nouveau] [PATCH 000/141] Fix fall-through warnings for Clang

2020-11-22 Thread Joe Perches
On Sun, 2020-11-22 at 11:12 -0800, James Bottomley wrote: > On Sun, 2020-11-22 at 10:25 -0800, Joe Perches wrote: > > On Sun, 2020-11-22 at 10:21 -0800, James Bottomley wrote: > > > Please tell me our reward for all this effort isn't a single > > > missing error

Re: [Nouveau] [PATCH 000/141] Fix fall-through warnings for Clang

2020-11-22 Thread Joe Perches
On Sun, 2020-11-22 at 10:21 -0800, James Bottomley wrote: > Please tell me > our reward for all this effort isn't a single missing error print. There were quite literally dozens of logical defects found by the fallthrough additions. Very few were logging only. _

Re: [Nouveau] [PATCH 000/141] Fix fall-through warnings for Clang

2020-11-20 Thread Joe Perches
On Fri, 2020-11-20 at 12:21 -0600, Gustavo A. R. Silva wrote: > Hi all, > > This series aims to fix almost all remaining fall-through warnings in > order to enable -Wimplicit-fallthrough for Clang. > > In preparation to enable -Wimplicit-fallthrough for Clang, explicitly > add multiple break/goto

Re: [Nouveau] [RFC] treewide: cleanup unreachable breaks

2020-10-20 Thread Joe Perches
On Mon, 2020-10-19 at 12:42 -0700, Nick Desaulniers wrote: > On Sat, Oct 17, 2020 at 10:43 PM Greg KH wrote: > > On Sat, Oct 17, 2020 at 09:09:28AM -0700, t...@redhat.com wrote: > > > From: Tom Rix > > > > > > This is a upcoming change to clean up a new warning treewide. > > > I am wondering if

Re: [Nouveau] [Ocfs2-devel] [RFC] treewide: cleanup unreachable breaks

2020-10-18 Thread Joe Perches
On Sun, 2020-10-18 at 19:59 +0100, Matthew Wilcox wrote: > On Sat, Oct 17, 2020 at 09:09:28AM -0700, t...@redhat.com wrote: > > clang has a number of useful, new warnings see > > https://urldefense.com/v3/__https://clang.llvm.org/docs/DiagnosticsReference.html__;!!GqivPVa7Brio!Krxz78O3RKcB9JBMVo_F9

Re: [Nouveau] [Cocci] [RFC] treewide: cleanup unreachable breaks

2020-10-17 Thread Joe Perches
On Sat, 2020-10-17 at 20:21 +0200, Julia Lawall wrote: > On Sat, 17 Oct 2020, Joe Perches wrote: > > On Sat, 2020-10-17 at 09:09 -0700, t...@redhat.com wrote: > > > From: Tom Rix > > > > > > This is a upcoming change to clean up a new warning treewide. > &g

Re: [Nouveau] [RFC] treewide: cleanup unreachable breaks

2020-10-17 Thread Joe Perches
On Sat, 2020-10-17 at 09:09 -0700, t...@redhat.com wrote: > From: Tom Rix > > This is a upcoming change to clean up a new warning treewide. > I am wondering if the change could be one mega patch (see below) or > normal patch per file about 100 patches or somewhere half way by collecting > early a

Re: [Nouveau] [trivial PATCH] treewide: Convert switch/case fallthrough; to break;

2020-09-11 Thread Joe Perches
On Thu, 2020-09-10 at 15:21 +0100, Robin Murphy wrote: > On 2020-09-09 21:06, Joe Perches wrote: > > fallthrough to a separate case/default label break; isn't very readable. > > > > Convert pseudo-keyword fallthrough; statements to a simple break; when > > the n

Re: [Nouveau] [trivial PATCH] treewide: Convert switch/case fallthrough; to break;

2020-09-09 Thread Joe Perches
On Wed, 2020-09-09 at 19:36 -0300, Jason Gunthorpe wrote: > On Wed, Sep 09, 2020 at 01:06:39PM -0700, Joe Perches wrote: > > fallthrough to a separate case/default label break; isn't very readable. > > > > Convert pseudo-keyword fallthrough; statements to a simple brea

[Nouveau] [trivial PATCH] treewide: Convert switch/case fallthrough; to break;

2020-09-09 Thread Joe Perches
h] -n "fallthrough;(\s*(case\s+\w+|default)\s*:\s*){1,7}break;" * Miscellanea: o Move or coalesce a couple label blocks above a default: block. Signed-off-by: Joe Perches --- Compiled allyesconfig x86-64 only. A few files for other arches were not compiled. arch/arm/mach-

Re: [Nouveau] [PATCH][next] drm/nouveau: Use fallthrough pseudo-keyword

2020-07-07 Thread Joe Perches
On Wed, 2020-07-08 at 13:22 +1000, Ben Skeggs wrote: > On Wed, 8 Jul 2020 at 03:31, Gustavo A. R. Silva > wrote: > > Replace the existing /* fall through */ comments and its variants with > > the new pseudo-keyword macro fallthrough[1]. Also, remove unnecessary > > fall-through markings when it i

[Nouveau] [PATCH -next 000/491] treewide: use fallthrough;

2020-03-30 Thread Joe Perches
ex --quiet HEAD --`; next if (!$?); # Commit the changes my $fh; open($fh, "+>", "cvt_fallthrough.commit_msg") or die "$0: can't create temporary file: $!\n"; print $fh <https://lore.kernel.org/lkml/b56602fcf79f849e733e7b521bb0e17895d390fa.1582230379.git@perche

Re: [Nouveau] [PATCH v4 2/6] drm/nouveau: Add NV_PRINTK_ONCE and variants

2018-09-06 Thread Joe Perches
On Thu, 2018-09-06 at 17:43 -0400, Lyude Paul wrote: > Since we're about to use this in nouveau_backlight.c. Same thing as > DRM_WARN_ONCE, DRM_INFO_ONCE, etc... Can you redefine this in terms of the patches I submitted instead? https://lore.kernel.org/patchwork/patch/979598/ https://lore.kernel.

[Nouveau] [PATCH 1/2] drm/nouveau: Add new logging function nv_cli_printk

2018-08-30 Thread Joe Perches
th nouveau) textdata bss dec hex filename 1737254 1084841048 1846786 1c2e02 (TOTALS) (new) 1740706 1084841048 1850238 1c3b7e (TOTALS) (old) Signed-off-by: Joe Perches --- drivers/gpu/drm/nouveau/nouveau_drm.c | 21 + drivers/gpu/drm/nouveau/nou

[Nouveau] [PATCH 2/2] drm/nouveau: Convert NV_PRINTK macros and uses to new nv_cli_ macros

2018-08-30 Thread Joe Perches
1048 1846786 1c2e02 (TOTALS) (old) Miscellanea: o Add nv_cli_ macros that use nouveau_cli_printk o Convert the NV_PRINTK uses to the new nv_cli_ macros o Realign arguments of the conversions Signed-off-by: Joe Perches --- drivers/gpu/drm/nouveau/nouveau_abi16.c | 2 +- drivers/gpu/drm/nouveau

[Nouveau] [PATCH 0/2] drm/nouveau: Use more standard logging styles

2018-08-30 Thread Joe Perches
Reduces object size ~4kb Joe Perches (2): drm/nouveau: Add new logging function nv_cli_printk drm/nouveau: Convert NV_PRINTK macros and uses to new nv_cli_ macros drivers/gpu/drm/nouveau/nouveau_abi16.c | 2 +- drivers/gpu/drm/nouveau/nouveau_chan.c | 12 +++ drivers/gpu/drm/nouveau

[Nouveau] [PATCH] gpu: Consistently use octal not symbolic permissions

2018-06-06 Thread Joe Perches
to open parenthesis o drivers/gpu/drm/msm/adreno/a5xx_debugfs.c has a world-writeable debug permission for "reset" - perhaps that should be modified Signed-off-by: Joe Perches --- drivers/gpu/drm/amd/amdgpu/amdgpu_debugfs.c| 2 +- drivers/gpu/drm/amd/amdgpu/amdgpu_pm.c

Re: [Nouveau] [PATCH] gpu: Consistently use octal not symbolic permissions

2018-06-06 Thread Joe Perches
On Fri, 2018-05-25 at 09:41 +0300, Jani Nikula wrote: > On Thu, 24 May 2018, Joe Perches wrote: > > There is currently a mixture of octal and symbolic permissions uses > > in files in drivers/gpu/drm and one file in drivers/gpu. > > > > There are ~270 existing

Re: [Nouveau] [PATCH 01/10] arch:powerpc: return -ENOMEM on failed allocation

2017-09-13 Thread Joe Perches
On Wed, 2017-09-13 at 13:02 +0530, Allen Pais wrote: > Signed-off-by: Allen Pais I think the changelog for this series of conversions should show that you've validated the change by inspecting the return call chain at each modified line. Also, it seems you've cc'd the same mailing lists for all

Re: [Nouveau] [PATCH libdrm] drm: Remove create_handle() drm_framebuffer "virtual".

2017-08-10 Thread Joe Kniss
On Wed, Aug 9, 2017 at 4:13 PM, Joe Kniss wrote: > On Wed, Aug 9, 2017 at 12:14 PM, Noralf Trønnes wrote: >> >> Den 09.08.2017 01.42, skrev Joe Kniss: >>> >>> Because all drivers currently use gem objects for framebuffer planes, >>> the virtual create_h

Re: [Nouveau] [PATCH libdrm] drm: Remove create_handle() drm_framebuffer "virtual".

2017-08-09 Thread Joe Kniss
On Wed, Aug 9, 2017 at 12:14 PM, Noralf Trønnes wrote: > > Den 09.08.2017 01.42, skrev Joe Kniss: >> >> Because all drivers currently use gem objects for framebuffer planes, >> the virtual create_handle() is not required. This change adds a >> struct dr

[Nouveau] [PATCH] Add drm ioctl DRM_IOCTL_MODE_GETFB2 & associated helpers.

2017-07-31 Thread Joe Kniss
: Joe Kniss --- drivers/gpu/drm/amd/amdgpu/amdgpu_display.c | 5 +- drivers/gpu/drm/armada/armada_fb.c | 1 + drivers/gpu/drm/drm_crtc_internal.h | 2 + drivers/gpu/drm/drm_fb_cma_helper.c | 11 ++-- drivers/gpu/drm/drm_framebuffer.c | 79

[Nouveau] Known bug? Two adjacent letters randomly not rendered or painted over

2017-05-26 Thread Joe Kesselman (via Android)
Hi, folks. Using the Noveau drivers on my RHEL7 Thinkpad (which is how our IS shop supplies these machines), I will see it drop two letters out of a window full of text (as if rendering them in the background color or drawing a rectangle of that color over them). This happens in everything fr

Re: [Nouveau] [PATCH 00/35] treewide trivial patches converting pr_warning to pr_warn

2017-03-03 Thread Joe Perches
On Thu, 2017-02-23 at 17:41 +, Emil Velikov wrote: > On 23 February 2017 at 17:18, Joe Perches wrote: > > On Thu, 2017-02-23 at 09:28 -0600, Rob Herring wrote: > > > On Fri, Feb 17, 2017 at 1:11 AM, Joe Perches wrote: > > > > There are ~4300 uses of pr_w

[Nouveau] [PATCH 2/2] gpu: drm: Convert printk(KERN_ to pr_

2017-03-03 Thread Joe Perches
Use a more common logging style. Miscellanea: o Coalesce formats and realign arguments o Neaten a few macros now using pr_ Signed-off-by: Joe Perches --- drivers/gpu/drm/amd/amdgpu/amdgpu.h| 3 +- drivers/gpu/drm/amd/amdgpu/amdgpu_afmt.c | 4 +- drivers/gpu/drm/amd

Re: [Nouveau] [PATCH 00/35] treewide trivial patches converting pr_warning to pr_warn

2017-03-03 Thread Joe Perches
On Thu, 2017-02-23 at 09:28 -0600, Rob Herring wrote: > On Fri, Feb 17, 2017 at 1:11 AM, Joe Perches wrote: > > There are ~4300 uses of pr_warn and ~250 uses of the older > > pr_warning in the kernel source tree. > > > > Make the use of pr_warn consistent across all

[Nouveau] [PATCH 0/3] gpu: drm: Convert printk(KERN_ to pr_

2017-02-28 Thread Joe Perches
Broken up for Daniel Vetter Joe Perches (3): gpu: drm: amd/radeon: Convert printk(KERN_ to pr_ gpu: drm: core: Convert printk(KERN_ to pr_ gpu: drm: drivers: Convert printk(KERN_ to pr_ drivers/gpu/drm/amd/amdgpu/amdgpu.h| 3 +- drivers/gpu/drm/amd/amdgpu/amdgpu_afmt.c

[Nouveau] [PATCH 3/3] gpu: drm: drivers: Convert printk(KERN_ to pr_

2017-02-28 Thread Joe Perches
Use a more common logging style. Miscellanea: o Coalesce formats and realign arguments o Neaten a few macros now using pr_ Signed-off-by: Joe Perches --- drivers/gpu/drm/gma500/cdv_intel_lvds.c | 9 - drivers/gpu/drm/gma500/oaktrail_lvds.c| 18

[Nouveau] [PATCH 0/2] gpu: drm: Use pr_cont and neaten logging

2017-02-27 Thread Joe Perches
Joe Perches (2): drm: Use pr_cont where appropriate gpu: drm: Convert printk(KERN_ to pr_ drivers/gpu/drm/amd/amdgpu/amdgpu.h| 3 +- drivers/gpu/drm/amd/amdgpu/amdgpu_afmt.c | 4 +- drivers/gpu/drm/amd/amdgpu/amdgpu_atpx_handler.c | 4 +- drivers/gpu/drm/amd

[Nouveau] [PATCH 00/35] treewide trivial patches converting pr_warning to pr_warn

2017-02-17 Thread Joe Perches
with 'sed s/\bpr_warning\b/pr_warn/' and some emacsing. Miscellanea: o Coalesce formats and realign arguments Some files not compiled - no cross-compilers Joe Perches (35): alpha: Convert remaining uses of pr_warning to pr_warn ARM: ep93xx: Convert remaining uses of pr_warning

[Nouveau] [PATCH 09/35] x86: Convert remaining uses of pr_warning to pr_warn

2017-02-16 Thread Joe Perches
line Signed-off-by: Joe Perches --- arch/x86/kernel/amd_gart_64.c | 12 +++-- arch/x86/kernel/apic/apic.c| 46 -- arch/x86/kernel/apic/apic_noop.c | 2 +- arch/x86/kernel/setup_percpu.c | 4 +-- arch/x86/kernel/tboot.c

Re: [Nouveau] [PATCH v2 0/7] lib: string: add functions to case-convert strings

2016-07-05 Thread Joe Perches
On Tue, 2016-07-05 at 15:36 -0700, Markus Mayer wrote: > On 5 July 2016 at 15:14, Joe Perches wrote: > > On Tue, 2016-07-05 at 13:47 -0700, Markus Mayer wrote: > > > This series introduces a family of generic string case conversion > > > functions. This kind of functio

Re: [Nouveau] [PATCH v2 0/7] lib: string: add functions to case-convert strings

2016-07-05 Thread Joe Perches
On Tue, 2016-07-05 at 13:47 -0700, Markus Mayer wrote: > This series introduces a family of generic string case conversion > functions. This kind of functionality is needed in several places in > the kernel. Right now, everybody seems to be implementing their own > copy of this functionality. > >

Re: [Nouveau] [PATCH V3] get_maintainer: use filename-only regex match for Tegra

2013-03-14 Thread Joe Perches
a entry from using K: to N: Acked-by: Joe Perches ___ Nouveau mailing list Nouveau@lists.freedesktop.org http://lists.freedesktop.org/mailman/listinfo/nouveau

Re: [Nouveau] [PATCH V2 3/3] get_maintainer: prevent keywords from matching filenames

2013-03-14 Thread Joe Perches
On Wed, 2013-03-06 at 23:47 -0700, Stephen Warren wrote: > On 03/06/2013 05:40 PM, Joe Perches wrote: > > Which is why I showed the whole thing in a single patch. > > No worries if it's simply to increase the patch count... > > I'm not sure what showed refers to?

Re: [Nouveau] [PATCH V2 3/3] get_maintainer: prevent keywords from matching filenames

2013-03-14 Thread Joe Perches
On Wed, 2013-03-06 at 17:34 -0700, Stephen Warren wrote: > On 03/06/2013 05:30 PM, Joe Perches wrote: > > On Wed, 2013-03-06 at 17:29 -0700, Stephen Warren wrote: > >> From: Stephen Warren > >> > >> This reverts most of eb90d08 "get_maintainer: allow keyw

Re: [Nouveau] [PATCH V2 3/3] get_maintainer: prevent keywords from matching filenames

2013-03-14 Thread Joe Perches
On Wed, 2013-03-06 at 17:29 -0700, Stephen Warren wrote: > From: Stephen Warren > > This reverts most of eb90d08 "get_maintainer: allow keywords to match > filenames"; all except the parts that are required to implement the new > N: entry type. Just combine patches 1 and 3 into a single patch.

Re: [Nouveau] [PATCH 1/2] get_maintainer: create filename-only regex match type

2013-03-14 Thread Joe Perches
On Wed, 2013-03-06 at 16:36 -0700, Stephen Warren wrote: > From: Stephen Warren > > Create a new N: entry type in MAINTAINERS which performs a regex match > against filenames; either those extracted from patch +++ or --- lines, > or those specified on the command-line using the -f option. NAK A

Re: [Nouveau] nouveau lockdep splat

2013-03-14 Thread Joe Perches
On Wed, 2013-03-06 at 12:31 -0700, Stephen Warren wrote: > On 03/06/2013 12:14 PM, Marcin Slusarz wrote: > > On Wed, Mar 06, 2013 at 01:04:29AM +0100, Borislav Petkov wrote: > >> On Tue, Mar 05, 2013 at 05:30:52PM +0100, Lucas Stach wrote: > >>> Dropping Tegra ML, it's not the place where Nouveau m

[Nouveau] More on getting Nouveau to work

2010-06-12 Thread Joe Zeff
I installed Fluxbox, killed Xorg and logged in again. I got a usable desktop, rather than a blank white screen. Progress, sort of. I brought up Gnome's configuration editor, and told it to use metacity, not compiz, logged out, and back in. No change. Checking, however, it's still using com

[Nouveau] Need help getting nouveau drivers working on Fedora 13

2010-06-11 Thread Joe Zeff
My desktop computer uses a GeForce FX 5200 card and, when I was using Fedora 11, the kmod-nvidia drivers (a Fedora-specific repackaging of the binary blob) worked Just Fine. Now, even though I've followed all of the instructions for them, they don't. In fact, my system won't even complete boo