[PATCH] Added test script to enter pin to sim card.

2009-11-24 Thread Ryan M. Raasch
--- test/enter-pin.py | 28 1 files changed, 28 insertions(+), 0 deletions(-) create mode 100755 test/enter-pin.py diff --git a/test/enter-pin.py b/test/enter-pin.py new file mode 100755 index 000..77de93a --- /dev/null +++ b/test/enter-pin.py @@ -0,0 +1,28 @@

Re: [PATCH] Added test script to enter pin to sim card.

2009-11-24 Thread Marcel Holtmann
Hi Ryan, --- test/enter-pin.py | 28 1 files changed, 28 insertions(+), 0 deletions(-) create mode 100755 test/enter-pin.py don't forget to modify EXTRA_DIST of Makefile.am and please remove the .py suffix. We don't do that with our test scripts. diff --git

[PATCH] Added test script to unlock sim card (revised).

2009-11-24 Thread Ryan M. Raasch
--- Makefile.am |3 ++- test/unlock-sim | 25 + 2 files changed, 27 insertions(+), 1 deletions(-) create mode 100755 test/unlock-sim diff --git a/Makefile.am b/Makefile.am index 4b0d7e8..2420c2c 100644 --- a/Makefile.am +++ b/Makefile.am @@ -242,7 +242,8 @@

RE: Patch on unsupported AT command

2009-11-24 Thread Gu, Yang
-Original Message- From: ofono-boun...@ofono.org [mailto:ofono-boun...@ofono.org] On Behalf Of Marcel Holtmann Sent: Monday, November 23, 2009 2:21 PM To: ofono@ofono.org Subject: RE: Patch on unsupported AT command Hi Yang, looks good so far, but ... +static gboolean

RE: Patch on unsupported AT command

2009-11-24 Thread Marcel Holtmann
Hi Yang, Maybe it is too early in the morning to do code review, but this should be doing the same, but be a lot simpler to read ;) You're absolutely right. In this way, the code is more readable. Please review again. both patches have been applied. Thanks. Regards Marcel

[PATCH] Fix: Add check for register_auto method

2009-11-24 Thread Zhenhua Zhang
Add check for register_auto method to avoid crash. HFP backend does not provide implementation for register_auto. --- src/network.c |7 +-- 1 files changed, 5 insertions(+), 2 deletions(-) diff --git a/src/network.c b/src/network.c index 8f99490..24cb911 100644 --- a/src/network.c +++

Re: [PATCH] Fix: Add check for register_auto method

2009-11-24 Thread Denis Kenzior
Hi Zhenhua, Add check for register_auto method to avoid crash. HFP backend does not provide implementation for register_auto. Patch has been applied. Thanks. Regards, -Denis ___ ofono mailing list ofono@ofono.org

Re: [PATCH 2/2] Fix: Move CHLD from voicecall driver to plugin

2009-11-24 Thread Denis Kenzior
Hi Zhenhua, The second patch is to move CHLD=? from voicecall.c to plugin. According HFP v1.5 spec, AT+CHLD=? should be a part of SLC connection. So we should not do it after SLC connection is created. Patch has been applied. Thanks. Regards, -Denis