[openib-general] Re: SDP_CONN_LOCK

2005-02-22 Thread Michael S. Tsirkin
Quoting r. Libor Michalek [EMAIL PROTECTED]: Subject: Re: SDP_CONN_LOCK On Thu, Feb 17, 2005 at 05:35:17PM +0200, Michael S. Tsirkin wrote: Hi, Libor! Could you please explain what are the SDP_CONN_LOCK and friends doing in SDP? It seems they just implement exclusive access to

[openib-general] [PATCH] PUT after UNLOCK

2005-02-22 Thread Michael S. Tsirkin
SDP_CONN_PUT was called before SDP_CONN_UNLOCK. If this is the last reference, the connection could be removed and an attempt to unlock would crash. Signed-off-by: Michael S. Tsirkin [EMAIL PROTECTED] Index: sdp_inet.c === ---

[openib-general] SDP: BUG 2034 workaround

2005-02-22 Thread Michael S. Tsirkin
sdp_inet.c, inside _sdp_inet_listen, we have: #if 0 /* BUG 2034 workaround. */ conn-backlog_max = backlog; #else conn-backlog_max = 1024; #endif What gives? what would be the proper fix as opposed to a work-around? -- MST - Michael S. Tsirkin

[openib-general] Re: Sex pictures

2005-02-22 Thread autoresponse
Hello, In an effort to improve our customer service and the speed with which we answer your e-mails, we have created a new web-based contact system on the neopets.com site, which is located at http://www.neopets.com/contact.phtml . From this new Contact Us page, you are able to send abuse

Re: [openib-general] [PATCH][IPOIB] bring interface down panic

2005-02-22 Thread Roland Dreier
Shirley, can you read Documentation/SubmittingPatches, and if the declaration in that file applies, resend your patches with a Signed-off-by: line? Thanks, Roland ___ openib-general mailing list openib-general@openib.org

Re: [openib-general] [PATCH] make device_cap_flags unsigned

2005-02-22 Thread Roland Dreier
Michael Since device_cap_flags is a set of ORed values, make the Michael result unsigned. Also to be in line with other flags. This doesn't seem to make any practical difference, since the largest device cap flag is 115, and even if it were 131 we never do any non-bitwise arithmetic so

[openib-general] Re: [PATCH] initialize device_cap_flags in mthca

2005-02-22 Thread Michael S. Tsirkin
Quoting r. Michael S. Tsirkin [EMAIL PROTECTED]: Subject: [PATCH] initialize device_cap_flags in mthca device_cap_flags are uninitialized in mthca. Signed-off-by: Michael S. Tsirkin [EMAIL PROTECTED] This was reporting the RQ_SIG capability which is now gone. Here's an update. Index:

[openib-general] [PATCH] [CM]: Add initial reject handling code

2005-02-22 Thread Sean Hefty
This patch adds initial support for handling CM reject messages. It should work with the following reject codes: 1-3, 5, 8-9, 11-23, 26-29, 32-33. (These are basically rejections by the remote consumer, versus by the remote CM.) I still need to determine the proper handling for the reject codes

[openib-general] Re: ANNOUNCE: First usable version of userspace verbs

2005-02-22 Thread Michael S. Tsirkin
Quoting r. Roland Dreier [EMAIL PROTECTED]: Subject: ANNOUNCE: First usable version of userspace verbs I'm happy to announce the initial availability of userspace verbs support for brave testers. To try this out, check out the roland-uverbs subversion branch: svn co

[openib-general] Re: ANNOUNCE: First usable version of userspace verbs

2005-02-22 Thread Roland Dreier
Michael Would you like help with (2)? Specifically, how should Michael are backport patches split up? I guess per file? Still, Michael it seems unlikely they can be made independent, right? No thanks, I think I can handle it. I'm planning on making the patches independent and

Re: [openib-general] Re: [PATCH][SDP][14/22] Whitespace cleanup in sdp_proto.h

2005-02-22 Thread Libor Michalek
On Sun, Feb 20, 2005 at 10:07:43AM -0800, Tom Duffy wrote: On Sun, 2005-02-20 at 02:05 +0200, Michael S. Tsirkin wrote: I think we also should replace __inline__ with inline everywhere. Also, I think the convention is to add __ before inline functions if they are an implementation

[openib-general] Re: [PATCH] 1/2 separate locking for send and receive q in mthca

2005-02-22 Thread Michael S. Tsirkin
Quoting r. Roland Dreier [EMAIL PROTECTED]: Subject: Re: [PATCH] 1/2 separate locking for send and receive q in mthca Michael Instead of doing this, how about something else I would Michael prefer: we could avoid locking the QP on CQ poll Michael altogether, if there is a

Re: [openib-general] Re: Re: [PATCH][SDP][14/22] Whitespace clean up in sdp_proto.h

2005-02-22 Thread Michael S. Tsirkin
Quoting r. Tom Duffy [EMAIL PROTECTED]: Subject: Re: [openib-general] Re: Re: [PATCH][SDP][14/22] Whitespace clean up in sdp_proto.h On Tue, 2005-02-22 at 22:32 +0200, Michael S. Tsirkin wrote: Good. By the way, do you plan to keep the convention of writing 0 == foo? I personally

[openib-general] Re: [PATCH] Rename debug_level to ipoib_debug_level

2005-02-22 Thread Michael S. Tsirkin
Quoting r. Roland Dreier [EMAIL PROTECTED]: Subject: [PATCH] Rename debug_level to ipoib_debug_level This renames the variable debug_level to ipoib_debug_level in the IPoIB module to avoid name clashes if IPoIB is built into the kernel. SDP has the same variable name so this fixes

[openib-general] Re: Re: Re: [PATCH][SDP][14/22] Whitespace clean up in sdp_proto.h

2005-02-22 Thread Michael S. Tsirkin
Quoting r. Michael S. Tsirkin [EMAIL PROTECTED]: Subject: Re: Re: Re: [PATCH][SDP][14/22] Whitespace clean up in sdp_proto.h Quoting r. Tom Duffy [EMAIL PROTECTED]: Subject: Re: [openib-general] Re: Re: [PATCH][SDP][14/22] Whitespace clean up in sdp_proto.h On Tue, 2005-02-22 at

Re: [openib-general] linked lists in sdp

2005-02-22 Thread Libor Michalek
On Sun, Feb 20, 2005 at 02:45:15PM +0200, Michael S. Tsirkin wrote: Hi! sdp_advt seems to re-implement linked list. Why is not the standard linked list used? There is some redundancy between the different lists even within the sdp code base. There are three objects, iocb, buff, and advt

[openib-general] Re: RFC on SDP checkin

2005-02-22 Thread Libor Michalek
On Mon, Feb 21, 2005 at 08:12:57PM +0200, Michael S. Tsirkin wrote: Quoting r. Libor Michalek [EMAIL PROTECTED]: On Thu, Feb 17, 2005 at 04:03:59PM +0200, Michael S. Tsirkin wrote: Quoting r. Libor Michalek [EMAIL PROTECTED]: Possible Issues - Memory locking for AIO requires a

Re: [openib-general] [PATCH][SDP][0/22] Whitespace cleanup in SDP

2005-02-22 Thread Libor Michalek
On Tue, Feb 22, 2005 at 12:57:00PM -0800, Tom Duffy wrote: On Tue, 2005-02-22 at 12:20 -0800, Libor Michalek wrote: Thanks Tom, I've applied and commited the patches. Did you choose not to apply these changes, or was this a simple oversight? Yup, it was an oversight. I had to hand

Re: [openib-general] [PATCH][SDP][0/22] Whitespace cleanup in SDP

2005-02-22 Thread Roland Dreier
Speaking of missing patches, I still see a lot of warnings from SDP on 64-bit archs because of %ll printk formats being used to print u64 values inside of sdp_debug_data statements. Is there a patch floating around for this or do you want me to write one? - R.

[openib-general] [PATCH] [CM] add reject handling for timeouts

2005-02-22 Thread Sean Hefty
The following patch adds reject handling for reject code 4, timeout. The update requires searching for the local cm_id based on the remote CA GUID and remote communication ID. Signed-off-by: Sean Hefty [EMAIL PROTECTED] Index: infiniband/core/cm.c

Re: [openib-general] [PATCH] prepend sdp_ to global names

2005-02-22 Thread Libor Michalek
On Mon, Feb 21, 2005 at 03:32:00PM +0200, Michael S. Tsirkin wrote: Some extern (non-static) variables did not start with sdp_ or anything like that. Here's a fix. Thanks, applied and commited. I did change a few lines to keep them under 80 columns wide. -Libor

Re: [openib-general] Solaris IPoIB MTU with OpenSM

2005-02-22 Thread Nitin Hande
Hal, On Thu, 2005-02-17 at 13:12, Hal Rosenstock wrote: Hi Nitin, On Wed, 2005-02-16 at 17:33, Nitin Hande wrote: On Wed, 2005-02-16 at 13:26, Hal Rosenstock wrote: On Wed, 2005-02-16 at 16:08, Nitin Hande wrote: Hal, [snip..] [snip...] Before the patch the