Re: [jfx17] RFR: 8268642: Expand the javafx.beans.property.Property documentation [v2]

2021-07-12 Thread Kevin Rushforth
On Sat, 10 Jul 2021 12:33:52 GMT, Nir Lisker wrote: >> Maybe we could simply the mental model of the property specification by >> making it illegal in all cases to use unidirectional and bidirectional >> bindings at the same time. The specification would be reduced to "it's >> illegal",

Re: RFR: 8269638: Property methods, setters, and getters in printing API should be final

2021-07-12 Thread Phil Race
On Mon, 12 Jul 2021 18:50:34 GMT, Phil Race wrote: > - Make various setters and getters and properties final as needed > - Move documentation to the property so the setters and getters inherit it, > with an exception for the special case of JobSettings.setPageRanges() > - Override toString() on

Re: RFR: 8269638: Property methods, setters, and getters in printing API should be final [v2]

2021-07-12 Thread Phil Race
On Mon, 12 Jul 2021 21:28:41 GMT, Kevin Rushforth wrote: >> Phil Race has updated the pull request incrementally with one additional >> commit since the last revision: >> >> 8269638: Property methods, setters, and getters in printing API should be >> final > >

Re: RFR: 8269638: Property methods, setters, and getters in printing API should be final [v2]

2021-07-12 Thread Phil Race
> - Make various setters and getters and properties final as needed > - Move documentation to the property so the setters and getters inherit it, > with an exception for the special case of JobSettings.setPageRanges() > - Override toString() on the properties in JobSettings so it doesn't delegate

Re: TreeTableCell: Misnamed / inconsistent methods for row and column properties

2021-07-12 Thread Kevin Rushforth
In looking at this more closely, I now think that option 2 is the better approach for the following reasons: * TreeTablePosition extends TablePositionBase (which is also extended by TablePosition), and inherits a getTableColumn() method that is overridden with a covariant return type (using

Re: RFR: 8269638: Property methods, setters, and getters in printing API should be final

2021-07-12 Thread Kevin Rushforth
On Mon, 12 Jul 2021 18:50:34 GMT, Phil Race wrote: > - Make various setters and getters and properties final as needed > - Move documentation to the property so the setters and getters inherit it, > with an exception for the special case of JobSettings.setPageRanges() > - Override toString() on

RFR: 8269638: Property methods, setters, and getters in printing API should be final

2021-07-12 Thread Phil Race
- Make various setters and getters and properties final as needed - Move documentation to the property so the setters and getters inherit it, with an exception for the special case of JobSettings.setPageRanges() - Override toString() on the properties in JobSettings so it doesn't delegate to the

TreeTableCell: Misnamed / inconsistent methods for row and column properties

2021-07-12 Thread Kevin Rushforth
While evaluating a javadoc fix [1] that removes spurious warnings for missing comments on JavaFX property methods, I looked at the remaining warnings, and discovered an inconsistency in the naming of two of the properties in the TreeTableCell class. I filed JDK-8270314 [2] to track this.

[jfx17] RFR: 8270246: Deprecate for removal implementation methods in Scene

2021-07-12 Thread Kevin Rushforth
The following methods in Scene were former `impl_*` method that were intended to be encapsulated as part of [JDK-8157295](https://bugs.openjdk.java.net/browse/JDK-8157295) in JDK 9, but were mistakenly left as public: public void disposePeer() public void

Re: RFR: 8269374: Menu inoperable after setting stage to second monitor

2021-07-12 Thread Kevin Rushforth
On Mon, 12 Jul 2021 12:46:10 GMT, Jose Pereda wrote: > On Windows, with two monitors with different DPI settings, if a JavaFX > application changes screens (either by dragging or programmatically) there is > a resize event to adjust the view to its new platform scale. > > Note that there is

Re: RFR: 8240506: TextFieldSkin/Behavior: misbehavior on switching skin [v2]

2021-07-12 Thread Jeanette Winzenburg
On Mon, 28 Jun 2021 13:44:16 GMT, Marius Hanl wrote: >> Jeanette Winzenburg has updated the pull request incrementally with one >> additional commit since the last revision: >> >> addressed review issues > > Just a formal review, I left some comments inline @Maran23 did resolve all we

Re: RFR: 8089398: [ChoiceBox, ComboBox] throws NPE on setting value on null selectionModel [v4]

2021-07-12 Thread Jeanette Winzenburg
On Thu, 8 Jul 2021 21:05:51 GMT, Marius Hanl wrote: >> modules/javafx.controls/src/test/java/test/javafx/scene/control/ComboBoxTest.java >> line 324: >> >>> 322: >>> 323: comboBox.layout(); >>> 324: >> >> KISS again :) >> >> - buttonCell is unrelated >> - setting the value is a not

Re: RFR: 8089398: [ChoiceBox, ComboBox] throws NPE on setting value on null selectionModel [v4]

2021-07-12 Thread Jeanette Winzenburg
On Sun, 11 Jul 2021 18:28:24 GMT, Marius Hanl wrote: >>> >>> >>> Hmm, but leaving a test without an assert is also bad. You have any >>> suggestions? >> >> Not aware of such a rule - if we fix code throwing an exception there is not >> much to assert, except that it fails before and passes

Re: RFR: 8188026: TextFieldXXCell: NPE on calling startEdit

2021-07-12 Thread Jeanette Winzenburg
On Sun, 11 Jul 2021 18:06:52 GMT, Marius Hanl wrote: > > just checked my notes (there's a cell-editing branch in my fork where I'm > > experimenting) - astonishingly the answer is no, could not see anything :) > > And actually, seems like we don't even need to return immediately: would > >

RFR: 8269374: Menu inoperable after setting stage to second monitor

2021-07-12 Thread Jose Pereda
On Windows, with two monitors with different DPI settings, if a JavaFX application changes screens (either by dragging or programmatically) there is a resize event to adjust the view to its new platform scale. Note that there is already a