Re: RFR: 8311895: CSS Transitions [v20]

2024-05-27 Thread drmarmac
On Sun, 26 May 2024 08:08:26 GMT, Michael Strauß wrote: >> Implementation of [CSS >> Transitions](https://gist.github.com/mstr2/c72f8c9faa87de14926978f517a6018a). >> >> ### Future enhancements >> CSS transitions requires all participating objects to implement the >> `Interpolatable`

Re: RFR: 8311895: CSS Transitions [v16]

2024-05-24 Thread drmarmac
On Thu, 2 May 2024 08:40:28 GMT, Michael Strauß wrote: >> Implementation of [CSS >> Transitions](https://gist.github.com/mstr2/c72f8c9faa87de14926978f517a6018a). >> >> ### Future enhancements >> CSS transitions requires all participating objects to implement the >> `Interpolatable` interface.

Integrated: 8331214: Doc: update spec for SpinnerFactory classes

2024-05-07 Thread drmarmac
On Mon, 6 May 2024 08:24:52 GMT, drmarmac wrote: > This PR updates the javadoc for the SpinnerFactory wrap-around behavior > introduced in #1431. This pull request has now been integrated. Changeset: 36e65e8b Author:drmarmac <6900949+drmar...@users.noreply.github.com> Comm

Re: RFR: 8331214: Doc: update spec for SpinnerFactory classes [v2]

2024-05-07 Thread drmarmac
On Tue, 7 May 2024 15:39:29 GMT, Andy Goryachev wrote: >> I guess that's because IntelliJ doesn't process the javafx properties. > > that's why _some say_ eclipse is better: > > ![Screenshot 2024-05-07 at 08 37 >

Re: RFR: 8331214: Doc: update spec for SpinnerFactory classes [v2]

2024-05-07 Thread drmarmac
On Mon, 6 May 2024 23:22:36 GMT, Kevin Rushforth wrote: >> modules/javafx.controls/src/main/java/javafx/scene/control/SpinnerValueFactory.java >> line 417: >> >>> 415: * integer values. >>> 416: * >>> 417: * If {@link #wrapAroundProperty wrapAround} is {@code true}, the >>>

Re: RFR: 8331214: Doc: update spec for SpinnerFactory classes [v3]

2024-05-07 Thread drmarmac
> This PR updates the javadoc for the SpinnerFactory wrap-around behavior > introduced in #1431. drmarmac has updated the pull request incrementally with one additional commit since the last revision: javaDoc: Qualify property links - Changes: - all: https://git.openj

Re: RFR: 8331214: Doc: update spec for SpinnerFactory classes [v2]

2024-05-06 Thread drmarmac
On Mon, 6 May 2024 17:59:14 GMT, Andy Goryachev wrote: >> I don't think this will help. This is the same issue I mentioned in PR #1389 >> -- you need to link to the property _method_, so I think changing to the >> following will do it: >> >> >> * If {@link #wrapAroundProperty wrapAround} >>

Re: RFR: 8331214: Doc: update spec for SpinnerFactory classes [v2]

2024-05-06 Thread drmarmac
On Mon, 6 May 2024 16:27:52 GMT, Andy Goryachev wrote: >> modules/javafx.controls/src/main/java/javafx/scene/control/SpinnerValueFactory.java >> line 420: >> >>> 418: * the minimum value to the maximum value (and vice versa). As a >>> consequence of that, the number >>> 419: * of

Re: RFR: 8331214: Doc: update spec for SpinnerFactory classes [v2]

2024-05-06 Thread drmarmac
> This PR updates the javadoc for the SpinnerFactory wrap-around behavior > introduced in #1431. drmarmac has updated the pull request incrementally with one additional commit since the last revision: javaDoc updates according to code review - Changes: - all:

RFR: 8331214: Doc: update spec for SpinnerFactory classes

2024-05-06 Thread drmarmac
This PR updates the javadoc for the SpinnerFactory wrap-around behavior introduced in #1431. - Commit messages: - Update SpinnerValueFactory documentation Changes: https://git.openjdk.org/jfx/pull/1450/files Webrev: https://webrevs.openjdk.org/?repo=jfx=1450=00 Issue:

Integrated: 8271865: SortedList::getViewIndex behaves not correctly for some index values

2024-05-03 Thread drmarmac
On Sun, 24 Mar 2024 15:11:29 GMT, drmarmac wrote: > This PR adds the missing checks, as well as code documentation that an > IndexOutOfBoundsException may be thrown. This pull request has now been integrated. Changeset: 54005125 Author:drmarmac <6900949+drmar...@users.noreply.g

Re: RFR: 8271865: SortedList::getViewIndex behaves not correctly for some index values [v2]

2024-05-02 Thread drmarmac
On Thu, 2 May 2024 12:18:30 GMT, Kevin Rushforth wrote: >> drmarmac has updated the pull request incrementally with one additional >> commit since the last revision: >> >> JavaDoc updates > > modules/javafx.base/src/main/java/javafx/collections/transformation/T

Re: RFR: 8271865: SortedList::getViewIndex behaves not correctly for some index values [v3]

2024-05-02 Thread drmarmac
> This PR adds the missing checks, as well as code documentation that an > IndexOutOfBoundsException may be thrown. drmarmac has updated the pull request with a new target base due to a merge or a rebase. The incremental webrev excludes the unrelated changes brought in by the merge/

Re: RFR: 8271865: SortedList::getViewIndex behaves not correctly for some index values

2024-05-02 Thread drmarmac
On Sun, 24 Mar 2024 15:11:29 GMT, drmarmac wrote: > This PR adds the missing checks, as well as code documentation that an > IndexOutOfBoundsException may be thrown. I've updated the PR with Kevin's suggestions. - PR Comment: https://git.openjdk.org/jfx/pull/1432#issuec

Re: RFR: 8271865: SortedList::getViewIndex behaves not correctly for some index values [v2]

2024-05-02 Thread drmarmac
On Mon, 29 Apr 2024 22:48:28 GMT, Kevin Rushforth wrote: >> drmarmac has updated the pull request incrementally with one additional >> commit since the last revision: >> >> JavaDoc updates > > modules/javafx.base/src/main/java/javafx/collections/transformation/T

Re: RFR: 8271865: SortedList::getViewIndex behaves not correctly for some index values [v2]

2024-05-02 Thread drmarmac
> This PR adds the missing checks, as well as code documentation that an > IndexOutOfBoundsException may be thrown. drmarmac has updated the pull request incrementally with one additional commit since the last revision: JavaDoc updates - Changes: - all:

Re: RFR: 8242553: IntegerSpinner and DoubleSpinner do not wrap around values correctly in some cases [v2]

2024-05-02 Thread drmarmac
On Wed, 10 Apr 2024 11:47:28 GMT, drmarmac wrote: >> This PR should fix the issue and cover all relevant cases with new tests. >> >> Note: This involves a small behavior change, as can be seen in >> dblSpinner_testWrapAround_decrement_twoSteps() in SpinnerTest.java:7

Integrated: 8242553: IntegerSpinner and DoubleSpinner do not wrap around values correctly in some cases

2024-04-18 Thread drmarmac
On Sun, 24 Mar 2024 15:11:16 GMT, drmarmac wrote: > This PR should fix the issue and cover all relevant cases with new tests. > > Note: This involves a small behavior change, as can be seen in > dblSpinner_testWrapAround_decrement_twoSteps() in SpinnerTest.java:749. With &

Re: RFR: 8242553: IntegerSpinner and DoubleSpinner do not wrap around values correctly in some cases [v2]

2024-04-10 Thread drmarmac
vior is similar to that of the IntegerSpinner. drmarmac has updated the pull request incrementally with one additional commit since the last revision: Use direction-dependent modulo arithmetic in DoubleSpinnerValueFactory wrap-around logic - Changes: - all: https://git.openjdk.org/jfx/pull/1431/files

Re: RFR: 8242553: IntegerSpinner and DoubleSpinner do not wrap around values correctly in some cases

2024-04-10 Thread drmarmac
On Sun, 24 Mar 2024 15:11:16 GMT, drmarmac wrote: > This PR should fix the issue and cover all relevant cases with new tests. > > Note: This involves a small behavior change, as can be seen in > dblSpinner_testWrapAround_decrement_twoSteps() in SpinnerTest.java:749. With &

Re: RFR: 8242553: IntegerSpinner and DoubleSpinner do not wrap around values correctly in some cases

2024-03-30 Thread drmarmac
On Sun, 24 Mar 2024 15:11:16 GMT, drmarmac wrote: > This PR should fix the issue and cover all relevant cases with new tests. > > Note: This involves a small behavior change, as can be seen in > dblSpinner_testWrapAround_decrement_twoSteps() in SpinnerTest.java:749. With &

Integrated: 8273349: Check uses of Stream::peek in controls and replace as needed

2024-03-29 Thread drmarmac
On Sun, 24 Mar 2024 15:10:22 GMT, drmarmac wrote: > This PR removes potentially incorrect usages of Stream.peek(). > The changed code should be covered by the tests that are already present. This pull request has now been integrated. Changeset: 0d2ad0e0 Author:drmarmac <6900

Re: RFR: 8273349: Check uses of Stream::peek in controls and replace as needed [v3]

2024-03-28 Thread drmarmac
On Thu, 28 Mar 2024 17:53:14 GMT, Andy Goryachev wrote: >> drmarmac has updated the pull request incrementally with two additional >> commits since the last revision: >> >> - Preallocate in SelectedIndicesList.set() >> - Remove unused import > > modules/

Re: RFR: 8273349: Check uses of Stream::peek in controls and replace as needed [v2]

2024-03-28 Thread drmarmac
On Thu, 28 Mar 2024 06:07:24 GMT, Karthik P K wrote: >> You don't need to return a list, you create it ahead of time like was done >> in line 167 >> >> List indices = new ArrayList<>(); >> >> and the add the elements in `forEach`. > >> Why do the double-iteration pattern here and not do the

Re: RFR: 8273349: Check uses of Stream::peek in controls and replace as needed [v3]

2024-03-28 Thread drmarmac
On Thu, 28 Mar 2024 08:49:44 GMT, drmarmac wrote: >> This PR removes potentially incorrect usages of Stream.peek(). >> The changed code should be covered by the tests that are already present. > > drmarmac has updated the pull request incrementally with two additional > c

Re: RFR: 8273349: Check uses of Stream::peek in controls and replace as needed [v3]

2024-03-28 Thread drmarmac
> This PR removes potentially incorrect usages of Stream.peek(). > The changed code should be covered by the tests that are already present. drmarmac has updated the pull request incrementally with two additional commits since the last revision: - Preallocate in SelectedIndicesLi

Re: RFR: 8242553: IntegerSpinner and DoubleSpinner do not wrap around values correctly in some cases

2024-03-27 Thread drmarmac
On Sun, 24 Mar 2024 15:11:16 GMT, drmarmac wrote: > This PR should fix the issue and cover all relevant cases with new tests. > > Note: This involves a small behavior change, as can be seen in > dblSpinner_testWrapAround_decrement_twoSteps() in SpinnerTest.java:749. With &

Integrated: 8267565: Support "@3x" and greater high-density image naming convention

2024-03-27 Thread drmarmac
On Fri, 22 Mar 2024 16:17:29 GMT, drmarmac wrote: > This PR extends the range of hi-res images that are loaded via naming > convention, now including scale factors higher than `@2x`. > Supporting these is already being > [recommended](https://developer.apple.com/design/hum

Re: RFR: 8242553: IntegerSpinner and DoubleSpinner do not wrap around values correctly in some cases

2024-03-27 Thread drmarmac
On Sun, 24 Mar 2024 15:11:16 GMT, drmarmac wrote: > This PR should fix the issue and cover all relevant cases with new tests. > > Note: This involves a small behavior change, as can be seen in > dblSpinner_testWrapAround_decrement_twoSteps() in SpinnerTest.java:749. With &

Re: RFR: 8273349: Check uses of Stream::peek in controls and replace as needed [v2]

2024-03-27 Thread drmarmac
On Tue, 26 Mar 2024 16:32:53 GMT, Karthik P K wrote: >> drmarmac has updated the pull request incrementally with one additional >> commit since the last revision: >> >> Remove outdated comment > > modules/javafx.controls/src/main/java/javafx/scene/control

Re: RFR: 8273349: Check uses of Stream::peek in controls and replace as needed [v2]

2024-03-27 Thread drmarmac
> This PR removes potentially incorrect usages of Stream.peek(). > The changed code should be covered by the tests that are already present. drmarmac has updated the pull request incrementally with one additional commit since the last revision: Remove outdated comment - C

Re: RFR: 8273349: Check uses of Stream::peek in controls and replace as needed

2024-03-27 Thread drmarmac
On Sun, 24 Mar 2024 15:10:22 GMT, drmarmac wrote: > This PR removes potentially incorrect usages of Stream.peek(). > The changed code should be covered by the tests that are already present. I also removed a code comment that explained the usage of peek() here, which would be outdat

Re: RFR: 8267565: Support "@3x" and greater high-density image naming convention [v2]

2024-03-26 Thread drmarmac
some platforms. > > I tested this manually on Windows with "300%" UI scale factor, and verified > `@2x` still works on macOS. drmarmac has updated the pull request incrementally with one additional commit since the last revision: Change name2x to nameScaled

Re: RFR: 8267565: Support "@3x" and greater high-density image naming convention

2024-03-26 Thread drmarmac
On Fri, 22 Mar 2024 16:17:29 GMT, drmarmac wrote: > This PR extends the range of hi-res images that are loaded via naming > convention, now including scale factors higher than `@2x`. > Supporting these is already being > [recommended](https://developer.apple.com/design/hum

Re: RFR: 8267565: Support "@3x" and greater high-density image naming convention

2024-03-26 Thread drmarmac
On Fri, 22 Mar 2024 16:17:29 GMT, drmarmac wrote: > This PR extends the range of hi-res images that are loaded via naming > convention, now including scale factors higher than `@2x`. > Supporting these is already being > [recommended](https://developer.apple.com/design/hum

Re: RFR: 8242553: IntegerSpinner and DoubleSpinner do not wrap around values correctly in some cases

2024-03-25 Thread drmarmac
On Sun, 24 Mar 2024 15:11:16 GMT, drmarmac wrote: > This PR should fix the issue and cover all relevant cases with new tests. > > Note: This involves a small behavior change, as can be seen in > dblSpinner_testWrapAround_decrement_twoSteps() in SpinnerTest.java:749. With &

RFR: 8271865: SortedList::getViewIndex behaves not correctly for some index values

2024-03-24 Thread drmarmac
This PR adds the missing checks, as well as code documentation that an IndexOutOfBoundsException may be thrown. - Commit messages: - TransformationList.getSourceIndex/getViewIndex should throw IOOBE - Add failing test Changes: https://git.openjdk.org/jfx/pull/1432/files Webrev:

RFR: 8242553: IntegerSpinner and DoubleSpinner do not wrap around values correctly in some cases

2024-03-24 Thread drmarmac
This PR should fix the issue and cover all relevant cases with new tests. - Commit messages: - Fixed wrap-around behavior for SpinnerValueFactory - Add failing tests Changes: https://git.openjdk.org/jfx/pull/1431/files Webrev: https://webrevs.openjdk.org/?repo=jfx=1431=00

RFR: 8273349: Check uses of Stream::peek in controls and replace as needed

2024-03-24 Thread drmarmac
This PR removes potentially incorrect usages of Stream.peek(). The changed code should be covered by the tests that are already present. - Commit messages: - Remove Stream.peek() operation Changes: https://git.openjdk.org/jfx/pull/1430/files Webrev:

RFR: 8267565: Support "@1x" and "@3x" high-density image naming convention

2024-03-22 Thread drmarmac
This PR extends the range of hi-res images that are loaded via naming convention, now including scale factors higher than "@2x". Supporting these is already being [recommended](https://developer.apple.com/design/human-interface-guidelines/images#Best-practices) for some platforms. I tested