[Openocd-development] [PATCH 07/11] parport: use register_commands()

2009-11-24 Thread zw
From: Zachary T Welch Use register_commands() with a command registration array. Signed-off-by: Zachary T Welch --- src/jtag/parport.c | 57 +-- 1 files changed, 37 insertions(+), 20 deletions(-) diff --git a/src/jtag/parport.c b/src/jtag/parp

[Openocd-development] [PATCH 10/11] vsllink: use register_commands()

2009-11-24 Thread zw
From: Zachary T Welch Use register_commands() with command registration array. Signed-off-by: Zachary T Welch --- src/jtag/vsllink.c | 55 +-- 1 files changed, 35 insertions(+), 20 deletions(-) diff --git a/src/jtag/vsllink.c b/src/jtag/vsllin

[Openocd-development] [PATCH 09/11] jtag: use register_commands()

2009-11-24 Thread zw
From: Zachary T Welch Use register commands with command registration array. Signed-off-by: Zachary T Welch --- src/jtag/tcl.c | 186 1 files changed, 119 insertions(+), 67 deletions(-) diff --git a/src/jtag/tcl.c b/src/jtag/tcl.c inde

[Openocd-development] [PATCH 19/20] remove flash_driver->register_callbacks

2009-11-24 Thread zw
From: Zachary T Welch Replace flash_driver callback with pointer to command_registration. Eliminates all related routines and allows drivers to omit commands. Signed-off-by: Zachary T Welch --- src/flash/at91sam3.c |7 +-- src/flash/at91sam7.c |7 +-- src/flash/avrf.c |

[Openocd-development] [PATCH 01/22] arm11: use register_commands()

2009-11-24 Thread zw
From: Zachary T Welch Signed-off-by: Zachary T Welch --- src/target/arm11.c | 97 +--- 1 files changed, 62 insertions(+), 35 deletions(-) diff --git a/src/target/arm11.c b/src/target/arm11.c index 66954fa..835234c 100644 --- a/src/target/arm11

[Openocd-development] [PATCH 02/22] arm720t: use register_commands()

2009-11-24 Thread zw
From: Zachary T Welch Signed-off-by: Zachary T Welch --- src/target/arm720t.c | 38 +++--- 1 files changed, 23 insertions(+), 15 deletions(-) diff --git a/src/target/arm720t.c b/src/target/arm720t.c index 4ca80e1..52a311c 100644 --- a/src/target/arm720t.c +++

[Openocd-development] [PATCH 03/22] arm7_9_common: use register_commands()

2009-11-24 Thread zw
From: Zachary T Welch Signed-off-by: Zachary T Welch --- src/target/arm7_9_common.c | 57 --- 1 files changed, 37 insertions(+), 20 deletions(-) diff --git a/src/target/arm7_9_common.c b/src/target/arm7_9_common.c index 1601ee1..b40be8d 100644 --- a/s

[Openocd-development] [PATCH 05/22] arm926ejs: use register_commands()

2009-11-24 Thread zw
From: Zachary T Welch Signed-off-by: Zachary T Welch --- src/target/arm926ejs.c | 36 ++-- 1 files changed, 22 insertions(+), 14 deletions(-) diff --git a/src/target/arm926ejs.c b/src/target/arm926ejs.c index 030405a..329aa12 100644 --- a/src/target/arm926ejs

[Openocd-development] [PATCH 06/22] arm966e: use register_commands()

2009-11-24 Thread zw
From: Zachary T Welch Signed-off-by: Zachary T Welch --- src/target/arm966e.c | 35 +++ 1 files changed, 23 insertions(+), 12 deletions(-) diff --git a/src/target/arm966e.c b/src/target/arm966e.c index f617875..70cc3c4 100644 --- a/src/target/arm966e.c +++ b/

[Openocd-development] [PATCH 07/22] arm9tdmi: use register_commands()

2009-11-24 Thread zw
From: Zachary T Welch Signed-off-by: Zachary T Welch --- src/target/arm9tdmi.c | 33 + 1 files changed, 21 insertions(+), 12 deletions(-) diff --git a/src/target/arm9tdmi.c b/src/target/arm9tdmi.c index f965429..87ace05 100644 --- a/src/target/arm9tdmi.c +++

[Openocd-development] [PATCH 10/10] support OPENOCD_DEBUG_LEVEL environment setting

2009-11-24 Thread zw
From: Zachary T Welch Detect the OPENOCD_DEBUG_LEVEL setting in log_init(), allowing the very early startup phases to be debugged. Signed-off-by: Zachary T Welch --- src/helper/log.c | 13 + 1 files changed, 13 insertions(+), 0 deletions(-) diff --git a/src/helper/log.c b/src/he

[Openocd-development] [PATCH 09/10] log: improve initialization

2009-11-24 Thread zw
From: Zachary T Welch Removes redundant assignment of start_ms from log_register_commands(). Eliminates command_context parameter and return value. Adds Doxygen comment block for this API call. Signed-off-by: Zachary T Welch --- src/helper/log.c | 11 +++ src/helper/log.h |5

[Openocd-development] [PATCH 02/20] at91sam7: use register_commands()

2009-11-24 Thread zw
From: Zachary T Welch Signed-off-by: Zachary T Welch --- src/flash/at91sam7.c | 30 +- 1 files changed, 21 insertions(+), 9 deletions(-) diff --git a/src/flash/at91sam7.c b/src/flash/at91sam7.c index 1665b91..0204660 100644 --- a/src/flash/at91sam7.c +++ b/src/fl

[Openocd-development] [PATCH 11/11] remove register_callbacks from jtag interface

2009-11-24 Thread zw
From: Zachary T Welch Changes the jtag_interface->register_callbacks field to a list of commands to be registered. Changes callback to invocation of register_commands() with that command registration list. Removes all JTAG interface driver register_command callback functions, which the previous

[Openocd-development] [PATCH 13/20] stellaris: use register_commands()

2009-11-24 Thread zw
From: Zachary T Welch Signed-off-by: Zachary T Welch --- src/flash/stellaris.c | 27 --- 1 files changed, 20 insertions(+), 7 deletions(-) diff --git a/src/flash/stellaris.c b/src/flash/stellaris.c index 2d653ec..1cff486 100644 --- a/src/flash/stellaris.c +++ b/src/f

[Openocd-development] [PATCH 17/20] str9xpec: use register_commands()

2009-11-24 Thread zw
From: Zachary T Welch Signed-off-by: Zachary T Welch --- src/flash/str9xpec.c | 119 ++ 1 files changed, 81 insertions(+), 38 deletions(-) diff --git a/src/flash/str9xpec.c b/src/flash/str9xpec.c index 7519413..7f6a29a 100644 --- a/src/flash/st

[Openocd-development] [PATCH 18/20] tms470: use register_commands()

2009-11-24 Thread zw
From: Zachary T Welch Signed-off-by: Zachary T Welch --- src/flash/tms470.c | 39 --- 1 files changed, 32 insertions(+), 7 deletions(-) diff --git a/src/flash/tms470.c b/src/flash/tms470.c index bf58f1d..3f32b51 100644 --- a/src/flash/tms470.c +++ b/src/f

[Openocd-development] [SERIES 5/6:0/22] target: update command registration

2009-11-24 Thread zw
Hi all, This series updates the target layer to use new command registration. Each module is converted, then the callbacks converted to pointers. Cheers, Zach ___ Openocd-development mailing list Openocd-development@lists.berlios.de https://lists.berl

[Openocd-development] [PATCH 20/20] remove nand_controller->register_callbacks

2009-11-24 Thread zw
From: Zachary T Welch Replace flash_driver callback with pointer to command_registration. Eliminates all related routines and allows drivers to omit commands. Signed-off-by: Zachary T Welch --- src/flash/davinci_nand.c|6 -- src/flash/lpc3180_nand_controller.c |7 +-

[Openocd-development] [PATCH 04/20] cfi: use register_commands()

2009-11-24 Thread zw
From: Zachary T Welch Signed-off-by: Zachary T Welch --- src/flash/cfi.c |6 -- 1 files changed, 0 insertions(+), 6 deletions(-) diff --git a/src/flash/cfi.c b/src/flash/cfi.c index e743fe9..b92ecbd 100644 --- a/src/flash/cfi.c +++ b/src/flash/cfi.c @@ -591,12 +591,6 @@ static int cfi

Re: [Openocd-development] [SERIES 0/6:0/84] command registration

2009-11-24 Thread Dean Glazeski
First of all, screw you for all of these patches. Frekin' 80+ emails! Dang :). Anyway, what's an efficient way for me to try and port my AT91SAM9 NAND flash over to this new interface? I'm thinking I create a branch for your changes, pull your changes against current orign/master, and merge in m

[Openocd-development] [patch 1/4] Cortex-A8: minor cleanup

2009-11-24 Thread David Brownell
Make various functions static, add some comments, report vector catch as a flavor of DBG_REASON_BREAKPOINT, get rid of needless/undesirable ARMV4_5_CORE_REG_MODE, etc. --- src/target/cortex_a8.c | 54 --- src/target/cortex_a8.h |7 +- 2 files c

[Openocd-development] [patch 2/4] Cortex-A8: implement dpm

2009-11-24 Thread David Brownell
This implements the DPM interface for Cortex-A8 cores, adding the CPSR synchronization operation it needs. --- src/target/arm_dpm.c | 13 +-- src/target/arm_dpm.h |3 src/target/armv7a.h|2 src/target/cortex_a8.c | 167 +++ 4 files c

[Openocd-development] [patch 4/4] Cortex-A8: avoid DSCR reads

2009-11-24 Thread David Brownell
There was a lot of needless handshaking overhead in the current Cortex-A8 DCC/ITR operations, since the status read by each step was discarded rather than letting the next step know it. This shrinks the handshaking by: (a) passing status along from previous steps, avoiding re-fetching; and the bi

[Openocd-development] [patch 3/4] Cortex-A8: hook up dpm

2009-11-24 Thread David Brownell
This replaces two versions of register access functions. One was commented out, and seemed to have uncertain intent. The other was fairly new, and helped motivate the DPM stuff. --- src/target/cortex_a8.c | 358 --- 1 file changed, 35 insertions(+), 3

[Openocd-development] [patch 0/4] Cortex-A8: support new DPM interface

2009-11-24 Thread David Brownell
The end-user visible win here is "faster register access", but there's also a lot to be said for starting to share code with ARM11; this way they can improve together. - Cleanup some messybits - Implement the DPM interface, and add a new DPM op the A8 needs - Hook up that DPM stuff, remove

Re: [Openocd-development] [SERIES 0/6:0/84] command registration

2009-11-24 Thread Zach Welch
On Tue, 2009-11-24 at 16:33 -0600, Dean Glazeski wrote: > First of all, screw you for all of these patches. Frekin' 80+ emails! Yeah, sorry. ;) I particularly apologize for 'git send-email' failing to properly thread the messages for each series under their summaries. Even so, only the first and

Re: [Openocd-development] [SERIES 0/6:0/84] command registration

2009-11-24 Thread David Brownell
On Tuesday 24 November 2009, Zach Welch wrote: > The following benefits can be expected from this work: > - Command registration is much simpler and easier to read and update. > - All registrations now get proper error checking. > - Eliminates redundant calls to register command: smaller binaries.

Re: [Openocd-development] [PATCH 07/10] allow target_type.h to be included alone

2009-11-24 Thread David Brownell
On Tuesday 24 November 2009, z...@superlucidity.net wrote: > It is an error to require other headers to be included first, so declare > what we can (struct declarations) and include the rest (Jim types). This one seemed out of step with the rest of these 80+ patches. Any particular reason why tha

Re: [Openocd-development] [PATCH 07/10] allow target_type.h to be included alone

2009-11-24 Thread Zach Welch
On Tue, 2009-11-24 at 16:54 -0800, David Brownell wrote: > On Tuesday 24 November 2009, z...@superlucidity.net wrote: > > It is an error to require other headers to be included first, so declare > > what we can (struct declarations) and include the rest (Jim types). > > This one seemed out of step

Re: [Openocd-development] [SERIES 0/6:0/84] command registration

2009-11-24 Thread Zach Welch
On Tue, 2009-11-24 at 16:51 -0800, David Brownell wrote: > On Tuesday 24 November 2009, Zach Welch wrote: > > The following benefits can be expected from this work: > > - Command registration is much simpler and easier to read and update. > > - All registrations now get proper error checking. > >

Re: [Openocd-development] [SERIES 0/6:0/84] command registration

2009-11-24 Thread Nicolas Pitre
On Tue, 24 Nov 2009, Zach Welch wrote: > On Tue, 2009-11-24 at 16:33 -0600, Dean Glazeski wrote: > > First of all, screw you for all of these patches. Frekin' 80+ emails! > > Yeah, sorry. ;) I particularly apologize for 'git send-email' failing > to properly thread the messages for each series

Re: [Openocd-development] [SERIES 0/6:0/84] command registration

2009-11-24 Thread Zach Welch
On Tue, 2009-11-24 at 21:55 -0500, Nicolas Pitre wrote: > On Tue, 24 Nov 2009, Zach Welch wrote: > > > On Tue, 2009-11-24 at 16:33 -0600, Dean Glazeski wrote: > > > First of all, screw you for all of these patches. Frekin' 80+ emails! > > > > Yeah, sorry. ;) I particularly apologize for 'git se

Re: [Openocd-development] [SERIES 0/6:0/84] command registration

2009-11-24 Thread Nicolas Pitre
On Tue, 24 Nov 2009, Zach Welch wrote: > On Tue, 2009-11-24 at 21:55 -0500, Nicolas Pitre wrote: > > On Tue, 24 Nov 2009, Zach Welch wrote: > > > > > On Tue, 2009-11-24 at 16:33 -0600, Dean Glazeski wrote: > > > > First of all, screw you for all of these patches. Frekin' 80+ emails! > > > > > >

Re: [Openocd-development] [SERIES 0/6:0/84] command registration

2009-11-24 Thread Zach Welch
On Tue, 2009-11-24 at 22:08 -0500, Nicolas Pitre wrote: > On Tue, 24 Nov 2009, Zach Welch wrote: > > > On Tue, 2009-11-24 at 21:55 -0500, Nicolas Pitre wrote: > > > On Tue, 24 Nov 2009, Zach Welch wrote: > > > > > > > On Tue, 2009-11-24 at 16:33 -0600, Dean Glazeski wrote: > > > > > First of all,

Re: [Openocd-development] [SERIES 0/6:0/84] command registration

2009-11-24 Thread Nicolas Pitre
On Tue, 24 Nov 2009, Zach Welch wrote: > On Tue, 2009-11-24 at 22:08 -0500, Nicolas Pitre wrote: > > Your usage of --in-reply-to is wrong. That made all patch series to end > > up in the same thread. > > How could I have done it right? Of course, this assumes that sending 6 > patche series in

Re: [Openocd-development] [SERIES 0/6:0/84] command registration

2009-11-24 Thread Zach Welch
On Tue, 2009-11-24 at 23:32 -0500, Nicolas Pitre wrote: > On Tue, 24 Nov 2009, Zach Welch wrote: > > > On Tue, 2009-11-24 at 22:08 -0500, Nicolas Pitre wrote: > > > Your usage of --in-reply-to is wrong. That made all patch series to end > > > up in the same thread. > > > > How could I have done

[Openocd-development] Flash Code for ADI's ADUC706x

2009-11-24 Thread EG
Hello, please find a tar attached containing additional files and a diff to add flash support for the ADUC706x controller to openocd 0.3.1 ... Best regards, Enrico -- {Diese eMail (inklusive aller enthaltenen Dateien) ist vertraulich und ausschliesslich fuer den genannten Empfaenger bestimmt. B

Re: [Openocd-development] Flash Code for ADI's ADUC706x

2009-11-24 Thread Zach Welch
On Wed, 2009-11-25 at 08:00 +0100, EG wrote: > Hello, > please find a tar attached containing additional files and a diff to > add flash support for the ADUC706x controller to openocd 0.3.1 ... > Best regards, Enrico Enrico, Some initial feedback: 1. Please send only plain text attachments

Re: [Openocd-development] Flash Code for ADI's ADUC706x

2009-11-24 Thread Øyvind Harboe
Start with creating a git patch against 0.3.1. This is actually quite easy, but will require that you google up the very basics of git. 1. Run git clone 2. Create your very own branch: git checkout -b aducflash v0.3.1 3. Copy all the files from your modified 0.3.1 4. Create the git patch: git

Re: [Openocd-development] [SERIES 0/6:0/84] command registration

2009-11-24 Thread Øyvind Harboe
On Wed, Nov 25, 2009 at 1:51 AM, David Brownell wrote: > On Tuesday 24 November 2009, Zach Welch wrote: >> The following benefits can be expected from this work: >> - Command registration is much simpler and easier to read and update. >> - All registrations now get proper error checking. >> - Elim

<    1   2