At Fri, 8 Dec 2006 20:20:20 +0200,
Alon Bar-Lev <[EMAIL PROTECTED]> wrote:
> 
> On Saturday 25 November 2006 01:35, Andreas Jellinghaus wrote:
> > BSD had for a long time this clause in its license:
> > 3. All advertising materials mentioning features or use of this
> > software must display the following acknowledgement:
> >       This product includes software developed by the University of
> >       California, Berkeley and its contributors.
> >
> > This clause caused a lot of problems. Some people like the FSF
> > Europe think it makes a license incompatible with the GPL, but even
> > if not it causes a lot of headache for everyone to make sure it is
> > adhered.
> 
> Hi!
> 
> I've modified pkcs11-helper to use the new free pkcs11.h header.
> I was surprised that it went relatively OK, good work! :)

I am glad to hear it worked well.
 
> Some modifications:
> 
> 1. I changed __WIN32 to _WIN32, since _WIN32 is the constant
> compilers use.
> If you require __WIN32, please revert but add _WIN32.

Ok with me.  I just picked one at random from my cross compiler setup.

> 2. Added CRYPTOKI_FORCE_WIN32, so that you can force the file
> to generate WIN32 fixups. This is important for cygwin environment.

Ok.
 
> 3. Added missing CKR_FUNCTION_REJECTED.

Ok.
 
> 4. I don't understand the uppercase/lowercase game you play here...
> But to #define common words as fixups is incorrect approach.
> Why not leave the original names?

Well, two reasons: We like the GNU coding standard, and I toyed with
the idea to just change the API so that we could make our own code
consistent.  But I haven't gotten around to do that yet (that's
because I wrote the code against the original API first before writing
the header file replacement).

The other reason, again of questionable value, is that it strengthens
our copyright on the file and makes it more of a work distinct from
the RSA header file.

Two bad reasons don't necessarily make a good reason, but I still
kinda like it that way.  Although I have to admit that the macro
definitions are gross!

> I've reverted the minimum required which conflict with Windows native
> definitions.
> -#define CreateMutex create_mutex
> -#define DestroyMutex destroy_mutex
> -#define LockMutex lock_mutex
> -#define UnlockMutex unlock_mutex

Yeah, well, I was afraid that something like that would happen.  One
possibility would be an API switch that selects between original
naming and GNU coding standard naming.

> 5. CK_RV type should be unsigned long.

Excellent catch!
 
> Please consider adding version information in the file text,
> so we can synchronize revisions.

Yes, good idea.

I will merge back your changes into my version after looking at your
other mails.  Thanks a lot for getting back to me about them!

Marcus

_______________________________________________
opensc-devel mailing list
opensc-devel@lists.opensc-project.org
http://www.opensc-project.org/mailman/listinfo/opensc-devel

Reply via email to