There's now a manpage that explains where and when engines can be named. :)
Not changing the behavior back to what it was, sorry.
Closing the ticket.
--
Rich Salz, OpenSSL dev team; rs...@openssl.org
--
Ticket here: http://rt.openssl.org/Ticket/Display.html?id=4194
Please log in as guest with pa
The old style of complete intermix of flags and parameters is not going to
happen.
___
openssl-dev mailing list
To unsubscribe: https://mta.openssl.org/mailman/listinfo/openssl-dev
Salz, Rich via RT wrote:
> So you're saying just close this ticket?
>
No. My request is to restore flexible engine command line and optionally
help string.
I only disagree with proposed partial correction for command line.
___
openssl-dev mailing list
So you're saying just close this ticket?
___
openssl-dev mailing list
To unsubscribe: https://mta.openssl.org/mailman/listinfo/openssl-dev
So you're saying just close this ticket?
___
openssl-dev mailing list
To unsubscribe: https://mta.openssl.org/mailman/listinfo/openssl-dev
Never mind that comment. Wrong thread...
Richard Levitte via RT skrev: (3 januari 2016 19:55:13 CET)
>The different subcommands act differently in this regard. I think it's
>time they get streamlined, and yes, I agree with the "any order"
>paradigm.
>
>I might do this tonight...
>
>Cheers
>Ri
The different subcommands act differently in this regard. I think it's time
they get streamlined, and yes, I agree with the "any order" paradigm.
I might do this tonight...
Cheers
Richard
Roumen Petrov via RT skrev: (3 januari 2016 19:31:29 CET)
>Salz, Rich via RT wrote:
>> Tweaked, sigh.
Salz, Rich via RT wrote:
> Tweaked, sigh.
> ; ./util/opensslwrap.sh engine - dynamic -pre
> engine: Cannot mix flags and engine names.
> engine: Use -help for summary.
> exit 1
>
If engine name cannot be at any position then please keep it as is. i.e.
at last position. In this ca
Tweaked, sigh.
; ./util/opensslwrap.sh engine - dynamic -pre
engine: Cannot mix flags and engine names.
engine: Use -help for summary.
exit 1
___
openssl-dev mailing list
To unsubscribe: https://mta.openssl.org/mailman/listinfo/openssl-
Salz, Rich via RT wrote:
> Please see this:
>
> https://github.com/openssl/openssl/compare/master...richsalz:rt4194?expand=1
>
It should fail with openssl engine - dynamic -pre
SO_PATH:/lib/libfoo.so
Help string looks good.
Roumen
___
Please see this:
https://github.com/openssl/openssl/compare/master...richsalz:rt4194?expand=1
___
openssl-dev mailing list
To unsubscribe: https://mta.openssl.org/mailman/listinfo/openssl-dev
Rich Salz via RT wrote:
> [SNIP]
> out = dup_bio_out(FORMAT_TEXT);
> - prog = opt_init(argc, argv, engine_options);
> if (!engines || !pre_cmds || !post_cmds)
> goto end;
> + while ((argv1 = argv[1]) != NULL && *argv1 != '-') {
> + sk_OPENSSL_STRING_push(engines, *argv1);
> + argc--;
> + argv++;
>
The patch is wrong, this one is better.
diff --git a/apps/engine.c b/apps/engine.c
index c373df5..ab663ea 100644
--- a/apps/engine.c
+++ b/apps/engine.c
@@ -312,12 +312,17 @@ int engine_main(int argc, char **argv)
BIO *out;
const char *indent = " ";
OPTION_CHOICE o;
- char *prog;
+ char *prog, *ar
Does this diff fix it?
; g diff apps/engine.c
diff --git a/apps/engine.c b/apps/engine.c
index c373df5..3c0ff96 100644
--- a/apps/engine.c
+++ b/apps/engine.c
@@ -312,12 +312,17 @@ int engine_main(int argc, char **argv)
BIO *out;
const char *indent = " ";
OPTION_CHOICE o;
-ch
Does this diff fix it?
; g diff apps/engine.c
diff --git a/apps/engine.c b/apps/engine.c
index c373df5..3c0ff96 100644
--- a/apps/engine.c
+++ b/apps/engine.c
@@ -312,12 +312,17 @@ int engine_main(int argc, char **argv)
BIO *out;
const char *indent = " ";
OPTION_CHOICE o;
-ch
Salz, Rich via RT wrote:
> I don't know that I would call it a regression, but rather a difference. :)
> I'll fix the summary but not the old uncommon behavior.
Unlike other commands engine is flexible and documented behaviour (see
previous post with quoted text).
As result in samples first is en
I don't know that I would call it a regression, but rather a difference. :)
I'll fix the summary but not the old uncommon behavior.
___
openssl-dev mailing list
To unsubscribe: https://mta.openssl.org/mailman/listinfo/openssl-dev
Hello,
OpenSSL engine command allows user to specify cryptographic module name
at any position.
For instance README.ENGINE recommend following:
openssl engine dynamic \
-pre SO_PATH:/lib/libfoo.so \
The master branch (future 1.1) requires engine names to be specified
after all o
18 matches
Mail list logo