[OpenWrt-Devel] [PATCH 1/2] kernel: add DT binding support to AVM EVA parser

2018-11-30 Thread David Bauer
It allows selecting split-firmware parser directly by specifying image-format in the device-tree. Signed-off-by: David Bauer --- .../generic/files/drivers/mtd/mtdsplit/mtdsplit_eva.c | 11 +++ 1 file changed, 11 insertions(+) diff --git

[OpenWrt-Devel] [PATCH 2/2] ath79: add AVM 4020 firmware partition compatible

2018-11-30 Thread David Bauer
This commit adds firmware partition compatible for the AVM FRITZ!Box 4020. This allows to select the correct mtdsplit parser instead of trying all available ones one by one. Signed-off-by: David Bauer --- target/linux/ath79/dts/qca9561_avm_fritz4020.dts | 1 + 1 file changed, 1 insertion(+)

Re: [OpenWrt-Devel] [PATCH fstools RFC] block: generate hotplug.d mount even "add" after mounting

2018-11-30 Thread Rafał Miłecki
On Fri, 30 Nov 2018 at 21:01, Michael Heimpold wrote: > I really appreciate working on this, thanks! > I just tried to apply this on top of current master but it fails to compile. > Additionally, a few comments inline below. Thanks! You need to apply this on top of the other 4 patches I sent

Re: [OpenWrt-Devel] [PATCH] odhcpd: allow specifying lease trigger mode

2018-11-30 Thread Michał Kępień via openwrt-devel
The sender domain has a DMARC Reject/Quarantine policy which disallows sending mailing list messages using the original "From" header. To mitigate this problem, the original message has been wrapped automatically by the mailing list software.--- Begin Message --- > > What usecase do you want to

Re: [OpenWrt-Devel] [PATCH fstools RFC] block: generate hotplug.d mount even "add" after mounting

2018-11-30 Thread Michael Heimpold
Hi, I really appreciate working on this, thanks! I just tried to apply this on top of current master but it fails to compile. Additionally, a few comments inline below. Am Freitag, 30. November 2018, 16:07:40 CET schrieb Rafał Miłecki: > From: Rafał Miłecki > > This is what was implemented in

Re: [OpenWrt-Devel] [PATCH fstools RFC] block: generate hotplug.d mount even "add" after mounting

2018-11-30 Thread John Crispin
On 30/11/2018 16:07, Rafał Miłecki wrote: From: Rafał Miłecki This is what was implemented in mountd and what some scripts used to use. It's a pretty generic solution for managing software that may use e.g. USB storage. Signed-off-by: Rafał Miłecki looks good, I agree that this is a

[OpenWrt-Devel] [PATCH fstools 1/2] block: make umount_device() function more generic

2018-11-30 Thread Rafał Miłecki
From: Rafał Miłecki Make it accept device path instead of struct probe_info. This way it can be reused by code fired when device is already gone. To keep existing functionality two checks have been moved to the main_umount(). Signed-off-by: Rafał Miłecki --- block.c | 37

[OpenWrt-Devel] [PATCH fstools 2/2] block: don't duplicate unmounting code in the mount_action()

2018-11-30 Thread Rafał Miłecki
From: Rafał Miłecki Use umount_device() helper instead. Signed-off-by: Rafał Miłecki --- block.c | 12 +--- 1 file changed, 1 insertion(+), 11 deletions(-) diff --git a/block.c b/block.c index bef5550..2ceee8d 100644 --- a/block.c +++ b/block.c @@ -1132,27 +1132,17 @@ static int

[OpenWrt-Devel] [PATCH fstools RFC] block: generate hotplug.d mount even "add" after mounting

2018-11-30 Thread Rafał Miłecki
From: Rafał Miłecki This is what was implemented in mountd and what some scripts used to use. It's a pretty generic solution for managing software that may use e.g. USB storage. Signed-off-by: Rafał Miłecki --- It's just a RFC for now. It's mainly missing a "remove" event support. --- block.c

[OpenWrt-Devel] [PATCH fstools 3/4] block: simplify code picking mount target directory

2018-11-30 Thread Rafał Miłecki
From: Rafał Miłecki Using a set of 3 conditional block each setting "target" variable makes code easier to follow. Signed-off-by: Rafał Miłecki --- block.c | 7 --- 1 file changed, 4 insertions(+), 3 deletions(-) diff --git a/block.c b/block.c index f42d0d6..0671aca 100644 --- a/block.c

[OpenWrt-Devel] [PATCH fstools 4/4] block: don't duplicate mounting code in the mount_device()

2018-11-30 Thread Rafał Miłecki
From: Rafał Miłecki Once target directory gets specified mounting code is identical for devices having and not having UCI config entry. Share it. Signed-off-by: Rafał Miłecki --- block.c | 49 - 1 file changed, 20 insertions(+), 29 deletions(-)

[OpenWrt-Devel] [PATCH fstools 1/4] block: fix formatting & indent in the mount_device()

2018-11-30 Thread Rafał Miłecki
From: Rafał Miłecki There was some misformatted code that seemed like switch block having an else block. This improves code readability. Signed-off-by: Rafał Miłecki --- block.c | 34 ++ 1 file changed, 18 insertions(+), 16 deletions(-) diff --git a/block.c

[OpenWrt-Devel] [PATCH fstools 2/4] block: move blockd_notify() call out of the conditional blocks

2018-11-30 Thread Rafał Miłecki
From: Rafał Miłecki That function is called no matter if "m" variable is null or not. This saves a one duplicated line & allows merging two conditional blocks starting with if (m). It doesn't change code execution order. Signed-off-by: Rafał Miłecki --- block.c | 16 +++- 1 file

Re: [OpenWrt-Devel] [PATCH 3/4] ramips: enforce image metadata verification

2018-11-30 Thread Petr Štetiar
Mathias Kresin [2018-11-30 12:43:24]: Hi, > Now that we got rid of all legacy images, we can enforce image metadata > verification. > > Signed-off-by: Mathias Kresin I've just tested your staging tree on my bdcom-wap2100: root@OpenWrt:/# cat /etc/openwrt_version r8623-fd6930b so you can

Re: [OpenWrt-Devel] [PATCH] ramips: upgrade: Enable checking of image metadata

2018-11-30 Thread Petr Štetiar
Mathias Kresin [2018-11-30 12:47:52]: Hi, > I've just send a patch series which drops the remaining legacy images, > enables the image metadata verification for all images and gets rid of the > old image checks. thanks a lot for taking care of that! -- ynezz

Re: [OpenWrt-Devel] [PATCH] ramips: upgrade: Enable checking of image metadata

2018-11-30 Thread Mathias Kresin
29/11/2018 10:36, Petr Štetiar: Checking metadata in image before flashing is nice for a good user experience and bricking protection as well, so enable it by default for all boards but the four legacy ones. Cc: Mathias Kresin Signed-off-by: Petr Štetiar ---

[OpenWrt-Devel] [PATCH 4/4] ramips: drop old image validation code

2018-11-30 Thread Mathias Kresin
Due to the enforced image metadata we ensure that the correct image is uploaded. Checks based on a magic arn't required any more. Signed-off-by: Mathias Kresin --- .../ramips/base-files/lib/upgrade/platform.sh | 330 +- 1 file changed, 1 insertion(+), 329 deletions(-) diff

[OpenWrt-Devel] [PATCH 2/4] ramips: drop support for legacy images

2018-11-30 Thread Mathias Kresin
Beside one exception, no one took care of the remaining boards using legacy image build code during the last two years. Since OpenWrt 14.07 the ALLNET ALL0239-3G image building is broken. The Sitecom WL-341 v3 imge build code looks pretty hackish and broken. It's uestionable if the legacy image

[OpenWrt-Devel] [PATCH 1/4] ramips: use new image build code for D-Link DCS-930 family

2018-11-30 Thread Mathias Kresin
Drop the factory images and the firmware tool to create them. They don't work any more, since the factory image has an uImage header covering the whole kernel + rootfs. This way the uImage splitter will not be able to find the rootfs and the kernel will panic later on. The factory images were

[OpenWrt-Devel] [PATCH 3/4] ramips: enforce image metadata verification

2018-11-30 Thread Mathias Kresin
Now that we got rid of all legacy images, we can enforce image metadata verification. Signed-off-by: Mathias Kresin --- target/linux/ramips/base-files/lib/upgrade/platform.sh | 1 + 1 file changed, 1 insertion(+) diff --git a/target/linux/ramips/base-files/lib/upgrade/platform.sh