[PATCH 3/3] hostapd: ubus: add get_status method

2020-11-04 Thread David Bauer
This adds a new get_status method to a hostapd interface, which provides information about the current interface status. Signed-off-by: David Bauer --- .../services/hostapd/src/src/ap/ubus.c| 40 +++ 1 file changed, 40 insertions(+) diff --git

[PATCH 1/3] hostapd: ubus: add driver information to client list

2020-11-04 Thread David Bauer
This adds information from mac80211 to hostapd get_client ubus function. This way, TX as well as RX status information as well as the signal can be determined. Signed-off-by: David Bauer --- .../services/hostapd/src/src/ap/ubus.c| 24 +++ 1 file changed, 24 insertions(+)

[PATCH 2/3] hostapd: ubus: add VHT capabilities to client list

2020-11-04 Thread David Bauer
This adds parsed VHT capability information to the hostapd get_clients method. Signed-off-by: David Bauer --- .../services/hostapd/src/src/ap/ubus.c| 71 +++ 1 file changed, 71 insertions(+) diff --git a/package/network/services/hostapd/src/src/ap/ubus.c

Re: [PATCH 2/5] ramips: mt7621: drop custom uImage function

2020-11-04 Thread Sander Vanheule
Hi Adrian, On Wed, 2020-11-04 at 14:42 +0100, Adrian Schmutzler wrote: > Hi Sander, > > > -Original Message- > > From: openwrt-devel > > [mailto:openwrt-devel-boun...@lists.openwrt.org] > > On Behalf Of Sander Vanheule > > Sent: Mittwoch, 4. November 2020 10:21 > > To:

[PATCH v2 3/6] rtl838x: add support for D-Link DGS-1210-28

2020-11-04 Thread Petr Štetiar
Hardware specification -- * RTL8382M SoC, 1 MIPS 4KEc core @ 500MHz * 128MB DRAM * 32MB NOR Flash (MX25L25635E) * 24 x 10/100/1000BASE-T ports - Internal PHY with 8 ports (RTL8218B) - Two external PHYs with 8 ports each (RTL8218B) * 4 x Gigabit RJ45/SFP Combo

[PATCH v2 2/6] rtl838x: d-link_dgs-1210: refactor common family bits

2020-11-04 Thread Petr Štetiar
So the common bits can be easily shared with other boards in the family and while at it add missing SPDX license identifiers into the DTS files and fixed alphabetic sorting of the devices in the images. Signed-off-by: Petr Štetiar --- .../dts/rtl8382_d-link_dgs-1210-10p.dts | 2 +

[PATCH v2 6/6] rtl838x: dts: use macros for phy and switch definitions

2020-11-04 Thread Petr Štetiar
It's quite more readable, saves some tedious copy, more error prone etc. Signed-off-by: Petr Štetiar --- .../dts/rtl8382_allnet_all-sg8208m.dts| 111 +- .../dts/rtl8382_d-link_dgs-1210-10p.dts | 125 +- .../dts/rtl8382_d-link_dgs-1210-16.dts| 261 ++---

[PATCH v2 0/6] rtl838x: add support for D-Link DGS-1210-28

2020-11-04 Thread Petr Štetiar
Hi, this patch series adds support for D-Link DGS-1210-28 device which is 28-Port Gigabit Switch. While at it, did some cleanup and refactoring so it's easier to add other devices from the same family. Changes since v1: - fixed two dtc warnings - fixed device order in image makefile - added

[PATCH v2 1/6] rtl838x: clean whitespace issues in rtl8382_d-link_dgs-1210-16.dts

2020-11-04 Thread Petr Štetiar
So it's tidy. Signed-off-by: Petr Štetiar --- target/linux/rtl838x/dts/rtl8382_d-link_dgs-1210-16.dts | 7 +++ 1 file changed, 3 insertions(+), 4 deletions(-) diff --git a/target/linux/rtl838x/dts/rtl8382_d-link_dgs-1210-16.dts b/target/linux/rtl838x/dts/rtl8382_d-link_dgs-1210-16.dts

[PATCH v2 4/6] rtl838x: rtl838x.dtsi: remove reg property from root node

2020-11-04 Thread Petr Štetiar
Fixes following dtc warning: ../dts/rtl838x.dtsi:38.3-145.3: Warning (reg_format): /: Root node has a "reg" property Signed-off-by: Petr Štetiar --- target/linux/rtl838x/dts/rtl838x.dtsi | 1 - 1 file changed, 1 deletion(-) diff --git a/target/linux/rtl838x/dts/rtl838x.dtsi

[PATCH v2 5/6] rtl838x: rtl838x.dtsi: fix missing interrupt-parent for uart0

2020-11-04 Thread Petr Štetiar
Fixes following dtc warning: Warning (interrupts_property): /uart@b8002000: Missing interrupt-parent Signed-off-by: Petr Štetiar --- target/linux/rtl838x/dts/rtl838x.dtsi | 2 ++ 1 file changed, 2 insertions(+) diff --git a/target/linux/rtl838x/dts/rtl838x.dtsi

firewall3: add udp/icmp flood protection

2020-11-04 Thread Maksym Kovalchuck
Signed-off-by: Maksym Kovalchuck --- defaults.c | 54 ++ options.h | 14 +++--- 2 files changed, 65 insertions(+), 3 deletions(-) diff --git a/defaults.c b/defaults.c index f03765c..a8c9d4d 100644 --- a/defaults.c +++ b/defaults.c @@

RE: [PATCH 2/5] ramips: mt7621: drop custom uImage function

2020-11-04 Thread Adrian Schmutzler
Hi Sander, > -Original Message- > From: openwrt-devel [mailto:openwrt-devel-boun...@lists.openwrt.org] > On Behalf Of Sander Vanheule > Sent: Mittwoch, 4. November 2020 10:21 > To: openwrt-devel@lists.openwrt.org > Cc: Sander Vanheule > Subject: [PATCH 2/5] ramips: mt7621: drop custom

RE: [PATCH 2/3] rtl838x: d-link_dgs-1210: refactor common family bits

2020-11-04 Thread Adrian Schmutzler
Hi Petr, > -Original Message- > From: openwrt-devel [mailto:openwrt-devel-boun...@lists.openwrt.org] > On Behalf Of Petr Štetiar > Sent: Mittwoch, 4. November 2020 13:11 > To: openwrt-devel@lists.openwrt.org > Cc: Petr Štetiar > Subject: [PATCH 2/3] rtl838x: d-link_dgs-1210: refactor

[PATCH 3/3] rtl838x: add support for D-Link DGS-1210-28

2020-11-04 Thread Petr Štetiar
Hardware specification -- * RTL8382M SoC, 1 MIPS 4KEc core @ 500MHz * 128MB DRAM * 32MB NOR Flash (MX25L25635E) * 24 x 10/100/1000BASE-T ports - Internal PHY with 8 ports (RTL8218B) - Two external PHYs with 8 ports each (RTL8218B) * 4 x Gigabit RJ45/SFP Combo

[PATCH 1/3] rtl838x: clean whitespace issues in rtl8382_d-link_dgs-1210-16.dts

2020-11-04 Thread Petr Štetiar
So it's tidy. Signed-off-by: Petr Štetiar --- target/linux/rtl838x/dts/rtl8382_d-link_dgs-1210-16.dts | 7 +++ 1 file changed, 3 insertions(+), 4 deletions(-) diff --git a/target/linux/rtl838x/dts/rtl8382_d-link_dgs-1210-16.dts b/target/linux/rtl838x/dts/rtl8382_d-link_dgs-1210-16.dts

[PATCH 0/3] rtl838x: add support for D-Link DGS-1210-28

2020-11-04 Thread Petr Štetiar
Hi, this patch series adds support for D-Link DGS-1210-28 device which is 28-Port Gigabit Switch. While at it, did some cleanup and refactoring so it's easier to add other devices from the same family. Cheers, Petr Petr Štetiar (3): rtl838x: clean whitespace issues in

[PATCH 2/3] rtl838x: d-link_dgs-1210: refactor common family bits

2020-11-04 Thread Petr Štetiar
So it can be easily shared with other boards in the family and while at it add missing SPDX license identifiers into the DTS files. Signed-off-by: Petr Štetiar --- .../dts/rtl8382_d-link_dgs-1210-16.dts| 81 +- .../rtl838x/dts/rtl8382_d-link_dgs-1210.dtsi | 84

[PATCH 1/5] build: uImage: allow override of default arguments

2020-11-04 Thread Sander Vanheule
For some build recipes, the argument to Build/uImage is used to sneak in extra arguments for mkimage, whereas this appears to have been intended to specificy the compression method only. Use the first provided word for -C to be backwards compatible with current calls to Build/uImage. Use the rest

[PATCH 3/5] build: add UIMAGE_MAGIC to device variables

2020-11-04 Thread Sander Vanheule
Allow a device recipe to specify a custom UIMAGE_MAGIC value, as used by OpenWrt's -M flag for mkimage. This allows to automatically customize the magic bytes in all calls to Build/uImage for this device, similar to the behaviour of UIMAGE_NAME. Since the -M argument is inserted before the user

[PATCH 2/5] ramips: mt7621: drop custom uImage function

2020-11-04 Thread Sander Vanheule
Use the mkimage argument overrides provided by uImage to implement the customisations required for the initramfs, instead of the near-identical custom function. Signed-off-by: Sander Vanheule --- Build tested for iodata_wn1167gr2, where uImage lzma -M 0x434f4d42 -n '3.10(XBC.1)b10' ...

[PATCH 0/5] Make Build/uImage more flexible

2020-11-04 Thread Sander Vanheule
Some devices use custom mkimage calls that differ only slightly from Build/uImage. Other devices use the argument to uImage to inject an extra argument to mkimage. This set of patches aims to make adding or overriding mkimage arguments more reliable, while maintaining backwards compatiblity with

[PATCH 5/5] rtl83xx: drop custom mkimage build function

2020-11-04 Thread Sander Vanheule
UIMAGE_MAGIC is now supported by Build/uImage, in addition to UIMAGE_NAME. This removes the need for a custom mkimage call, so let's remove it. Signed-off-by: Sander Vanheule --- target/linux/rtl838x/image/Makefile | 13 + 1 file changed, 1 insertion(+), 12 deletions(-) diff --git

[PATCH 4/5] ath79: netgear: trim down uImage customisations

2020-11-04 Thread Sander Vanheule
Replace NETGEAR_KERNEL_MAGIC by UIMAGE_MAGIC to better match the variable's purpose. This allows to drop UIMAGE_MAGIC where it equals the default for uImages, and remove the custom Build/netgear-uImage. Signed-off-by: Sander Vanheule --- Build tested for Netgear WNDR3700v2 and EX6400.