[osg-users] Shadow Volumes integration

2013-01-31 Thread PCJohn
Hi, me and my coleague have developed number of Shadow Volume shadow algorithms and we would like to contribute them one day to OSG. To mention the reason for Shadow Volumes: They are often used in CAD, etc. as they work in screen space, thus they do not suffer with aliasing/resolution problem

Re: [osg-users] Shadow Volumes integration

2013-01-31 Thread Jean-Sébastien Guay
Hi John, One suggestion, you could use nested namespaces, and then abbreviate locally so it's easier to read. For example: namespace osgShadow { namespace ShadowVolume { class Occluder { ... } } } // then in some .cpp file where you need to use it: namespace osgsv = osgS

Re: [osg-users] Shadow Volumes integration

2013-02-01 Thread Robert Osfield
Hi Johan and J&S, My inclination would be towards using a nested namespace as suggest by J-S, this will avoid wider namespace pollution with generic names, but still allow the implementation to use the short hand and end up with more readable code. Another twist on this is to use the class as a n

Re: [osg-users] Shadow Volumes integration

2013-02-01 Thread PCJohn
Hi Robert and J-S, thanks for suggestions. The namespace trick seems interesting. I will try to lead our code in this direction. John On Friday 01 of February 2013 09:05:47 Robert Osfield wrote: > Hi Johan and J&S, > > My inclination would be towards using a nested namespace as suggest by > J-S,