Re: [ovs-dev] [PATCH net-next v3 0/2] openvswitch: allow specifying ifindex of new interfaces

2022-08-26 Thread patchwork-bot+netdevbpf
Hello: This series was applied to netdev/net-next.git (master) by Jakub Kicinski : On Thu, 25 Aug 2022 05:04:48 +0300 you wrote: > Hi! > > CRIU currently do not support checkpoint/restore of OVS configurations, but > there was several requests for it. For example, >

Re: [ovs-dev] [PATCH net v2] openvswitch: fix memory leak at failed datapath creation

2022-08-26 Thread patchwork-bot+netdevbpf
Hello: This patch was applied to netdev/net.git (master) by Jakub Kicinski : On Thu, 25 Aug 2022 05:03:26 +0300 you wrote: > ovs_dp_cmd_new()->ovs_dp_change()->ovs_dp_set_upcall_portids() > allocates array via kmalloc. > If for some reason new_vport() fails during ovs_dp_cmd_new() >

Re: [ovs-dev] [PATCH 1/2] dpif-netdev/dpcls: Specialize more subtable signatures.

2022-08-26 Thread Ilya Maximets
On 8/25/22 16:45, Cian Ferriter wrote: > The subtable signatures being specialized here were found in an NVGRE > tunnel scenario. > > Signed-off-by: Cian Ferriter Hi, Cian. Not a review, just a comment. Please, give this patch a more descriptive subject. There is already a patch named

Re: [ovs-dev] [PATCH ovn v2] controller: fix potential segmentation violation when removing ports

2022-08-26 Thread Xavier Simonart
Hi Han Agreed that v2 is not correct as we might have cases where the peers are not added symmetrically (I'll add a test case highlighting this), and we'll hit the same kind of issue/crash. However, I am not sure that I can simply move "local_datapath_peer_port_add(ld, pb, peer);" into the above

Re: [ovs-dev] [PATCH ovn] tests: remove ofport-request from tests

2022-08-26 Thread Dumitru Ceara
On 8/22/22 12:27, Xavier Simonart wrote: > Testsuite used ofport-request for most of its tests. > However, this causes random tess failures as the Openflow port > number assigned to patch ports can change after its initial assignment. > For instance: > - OVN adds patch port ovn-hv1-0 => get ofport

Re: [ovs-dev] [PATCH] raft: Fix unnecessary periodic compactions.

2022-08-26 Thread Dumitru Ceara
On 8/20/22 01:08, Ilya Maximets wrote: > While creating a new database file and storing a new snapshot > into it, raft module by mistake updates the base offset for the > old file. So, the base offset of a new file remains zero. Then > the old file is getting replaced with the new one, copying

Re: [ovs-dev] [PATCH] ovsdb: Don't store rows that didn't change in transaction history.

2022-08-26 Thread Dumitru Ceara
On 8/4/22 18:37, Ilya Maximets wrote: > Transaction history is used to construct database updates for clients. > But if the row didn't change it will never be used for monitor updates, > because ovsdb_monitor_changes_classify() will always return > OVSDB_CHANGES_NO_EFFECT. So,

[ovs-dev] [PATCH 2/2] ovs-thread: Clean duplicated count_total_cores

2022-08-26 Thread Adrian Moreno
Total cpu count is already being calculated as part of count_cpu_cores. Consolidate both functions to avoid code duplication. Signed-off-by: Adrian Moreno --- lib/ovs-thread.c | 30 ++ 1 file changed, 10 insertions(+), 20 deletions(-) diff --git a/lib/ovs-thread.c

[ovs-dev] [PATCH 1/2] ovs-thread: Detect changes in cpu affinity

2022-08-26 Thread Adrian Moreno
It might be OK to consider the total number of online CPUs as a static value (although certain platforms do support CPU hot-plugging and CPUs can get disabled). However, it's much more likely that ovs-vswitchd's CPU affinity mask is modified dynamically. Fix cpu calculation to detect changes in

[ovs-dev] [PATCH 0/2] Detect changes in cpu affinity

2022-08-26 Thread Adrian Moreno
This small series aims to detect when the cpu affinity changes so that the number of revalidator/handler threads can be adjusted accordingly. This is specially important on per-cpu dispatch mode. The only reason for splitting this into two patches is because the first one can be backported easily

Re: [ovs-dev] [PATCH] python-c-ext: Use designated initializers for type and module.

2022-08-26 Thread Dumitru Ceara
On 7/22/22 21:19, Ilya Maximets wrote: > Python documentation suggests to do so "to avoid listing all the > PyTypeObject fields that you don't care about and also to avoid > caring about the fields' declaration order". And that does make > sense. > > Signed-off-by: Ilya Maximets > --- Aside

Re: [ovs-dev] [PATCH ovn v2] northd: Fix multicast table full

2022-08-26 Thread Dumitru Ceara
On 8/25/22 12:16, Xavier Simonart wrote: > active_v4_flows count was intialized when the northd node was computed. > However, neither sb_multicast_group nor en_sb_igmp_group causes northd > updates. Hence this count could keep increasing while processing igmp groups. > > This issue was sometimes

Re: [ovs-dev] [PATCH] dp-packet: Allow DPDK packet resize.

2022-08-26 Thread Ilya Maximets
On 8/26/22 14:14, David Marchand wrote: > Hi Ilya, > > On Thu, Jun 30, 2022 at 3:06 PM Ilya Maximets wrote: >> >> On 3/18/22 16:33, David Marchand wrote: >>> DPDK based dp-packets points to data buffers that can't be expanded >>> dynamically. >>> Their layout is as follows: >>> - a 128 bytes

[ovs-dev] [PATCH ovn] lb: Remove unused ovn_northd_lb_vip vip_port_str member.

2022-08-26 Thread Dumitru Ceara
Signed-off-by: Dumitru Ceara --- lib/lb.c | 5 + lib/lb.h | 1 - 2 files changed, 1 insertion(+), 5 deletions(-) diff --git a/lib/lb.c b/lib/lb.c index 7b0ed1abe..580efe7f7 100644 --- a/lib/lb.c +++ b/lib/lb.c @@ -103,7 +103,6 @@ void ovn_northd_lb_vip_init(struct ovn_northd_lb_vip

Re: [ovs-dev] [PATCH] dp-packet: Allow DPDK packet resize.

2022-08-26 Thread David Marchand
Hi Ilya, On Thu, Jun 30, 2022 at 3:06 PM Ilya Maximets wrote: > > On 3/18/22 16:33, David Marchand wrote: > > DPDK based dp-packets points to data buffers that can't be expanded > > dynamically. > > Their layout is as follows: > > - a 128 bytes headroom chosen at DPDK build time

Re: [ovs-dev] [PATCH net-next] genetlink: start to validate reserved header bytes

2022-08-26 Thread Paul Moore
On Wed, Aug 24, 2022 at 8:18 PM Jakub Kicinski wrote: > > We had historically not checked that genlmsghdr.reserved > is 0 on input which prevents us from using those precious > bytes in the future. > > One use case would be to extend the cmd field, which is > currently just 8 bits wide and 256 is

Re: [ovs-dev] [PATCH net-next v3 0/2] openvswitch: allow specifying ifindex of new interfaces

2022-08-26 Thread Christian Brauner
On Thu, Aug 25, 2022 at 05:04:48AM +0300, Andrey Zhadchenko wrote: > Hi! > > CRIU currently do not support checkpoint/restore of OVS configurations, but > there was several requests for it. For example, > https://github.com/lxc/lxc/issues/2909 > > The main problem is ifindexes of newly created

[ovs-dev] [PATCH v2 1/1] ofproto-dpif-trace: add --name option for ofproto/trace

2022-08-26 Thread Nobuhiro MIKI
Most of commands in ovs-ofctl and ovs-appctl can display port names instead of port numbers by using --names option. This change adds similar functionality to ofproto/trace. For backward compatibility, the default behavior is the same as before. Signed-off-by: Nobuhiro MIKI -- v2: * fix NEWS

Re: [ovs-dev] [PATCH v1 1/1] datapath-windows: Add IPv6 conntrack ip fragment support on windows

2022-08-26 Thread Wilson Peng via dev
Alin, And help check the new fix patch below, it could be applied to Mater and branch-3.0. It could make Geneve V6 tunnel could be Working for checksum offload enabled case. [ovs-dev,ovs-dev,v1,1/1] datapath-windows: Correct Geneve IPV6 header checksum parameter

Re: [ovs-dev] [PATCH v1 1/1] datapath-windows: Add IPv6 conntrack ip fragment support on windows

2022-08-26 Thread Dejing Liu via dev
Hi Alin, How about the status of latest patch, looking forward to your reply. Regards Dejing From: Dejing Liu Date: Monday, August 15, 2022 at 5:46 PM To: Alin-Gabriel Serdean , d...@openvswitch.org Cc: svc.ovs-community , Wilson Peng , Frank Guo , Lina Li Subject: Re: [ovs-dev] [PATCH

[ovs-dev] [PATCH nf] netfilter: remove nf_conntrack_helper sysctl toggle

2022-08-26 Thread Pablo Neira Ayuso
__nf_ct_try_assign_helper() remains in place but it now requires a template to configure the helper. A toggle to disable automatic helper assignment was added by: a9006892643a ("netfilter: nf_ct_helper: allow to disable automatic helper assignment") in 2012 to address the issues described in

Re: [ovs-dev] [PATCH 1/1] ofproto-dpif-trace: add --name option for ofproto/trace

2022-08-26 Thread Nobuhiro MIKI
On Wed, Aug 24, 2022 at 09:25:10AM -0400, Aaron Conole wrote: > Nobuhiro MIKI writes: > > > Most of commands in ovs-ofctl and ovs-appctl can display port names > > instead of port numbers by using --names option. This change adds > > similar functionality to ofproto/trace. > > > > For backward