Re: [ovs-dev] [PATCH ovn] tests: Simplify ovn-northd specific tests.

2022-10-05 Thread Dumitru Ceara
On 10/5/22 02:04, Han Zhou wrote: > On Fri, Sep 30, 2022 at 5:49 AM Dumitru Ceara wrote: >> >> Avoid having to add OVN_FOR_EACH_NORTHD for each test in ovn-northd.at. >> We know that all tests in there should be run for all types of northd >> and w/ or w/o parallelization enabled. Just wrap the w

[ovs-dev] [PATCH net-next 0/3] net: add helper support in tc act_ct for ovs offloading

2022-10-05 Thread Xin Long
Ilya reported an issue that FTP traffic would be broken when the OVS flow with ct(commit,alg=ftp) installed in the OVS kernel module, and it was caused by that TC didn't support the ftp helper offloaded from OVS. This patchset is to add the helper support in act_ct for ovs offloading in kernel net

[ovs-dev] [PATCH net-next 1/3] net: move the helper function to nf_conntrack_helper for ovs and tc

2022-10-05 Thread Xin Long
Move ovs_ct_helper from openvswitch to nf_conntrack_helper and rename as nf_ct_helper so that it can be used in TC act_ct in the next patch. Note that it also adds the checks for the family and proto, as in TC act_ct, the packets with correct family and proto are not guaranteed. Signed-off-by: Xin

[ovs-dev] [PATCH net-next 2/3] net: sched: call tcf_ct_params_free to free params in tcf_ct_init

2022-10-05 Thread Xin Long
This patch is to make the err path simple by calling tcf_ct_params_free(), so that it won't cause problems when more members are added into param and need freeing on the err path. Signed-off-by: Xin Long --- net/sched/act_ct.c | 35 ++- 1 file changed, 18 insertio

[ovs-dev] [PATCH net-next 3/3] net: sched: add helper support in act_ct

2022-10-05 Thread Xin Long
This patch is to add helper support in act_ct for OVS actions=ct(alg=xxx) offloading, which is corresponding to Commit cae3a2627520 ("openvswitch: Allow attaching helpers to ct action") in OVS kernel part. The difference is when adding TC actions family and proto cannot be got from the filter/matc

[ovs-dev] [PATCH ovn] tests: Don't run ovn-northd specific tests with ovn-controller flavors.

2022-10-05 Thread Dumitru Ceara
There's no point to do that because ovn-controller is not even running in ovn-northd.at tests. Wrap all tests in ovn-northd.at with calls to the newly added OVN_FOR_EACH_NORTHD_NO_HV(). This also fixes the fact that some tests were not run for all flavors of northd. Signed-off-by: Dumitru Ceara

Re: [ovs-dev] [PATCH ovn] northd.c: Adjust and add stopwatch for "lflows_to_sb".

2022-10-05 Thread Dumitru Ceara
On 10/5/22 01:14, Han Zhou wrote: > The stopwatch "lflows_dp_groups" was stopped in the middle of syncing > lflows to SB. This patch adjust it properly and add the new stopwatch > "lflows_to_sb" to measure the time for syncing lflows to SB. > > Signed-off-by: Han Zhou > --- Looks good to me, tha

[ovs-dev] [PATCH] ovs-tcpdump: Fix bond port unable to capture jumbo frames.

2022-10-05 Thread miterv
From: Lin Huang Currently the ovs-tcpdump utility creates a tap port to capture the frames of a bond port. If a user want to capture the packets from the bond port which member interface's mtu is more than 1500. By default the utility creates a tap port which mtu is 1500, regardless the member i

[ovs-dev] [PATCH 0/4] Configurable pmd-rxq-show 'pmd usage' time frame.

2022-10-05 Thread Kevin Traynor
Patch 1 is the main focus of the series as it adds to ability to specify the time frame for the 'ovs-appctl dpif-netdev/pmd-rxq-show' stat so that pmd usage can be evaluated to the granularity of 5 secs instead of the previous 60. Patch 2 adds docs/NEWS. Separate patch for ease of review, it can b

[ovs-dev] [PATCH 1/4] dpif-netdev: Make pmd-rxq-show time configurable.

2022-10-05 Thread Kevin Traynor
pmd-rxq-show shows the Rx queue to pmd assignments as well as the pmd usage of each Rx queue. Up until now a tail length of 60 seconds pmd usage was shown for each Rx queue, as this is the value used during rebalance to avoid any spike affects. When debugging or tuning, it is also convienent to d

[ovs-dev] [PATCH 3/4] tests: Add unit tests for pmd-rxq-show secs parameter.

2022-10-05 Thread Kevin Traynor
The default and maximum is 60 secs. Values are rounded up to a granularity of 5 secs. Signed-off-by: Kevin Traynor --- tests/pmd.at | 53 1 file changed, 53 insertions(+) diff --git a/tests/pmd.at b/tests/pmd.at index 61682a79f..ed90f88c4 10

[ovs-dev] [PATCH 2/4] docs: Add documention for pmd-rxq-show secs parameter.

2022-10-05 Thread Kevin Traynor
Add description of new '-secs' parameter in docs. Also, add to NEWS as it is a user facing change. Signed-off-by: Kevin Traynor --- Documentation/topics/dpdk/pmd.rst | 23 ++- NEWS | 3 +++ 2 files changed, 21 insertions(+), 5 deletions(-) diff

[ovs-dev] [PATCH 4/4] dpif-netdev: Rename pmd_info_show_rxq variables.

2022-10-05 Thread Kevin Traynor
There are some similar readings taken for pmds and Rx queues in this function and a few of the variable names are ambiguous. Improve the readability of the code by updating some variables names to indicate that they are readings related to the pmd. Signed-off-by: Kevin Traynor --- lib/dpif-netd

Re: [ovs-dev] [PATCH v2 ovn] controller: fix ipv6 prefix delegation in gw router mode

2022-10-05 Thread Lorenzo Bianconi
> On Tue, Oct 4, 2022 at 11:00 AM Lorenzo Bianconi < > lorenzo.bianc...@redhat.com> wrote: > > > > Fix regression in ipv6 prefix delegation running in gw router mode > > introduce by the following commit '04292cc2dc2c ("controller: fix > > potential segmentation violation when removing ports")'. >

Re: [ovs-dev] [PATCH v2 ovn] controller: fix ipv6 prefix delegation in gw router mode

2022-10-05 Thread Lorenzo Bianconi
On Oct 05, Xavier Simonart wrote: > Hi Lorenzo > > Thanks for providing this patch. > One very minor typo: see below. > Otherwise looks good to me > > Thanks > Xavier > > On Tue, Oct 4, 2022 at 8:00 PM Lorenzo Bianconi > wrote: > > > Fix regression in ipv6 prefix delegation running in gw route

Re: [ovs-dev] [PATCH ovn 4/8] Add NB and SB Template_Var tables.

2022-10-05 Thread Dumitru Ceara
On 10/5/22 07:30, Han Zhou wrote: > On Tue, Oct 4, 2022 at 10:27 PM Han Zhou wrote: >> >> >> >> On Fri, Sep 30, 2022 at 7:02 AM Dumitru Ceara wrote: >>> >>> Propagate the contents of the NB table to the Southbound. >>> >>> Signed-off-by: Dumitru Ceara >>> --- >>> Note: >>> - ovn-trace doesn't su

Re: [ovs-dev] [PATCH ovn 3/8] lflow: Factor out the lflow reference handling code into a new module.

2022-10-05 Thread Dumitru Ceara
On 10/5/22 07:20, Han Zhou wrote: > On Fri, Sep 30, 2022 at 7:01 AM Dumitru Ceara wrote: >> >> This makes it easier to have an overview of what the code does and at the >> same time it allows multiple users to define and manage >> "resource <-> object" dependencies. >> >> Signed-off-by: Dumitru Ce

Re: [ovs-dev] [PATCH ovn 5/8] controller: Add support for templated actions and matches.

2022-10-05 Thread Dumitru Ceara
On 10/5/22 07:42, Han Zhou wrote: > On Fri, Sep 30, 2022 at 7:02 AM Dumitru Ceara wrote: >> >> Expand SB.Template_Var records in two stages: >> 1. first expand them to local values in match/action strings >> 2. then reparse the expanded strings > > I haven't completed the full review of this patc

Re: [ovs-dev] [PATCH ovn 0/8] Add OVN component templates.

2022-10-05 Thread Dumitru Ceara
On 10/5/22 08:19, Han Zhou wrote: > On Fri, Sep 30, 2022 at 7:01 AM Dumitru Ceara wrote: >> >> Sometimes network components are compute node-specific. Sometimes such >> components are replicated, almost identically, for multiple nodes >> in the cluster. >> >> One such example is the case of Kuber

Re: [ovs-dev] [PATCH] ovs-tcpdump: Fix bond port unable to capture jumbo frames.

2022-10-05 Thread Aaron Conole
mit...@outlook.com writes: > From: Lin Huang > > Currently the ovs-tcpdump utility creates a tap port to capture the > frames of a bond port. > > If a user want to capture the packets from the bond port which member > interface's mtu is more than 1500. By default the utility creates a > tap port

Re: [ovs-dev] [PATCH ovn] spec: require python3-openvswitch for ovn-detrace

2022-10-05 Thread Numan Siddique
On Tue, Oct 4, 2022 at 5:41 AM Dumitru Ceara wrote: > > On 9/21/22 15:36, Vladislav Odintsov wrote: > > Signed-off-by: Vladislav Odintsov > > --- > > Hi Vladislav, > > > rhel/ovn-fedora.spec.in | 1 + > > 1 file changed, 1 insertion(+) > > > > diff --git a/rhel/ovn-fedora.spec.in b/rhel/ovn-fedo

Re: [ovs-dev] [PATCH v2 ovn] controller: fix ipv6 prefix delegation in gw router mode

2022-10-05 Thread Han Zhou
On Wed, Oct 5, 2022 at 6:06 AM Lorenzo Bianconi wrote: > > > On Tue, Oct 4, 2022 at 11:00 AM Lorenzo Bianconi < > > lorenzo.bianc...@redhat.com> wrote: > > > > > > Fix regression in ipv6 prefix delegation running in gw router mode > > > introduce by the following commit '04292cc2dc2c ("controller:

[ovs-dev] [PATCH v3 ovn] controller: fix ipv6 prefix delegation in gw router mode

2022-10-05 Thread Lorenzo Bianconi
Fix regression in ipv6 prefix delegation running in gw router mode introduce by the following commit '04292cc2dc2c ("controller: fix potential segmentation violation when removing ports")'. Fixes: 04292cc2dc2c ("controller: fix potential segmentation violation when removing ports") Reported-at: h

Re: [ovs-dev] [PATCH ovn 0/8] Add OVN component templates.

2022-10-05 Thread Han Zhou
On Wed, Oct 5, 2022 at 8:24 AM Dumitru Ceara wrote: > > On 10/5/22 08:19, Han Zhou wrote: > > On Fri, Sep 30, 2022 at 7:01 AM Dumitru Ceara wrote: > >> > >> Sometimes network components are compute node-specific. Sometimes such > >> components are replicated, almost identically, for multiple nod

[ovs-dev] [PATCH v1 1/5] treewide: use prandom_u32_max() when possible

2022-10-05 Thread Jason A. Donenfeld via dev
Rather than incurring a division or requesting too many random bytes for the given range, use the prandom_u32_max() function, which only takes the minimum required bytes from the RNG and avoids divisions. Signed-off-by: Jason A. Donenfeld --- arch/x86/mm/pat/cpa-test.c| 4 +-

[ovs-dev] [PATCH v1 2/5] treewide: use get_random_{u8, u16}() when possible

2022-10-05 Thread Jason A. Donenfeld via dev
Rather than truncate a 32-bit value to a 16-bit value or an 8-bit value, simply use the get_random_{u8,u16}() functions, which are faster than wasting the additional bytes from a 32-bit value. Signed-off-by: Jason A. Donenfeld --- crypto/testmgr.c | 8 +++

[ovs-dev] [PATCH v1 3/5] treewide: use get_random_u32() when possible

2022-10-05 Thread Jason A. Donenfeld via dev
The prandom_u32() function has been a deprecated inline wrapper around get_random_u32() for several releases now, and compiles down to the exact same code. Replace the deprecated wrapper with a direct call to the real function. Signed-off-by: Jason A. Donenfeld --- Documentation/networking/filte

[ovs-dev] [PATCH v1 5/5] prandom: remove unused functions

2022-10-05 Thread Jason A. Donenfeld via dev
With no callers left of prandom_u32() and prandom_bytes(), remove these deprecated wrappers. Signed-off-by: Jason A. Donenfeld --- include/linux/prandom.h | 12 1 file changed, 12 deletions(-) diff --git a/include/linux/prandom.h b/include/linux/prandom.h index 78db003bc290..e0a075

[ovs-dev] [PATCH v1 4/5] treewide: use get_random_bytes when possible

2022-10-05 Thread Jason A. Donenfeld via dev
The prandom_bytes() function has been a deprecated inline wrapper around get_random_bytes() for several releases now, and compiles down to the exact same code. Replace the deprecated wrapper with a direct call to the real function. Signed-off-by: Jason A. Donenfeld --- arch/powerpc/crypto/crc-vp

Re: [ovs-dev] [PATCH ovn 5/8] controller: Add support for templated actions and matches.

2022-10-05 Thread Han Zhou
On Wed, Oct 5, 2022 at 8:06 AM Dumitru Ceara wrote: > > On 10/5/22 07:42, Han Zhou wrote: > > On Fri, Sep 30, 2022 at 7:02 AM Dumitru Ceara wrote: > >> > >> Expand SB.Template_Var records in two stages: > >> 1. first expand them to local values in match/action strings > >> 2. then reparse the exp

Re: [ovs-dev] [PATCH ovn] northd.c: Adjust and add stopwatch for "lflows_to_sb".

2022-10-05 Thread Han Zhou
On Wed, Oct 5, 2022 at 2:59 AM Dumitru Ceara wrote: > > On 10/5/22 01:14, Han Zhou wrote: > > The stopwatch "lflows_dp_groups" was stopped in the middle of syncing > > lflows to SB. This patch adjust it properly and add the new stopwatch > > "lflows_to_sb" to measure the time for syncing lflows to

Re: [ovs-dev] [PATCH v3 ovn] controller: fix ipv6 prefix delegation in gw router mode

2022-10-05 Thread Han Zhou
On Wed, Oct 5, 2022 at 1:19 PM Lorenzo Bianconi wrote: > > Fix regression in ipv6 prefix delegation running in gw router mode > introduce by the following commit '04292cc2dc2c ("controller: fix > potential segmentation violation when removing ports")'. > > Fixes: 04292cc2dc2c ("controller: fix pot

Re: [ovs-dev] [PATCH v1 1/5] treewide: use prandom_u32_max() when possible

2022-10-05 Thread Kees Cook
On Wed, Oct 05, 2022 at 11:48:40PM +0200, Jason A. Donenfeld wrote: > Rather than incurring a division or requesting too many random bytes for > the given range, use the prandom_u32_max() function, which only takes > the minimum required bytes from the RNG and avoids divisions. Yes please! Since

Re: [ovs-dev] [PATCH v1 2/5] treewide: use get_random_{u8, u16}() when possible

2022-10-05 Thread Kees Cook
On Wed, Oct 05, 2022 at 11:48:41PM +0200, Jason A. Donenfeld wrote: > Rather than truncate a 32-bit value to a 16-bit value or an 8-bit value, > simply use the get_random_{u8,u16}() functions, which are faster than > wasting the additional bytes from a 32-bit value. > > Signed-off-by: Jason A. Don

Re: [ovs-dev] [PATCH v1 5/5] prandom: remove unused functions

2022-10-05 Thread Kees Cook
On Wed, Oct 05, 2022 at 11:48:44PM +0200, Jason A. Donenfeld wrote: > With no callers left of prandom_u32() and prandom_bytes(), remove these > deprecated wrappers. > > Signed-off-by: Jason A. Donenfeld Reviewed-by: Kees Cook -- Kees Cook ___ dev ma

Re: [ovs-dev] [PATCH v1 4/5] treewide: use get_random_bytes when possible

2022-10-05 Thread Kees Cook
On Wed, Oct 05, 2022 at 11:48:43PM +0200, Jason A. Donenfeld wrote: > The prandom_bytes() function has been a deprecated inline wrapper around > get_random_bytes() for several releases now, and compiles down to the > exact same code. Replace the deprecated wrapper with a direct call to > the real f

Re: [ovs-dev] [PATCH v1 4/5] treewide: use get_random_bytes when possible

2022-10-05 Thread Kees Cook
On Wed, Oct 05, 2022 at 11:48:43PM +0200, Jason A. Donenfeld wrote: > The prandom_bytes() function has been a deprecated inline wrapper around > get_random_bytes() for several releases now, and compiles down to the > exact same code. Replace the deprecated wrapper with a direct call to > the real f

Re: [ovs-dev] [PATCH v1 0/5] treewide cleanup of random integer usage

2022-10-05 Thread Kees Cook
On Wed, Oct 05, 2022 at 11:48:39PM +0200, Jason A. Donenfeld wrote: > Hi folks, > > This is a five part treewide cleanup of random integer handling. The > rules for random integers are: > > - If you want a secure or an insecure random u64, use get_random_u64(). > - If you want a secure or an inse

Re: [ovs-dev] [PATCH v1 0/5] treewide cleanup of random integer usage

2022-10-05 Thread Kees Cook
On Wed, Oct 05, 2022 at 09:55:43PM -0700, Kees Cook wrote: > If any of the subsystems ask you to break this up (I hope not), I've got > this[1], which does a reasonable job of splitting a commit up into > separate commits for each matching subsystem. [1] https://github.com/kees/kernel-tools/blob/t

[ovs-dev] [RFC PATCH 2/2] openflow: Add extension to flush CT by 5-tuple

2022-10-05 Thread Ales Musil
Curently there was only extension to flush CT by zone. Add another extension that will allow CT flush by full or partial 5-tuple. The extension can also specify the direction orig or reply. Reported-at: https://bugzilla.redhat.com/2120546 Signed-off-by: Ales Musil --- I'm mainly unsure about the

[ovs-dev] [RFC PATCH 1/2] dpif: Add support for CT flush with partial tuple

2022-10-05 Thread Ales Musil
Curreently in order to flush conntrack you would need to specify full 5-tuple. Add support for partial match it still has some limitations however it is capable of flushing all that match specified field e.g. source ip address. Reported-at: https://bugzilla.redhat.com/2120546 Signed-off-by: Ales M