Commit 08e9e5337383 fixed proper initialization of the dns-resolve
module, and made DNS resolution asynchronous.
A side effect of that change revealed a long standing logic bug
which broke ovsdb-server listener configuration using DNS names.
Previously this worked because the DNS resolution would
Hi Ilya,
Aside from the finding you made in patch 3, I couldn't find anything
wrong with the series. I have a minor suggestion on patch 7, but it's
nothing that should hold up merging the series.
For the series,
Acked-by: Mark Michelson
Thanks for the improvement!
On 2/7/23 06:42, Ilya Max
On 2/7/23 06:43, Ilya Maximets wrote:
Previous change introduced the ovn_lflow_add_with_dp_group() wrapper
and applied it to all the non-metered logical flows. Metered ones are
a bit more complex, but still can be optimized to use the new wrapper
in cases where CoPP is not enabled or enabled onl
On 8 Feb 2023, at 17:32, Simon Horman wrote:
> On Tue, Feb 07, 2023 at 03:03:57PM +0100, Eelco Chaudron wrote:
>> Include and run the system-traffic.at tests as part of the system offload
>> testsuite. Exclude all the tests that will not run without any special
>> modifications.
>>
>> Lowered l
On Wed, Feb 08, 2023 at 05:32:30PM +0100, Simon Horman wrote:
> On Tue, Feb 07, 2023 at 03:03:57PM +0100, Eelco Chaudron wrote:
> > Include and run the system-traffic.at tests as part of the system offload
> > testsuite. Exclude all the tests that will not run without any special
> > modifications.
On Tue, Feb 07, 2023 at 03:07:24PM +0100, Eelco Chaudron wrote:
> With some datapaths, read TC, it takes a bit longer to update the
> OpenFlow statistics. Rather than adding an additional delay, try
> to read the counters multiple times until we get the desired value.
>
> Signed-off-by: Eelco Chau
On Tue, Feb 07, 2023 at 03:06:23PM +0100, Eelco Chaudron wrote:
> If a tc flow was installed but has not yet been used, report it as such.
>
> In addition, add a delay to the "IGMP - flood under normal action" test
> case to make it work with many repetitions. This delay is also present
> in other
On Tue, Feb 07, 2023 at 03:06:07PM +0100, Eelco Chaudron wrote:
> Make the order of the Netlink attributes for odp_flow_key_from_flow__()
> the same as the kernel will return them.
>
> This will make sure the attributes displayed in the dpctl/dump-flows
> output appear in the same order for all da
On Tue, Feb 07, 2023 at 03:05:57PM +0100, Eelco Chaudron wrote:
> tc does not include ethernet header length in packet byte count.
> This fix will allow the packets that go trough tc to be 14 bytes less.
>
> This difference in the TC implementation is already described in
> tc-offload.rst.
>
> Si
On Tue, Feb 07, 2023 at 03:05:46PM +0100, Eelco Chaudron wrote:
> The tc conntrack implementation does not support the timeout option.
> The current implementation is silently ignoring the timeout option
> by adding a general conntrack entry.
>
> This patch will skip the related test by overriding
On Tue, Feb 07, 2023 at 03:05:25PM +0100, Eelco Chaudron wrote:
> tc does not support conntrack ALGs. Even worse, with tc enabled, they
> should not be used/configured at all. This is because even though TC
> will ignore the rules with ALG configured, i.e., they will flow through
> the kernel modul
On Tue, Feb 07, 2023 at 03:05:07PM +0100, Eelco Chaudron wrote:
> Flush datapath flows as TC flows take some more time to be flushed out.
> The flush speeds this up.
>
> Signed-off-by: Eelco Chaudron
> Acked-by: Roi Dayan
Reviewed-by: Simon Horman
Tested-by: Simon Horman
_
On Tue, Feb 07, 2023 at 03:04:42PM +0100, Eelco Chaudron wrote:
> tc was not setting the OVS_CT_ATTR_FORCE_COMMIT flag when a forced
> commit was requested. This patch will fix this.
>
> Fixes: 576126a931cd ("netdev-offload-tc: Add conntrack support")
>
> Signed-off-by: Eelco Chaudron
> Acked-by
On Tue, Feb 07, 2023 at 03:04:17PM +0100, Eelco Chaudron wrote:
> TC flower does not allow the push of the implicit null labels (RFC3032).
> Avoid the use of such labels in the MPLS test cases.
>
> Signed-off-by: Eelco Chaudron
> Acked-by: Roi Dayan
Reviewed-by: Simon Horman
Tested-by: Simon H
On Tue, Feb 07, 2023 at 03:03:57PM +0100, Eelco Chaudron wrote:
> Include and run the system-traffic.at tests as part of the system offload
> testsuite. Exclude all the tests that will not run without any special
> modifications.
>
> Lowered log level for "recirc_id sharing not supported" message,
On Tue, Feb 07, 2023 at 03:03:57PM +0100, Eelco Chaudron wrote:
> Include and run the system-traffic.at tests as part of the system offload
> testsuite. Exclude all the tests that will not run without any special
> modifications.
>
> Lowered log level for "recirc_id sharing not supported" message,
old_meter needs to be free after it is detached regardless of whether
the new meter is successfully attached.
Fixes: c7c4c44c9a95 ("net: openvswitch: expand the meters supported number")
Signed-off-by: Hangyu Hua
---
net/openvswitch/meter.c | 4 +++-
1 file changed, 3 insertions(+), 1 deletion(-
On Wed, Feb 8, 2023 at 6:29 AM Jakub Kicinski wrote:
> On Mon, 6 Feb 2023 18:13:12 +0200 Andy Shevchenko wrote:
> > +static inline bool string_is_valid(const char *s, int len)
> > +{
> > + return memchr(s, '\0', len) ? true : false;
> > +}
>
> I was tempted to suggest adding a kdoc, but perha
Hi Eelco, Ilya,
I’ve submitted v2 with requested changes addressed:
https://patchwork.ozlabs.org/project/openvswitch/patch/20230208152243.3686696-1-odiv...@gmail.com/Please,
let me know if this revision is okay or needs any improvements.
> On 7 Feb 2023, at 18:41, Eelco Chaudron wrote:
>
>
>
This patch adds new ovs-ctl options to pass umask configuration to allow
OVS daemons set requested socket permissions on group. Previous
behaviour (if using with systemd service unit) created sockets with 0750
permissions mask (group has no write permission).
Write permission for group is reasona
On Wed, Feb 08, 2023 at 03:43:06PM +0100, Jiri Pirko wrote:
> Wed, Feb 08, 2023 at 02:31:51PM CET, andriy.shevche...@linux.intel.com wrote:
> >Move string_is_valid() to the header for wider use.
> >
> >While at it, rename to string_is_terminated() to be
> >precise about its semantics.
>
> While at
Wed, Feb 08, 2023 at 02:31:53PM CET, andriy.shevche...@linux.intel.com wrote:
>Use string_is_terminated() helper instead of cpecific memchr() call.
>This shows better the intention of the call.
>
>Signed-off-by: Andy Shevchenko
>Reviewed-by: Simon Horman
Reviewed-by: Jiri Pirko
Wed, Feb 08, 2023 at 02:31:52PM CET, andriy.shevche...@linux.intel.com wrote:
>Use string_is_terminated() helper instead of cpecific memchr() call.
>This shows better the intention of the call.
>
>Signed-off-by: Andy Shevchenko
>Reviewed-by: Simon Horman
Reviewed-by: Jiri Pirko
Wed, Feb 08, 2023 at 02:31:51PM CET, andriy.shevche...@linux.intel.com wrote:
>Move string_is_valid() to the header for wider use.
>
>While at it, rename to string_is_terminated() to be
>precise about its semantics.
While at it, you could drop the ternary operator and return memchr()
directly.
Wi
Use string_is_terminated() helper instead of cpecific memchr() call.
This shows better the intention of the call.
Signed-off-by: Andy Shevchenko
Reviewed-by: Simon Horman
---
v3: renamed to string_is_terminated (Jakub)
v2: added tag and updated subject (Simon)
net/netlink/genetlink.c | 4 ++--
Use string_is_terminated() helper instead of cpecific memchr() call.
This shows better the intention of the call.
Signed-off-by: Andy Shevchenko
Reviewed-by: Simon Horman
---
v3: renamed to string_is_terminated (Jakub)
v2: added tag and updated subject (Simon)
net/openvswitch/conntrack.c | 5 ++
Move string_is_valid() to the header for wider use.
While at it, rename to string_is_terminated() to be
precise about its semantics.
Signed-off-by: Andy Shevchenko
Reviewed-by: Simon Horman
---
v3: renamed to string_is_terminated (Jakub)
v2: added tag and updated subject (Simon)
include/linux/
On Tue, Feb 07, 2023 at 05:52:09PM -0500, Xin Long wrote:
> This patch has no functional changes and just moves frag check and
> tc_skb_cb update out of handle_fragments, to make it easier to move
> the duplicate code from handle_fragments() into nf_conntrack_ovs later.
>
> Signed-off-by: Xin Long
On Tue, Feb 07, 2023 at 05:52:10PM -0500, Xin Long wrote:
> Now handle_fragments() in OVS and TC have the similar code, and
> this patch removes the duplicate code by moving the function
> to nf_conntrack_ovs.
>
> Note that skb_clear_hash(skb) or skb->ignore_df = 1 should be
> done only when defra
On Tue, Feb 07, 2023 at 05:52:08PM -0500, Xin Long wrote:
> This patch has no functional changes and just moves key and ovs_cb update
> out of handle_fragments, and skb_clear_hash() and skb->ignore_df change
> into handle_fragments(), to make it easier to move the duplicate code
> from handle_fragm
On Tue, Feb 07, 2023 at 05:52:07PM -0500, Xin Long wrote:
> There are almost the same code in ovs_skb_network_trim() and
> tcf_ct_skb_network_trim(), this patch extracts them into a function
> nf_ct_skb_network_trim() and moves the function to nf_conntrack_ovs.
>
> Signed-off-by: Xin Long
Review
On Tue, Feb 07, 2023 at 05:52:06PM -0500, Xin Long wrote:
> Similar to nf_nat_ovs created by Commit ebddb1404900 ("net: move the
> nat function to nf_nat_ovs for ovs and tc"), this patch is to create
> nf_conntrack_ovs to get these functions shared by OVS and TC only.
>
> There are nf_ct_helper()
On Wed, Feb 08, 2023 at 07:29:27AM +0100, Ales Musil wrote:
> On Tue, Feb 7, 2023 at 11:54 AM Simon Horman
> wrote:
>
> > On Mon, Feb 06, 2023 at 12:46:10PM +0100, Ales Musil wrote:
> > > The inner header was not handled properly.
> > > Simplify the code which allows proper handling
> > > of the
On Tue, Feb 7, 2023 at 9:08 AM Ales Musil wrote:
> There are essentially three problems with the current
> combination of DGP + SNAT + LB:
>
> 1) The first packet is being SNATed in common zone due
> to a problem with pinctrl not preserving ct_mark/ct_label.
> The commit would create a SNAT entry
34 matches
Mail list logo