Change 32041: Optimise the logic in isPRINT(), possible following Jarkko's bugfix

2007-10-06 Thread Nicholas Clark
Change 32041 by [EMAIL PROTECTED] on 2007/10/06 10:27:17 Optimise the logic in isPRINT(), possible following Jarkko's bugfix of change 10855. (to the implementation added in change 18) Nothing that a decent compiler optimiser would have missed. Affected files ... ... //de

Change 32040: Revert one hunk of change 32034 that had the possibility of being buggy

2007-10-06 Thread Nicholas Clark
Change 32040 by [EMAIL PROTECTED] on 2007/10/06 10:23:26 Revert one hunk of change 32034 that had the possibility of being buggy (the sprintf "%c" code will work correctly when the SV is UTF-8). Audit all the rest for UTF-8 correctness, and force SvUTF-8_off() in ut

Change 32042: Directly create the SV with Perl_newSVpvf() rather than using

2007-10-06 Thread Nicholas Clark
Change 32042 by [EMAIL PROTECTED] on 2007/10/06 12:22:58 Directly create the SV with Perl_newSVpvf() rather than using Perl_catSVpvf() to extend a zero-length SV. Affected files ... ... //depot/perl/perlio.c#371 edit Differences ... //depot/perl/perlio.c#371 (text) In

Change 32043: Avoid using *pvf functions when the format string is a fixed string.

2007-10-06 Thread Nicholas Clark
Change 32043 by [EMAIL PROTECTED] on 2007/10/06 12:23:15 Avoid using *pvf functions when the format string is a fixed string. Affected files ... ... //depot/perl/dump.c#277 edit ... //depot/perl/regcomp.c#613 edit Differences ... //depot/perl/dump.c#277 (text) Index: perl/dum

Change 32044: Use vnewSVpvf() rather than sv_vcatpvf() onto a newly created empty

2007-10-06 Thread Nicholas Clark
Change 32044 by [EMAIL PROTECTED] on 2007/10/06 12:54:32 Use vnewSVpvf() rather than sv_vcatpvf() onto a newly created empty string. Affected files ... ... //depot/perl/perlio.c#372 edit Differences ... //depot/perl/perlio.c#372 (text) Index: perl/perlio.c --- perl/pe

Change 32045: newSV(size) and SvPOK_on() will be more efficient than newSVpvs("")

2007-10-06 Thread Nicholas Clark
Change 32045 by [EMAIL PROTECTED] on 2007/10/06 12:55:29 newSV(size) and SvPOK_on() will be more efficient than newSVpvs("") followed by SvGROW(size+1) Affected files ... ... //depot/perl/utf8.c#304 edit Differences ... //depot/perl/utf8.c#304 (text) Index: perl/utf8.

Change 32046: Upgrade to Time-HiRes-1.9708

2007-10-06 Thread Steve Peters
Change 32046 by [EMAIL PROTECTED] on 2007/10/06 13:30:59 Upgrade to Time-HiRes-1.9708 Affected files ... ... //depot/perl/ext/Time/HiRes/HiRes.pm#75 edit Differences ... //depot/perl/ext/Time/HiRes/HiRes.pm#75 (text) Index: perl/ext/Time/HiRes/HiRes.pm --- perl/ext/Time/HiRes

Change 32047: Fix typo in change 32043 - s/sv_catpvf/sv_catpvs/

2007-10-06 Thread Nicholas Clark
Change 32047 by [EMAIL PROTECTED] on 2007/10/06 14:56:18 Fix typo in change 32043 - s/sv_catpvf/sv_catpvs/ Affected files ... ... //depot/perl/dump.c#278 edit Differences ... //depot/perl/dump.c#278 (text) Index: perl/dump.c --- perl/dump.c#277~32043~ 2007-10-06 05:23:15

Change 32048: Add a new flag PERL_PV_PRETTY_NOCLEAR (actually just

2007-10-06 Thread Nicholas Clark
Change 32048 by [EMAIL PROTECTED] on 2007/10/06 15:04:04 Add a new flag PERL_PV_PRETTY_NOCLEAR (actually just PERL_PV_ESCAPE_NOCLEAR), and change Perl_pv_pretty() so that if this bit is set, the output SV is not reset to an empty string. Affected files ... ... //depot/per

Change 32049: Use the PERL_PV_PRETTY_NOCLEAR flag to simplify the code in

2007-10-06 Thread Nicholas Clark
Change 32049 by [EMAIL PROTECTED] on 2007/10/06 15:04:53 Use the PERL_PV_PRETTY_NOCLEAR flag to simplify the code in Perl_regprop() for the EXACT node case. Affected files ... ... //depot/perl/regcomp.c#614 edit Differences ... //depot/perl/regcomp.c#614 (text) Index:

Change 32050: Fix precedence bug in the logic for PERL_PV_ESCAPE_NOCLEAR in

2007-10-06 Thread Nicholas Clark
Change 32050 by [EMAIL PROTECTED] on 2007/10/06 15:29:44 Fix precedence bug in the logic for PERL_PV_ESCAPE_NOCLEAR in Perl_pv_escape() Affected files ... ... //depot/perl/dump.c#280 edit Differences ... //depot/perl/dump.c#280 (text) Index: perl/dump.c --- perl/dump.

Change 32051: Nothing* outside the core uses the old misspelling

2007-10-06 Thread Nicholas Clark
Change 32051 by [EMAIL PROTECTED] on 2007/10/06 15:38:52 Nothing* outside the core uses the old misspelling PERL_PV_PRETTY_ELIPSES, so remove it. * well, nothing that Google can find. Same thing, isn't it? :-) Affected files ... ... //depot/perl/perl.h#798 edit Differenc

Change 32052: The scratch scalar used in -d processing for : and = options would leak

2007-10-06 Thread Nicholas Clark
Change 32052 by [EMAIL PROTECTED] on 2007/10/06 16:32:36 The scratch scalar used in -d processing for : and = options would leak as it was never freed. Affected files ... ... //depot/perl/perl.c#825 edit Differences ... //depot/perl/perl.c#825 (text) Index: perl/perl.

Change 32053: Add symlink support to Cwd::_vms_abs_path.

2007-10-06 Thread Craig A . Berry
Change 32053 by [EMAIL PROTECTED] on 2007/10/06 18:28:59 Add symlink support to Cwd::_vms_abs_path. Affected files ... ... //depot/perl/ext/Cwd/t/cwd.t#37 edit ... //depot/perl/lib/Cwd.pm#110 edit Differences ... //depot/perl/ext/Cwd/t/cwd.t#37 (text) Index: perl/ext/Cwd/t/cw

Change 32054: Remove remaining Cs and Cs

2007-10-06 Thread Nicholas Clark
Change 32054 by [EMAIL PROTECTED] on 2007/10/06 21:23:23 Remove remaining Cs and Cs Affected files ... ... //depot/perl/dump.c#281 edit ... //depot/perl/perl.c#826 edit ... //depot/perl/perly.act#36 edit ... //depot/perl/perly.y#90 edit ... //depot/perl/toke.c#795 edit Differences ...

Change 32055: Propagate the perlapi.pod part of change 32026 back to the source POD.

2007-10-06 Thread Nicholas Clark
Change 32055 by [EMAIL PROTECTED] on 2007/10/06 21:24:32 Propagate the perlapi.pod part of change 32026 back to the source POD. Affected files ... ... //depot/perl/sv.c#1430 edit Differences ... //depot/perl/sv.c#1430 (text) Index: perl/sv.c --- perl/sv.c#1429~32035~ 20

Change 32056: "A" should no longer be in the list of options acceptable to PERL5OPT,

2007-10-06 Thread Nicholas Clark
Change 32056 by [EMAIL PROTECTED] on 2007/10/06 22:22:20 "A" should no longer be in the list of options acceptable to PERL5OPT, now that assertions have been removed. Affected files ... ... //depot/perl/perl.c#827 edit Differences ... //depot/perl/perl.c#827 (text) In

Change 32057: Finally! Worked out how to const Perl_moreswitches().

2007-10-06 Thread Nicholas Clark
Change 32057 by [EMAIL PROTECTED] on 2007/10/06 23:44:50 Finally! Worked out how to const Perl_moreswitches(). Although I've committed crimes against indenting to avoid losing blame annotation history. Revisit this when we have verstion control that can easily see t

Change 32058: Re: several compilation problems on VMS in [EMAIL PROTECTED]

2007-10-06 Thread Nicholas Clark
Change 32058 by [EMAIL PROTECTED] on 2007/10/06 23:50:49 Subject: Re: several compilation problems on VMS in [EMAIL PROTECTED] From: "Craig A. Berry" <[EMAIL PROTECTED]> Message-ID: <[EMAIL PROTECTED]> Date: Sat, 6 Oct 2007 13:47:03 -0500 Affected files ... ... //