Re: Re: [perl #39777] Large Subroutine Segfaults IMCC

2006-07-10 Thread Vishal Soni
Hi Matt, I can patch up something that would spit out an error message and exit rather than Segfaulting. Right now there is no bounds check. Other thing I could do is re-allocate the Macro Array size when it gets full. So it would not fail until system starts swapping :-) I would prefer the se

Re: Re: [perl #39777] Large Subroutine Segfaults IMCC

2006-07-10 Thread Matt Diephouse
Vishal Soni <[EMAIL PROTECTED]> wrote: Hi Matt, This patch is because the number of .constant decls in IMCC is limited to 4096. This is a todo to make this dynamic. The evil code seems to have about 4200 .constant decls being generated. Here is the patch to fix it. For now I bumped up the limit

[CAGE] Output of CPD on src/

2006-07-10 Thread Juan Jose Natera
Hi, As per the cage/todo.pod I ran CPD (http://pmd.sourceforge.net) on src/, the attached file contains the output. With some pointers, I can figure out how to eliminate the code duplication, please advice. Regards, Juan Jose Skipping /home/juanjose/projects/parrot-bleed/src/exec_save.c du

Re: Stealing base

2006-07-10 Thread Chip Salzenberg
On Mon, Jul 10, 2006 at 09:25:53PM -0700, Allison Randal wrote: > Maybe get_top_global We can claim it stands for "the 'ole (bl***y) > path". ;) Now that's the Perl design metric I've come to know and love. :-) Seriously, it works for me. I suggest that you delay the final choice utnil yo

Re: Java Script in Parrot

2006-07-10 Thread Vishal Soni
Thanks Chris I looked at it but it does not implement Unicode in PGE and Optok too.. On Mon, 2006-07-10 at 23:30 -0500, Chris Dolan wrote: > On Jul 10, 2006, at 4:31 PM, Vishal Soni wrote: > > > This is is a good starting point. I have been writing the > > JavaScript grammar > > in PGE fromE

Re: Java Script in Parrot

2006-07-10 Thread Chris Dolan
On Jul 10, 2006, at 4:31 PM, Vishal Soni wrote: This is is a good starting point. I have been writing the JavaScript grammar in PGE fromECMA-262 spec. They lay out the operator precedence using Grammar rules. Instead of using rules for operator precedence I would like to use your optok appr

Re: Stealing base

2006-07-10 Thread Allison Randal
Bob Rogers wrote: >From: Chip Salzenberg <[EMAIL PROTECTED]> >Date: Mon, 10 Jul 2006 19:41:38 -0700 > >(You'll probably want to know that "get_base_global" has a slight object- >orientation connotation from my C++ experience; in C++, a superclass is >called a "base class". Whe

Re: "Dynamic" (was discussion for #39711 -- [TODO] Make PIR->PBC reentrant)

2006-07-10 Thread Audrey Tang
在 2006/7/5 上午 12:15 時,chromatic 寫到: On Tuesday 04 July 2006 21:01, Audrey Tang wrote: Hence I'm puzzled why you raise the "dynamic language" categorization as a justification, for that term usually refers to dynamic typing, not to :immediate. If it is referring to :immediate, then Python/ Ru

Stealing base

2006-07-10 Thread Bob Rogers
From: Chip Salzenberg <[EMAIL PROTECTED]> Date: Mon, 10 Jul 2006 19:41:38 -0700 (You'll probably want to know that "get_base_global" has a slight object- orientation connotation from my C++ experience; in C++, a superclass is called a "base class". Whether this matters depends enti

Re: HLL root globals and empty keys (was Re: test of get_namespace opcode)

2006-07-10 Thread Chip Salzenberg
On Mon, Jul 10, 2006 at 07:22:21PM -0700, Allison Randal wrote: > Chip Salzenberg wrote: > > I think that "hll" is the best I can think of, and given the existing > > ".HLL" directive, its meaning is immediately clear: > > I like that. Great! > > Seems to me that we should have get_namespace pat

Re: Re: HLL root globals and empty keys (was Re: test of get_namespace opcode)

2006-07-10 Thread Chip Salzenberg
On Mon, Jul 10, 2006 at 06:57:06PM -0700, Matt Diephouse wrote: > Patrick R. Michaud <[EMAIL PROTECTED]> wrote: > >I really like both of these suggestions. We also noted on #parrot that > >get_hll_global would really simplify things for the Tcl folks, which > >currently go through a macro to achie

Re: HLL root globals and empty keys (was Re: test of get_namespace opcode)

2006-07-10 Thread Allison Randal
Chip Salzenberg wrote: > > Hrm. Relative is the usual apposite to absolute, but we have a three-way > logic here, so appositives don't really work. I think that "hll" is the > best I can think of, and given the existing ".HLL" directive, its meaning > is immediately clear: I like that. > Seems

Re: Re: HLL root globals and empty keys (was Re: test of get_namespace opcode)

2006-07-10 Thread Matt Diephouse
Patrick R. Michaud <[EMAIL PROTECTED]> wrote: On Mon, Jul 10, 2006 at 02:53:15PM -0700, Chip Salzenberg wrote: > On Mon, Jul 10, 2006 at 03:23:56PM -0500, Patrick R. Michaud wrote: > > On Sat, Jul 08, 2006 at 01:57:58PM -0700, Chip Salzenberg wrote: > > > Relative is the usual apposite to absolut

Re: OSCON hackathon

2006-07-10 Thread Allison Randal
Chip Salzenberg wrote: > > I think it'd be great to maintain a hackathon designated location for those > who are between tutorials, or who like me just show up during tutorial days > for the hell of it. :-) There's a designated room for hackathon/Camp-style sessions inside the convention center

[perl #39784] Make Parrot's default namespace be untyped

2006-07-10 Thread via RT
# New Ticket Created by Chip Salzenberg # Please include the string: [perl #39784] # in the subject line of all future correspondence about this issue. # http://rt.perl.org/rt3/Ticket/Display.html?id=39784 > Parrot's default namespace implementation should be 100% untyped -- basically just a

Re: [perl #39778] Segfault when using a Namespace with an Iterator

2006-07-10 Thread Chip Salzenberg
On Sun, Jul 09, 2006 at 11:52:23PM -0700, Matt Diephouse wrote: > Trying to use an Iterator with a NameSpace makes Parrot segfault Ouch. The current namespace class is typed but in a silly way -- not with name mangling but with actually storing two things with exactly the same name. (One being a

Re: OSCON hackathon

2006-07-10 Thread Chip Salzenberg
On Mon, Jul 10, 2006 at 06:09:32PM -0500, Patrick R. Michaud wrote: > However, for those who cannot make it on Sunday, I notice that Monday and > Tuesday at OSCON are primarily dedicated for tutorial sessions, so people > arriving after Sunday and/or not attending or presenting tutorials can > perh

OSCON hackathon

2006-07-10 Thread Patrick R. Michaud
For those who are interested in doing hackathoning at OSCON, we're currently planning to do things on Sunday the 23rd. I'll see if I can find a designated place for us to meet and work. However, for those who cannot make it on Sunday, I notice that Monday and Tuesday at OSCON are primarily dedicat

Re: HLL root globals and empty keys (was Re: test of get_namespace opcode)

2006-07-10 Thread Patrick R. Michaud
On Mon, Jul 10, 2006 at 02:53:15PM -0700, Chip Salzenberg wrote: > On Mon, Jul 10, 2006 at 03:23:56PM -0500, Patrick R. Michaud wrote: > > On Sat, Jul 08, 2006 at 01:57:58PM -0700, Chip Salzenberg wrote: > > > Relative is the usual apposite to absolute, but we have a three-way > > > logic here, so

Re: HLL root globals and empty keys (was Re: test of get_namespace opcode)

2006-07-10 Thread Chip Salzenberg
On Mon, Jul 10, 2006 at 03:23:56PM -0500, Patrick R. Michaud wrote: > On Sat, Jul 08, 2006 at 01:57:58PM -0700, Chip Salzenberg wrote: > > Relative is the usual apposite to absolute, but we have a three-way > > logic here, so appositives don't really work. I think that "hll" is the > > best I can

Re: Java Script in Parrot

2006-07-10 Thread Vishal Soni
Hi Patrick, This is is a good starting point. I have been writing the JavaScript grammar in PGE fromECMA-262 spec. They lay out the operator precedence using Grammar rules. Instead of using rules for operator precedence I would like to use your optok approach. Is there some help I can get? I did

Re: Java Script in Parrot

2006-07-10 Thread Patrick R. Michaud
On Mon, Jul 10, 2006 at 09:19:14PM +0100, Norman Nunley, Jr wrote: > There's a rules grammar in http://svn.openfoundry.org/pugs/misc/ > JavaScript-FrontEnd/Grammar.pm > > When I last attempted to compile it with PGE, it gave up the ghost in > the character class definitions. Wow, thanks for th

Re: HLL root globals and empty keys (was Re: test of get_namespace opcode)

2006-07-10 Thread Patrick R. Michaud
On Sat, Jul 08, 2006 at 01:57:58PM -0700, Chip Salzenberg wrote: > Relative is the usual apposite to absolute, but we have a three-way > logic here, so appositives don't really work. I think that "hll" is the > best I can think of, and given the existing ".HLL" directive, its meaning > is immediat

Re: Java Script in Parrot

2006-07-10 Thread Patrick R. Michaud
On Sun, Jul 09, 2006 at 04:11:55PM -0700, chromatic wrote: > On Sunday 09 July 2006 02:15, Vishal Soni wrote: > > > I am not an expert on which approach is the way to go: > > 1. Hack Mozilla's JavaScript excution engine to generate PIR. > > If there's a fairly direct correspondence between JS byt

Re: HLL, perl6

2006-07-10 Thread Patrick R. Michaud
On Mon, Jul 10, 2006 at 12:10:37AM -0400, Will Coleda wrote: > I am currently trying to add some PGE to tcl (for the [expr] command, > where the optok parsing will be very helpful). > > While debugging, I noticed that perl6 isn't using the .HLL directive: > I suspect the namespace lookup issue

Re: I'm pre-hackathoning at OSCON, not post-hackathoning

2006-07-10 Thread Andy Lester
On Jul 10, 2006, at 12:39 PM, Patrick R. Michaud wrote: Yes, I'm now targeting any hackathoning in Portland to occur on the Sunday before OSCON instead of the Saturday after. I'll be in Monday afternoon and leaving Friday afternoon so nyeah! -- Andy Lester => [EMAIL PROTECTED] => www.petdanc

Re: [perl #39776] [BUG] PGE core dump

2006-07-10 Thread Patrick R. Michaud
On Sun, Jul 09, 2006 at 07:15:07PM -0700, Kevin Tew wrote: > ../../parrot ../../compilers/pge/pgc.pir > --output=lib/pruby_grammar_gen.pir lib/pruby.pg > Method 'reduce' not found > current instr.: 'parrot;PGE::Exp::Quant;reduce' pc 4358 > (compilers/pge/PGE/Exp.pir:402) > ... > pruby.pg is avail

Re: Ruby on Parrot

2006-07-10 Thread Patrick R. Michaud
On Fri, Jul 07, 2006 at 10:07:57AM -0600, Kevin Tew wrote: > I based the initial PGE grammar for PRuby off of > svn://rubyforge.org/var/svn/rubygrammar/grammars/antlr-v3/trunk/ruby.g > which is in complete. > I'm looking for a BNF style description of the Ruby grammar. Otherwise > I will have

Re: I'm pre-hackathoning at OSCON, not post-hackathoning

2006-07-10 Thread jerry gay
On 7/10/06, Patrick R. Michaud <[EMAIL PROTECTED]> wrote: On Fri, Jul 07, 2006 at 01:36:06PM -0700, Chip Salzenberg wrote: > I'm unable to hang around Portland after Friday afternoon, I'm sorry to > report, so Saturday hackathoning will miss me. However, I will be arriving > a day _early_ so I'l

Re: I'm pre-hackathoning at OSCON, not post-hackathoning

2006-07-10 Thread Patrick R. Michaud
On Fri, Jul 07, 2006 at 01:36:06PM -0700, Chip Salzenberg wrote: > I'm unable to hang around Portland after Friday afternoon, I'm sorry to > report, so Saturday hackathoning will miss me. However, I will be arriving > a day _early_ so I'll be in Portland all day Sunday. I understood Patrick > to

Re: Building a Fedora package

2006-07-10 Thread Steven Pritchard
On Sun, Jul 09, 2006 at 01:16:47AM -1000, Joshua Hoblitt wrote: > When you say, "On x86_64" I think what your really mean is a "x86_64 > system with multilib support". Right. > You are correct that the current build system does not support > multilib builds or installs (or at least it didn't the

Parrot Bug Summary

2006-07-10 Thread Parrot Bug Summary
Parrot Bug Summary http://rt.perl.org/rt3/NoAuth/parrot/Overview.html Generated at Mon Jul 10 13:15:01 2006 GMT --- * Numbers * New Issues * Overview of Open Issues * Ticket Status By Version * Requestors with m

[perl #39776] [BUG] PGE core dump

2006-07-10 Thread via RT
# New Ticket Created by Kevin Tew # Please include the string: [perl #39776] # in the subject line of all future correspondence about this issue. # http://rt.perl.org/rt3/Ticket/Display.html?id=39776 > --- osname= darwin osvers= 8.0 arch= darwin-thread-multi-2level cc= cc --- Flags: