Re: [PATCHES] use new List API names

2004-05-30 Thread Tom Lane
Neil Conway <[EMAIL PROTECTED]> writes: > Tom Lane wrote: >> I thought llast() and length() were going away too? > For llast(), I decided to keep it around: it is nicely symmetric > with linitial(), and it makes any code that actually needs the last > value in a list significantly more readable.

Re: [PATCHES] use new List API names

2004-05-30 Thread Neil Conway
Tom Lane wrote: I thought llast() and length() were going away too? For llast(), I decided to keep it around: it is nicely symmetric with linitial(), and it makes any code that actually needs the last value in a list significantly more readable. Since it's a macro there's no runtime cost. I had

Re: [PATCHES] use new List API names

2004-05-30 Thread Tom Lane
Neil Conway <[EMAIL PROTECTED]> writes: > This patch updates the remaining parts of the source tree to use the > new List API function names and disables the list compatibility API > by default. This patch compiles without warnings and passes the > regression tests. I thought llast() and length

[PATCHES] use new List API names

2004-05-30 Thread Neil Conway
This patch updates the remaining parts of the source tree to use the new List API function names and disables the list compatibility API by default. This patch compiles without warnings and passes the regression tests. This patch does not remove the usage of FastList; that should also be done.