Re: [Piglit] [PATCH] cl: Add local memory test

2013-06-13 Thread Aaron Watry
It's probably noting somewhere that these tests will fail on CL implementations where the maximum local workgroup size is < 16 (e.g. CPU implementations that limit to 1 thread per core). Also, I'm not sure if it really matters, but instead of: index2 = index + 1; index2 = index2 == 4 ? 0 : index2

[Piglit] [PATCH] Add a new test profile: gpu.tests.

2013-06-13 Thread Kenneth Graunke
Often, I make changes to Mesa which only affect tests that actually execute on the GPU. For such changes, there's no real benefit to running compiler-only/front-end tests, such as glslparsertest and asmparsertest files. There are a lot of those, so cutting them can save quite a bit of time when r

Re: [Piglit] [PATCH 05/18] arb_geometry_shader4: Test valid input primitives.

2013-06-13 Thread Paul Berry
On 7 June 2013 11:12, Fabian Bieler wrote: > Test that glProgramParameter() triggers the required errors. > > The geometry shader input primitive type is limited to a subset > of OpenGL primitive types. > > >From the ARB_geometry_shader4 spec (section Errors): > "The error INVALID_VALUE is genera

Re: [Piglit] [PATCH 04/18] shader_runner: Draw instanced rectangles using triangle strips instead of quads.

2013-06-13 Thread Paul Berry
On 3 June 2013 05:42, Fabian Bieler wrote: > This is usefull for core profile OpenGL contexts and geometry shaders. > s/usefull/useful/ here too. Reviewed-by: Paul Berry > --- > tests/shaders/shader_runner.c | 6 +++--- > 1 file changed, 3 insertions(+), 3 deletions(-) > > diff --git a/test

Re: [Piglit] [PATCH 03/18] util: Draw rectangles using triangle strips instead of quads.

2013-06-13 Thread Paul Berry
On 3 June 2013 05:39, Fabian Bieler wrote: > This is usefull for core profile OpenGL contexts and geometry shaders. > s/usefull/useful/ With that fixed, Reviewed-by: Paul Berry > --- > tests/util/piglit-util-gl.c | 22 +++--- > 1 file changed, 11 insertions(+), 11 deletions

Re: [Piglit] [PATCH 02/18] shader_runner: Allow new drawing modes.

2013-06-13 Thread Paul Berry
On 10 June 2013 16:54, Eric Anholt wrote: > Fabian Bieler writes: > > > Add primitives with adjacency and (for extreme future-proofness) patches > to > > recognized drawing modes. > > --- > > tests/shaders/shader_runner.c | 7 ++- > > 1 file changed, 6 insertions(+), 1 deletion(-) > > > > d

Re: [Piglit] [PATCH 01/18] shader_runner: Use piglit_heigth for framebuffer height.

2013-06-13 Thread Paul Berry
On 10 June 2013 15:26, Fabian Bieler wrote: > It used to be piglit_width which works, too, as the framebuffer is > hardcoded > to 250x250 pixels. > --- > tests/shaders/shader_runner.c | 2 +- > 1 file changed, 1 insertion(+), 1 deletion(-) > s/heigth/height/ in the subject. > > diff --git a/t

[Piglit] [PATCH 16/16] summary: Rename NewSummary to Summary

2013-06-13 Thread Dylan Baker
The old name existed simply as a holdover until the Summary name could be cleared up. Since it is now available, use the Summary name. Signed-off-by: Dylan Baker --- framework/summary.py| 4 ++-- piglit-summary-html.py | 2 +- piglit-summary-junit.py | 2 +- piglit-summary.py | 2 +-

[Piglit] [PATCH 15/16] summary.py: Remove all of the old summary backend

2013-06-13 Thread Dylan Baker
Since nothing now depends on the old summary backend, delete it. This first eliminates dead code, but also ensures that no new functionality becomes dependent on this code. Signed-off-by: Dylan Baker --- framework/summary.py | 232 +-- 1 file chang

[Piglit] [PATCH 14/16] piglit-summary.py: Make -s and -d mutually exclusive

2013-06-13 Thread Dylan Baker
Since -s/--summary will always override -d/--diff don't allow them to be called together. While this may seem a little confusing, the idea of asking for --diffs and then not getting them is a bug in the original implementation. Signed-off-by: Dylan Baker --- piglit-summary.py | 10 -- 1

[Piglit] [PATCH 13/16] piglit-summary.py: Use NewSummary for text generation

2013-06-13 Thread Dylan Baker
This changes piglit-summary.py to use the new text generation of the summary backend, instead of the old. Signed-off-by: Dylan Baker --- piglit-summary.py | 64 +-- 1 file changed, 10 insertions(+), 54 deletions(-) diff --git a/piglit-summary.

[Piglit] [PATCH 12/16] summary.py: Adds generateText() method and private helper

2013-06-13 Thread Dylan Baker
These two new methods allow the new summary backend to generated an equivalent output to the old summery backend output of piglit-summary.py. Signed-off-by: Dylan Baker --- framework/summary.py | 42 ++ 1 file changed, 42 insertions(+) diff --git a/framew

[Piglit] [PATCH 11/16] piglit-summary.py: convert from getopt to argparse

2013-06-13 Thread Dylan Baker
Argparse requires less code, and is much easier to read and maintain. Signed-off-by: Dylan Baker --- piglit-summary.py | 94 +-- 1 file changed, 29 insertions(+), 65 deletions(-) diff --git a/piglit-summary.py b/piglit-summary.py index 5169cc4

[Piglit] [PATCH 10/16] summary.py: Adds missing 'tests' field to junit

2013-06-13 Thread Dylan Baker
This field is required by the JUnit xsd, and was not provided. With this change the JUnit xml being produced is valid. xsd source: https://svn.jenkins-ci.org/trunk/hudson/dtkit/dtkit-format/ dtkit-junit-model/src/main/resources/com/thalesgroup/dtkit/junit/model/ xsd/junit-4.xsd Signed-off-by: Dyl

[Piglit] [PATCH 09/16] junit.py: Remove unused file

2013-06-13 Thread Dylan Baker
Since this is no longer in use, remove it Signed-off-by: Dylan Baker --- framework/junit.py | 377 - 1 file changed, 377 deletions(-) delete mode 100644 framework/junit.py diff --git a/framework/junit.py b/framework/junit.py deleted file mode

[Piglit] [PATCH 08/16] piglit-summary-junit.py: Use NewSummary.generateJUnit

2013-06-13 Thread Dylan Baker
Stop using the old JUnit generation code, and start using the new code. Signed-off-by: Dylan Baker --- piglit-summary-junit.py | 84 +++-- 1 file changed, 4 insertions(+), 80 deletions(-) diff --git a/piglit-summary-junit.py b/piglit-summary-junit.py

[Piglit] [PATCH 07/16] summary.py: Adds method to NewSummary to generate junit XML

2013-06-13 Thread Dylan Baker
This method is about 50% faster than the existing implementation which uses junit.py. Signed-off-by: Dylan Baker --- framework/summary.py | 55 1 file changed, 55 insertions(+) diff --git a/framework/summary.py b/framework/summary.py index 40

[Piglit] [PATCH 04/16] summary.py: Split functionality out of NewSummary constructor

2013-06-13 Thread Dylan Baker
Splits the code that finds problems, regressions, fixes, changes, and skips out of the constructor. Instead of incurring the overhead of calculating these every time whether they are needed or not the code can now be smarter about it's path, only generating the ones it needs, if any. Signed-off-by

[Piglit] [PATCH 06/16] junit.mako: Adds new mako file for generating junit xml

2013-06-13 Thread Dylan Baker
Using mako as an alternative to the junit.py file has a couple of advantages: First there is a lot less code involved, mako just does most of the work for us. Second, it works in almost the same way as the HTML generation. Signed-off-by: Dylan Baker --- templates/junit.mako | 11 +++ 1 f

[Piglit] [PATCH 05/16] piglit-summary-junit.py: Fixes whitespace errors

2013-06-13 Thread Dylan Baker
There were whitespace errors as a result of the recent tabs to spaces conversion. This patch corrects those Signed-off-by: Dylan Baker --- piglit-summary-junit.py | 14 +++--- 1 file changed, 7 insertions(+), 7 deletions(-) diff --git a/piglit-summary-junit.py b/piglit-summary-junit.py

[Piglit] [PATCH 03/16] summary: Generate a new empty page for pages with no results

2013-06-13 Thread Dylan Baker
This new page is able to convey the same information, but takes less time to generate Signed-off-by: Dylan Baker --- framework/summary.py| 21 - templates/empty_status.mako | 27 +++ 2 files changed, 43 insertions(+), 5 deletions(-) create mod

[Piglit] [PATCH 01/16] summary.py: replace multiple attributes with a single dict attribute

2013-06-13 Thread Dylan Baker
Replaces self.alltests, self.changes, self.problems, self.regressions, self.fixes, and self.skipped with self.test, a dictionary containing all of the same information. This cleans the namespace for the NewSummary object, as well as allowing for some other code simplification Signed-off-by: Dylan

[Piglit] [PATCH 02/16] summary.py: Do not generate comparison pages for single results

2013-06-13 Thread Dylan Baker
It is absolutely silly to generate pages for fixes, changes, and regressions when there is only one test result is provided. This still generates empty pages when two results are provided, because some developers have expressed a work flow that uses these empty pages. Signed-off-by: Dylan Baker -