Re: Polished FileSystem API proposal

2013-07-13 Thread Jonas Sicking
On Sat, Jul 13, 2013 at 1:27 AM, David Rajchenbach-Teller dtel...@mozilla.com wrote: Why both createFile, open{Read, Write, Append} and get? Is it to avoid a signature with dependent types? I think you are asking why have createFile when it can be implemented using openWrite or openAppend

Re: Polished FileSystem API proposal

2013-07-13 Thread Kenneth Rohde Christiansen
Hi there! A new file system API with a lot of promise :-) On Sat, Jul 13, 2013 at 2:31 AM, Jonas Sicking jo...@sicking.cc wrote: Hi All, Yesterday a few of us at mozilla went through the FileSystem API proposal we previously sent [1] and tightened it up. Executive Summary (aka TL;DR):

Re: Polished FileSystem API proposal

2013-07-13 Thread Jonas Sicking
On Sat, Jul 13, 2013 at 2:37 AM, Kenneth Rohde Christiansen kenneth.christian...@gmail.com wrote: Hi there! A new file system API with a lot of promise :-) On Sat, Jul 13, 2013 at 2:31 AM, Jonas Sicking jo...@sicking.cc wrote: Hi All, Yesterday a few of us at mozilla went through the

Re: [webcomponents]: Changing names of custom element callbacks

2013-07-13 Thread Bjoern Hoehrmann
* Steve Orvell wrote: These callbacks specifically mean the element has entered or left the *document*. We felt that entered/leftDocument was better than insertedInto/removedFromDocument but the key bit is *Document. This has caused enough confusion in discussion that being explicit seems

Re: Polished FileSystem API proposal

2013-07-13 Thread David Rajchenbach-Teller
Why both createFile, open{Read, Write, Append} and get? Is it to avoid a signature with dependent types? Cheers, David On 7/13/13 2:31 AM, Jonas Sicking wrote: PromiseFile createFile(DOMString path, MakeFileOptions options); PromiseDirectory createDirectory(DOMString path);

[FileAPI] Revisiting Deflate/Compression

2013-07-13 Thread Charles Pritchard
We've had a few conversations pop up about exposing deflate/inflate to the webapps environment. Years of them (more recently May 2013). Packaging a zip file is very simple in JS, it's just the inflate/deflate code that's a trudge. We all know the benefits of compressing JSON and XML over the