[pulseaudio-discuss] [PATCH 2/4] loopback: correct comments about the thread calling a function

2017-02-04 Thread Georg Chini
The comments were wrong and confusing. --- src/modules/module-loopback.c | 10 +- 1 file changed, 5 insertions(+), 5 deletions(-) diff --git a/src/modules/module-loopback.c b/src/modules/module-loopback.c index 016d403..2907bbc 100644 --- a/src/modules/module-loopback.c +++

[pulseaudio-discuss] [PATCH 1/4] loopback: Rename sink_input_buffer to loopback_memblockq_length

2017-02-04 Thread Georg Chini
The variable does no longer represent the length of the whole sink input buffer, therefore it has been renamed. --- src/modules/module-loopback.c | 6 +++--- 1 file changed, 3 insertions(+), 3 deletions(-) diff --git a/src/modules/module-loopback.c b/src/modules/module-loopback.c index

[pulseaudio-discuss] [PATCH 3/4] loopback: Initialize latency at startup and during source/sink changes

2017-02-04 Thread Georg Chini
The current code does not make any attempt to initialize the end-to-end latency to a value near the desired latency. This leads to underruns at startup because the memblockq is initially empty and to very long adjustment times for long latencies because the end-to-end latency at startup is

[pulseaudio-discuss] [PATCH 4/4] loopback: remove skip logic

2017-02-04 Thread Georg Chini
The skip logic is no longer needed as the code is now waiting for source and sink to start up. --- src/modules/module-loopback.c | 41 - 1 file changed, 4 insertions(+), 37 deletions(-) diff --git a/src/modules/module-loopback.c

[pulseaudio-discuss] [PATCH 0/4] loopback: Introduce logic for latency initialization

2017-02-04 Thread Georg Chini
Hello, I will split my series of loopback patches into smaller chunks that are easier to review. The first four patches deal with the latency initialization at startup and when the source or sink is moved. They also include some cosmetic changes. Georg Chini (4): loopback: Rename

[pulseaudio-discuss] [PATCH] backend-native: send DBus signal on headset button press

2017-02-04 Thread Georg Chini
Currently pressing the headset button is ignored. This patch sends a DBUS signal that can be caught by applications to trigger events like picking up or ending a phone call. --- src/modules/bluetooth/backend-native.c | 10 +- 1 file changed, 9 insertions(+), 1 deletion(-) diff --git

[pulseaudio-discuss] [PATCH] bluetooth: use native and ofono backends in parallel with headset=auto

2017-02-04 Thread Georg Chini
This patch changes the behavior of the headset=auto switch for module-bluez5-discover. With headset=auto now both backends will be active at the same time for the HF role and the switching between the backends is only done for the AG role. headset=ofono and headset=native remain unchanged. ---

[pulseaudio-discuss] [PATCH] backend-native: rebase of patch to support HSP HeadeSet profile

2017-02-04 Thread Georg Chini
This is a rebase of Wim Taymans patch to support the HSP headset role that has somehow been forgotten. Original patch can be found at https://lists.freedesktop.org/archives/pulseaudio-discuss/2015-February/023242.html Original commit message: In addition to the HSP Audio Gateway, also add support

[pulseaudio-discuss] [PATCH v2] bluetooth: Make use of getsockopt() to determine MTU configurable

2017-02-04 Thread Georg Chini
A recent patch changed the MTU size from the default value of 48 to the value returned by getsockopt(). This breaks HSP for some setups. To circumvent the problem, this patch introduces a boolean parameter "autodetect_mtu" for module-bluetooth-discover, module-bluez5-discover and

[pulseaudio-discuss] [PATCH] bluetooth: Correct fixed latency for HSP sink

2017-02-04 Thread Georg Chini
The fixed latency for the HSP sink was set to 125 ms plus one write block size. pa_sink_get_latency() however returns 28 ms like it does for A2DP and also for the HSP source. Therefore this patch corrects the fixed latency of the HSP sink to 25 ms plus one write block size, assuming that the

Re: [pulseaudio-discuss] [PATCH] bluetooth: Make use of getsockopt() configurable

2017-02-04 Thread Georg Chini
On 04.02.2017 19:29, Alexander E. Patrakov wrote: The choice of the option name is unfortunate. Imagine if another situation appears where we would either use or not use getsockopt() to get some other parameter. How about renaming it to something like autodetect_mtu? Yes, sounds much better.

Re: [pulseaudio-discuss] [PATCH] bluetooth: Make use of getsockopt() configurable

2017-02-04 Thread Alexander E. Patrakov
The choice of the option name is unfortunate. Imagine if another situation appears where we would either use or not use getsockopt() to get some other parameter. How about renaming it to something like autodetect_mtu? 2017-02-04 23:13 GMT+05:00 Georg Chini : > A recent patch

[pulseaudio-discuss] [PATCH] bluetooth: Make use of getsockopt() configurable

2017-02-04 Thread Georg Chini
A recent patch changed the MTU size from the default value of 48 to the value returned by getsockopt(). This breaks HSP for some setups. To circumvent the problem, this patch introduces a boolean parameter "use_getsockopt" for module-bluetooth-discover, module-bluez5-discover and

[pulseaudio-discuss] [PATCH] iochannel: don't use variable length array in union

2017-02-04 Thread Tanu Kaskinen
Clang didn't like the variable length array: pulsecore/iochannel.c:358:17: error: fields must have a constant size: 'variable length array in structure' extension will never be supported uint8_t data[CMSG_SPACE(sizeof(int) * nfd)]; ^ Commit 451d1d6762 introduced the