[issue26845] Misleading variable name in exception handling

2019-12-20 Thread STINNER Victor
STINNER Victor added the comment: Variable names have no impact on the execution. Sometimes, it's called "exc", sometimes "val", sometimes "exc_val" :-) This issue is not a bug. -- resolution: -> not a bug stage: -> resolved status: open -> closed

[issue26845] Misleading variable name in exception handling

2019-12-20 Thread Batuhan
Batuhan added the comment: I am not sure if calls like this constitutes a problem. By the way most of the things changed in Python/ceval.c including removal of END_FINALLY (issue 33387) but calls to _PyErr_Restore is still there with that same arguments. -- nosy: +BTaskaya, vstinner

[issue26845] Misleading variable name in exception handling

2016-04-25 Thread ProgVal
New submission from ProgVal: In Python/errors.c, PyErr_Restore is defined this way: void PyErr_Restore(PyObject *type, PyObject *value, PyObject *traceback) In Python/ceval.c, in the END_FINALLY case, it is called like this: PyErr_Restore(status, exc, tb); I believe “exc” should be renamed