[Python-ideas] Using Python for end user applications

2017-01-28 Thread Paul Moore
On 28 January 2017 at 02:11, C Anthony Risinger wrote: > I can't articulate it we'll, or even fully isolate the reasons for it. All I > really know is how I feel when peers ask me about Python or the reading I > get when others speak about their experience using it. Python is absolutely > one of m

Re: [Python-ideas] A more readable way to nest functions

2017-01-28 Thread Ed Kellett
On Fri, 27 Jan 2017 at 21:29 Ethan Furman wrote: On 01/27/2017 01:07 PM, Brent Brinkley wrote: > Suggested structure: > > print() <| some_func() <| another_func("Hello") My first question is what does this look like when print() and some_func() have other parameters? In other words, what woul

Re: [Python-ideas] A more readable way to nest functions

2017-01-28 Thread Chris Angelico
On Sat, Jan 28, 2017 at 11:41 PM, Ed Kellett wrote: > FWIW, I'd spell it without the (), so it's simply a right-associative binary > operator on expressions, (a -> b, a) -> b, rather than magic syntax. > > print XYZ some_func XYZ another_func("Hello") I'm not entirely sure I understand your e

Re: [Python-ideas] A more readable way to nest functions

2017-01-28 Thread zmo via Python-ideas
Hi list o/ This idea sounds fun, so as a thought experiment why not imagine one way of integrating it in what I believe would be pythonic enough. On Sat, Jan 28, 2017 at 12:41:24PM +, Ed Kellett wrote: > FWIW, I'd spell it without the (), so it's simply a right-associative > binary operator o

Re: [Python-ideas] A more readable way to nest functions

2017-01-28 Thread Ed Kellett
On Sat, 28 Jan 2017 at 14:27 zmo via Python-ideas wrote: > I agree this would look a bit more elegant. To focus on the feature of > that operator, instead of how to write it, I'll use XYZ instead of <| in > this post. My thoughts exactly :) > So, considering it's decided that the RHS is in ch

Re: [Python-ideas] A more readable way to nest functions

2017-01-28 Thread אלעזר
The title is misleading : it should be "nesting function calls" Elazar בתאריך שבת, 28 בינו' 2017, 18:38, מאת Ed Kellett ‏: > On Sat, 28 Jan 2017 at 14:27 zmo via Python-ideas > wrote: > > I agree this would look a bit more elegant. To focus on the feature of > that operator, instead of how to w

Re: [Python-ideas] A more readable way to nest functions

2017-01-28 Thread Steven D'Aprano
On Sat, Jan 28, 2017 at 03:16:27PM +0100, zmo via Python-ideas wrote: > Hi list o/ > > This idea sounds fun, so as a thought experiment why not imagine one > way of integrating it in what I believe would be pythonic enough. This idea is sometimes called "the Collection Pipeline" design pattern,