Hello,

In Modules/main.c, wherever PyImport_ImportModule() is use, the variables
(runpy and sys) are named as follows:

runpy = PyImport_ImportModule("runpy");    // line 265
sys = PyImport_ImportModule("sys");           // line 444

Can we also rename 'mod' to 'readline' for consistency in line 215?

PyObject *mod = PyImport_ImportModule("readline");    // line 215
if (mod == NULL) {
    PyErr_Clear();
}
else {
    Py_DECREF(mod);
}

Suggested changes:

PyObject *readline = PyImport_ImportModule("readline");
if (readline == NULL) {
    PyErr_Clear();
}
else {
    Py_DECREF(readline);
}

Let me know your thoughts.

New guy here,
Gerol
_______________________________________________
Python-ideas mailing list -- python-ideas@python.org
To unsubscribe send an email to python-ideas-le...@python.org
https://mail.python.org/mailman3/lists/python-ideas.python.org/
Message archived at 
https://mail.python.org/archives/list/python-ideas@python.org/message/BP5OXGO263N57SKCSNDSLLJROOP5OMGA/
Code of Conduct: http://python.org/psf/codeofconduct/

Reply via email to