Re: [Maya-Python] another naming convention topic: get prefix on none getter methods

2021-05-11 Thread Rudi Hammad
For instance in the MFnCurve there are the methods degree(), numCVs(), area(), lenght(), knot()... not getDegree(), getNumCVs(), getArea(), etc... So I wonder if there is a logic for that. It looks like anything without 'get' prefix returns a number?? ... ¯\_(ツ)_/¯ El martes, 11 de mayo de

Re: [Maya-Python] another naming convention topic: get prefix on none getter methods

2021-05-11 Thread Rudi Hammad
cool thanks for your opinion. I do use @property in somesituations, not saying to stay away (in fact we had a discusion is another thread about it a while back) I agree that function are usually verbes. And it is true that if you isolate the name pointPositions() it doesn't feel natural but

Re: [Maya-Python] another naming convention topic: get prefix on none getter methods

2021-05-11 Thread Alok Gandhi
I have generously used prefix for methods 'get' without any 'set'. I think there is no convention and my code readability is generally dictated by common sense and ease of understanding. Another point is that functions/methods sgould always be verbs as long as possible. So pointPositions() to me

[Maya-Python] another naming convention topic: get prefix on none getter methods

2021-05-11 Thread Rudi Hammad
So, I get the feeling that there isn't a clear naming convenction when it comes to use "get" as a prefix. I am not refering to the python @property, nor getter/setter methods. I am talking about normal methods. My criteria is: when ever I prefix a method with "get" it is because I am implying