Re: [Qemu-block] [Qemu-devel] [PATCH 0/5] crypto threads

2018-12-04 Thread no-reply
Patchew URL: https://patchew.org/QEMU/20181204184657.78028-1-vsement...@virtuozzo.com/ Hi, This series failed the docker-quick@centos7 build test. Please find the testing commands and their output below. If you have Docker installed, you can probably reproduce it locally. === TEST SCRIPT

[Qemu-block] [PATCH for-3.1? 1/5] crypto/block-luks: fix memory leak in qcrypto_block_luks_create

2018-12-04 Thread Vladimir Sementsov-Ogievskiy
Free block->cipher and block->ivgen on error path. Signed-off-by: Vladimir Sementsov-Ogievskiy --- crypto/block-luks.c | 3 +++ 1 file changed, 3 insertions(+) diff --git a/crypto/block-luks.c b/crypto/block-luks.c index 5738124773..51e24d23ca 100644 --- a/crypto/block-luks.c +++

Re: [Qemu-block] [Qemu-devel] [PATCH for-3.1? 1/5] crypto/block-luks: fix memory leak in qcrypto_block_luks_create

2018-12-04 Thread Peter Maydell
On Tue, 4 Dec 2018 at 18:50, Vladimir Sementsov-Ogievskiy wrote: > > Free block->cipher and block->ivgen on error path. > > Signed-off-by: Vladimir Sementsov-Ogievskiy > --- > crypto/block-luks.c | 3 +++ > 1 file changed, 3 insertions(+) > > diff --git a/crypto/block-luks.c

[Qemu-block] [PATCH 2/5] crypto/block: refactor qcrypto_block_*crypt_helper functions

2018-12-04 Thread Vladimir Sementsov-Ogievskiy
qcrypto_block_encrypt_helper and qcrypto_block_decrypt_helper are almost identical, let's reduce code duplication and simplify further improvements. Signed-off-by: Vladimir Sementsov-Ogievskiy --- crypto/block.c | 81 +++--- 1 file changed, 31

[Qemu-block] [PATCH 3/5] crypto/block: rename qcrypto_block_*crypt_helper

2018-12-04 Thread Vladimir Sementsov-Ogievskiy
Rename qcrypto_block_*crypt_helper to qcrypto_cipher_*crypt_helper, as it's not about QCryptoBlock. This is needed to introduce qcrypto_block_*crypt_helper in the next commit, which will have QCryptoBlock pointer and than will be able to use additional fields of it, which in turn will be used to

[Qemu-block] [PATCH 0/5] crypto threads

2018-12-04 Thread Vladimir Sementsov-Ogievskiy
Hi all. These series are preliminary step before moving encryption code in qcow2 to the threads. The first attempt of doing it is on list ([PATCH 00/11] qcow2: encryption threads : https://lists.gnu.org/archive/html/qemu-block/2018-11/msg00729.html) But it's approach with multiplying the whole

[Qemu-block] [PATCH 5/5] crypto: support multiple threads accessing one QCryptoBlock

2018-12-04 Thread Vladimir Sementsov-Ogievskiy
The two thing that should be handled are cipher and ivgen. For ivgen the solution is just mutex, as iv calculations should not be long in comparison with encryption/decryption. And for cipher let's just keep per-thread ciphers. Signed-off-by: Vladimir Sementsov-Ogievskiy --- crypto/blockpriv.h

[Qemu-block] [PATCH 4/5] crypto/block: introduce qcrypto_block_*crypt_helper functions

2018-12-04 Thread Vladimir Sementsov-Ogievskiy
Introduce QCryptoBlock-based functions and use them where possible. This is needed to implement thread-safe encrypt/decrypt operations. Signed-off-by: Vladimir Sementsov-Ogievskiy --- crypto/blockpriv.h | 14 ++ crypto/block-luks.c | 14 ++ crypto/block-qcow.c | 14

Re: [Qemu-block] [PATCH 03/18] xen: introduce 'xen-qdisk'

2018-12-04 Thread Paul Durrant
> -Original Message- > From: Qemu-devel [mailto:qemu-devel- > bounces+paul.durrant=citrix@nongnu.org] On Behalf Of Paul Durrant > Sent: 04 December 2018 15:20 > To: Anthony Perard > Cc: Kevin Wolf ; Stefano Stabellini > ; qemu-block@nongnu.org; qemu-de...@nongnu.org; > Max Reitz ;

Re: [Qemu-block] [PATCH 16/18] xen: automatically create XenQdiskDevice-s

2018-12-04 Thread Anthony PERARD
On Wed, Nov 21, 2018 at 03:12:09PM +, Paul Durrant wrote: > This patch adds a creator function for XenQdiskDevice-s so that they can > be created automatically when the Xen toolstack instantiates a new > PV backend. When the XenQdiskDevice is created this way it is also > necessary to create a

Re: [Qemu-block] [PATCH 17/18] MAINTAINERS: add myself as a Xen maintainer

2018-12-04 Thread Anthony PERARD
On Wed, Nov 21, 2018 at 03:12:10PM +, Paul Durrant wrote: > I have made many significant contributions to the Xen code in QEMU, > particularly the recent patches introducing a new PV device framework. > I intend to make further significant contributions, porting other PV back- > ends to the

Re: [Qemu-block] [PATCH 03/18] xen: introduce 'xen-qdisk'

2018-12-04 Thread Paul Durrant
> -Original Message- > From: Anthony PERARD [mailto:anthony.per...@citrix.com] > Sent: 04 December 2018 15:49 > To: Paul Durrant > Cc: qemu-block@nongnu.org; qemu-de...@nongnu.org; xen- > de...@lists.xenproject.org; Kevin Wolf ; Max Reitz > ; Stefano Stabellini > Subject: Re: [PATCH

Re: [Qemu-block] [PATCH 03/18] xen: introduce 'xen-qdisk'

2018-12-04 Thread Anthony PERARD
On Tue, Dec 04, 2018 at 03:20:04PM +, Paul Durrant wrote: > > > +static char *disk_to_vbd_name(unsigned int disk) > > > +{ > > > +unsigned int len = DIV_ROUND_UP(disk, 26); > > > +char *name = g_malloc0(len + 1); > > > + > > > +do { > > > +name[len--] = 'a' + (disk % 26); >

Re: [Qemu-block] [PATCH 15/18] xen: add a mechanism to automatically create XenDevice-s...

2018-12-04 Thread Anthony PERARD
On Wed, Nov 21, 2018 at 03:12:08PM +, Paul Durrant wrote: > +xen_backend_device_create(BUS(xenbus), type, name, opts, _err); > +qobject_unref(opts); > + > +if (local_err) { > +const char *msg = error_get_pretty(local_err); > + > +error_report("failed to create '%s'

Re: [Qemu-block] [Qemu-devel] [PATCH for-next 0/6] qemu-img: Add salvaging mode to convert

2018-12-04 Thread Eric Blake
On 12/3/18 9:39 PM, no-re...@patchew.org wrote: Patchew URL: https://patchew.org/QEMU/20181203175211.8230-1-mre...@redhat.com/ Hi, This series seems to have some coding style problems. See output below for more information: Updating 3c8cf5a9c21ff8782164d1def7f44bd888713384 fatal: unable

Re: [Qemu-block] [PATCH 03/18] xen: introduce 'xen-qdisk'

2018-12-04 Thread Paul Durrant
> -Original Message- > From: Anthony PERARD [mailto:anthony.per...@citrix.com] > Sent: 29 November 2018 16:06 > To: Paul Durrant > Cc: qemu-block@nongnu.org; qemu-de...@nongnu.org; xen- > de...@lists.xenproject.org; Kevin Wolf ; Max Reitz > ; Stefano Stabellini > Subject: Re: [PATCH

Re: [Qemu-block] [PATCH 07/18] xen: add event channel interface for XenDevice-s

2018-12-04 Thread Anthony PERARD
On Mon, Dec 03, 2018 at 04:24:24PM +, Anthony PERARD wrote: > On Wed, Nov 21, 2018 at 03:12:00PM +, Paul Durrant wrote: > > +static void xen_device_event(void *opaque) > > +{ > > +XenDevice *xendev = opaque; > > +unsigned long port = xenevtchn_pending(xendev->xeh); > > + > > +

Re: [Qemu-block] [qemu-s390x] [Qemu-devel] [PULL 2/2] iotests: simple mirror test with kvm on 1G image

2018-12-04 Thread Christian Borntraeger
On 04.12.2018 14:46, Christian Borntraeger wrote: > FWIW, this testcase fails with current qemu master on s390: > > QEMU -- > "/home/cborntra/REPOS/qemu/build/tests/qemu-iotests/../../s390x-softmmu/qemu-system-s390x" > -nodefaults -machine accel=qtest > QEMU_IMG -- >

Re: [Qemu-block] [Qemu-devel] [PULL 2/2] iotests: simple mirror test with kvm on 1G image

2018-12-04 Thread Christian Borntraeger
FWIW, this testcase fails with current qemu master on s390: QEMU -- "/home/cborntra/REPOS/qemu/build/tests/qemu-iotests/../../s390x-softmmu/qemu-system-s390x" -nodefaults -machine accel=qtest QEMU_IMG -- "/home/cborntra/REPOS/qemu/build/tests/qemu-iotests/../../qemu-img" QEMU_IO

Re: [Qemu-block] [PATCH 14/18] xen: add implementations of xen-qdisk connect and disconnect functions...

2018-12-04 Thread Anthony PERARD
On Wed, Nov 21, 2018 at 03:12:07PM +, Paul Durrant wrote: > diff --git a/hw/block/xen-qdisk.c b/hw/block/xen-qdisk.c > index 35f7b70480..8c88393832 100644 > --- a/hw/block/xen-qdisk.c > +++ b/hw/block/xen-qdisk.c > static void xen_qdisk_connect(XenQdiskDevice *qdiskdev, Error **errp) > { >

Re: [Qemu-block] [PATCH 13/18] xen: purge 'blk' and 'ioreq' from function names in dataplane/xen-qdisk.c

2018-12-04 Thread Anthony PERARD
On Wed, Nov 21, 2018 at 03:12:06PM +, Paul Durrant wrote: > This is a purely cosmetic patch that purges remaining use of 'blk' and > 'ioreq' in local function names. > > No functional change. > > Signed-off-by: Paul Durrant I don't think it's a good idee to use function names that could be

Re: [Qemu-block] [PATCH 12/18] xen: remove 'ioreq' struct/varable/field names from dataplane/xen-qdisk.c

2018-12-04 Thread Anthony PERARD
On Wed, Nov 21, 2018 at 03:12:05PM +, Paul Durrant wrote: > This is a purely cosmetic patch that purges the name 'ioreq' from struct, > variable and field names. (This name has been problematic for a long time > as 'ioreq' is the name used for generic I/O requests coming from Xen). > The patch

Re: [Qemu-block] [PATCH 11/18] xen: remove 'XenBlkDev' and 'blkdev' names from dataplane/xen-qdisk

2018-12-04 Thread Anthony PERARD
On Wed, Nov 21, 2018 at 03:12:04PM +, Paul Durrant wrote: > This is a purely cosmetic patch that substitutes the old 'struct XenBlkDev' > name with 'XenQdiskDataPlane' and 'blkdev' field/variable names with > 'dataplane', and then does necessary fix-up to adhere to coding style. > > No