[PATCH v5 00/13] hw/block/nvme: metadata and end-to-end data protection support

2021-03-10 Thread Klaus Jensen
From: Klaus Jensen This is v5 of a series that adds support for metadata and end-to-end data protection. First, on the subject of metadata, in v1, support was restricted to extended logical blocks, which was pretty trivial to implement, but required special initialization and broke DULBE. In v2,

Re: [PATCH] coroutine: add libucontext as external library

2021-03-10 Thread Daniel P . Berrangé
On Tue, Mar 09, 2021 at 01:21:29PM -0800, Joelle van Dyne wrote: > On Tue, Mar 9, 2021 at 10:24 AM Joelle van Dyne wrote: > > > > On Tue, Mar 9, 2021 at 7:38 AM Stefan Hajnoczi wrote: > > > > > > On Mon, Mar 08, 2021 at 07:26:36PM -0800, Joelle van Dyne wrote: > > > > iOS does not support ucontex

Re: [PATCH 2/9] hw/block/pflash_cfi01: Extract pflash_cfi01_fill_cfi_table()

2021-03-10 Thread David Edmondson
On Wednesday, 2021-03-10 at 00:50:21 +01, Philippe Mathieu-Daudé wrote: > Fill the CFI table in out of DeviceRealize() in a new function: > pflash_cfi01_fill_cfi_table(). > > Signed-off-by: Philippe Mathieu-Daudé Reviewed-by: David Edmondson > --- > hw/block/pflash_cfi01.c | 140 +

[RFC] nbd: decouple reconnect from drain

2021-03-10 Thread Roman Kagan
NBD connect coroutine takes an extra in_flight reference as if it's a request handler. This prevents drain from completion until the connection coroutine is releases the reference. When NBD is configured to reconnect, however, this appears to be fatal to the reconnection idea: the drain procedure

Re: [PATCH 1/9] hw/block/pflash_cfi: Fix code style for checkpatch.pl

2021-03-10 Thread David Edmondson
On Wednesday, 2021-03-10 at 00:50:20 +01, Philippe Mathieu-Daudé wrote: > We are going to move this code, fix its style first. > > Signed-off-by: Philippe Mathieu-Daudé Reviewed-by: David Edmondson > --- > hw/block/pflash_cfi01.c | 36 > hw/block/pflash_cf

Re: [PATCH 5/9] hw/block/pflash_cfi02: Open-code pflash_register_memory(rom=false)

2021-03-10 Thread Bin Meng
On Wed, Mar 10, 2021 at 7:51 AM Philippe Mathieu-Daudé wrote: > > There is only one call to pflash_register_memory() with > rom_mode == false. As we want to modify pflash_register_memory() > in the next patch, open-code this trivial function in place for > the 'rom_mode == false' case. > > Signed-

Re: [PATCH 7/9] hw/block/pflash_cfi02: Factor out DeviceReset method

2021-03-10 Thread Bin Meng
On Wed, Mar 10, 2021 at 7:55 AM Philippe Mathieu-Daudé wrote: > > There is multiple places doing a device reset. Factor that > out in a common method which matches the DeviceReset prototype, > so we can also remove the reset code from the DeviceRealize() > handler. Explicit the device is set in "r

Re: [PATCH 8/9] hw/block/pflash_cfi01: Clarify trace events

2021-03-10 Thread Bin Meng
On Wed, Mar 10, 2021 at 7:53 AM Philippe Mathieu-Daudé wrote: > > Use the 'mode_read_array' event when we set the device in such > mode, and use the 'reset' event in DeviceReset handler. > > Signed-off-by: Philippe Mathieu-Daudé > --- > hw/block/pflash_cfi01.c | 3 ++- > 1 file changed, 2 insert

Re: [PATCH 4/9] hw/block/pflash_cfi02: Set rom_mode to true in pflash_setup_mappings()

2021-03-10 Thread Bin Meng
On Wed, Mar 10, 2021 at 7:54 AM Philippe Mathieu-Daudé wrote: > > There is only one call to pflash_setup_mappings(). Convert 'rom_mode' > to boolean and set it to true directly within pflash_setup_mappings(). > > Signed-off-by: Philippe Mathieu-Daudé > --- > hw/block/pflash_cfi02.c | 4 ++-- > 1

Re: [PATCH 6/9] hw/block/pflash_cfi02: Rename register_memory(true) as mode_read_array

2021-03-10 Thread Bin Meng
On Wed, Mar 10, 2021 at 7:53 AM Philippe Mathieu-Daudé wrote: > > The same pattern is used when setting the flash in READ_ARRAY mode: > - Set the state machine command to READ_ARRAY > - Reset the write_cycle counter > - Reset the memory region in ROMD > > Refactor the current code by extracting th

Re: [PATCH 2/9] hw/block/pflash_cfi01: Extract pflash_cfi01_fill_cfi_table()

2021-03-10 Thread Bin Meng
On Wed, Mar 10, 2021 at 7:51 AM Philippe Mathieu-Daudé wrote: > > Fill the CFI table in out of DeviceRealize() in a new function: > pflash_cfi01_fill_cfi_table(). > > Signed-off-by: Philippe Mathieu-Daudé > --- > hw/block/pflash_cfi01.c | 140 +--- > 1 file ch

Re: [PATCH 3/9] hw/block/pflash_cfi02: Extract pflash_cfi02_fill_cfi_table()

2021-03-10 Thread Bin Meng
On Wed, Mar 10, 2021 at 7:52 AM Philippe Mathieu-Daudé wrote: > > Fill the CFI table in out of DeviceRealize() in a new function: > pflash_cfi02_fill_cfi_table(). > > Signed-off-by: Philippe Mathieu-Daudé > --- > hw/block/pflash_cfi02.c | 193 +--- > 1 file ch

Re: [PATCH 1/9] hw/block/pflash_cfi: Fix code style for checkpatch.pl

2021-03-10 Thread Bin Meng
On Wed, Mar 10, 2021 at 7:50 AM Philippe Mathieu-Daudé wrote: > > We are going to move this code, fix its style first. > > Signed-off-by: Philippe Mathieu-Daudé > --- > hw/block/pflash_cfi01.c | 36 > hw/block/pflash_cfi02.c | 9 ++--- > 2 files changed,

Re: [PATCH v3 3/4] fdc: Inline fdctrl_connect_drives() into fdctrl_realize_common()

2021-03-10 Thread Markus Armbruster
Richard Henderson writes: > On 3/9/21 8:12 AM, Markus Armbruster wrote: >> @@ -2565,6 +2551,7 @@ static void fdctrl_realize_common(DeviceState *dev, >> FDCtrl *fdctrl, >> Error **errp) >> { >> int i, j; >> +FDrive *drive; >> static int comman

Re: [PATCH v3 4/4] blockdev: Drop deprecated bogus -drive interface type

2021-03-10 Thread Markus Armbruster
Daniel P. Berrangé writes: > On Tue, Mar 09, 2021 at 05:12:13PM +0100, Markus Armbruster wrote: >> Drop the crap deprecated in commit a1b40bda08 "blockdev: Deprecate >> -drive with bogus interface type" (v5.1.0). >> >> Signed-off-by: Markus Armbruster >> --- >> docs/system/deprecated.rst

<    1   2