Re: [PATCH 00/10] vhost: stick to -errno error return convention

2022-01-06 Thread Michael S. Tsirkin
On Thu, Nov 11, 2021 at 06:33:44PM +0300, Roman Kagan wrote: > Error propagation between the generic vhost code and the specific backends is > not quite consistent: some places follow "return -1 and set errno" convention, > while others assume "return negated errno". Furthermore, not enough care i

Re: [PATCH v3 01/15] pcie: Add support for Single Root I/O Virtualization (SR/IOV)

2022-01-06 Thread Michael S. Tsirkin
On Tue, Dec 21, 2021 at 03:32:32PM +0100, Lukasz Maniak wrote: > From: Knut Omang > > This patch provides the building blocks for creating an SR/IOV > PCIe Extended Capability header and register/unregister > SR/IOV Virtual Functions. > > Signed-off-by: Knut Omang > --- > hw/pci/meson.build

Re: [PATCH v2 0/9] hw/dma: Use dma_addr_t type definition when relevant

2022-01-06 Thread Michael S. Tsirkin
On Tue, Jan 04, 2022 at 09:54:22AM +0100, Philippe Mathieu-Daudé wrote: > Since v1: > - Addressed David review comment (stick to dma_addr_t type) > - Addressed Peter review comment (incorrect doc string) PCI things: Reviewed-by: Michael S. Tsirkin who's merging all this? Yourself? > Hi, > >

Re: [PULL 0/2] SD/MMC patches for 2022-01-04

2022-01-06 Thread Philippe Mathieu-Daudé
On 4/1/22 19:42, Richard Henderson wrote: On 1/3/22 11:54 PM, Philippe Mathieu-Daudé wrote: The following changes since commit b5a3d8bc9146ba22a25116cb748c97341bf99737:    Merge tag 'pull-misc-20220103' of https://gitlab.com/rth7680/qemu into staging (2022-01-03 09:34:41 -0800) are availabl

[PULL 14/52] vhost-user-blk: reconnect on any error during realize

2022-01-06 Thread Michael S. Tsirkin
From: Roman Kagan vhost-user-blk realize only attempts to reconnect if the previous connection attempt failed on "a problem with the connection and not an error related to the content (which would fail again the same way in the next attempt)". However this distinction is very subtle, and may be

[PULL 22/52] vhost-user-blk: propagate error return from generic vhost

2022-01-06 Thread Michael S. Tsirkin
From: Roman Kagan Fix the only callsite that doesn't propagate the error code from the generic vhost code. Signed-off-by: Roman Kagan Message-Id: <2021153354.18807-11-rvka...@yandex-team.ru> Reviewed-by: Michael S. Tsirkin Signed-off-by: Michael S. Tsirkin Reviewed-by: Raphael Norwitz --

[PULL 28/52] hw/vhost-user-blk: turn on VIRTIO_BLK_F_SIZE_MAX feature for virtio blk device

2022-01-06 Thread Michael S. Tsirkin
From: Andy Pei Turn on pre-defined feature VIRTIO_BLK_F_SIZE_MAX for virtio blk device to avoid guest DMA request sizes which are too large for hardware spec. Signed-off-by: Andy Pei Message-Id: <1641202092-149677-1-git-send-email-andy@intel.com> Reviewed-by: Michael S. Tsirkin Signed-off-

Re: [PATCH V3] block/rbd: implement bdrv_co_block_status

2022-01-06 Thread Peter Lieven
14:16:56 2021     access_timestamp: Thu Jan  6 15:24:46 2022     modify_timestamp: Thu Jan  6 15:45:42 2022 $ rbd --conf /etc/ceph/ceph-dev01.conf --id lieven snap ls dhp-standard/c4ca7ee9-36ce-4fc9-9d3b-ece8a4f8b83e/c1ad11d0-4f6a-4cc1-8aa3-ff3c413c1471.raw SNAPID  NAME SIZE   

Re: [PATCH V3] block/rbd: implement bdrv_co_block_status

2022-01-06 Thread Ilya Dryomov
ut I would get rid of it and replace > >>> these gotos with returns. > >> > >> That would be return with the bitmask directly coded in if I also > >> > >> drop the ret variable. I can change that, no problem. > >> > >> > >>&

Re: [PATCH V3] block/rbd: implement bdrv_co_block_status

2022-01-06 Thread Peter Lieven
ring, exclusive-lock, object-map, fast-diff, deep-flatten op_features: flags: create_timestamp: Tue Sep 21 14:16:56 2021 access_timestamp: Thu Jan 6 15:24:46 2022 modify_timestamp: Thu Jan 6 15:45:42 2022 $ rbd --conf /etc/ceph/ceph-dev01.conf --id lieven snap ls d

Re: [PATCH V3] block/rbd: implement bdrv_co_block_status

2022-01-06 Thread Ilya Dryomov
RBD_FEATURE_FAST_DIFF)) { > >>>>>> +goto out; > >>>>>> +} > >>>>>> + > >>>>>> +/* check if RBD fast-diff result is valid */ > >>>>>> +r = rbd_get_flags(s->image, &am

Re: [PATCH V3] block/rbd: implement bdrv_co_block_status

2022-01-06 Thread Peter Lieven
>>>>>>> +*map = offset; >>>>>>>> +*file = bs; >>>>>>>> +*pnum = bytes; >>>>>>>> + >>>>>>>> +/* check if RBD image supports fast-diff */ >>>>>>>

Re: [PATCH v2 1/2] qemu-storage-daemon: Add vhost-user-blk help

2022-01-06 Thread Eric Blake
On Thu, Dec 23, 2021 at 11:14:25AM +0100, Philippe Mathieu-Daudé wrote: > Add missing vhost-user-blk help: > > $ qemu-storage-daemon -h > ... > --export [type=]vhost-user-blk,id=,node-name=, > addr.type=unix,addr.path=[,writable=on|off] > [,logical-block-size=][,n

Re: [PATCH v2 1/9] hw/nvram: Restrict stub to sysemu and tools

2022-01-06 Thread Richard Henderson
On 1/4/22 12:54 AM, Philippe Mathieu-Daudé wrote: +if have_system or have_tools ... if have_system + stub_ss.add(files('fw_cfg.c')) Disconnect in tests? r~

Re: [PATCH v2 2/9] hw/pci: Restrict pci-bus stub to sysemu

2022-01-06 Thread Richard Henderson
On 1/4/22 12:54 AM, Philippe Mathieu-Daudé wrote: From: Philippe Mathieu-Daudé Neither tools nor user-mode emulation require the PCI bus stub. Signed-off-by: Philippe Mathieu-Daudé Signed-off-by: Philippe Mathieu-Daudé --- stubs/meson.build | 2 +- 1 file changed, 1 insertion(+), 1 deletion(

Re: [PATCH v2 3/9] hw/pci: Document pci_dma_map()

2022-01-06 Thread Richard Henderson
On 1/4/22 12:54 AM, Philippe Mathieu-Daudé wrote: From: Philippe Mathieu-Daudé Signed-off-by: Philippe Mathieu-Daudé Signed-off-by: Philippe Mathieu-Daudé --- include/hw/pci/pci.h | 12 1 file changed, 12 insertions(+) diff --git a/include/hw/pci/pci.h b/include/hw/pci/pci.h

Re: [PATCH v2 4/9] hw/dma: Remove CONFIG_USER_ONLY check

2022-01-06 Thread Richard Henderson
On 1/4/22 12:54 AM, Philippe Mathieu-Daudé wrote: From: Philippe Mathieu-Daudé DMA API should not be included in user-mode emulation. If so, build should fail. Remove the CONFIG_USER_ONLY check. Signed-off-by: Philippe Mathieu-Daudé Signed-off-by: Philippe Mathieu-Daudé --- include/sysemu/dma

Re: [PATCH v2 7/9] hw/dma: Fix format string issues using dma_addr_t

2022-01-06 Thread Richard Henderson
On 1/4/22 12:54 AM, Philippe Mathieu-Daudé wrote: Signed-off-by: Philippe Mathieu-Daudé --- hw/ide/ahci.c| 2 +- hw/rdma/trace-events | 2 +- 2 files changed, 2 insertions(+), 2 deletions(-) Reviewed-by: Richard Henderson r~

Re: [PATCH v2 5/9] hw/rdma/rdma_utils: Rename rdma_pci_dma_map 'len' argument

2022-01-06 Thread Richard Henderson
On 1/4/22 12:54 AM, Philippe Mathieu-Daudé wrote: From: Philippe Mathieu-Daudé Various APIs use 'pval' naming for 'pointer to val'. rdma_pci_dma_map() uses 'plen' for 'PCI length', but since 'PCI' is already explicit in the function name, simplify and rename the argument 'len'. No logical change

Re: [PATCH v2 6/9] hw/scsi: Rename SCSIRequest::resid as 'residual'

2022-01-06 Thread Richard Henderson
On 1/4/22 12:54 AM, Philippe Mathieu-Daudé wrote: From: Philippe Mathieu-Daudé The 'resid' field is slightly confusing and could be interpreted as some ID. Rename it as 'residual' which is clearer to review. No logical change. Signed-off-by: Philippe Mathieu-Daudé Signed-off-by: Philippe Mathie