Re: [PATCH v2 00/24] hw/ide: QOM/QDev housekeeping

2023-02-24 Thread Philippe Mathieu-Daudé
ping for 3 patches :) On 20/2/23 10:13, Philippe Mathieu-Daudé wrote: Missing review: 2, 17, 20 Since v1: - addressed review comments John, can I get your formal Ack? Thanks, Phil.

Re: [PULL 00/29] Block layer patches

2023-02-24 Thread Philippe Mathieu-Daudé
Hi, On 24/2/23 19:50, Peter Maydell wrote: On Thu, 23 Feb 2023 at 18:51, Kevin Wolf wrote: The following changes since commit 79b677d658d3d35e1e776826ac4abb28cdce69b8: Merge tag 'net-pull-request' of https://github.com/jasowang/qemu into staging (2023-02-21 11:28:31 +) are

Re: [PATCH 0/2] block/qcow2: QAPI'fy Qcow2DiscardType

2023-02-24 Thread Richard Henderson
On 2/24/23 05:20, Philippe Mathieu-Daudé wrote: QAPI seems designed to maintain such enums, so convert Qcow2DiscardType to be QAPI generated. Besides, this is how Qcow2CompressionType is maintained. Philippe Mathieu-Daudé (2): block/qcow2: Rename QCOW2_DISCARD_TYPE enum definitions

[PATCH 5/7] tests/docker: use direct RUNC call to build containers

2023-02-24 Thread Alex Bennée
We don't really need stuff from docker.py to do the build as we have everything we need with a direct call. We do rely on the dockerfiles being able to tweak the UID/name mapping as the last step. Signed-off-by: Alex Bennée --- tests/docker/Makefile.include | 22 +- 1 file

[PATCH 7/7] tests/gitlab: use kaniko to build images

2023-02-24 Thread Alex Bennée
Apparently the docker-in-docker approach has some flaws including needing privileged mode to run and being quite slow. An alternative approach is to use Google's kaniko tool. It also works across different gitlab executors. Following the gitlab example code we drop all the direct docker calls and

[PATCH 0/7] testing/next: docker.py removal and kaniko updates

2023-02-24 Thread Alex Bennée
This series attempts to remove our dependence on the docker.py script and build things directly with the appropriate tool. I've been noodling around with how we build images on gitlab to see if they can cache better because the normal case should be we don't need to rebuild everything if the

Re: [PULL 00/29] Block layer patches

2023-02-24 Thread Peter Maydell
On Thu, 23 Feb 2023 at 18:51, Kevin Wolf wrote: > > The following changes since commit 79b677d658d3d35e1e776826ac4abb28cdce69b8: > > Merge tag 'net-pull-request' of https://github.com/jasowang/qemu into > staging (2023-02-21 11:28:31 +) > > are available in the Git repository at: > >

[PATCH 4/7] tests/docker: add USER stanzas to non-lci images

2023-02-24 Thread Alex Bennée
These are flat but not generated by lcitool so we need to manually update them with the `useradd` stanza. Signed-off-by: Alex Bennée --- tests/docker/dockerfiles/debian-all-test-cross.docker | 5 + tests/docker/dockerfiles/debian-alpha-cross.docker| 5 +

[PATCH 2/7] tests/dockerfiles: unify debian-toolchain references

2023-02-24 Thread Alex Bennée
We use the debian release number elsewhere so fix it for consistency along with the broken comment. Signed-off-by: Alex Bennée --- tests/docker/dockerfiles/debian-toolchain.docker | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git

[PATCH 6/7] tests/docker: use direct RUNC call to run test jobs

2023-02-24 Thread Alex Bennée
If we build them without the script we can certainly run them without it. Signed-off-by: Alex Bennée --- tests/docker/Makefile.include | 5 +++-- 1 file changed, 3 insertions(+), 2 deletions(-) diff --git a/tests/docker/Makefile.include b/tests/docker/Makefile.include index

[PATCH 1/7] configure: expose the direct container command

2023-02-24 Thread Alex Bennée
In the process of migrating away from using docker.py to build our containers we need to expose the command to the build environment. The script is still a useful way to probe which command works though. Signed-off-by: Alex Bennée --- configure | 3 +++ 1 file changed, 3 insertions(+) diff

[PATCH 3/7] tests/lcitool: append user setting stanza to dockerfiles

2023-02-24 Thread Alex Bennée
For the cross-compilation use-case it is important to add the host user to the dockerfile so we can map them to the docker environment when cross-building files. Signed-off-by: Alex Bennée --- .gitlab-ci.d/cirrus/freebsd-12.vars | 5 + .gitlab-ci.d/cirrus/freebsd-13.vars

Re: [PATCH v3 1/6] configure: Look for auxiliary Python installations

2023-02-24 Thread Eric Blake
On Tue, Feb 21, 2023 at 12:03:44PM +0100, Paolo Bonzini wrote: > > > > This configure loop will prefer, in order: > > > > 1. Whatever is specified in $PYTHON > > 2. python3 > > 3. python (Which is usually 2.x, but might be 3.x on some platforms.) > > 4. python3.11 down through python3.6 > > > >

Re: [PATCH v2 00/10] Resolve isabus global

2023-02-24 Thread Michael S. Tsirkin
On Thu, Jan 26, 2023 at 10:17:30PM +0100, Bernhard Beschow wrote: > This series resolves the global "isabus" variable and is basically a v2 of > [1]. > Note that the majority of the work consists of fixing ISA API calls in PIIX > IDE > which implicitly rely on the usage of the isabus global. >

Re: [PATCH v2 07/10] hw/ide/piix: Require an ISABus only for user-created instances

2023-02-24 Thread Michael S. Tsirkin
On Thu, Jan 26, 2023 at 10:17:37PM +0100, Bernhard Beschow wrote: > diff --git a/hw/isa/piix.c b/hw/isa/piix.c > index 54a1246a9d..f9974c2a77 100644 > --- a/hw/isa/piix.c > +++ b/hw/isa/piix.c > @@ -345,9 +345,14 @@ static void pci_piix_realize(PCIDevice *dev, const char > *uhci_type, > >

[PATCH] hw/ide: Remove unuseful IDE_DMA__COUNT definition

2023-02-24 Thread Philippe Mathieu-Daudé
First, IDE_DMA__COUNT represents the number of enumerated values, but is incorrectly listed as part of the enum. Second, IDE_DMA_CMD_str() is internal to core.c and only takes sane enums from ide_dma_cmd. So no need to check the 'enval' argument is within the enum range. Only checks

[PATCH 2/2] block/qcow2: QAPI'fy Qcow2DiscardType

2023-02-24 Thread Philippe Mathieu-Daudé
Let QAPI maintain the Qcow2DiscardType enum values. Mechanical renaming to Qcow2DiscardType doing: $ sed -i -e 's/enum qcow2_discard_type/Qcow2DiscardType/g' \ $(git grep -l qcow2_discard_type) Signed-off-by: Philippe Mathieu-Daudé --- block/qcow2-cluster.c | 4 ++--

[PATCH 1/2] block/qcow2: Rename QCOW2_DISCARD_TYPE enum definitions

2023-02-24 Thread Philippe Mathieu-Daudé
In order to QAPI'fy Qcow2DiscardType in the next commit, rename its definitions to a QAPI-ready format. Mechanical change doing: $ sed -i -e 's/QCOW2_DISCARD_/QCOW2_DISCARD_TYPE_/g' \ $(git grep -l QCOW2_DISCARD_) $ sed -i -e 's/QCOW2_DISCARD_TYPE_MAX/QCOW2_DISCARD_TYPE__MAX/g' \

[PATCH 0/2] block/qcow2: QAPI'fy Qcow2DiscardType

2023-02-24 Thread Philippe Mathieu-Daudé
QAPI seems designed to maintain such enums, so convert Qcow2DiscardType to be QAPI generated. Besides, this is how Qcow2CompressionType is maintained. Philippe Mathieu-Daudé (2): block/qcow2: Rename QCOW2_DISCARD_TYPE enum definitions block/qcow2: QAPI'fy Qcow2DiscardType

Re: [PULL 0/2] Python patches

2023-02-24 Thread Peter Maydell
On Thu, 23 Feb 2023 at 04:36, John Snow wrote: > > The following changes since commit 79b677d658d3d35e1e776826ac4abb28cdce69b8: > > Merge tag 'net-pull-request' of https://github.com/jasowang/qemu into > staging (2023-02-21 11:28:31 +) > > are available in the Git repository at: > >

[PATCH 2/9] block/mirror: set actively_synced even after the job is ready

2023-02-24 Thread Fiona Ebner
In preparation to allow switching from background to active mode. This ensures that setting actively_synced will not be missed when the switch happens after the job is ready. Signed-off-by: Fiona Ebner --- block/mirror.c | 6 +++--- 1 file changed, 3 insertions(+), 3 deletions(-) diff --git

[PATCH 9/9] mirror: return the total number of bytes sent upon query

2023-02-24 Thread Fiona Ebner
This can be used by management applications starting with a job in background mode to determine when the switch to active mode should happen. While the same information is already there, as the job-agnostic @offset, it's not clear to users what the value means for mirror: it's documentet to be

[PATCH 0/9] mirror: allow switching from background to active mode

2023-02-24 Thread Fiona Ebner
With active mode, the guest write speed is limited by the synchronous writes to the mirror target. For this reason, management applications might want to start out in background mode and only switch to active mode later, when certain conditions are met. This series adds a block-job-change QMP

[PATCH 3/9] mirror: implement mirror_change method

2023-02-24 Thread Fiona Ebner
which allows switching the @copy-mode from 'background' to 'write-blocking'. Once the job is in active mode, no new writes need to be registered in the dirty bitmap, because they are synchronously written to the target. But since the method is called from the monitor and IO might be happening in

[PATCH 6/9] blockjob: query driver-specific info via a new 'query' driver method

2023-02-24 Thread Fiona Ebner
Signed-off-by: Fiona Ebner --- blockjob.c | 4 include/block/blockjob_int.h | 5 + 2 files changed, 9 insertions(+) diff --git a/blockjob.c b/blockjob.c index 9bd51bc6ae..5570890001 100644 --- a/blockjob.c +++ b/blockjob.c @@ -349,6 +349,7 @@ BlockJobInfo

[PATCH 5/9] qapi/block-core: turn BlockJobInfo into a union

2023-02-24 Thread Fiona Ebner
In preparation to additionally return job-type-specific information. Signed-off-by: Fiona Ebner --- qapi/block-core.json | 8 +--- 1 file changed, 5 insertions(+), 3 deletions(-) diff --git a/qapi/block-core.json b/qapi/block-core.json index c1ac6de238..adb43a4592 100644 ---

[PATCH 4/9] qapi/block-core: use JobType for BlockJobInfo's type

2023-02-24 Thread Fiona Ebner
In preparation to turn BlockJobInfo into a union with @type as the discriminator. That requires it to be an enum. No functional change is intended. Signed-off-by: Fiona Ebner --- block/monitor/block-hmp-cmds.c | 4 ++-- blockjob.c | 2 +- qapi/block-core.json | 2

[PATCH 7/9] mirror: return mirror-specific information upon query

2023-02-24 Thread Fiona Ebner
To start out, only actively-synced is returned. For example, this is useful for jobs that started out in background mode and switched to active mode. Once actively-synced is true, it's clear that the mode switch has been completed. Note that completion of the switch might happen much earlier,

[PATCH 1/9] blockjob: introduce block-job-change QMP command

2023-02-24 Thread Fiona Ebner
which will allow changing job-type-specific options after job creation. In the JobVerbTable, the same allow bits as for set-speed are used, because set-speed could be considered an existing change command. Signed-off-by: Fiona Ebner --- Tried to go more general at first with a 'job-change'

[PATCH 8/9] mirror: return the remaining dirty bytes upon query

2023-02-24 Thread Fiona Ebner
This can be used by management applications starting with a job in background mode to determine when the switch to active mode should happen. Suggested-by: Vladimir Sementsov-Ogievskiy Signed-off-by: Fiona Ebner --- block/mirror.c | 1 + qapi/block-core.json | 4 +++- 2 files changed, 4

Re: [PATCH v3 1/5] hw/nvme: move adjustment of data_units{read,written}

2023-02-24 Thread Klaus Jensen
On Feb 24 09:20, Joel Granados wrote: > On Mon, Feb 20, 2023 at 12:59:22PM +0100, Jesper Devantier wrote: > > From: Joel Granados > > > > In order to return the units_{read/written} required by the SMART log we > > need to shift the number of bytes value by BDRV_SECTORS_BITS and multiply > > by

Re: [PATCH v3 3/5] hw/nvme: add basic endurance group support

2023-02-24 Thread Klaus Jensen
On Feb 24 09:51, Joel Granados wrote: > On Mon, Feb 20, 2023 at 12:59:24PM +0100, Jesper Devantier wrote: > > From: Klaus Jensen > > > > Add the mandatory Endurance Group identify data structures and log > > pages. > > > > For now, all namespaces in a subsystem belongs to a single Endurance > >

Re: [PATCH] MAINTAINERS: Cover RCU documentation

2023-02-24 Thread Paolo Bonzini
Queued, thanks. Paolo

Re: [PATCH v2 03/18] hw: Replace isa_get_irq() by isa_bus_get_irq() when ISABus is available

2023-02-24 Thread Thomas Huth
On 15/02/2023 17.16, Philippe Mathieu-Daudé wrote: Signed-off-by: Philippe Mathieu-Daudé --- hw/audio/cs4231a.c | 5 +++-- hw/audio/gus.c | 5 +++-- hw/audio/sb16.c | 7 --- hw/block/fdc-isa.c | 5 +++-- include/hw/timer/i8254.h | 3 ++- 5 files

Re: [PATCH v3 3/5] hw/nvme: add basic endurance group support

2023-02-24 Thread Joel Granados
On Mon, Feb 20, 2023 at 12:59:24PM +0100, Jesper Devantier wrote: > From: Klaus Jensen > > Add the mandatory Endurance Group identify data structures and log > pages. > > For now, all namespaces in a subsystem belongs to a single Endurance > Group. > > Signed-off-by: Klaus Jensen > --- >

Re: [PATCH v2 02/18] hw/isa: Factor isa_bus_get_irq() out of isa_get_irq()

2023-02-24 Thread Thomas Huth
On 15/02/2023 17.16, Philippe Mathieu-Daudé wrote: isa_get_irq() was added in commit 3a38d437ca ("Add isa_reserve_irq()" Fri Aug 14 11:36:15 2009) as: a temporary interface to be used to allocate ISA IRQs for devices which have not yet been converted to qdev, and for special

Re: [PATCH v2 01/18] hw/isa: Rename isa_get_dma() -> isa_bus_get_dma()

2023-02-24 Thread Thomas Huth
On 15/02/2023 17.16, Philippe Mathieu-Daudé wrote: isa_get_dma() returns a DMA channel handler from an ISABus. To emphasize this, rename it as isa_bus_get_dma(). Mechanical change using: $ sed -i -e 's/isa_get_dma/isa_bus_get_dma/g' \ $(git grep -l isa_get_dma) Signed-off-by:

Re: [PATCH v3 1/5] hw/nvme: move adjustment of data_units{read,written}

2023-02-24 Thread Joel Granados
On Mon, Feb 20, 2023 at 12:59:22PM +0100, Jesper Devantier wrote: > From: Joel Granados > > In order to return the units_{read/written} required by the SMART log we > need to shift the number of bytes value by BDRV_SECTORS_BITS and multiply > by 1000. This is a prep patch that moves this