Re: [PATCH 1/3] block: make BlockBackend->quiesce_counter atomic

2023-03-06 Thread Stefan Hajnoczi
On Fri, Mar 03, 2023 at 04:29:54PM +0100, Hanna Czenczek wrote: > On 27.02.23 21:57, Stefan Hajnoczi wrote: > > The main loop thread increments/decrements BlockBackend->quiesce_counter > > when drained sections begin/end. The counter is read in the I/O code > > path. Therefore this field is used

Re: [PATCH v3 13/16] slirp: open-code qemu_socket_(un)select()

2023-03-06 Thread Stefan Berger
On 3/6/23 09:03, Marc-André Lureau wrote: On Mon, Mar 6, 2023 at 5:59 PM Stefan Berger mailto:stef...@linux.ibm.com>> wrote: On 2/21/23 07:47, marcandre.lur...@redhat.com wrote: > From: Marc-André Lureau mailto:marcandre.lur...@redhat.com>>

Re: [PATCH v3 16/16] win32: replace closesocket() with close() wrapper

2023-03-06 Thread Stefan Berger
On 2/21/23 07:48, marcandre.lur...@redhat.com wrote: From: Marc-André Lureau Use a close() wrapper instead, so that we don't need to worry about closesocket() vs close() anymore, let's hope. Signed-off-by: Marc-André Lureau diff --git a/util/oslib-win32.c b/util/oslib-win32.c index

Re: [PATCH 02/43] migration: Pass migrate_caps_check() the old and new caps

2023-03-06 Thread Vladimir Sementsov-Ogievskiy
On 02.03.23 19:33, Juan Quintela wrote: We used to pass the old capabilities array and the new capabilities as a list. Signed-off-by: Juan Quintela Reviewed-by: Vladimir Sementsov-Ogievskiy -- Best regards, Vladimir

[PULL 0/5] hw/nvme updates

2023-03-06 Thread Klaus Jensen
From: Klaus Jensen Hi, The following changes since commit f003dd8d81f7d88f4b1f8802309eaa76f6eb223a: Merge tag 'pull-tcg-20230305' of https://gitlab.com/rth7680/qemu into staging (2023-03-06 10:20:04 +) are available in the Git repository at: https://gitlab.com/birkelund/qemu.git

[PULL 1/5] hw/nvme: move adjustment of data_units{read,written}

2023-03-06 Thread Klaus Jensen
From: Joel Granados Move the rounding of bytes read/written into nvme_smart_log which reports in units of 512 bytes, rounded up in thousands. This is in preparation for adding the Endurance Group Information log page which reports in units of billions, rounded up. Reviewed-by: Keith Busch

[PULL 2/5] hw/nvme: store a pointer to the NvmeSubsystem in the NvmeNamespace

2023-03-06 Thread Klaus Jensen
From: Niklas Cassel Each NvmeNamespace can be used by serveral controllers, but a NvmeNamespace can at most belong to a single NvmeSubsystem. Store a pointer to the NvmeSubsystem, if the namespace was realized with a NvmeSubsystem. Reviewed-by: Keith Busch Signed-off-by: Niklas Cassel

[PULL 5/5] hw/nvme: flexible data placement emulation

2023-03-06 Thread Klaus Jensen
From: Jesper Devantier Add emulation of TP4146 ("Flexible Data Placement"). Reviewed-by: Keith Busch Signed-off-by: Jesper Devantier Signed-off-by: Klaus Jensen --- hw/nvme/ctrl.c | 698 ++- hw/nvme/ns.c | 143 + hw/nvme/nvme.h

[PULL 3/5] hw/nvme: add basic endurance group support

2023-03-06 Thread Klaus Jensen
From: Klaus Jensen Add the mandatory Endurance Group identify data structures and log pages. For now, all namespaces in a subsystem belongs to a single Endurance Group. Reviewed-by: Keith Busch Signed-off-by: Klaus Jensen --- hw/nvme/ctrl.c | 52

[PULL 4/5] hw/nvme: basic directives support

2023-03-06 Thread Klaus Jensen
From: Gollu Appalanaidu Add support for the Directive Send and Recv commands and the Identify directive. Reviewed-by: Keith Busch Signed-off-by: Gollu Appalanaidu Signed-off-by: Klaus Jensen --- hw/nvme/ctrl.c | 40 +++- hw/nvme/nvme.h | 2 ++

Re: [PATCH v3 13/16] slirp: open-code qemu_socket_(un)select()

2023-03-06 Thread Stefan Berger
On 2/21/23 07:47, marcandre.lur...@redhat.com wrote: From: Marc-André Lureau We are about to make the QEMU socket API use file-descriptor space only, but libslirp gives us SOCKET as fd, still. Signed-off-by: Marc-André Lureau --- net/slirp.c | 10 +++--- 1 file changed, 7

Re: [PATCH 00/43] Migration: Create options.c for capabilities/params/properties

2023-03-06 Thread Vladimir Sementsov-Ogievskiy
On 02.03.23 19:33, Juan Quintela wrote: Hi This series move to options.c: - all migration capabilities code - all migration parameters code - all properties code - all qmp commands that only touch the previous And once there: - sort of functions - make consistent and coherent all the functions

Re: [PATCH 01/43] migration: rename enabled_capabilities to capabilities

2023-03-06 Thread Vladimir Sementsov-Ogievskiy
On 02.03.23 19:33, Juan Quintela wrote: It is clear from the context what that means, and such a long name with the extra long names of the capabilities make very difficilut to stay inside the 80 columns limit. Signed-off-by: Juan Quintela Reviewed-by: Vladimir Sementsov-Ogievskiy -- Best

Re: [PATCH v3 14/16] win32: avoid mixing SOCKET and file descriptor space

2023-03-06 Thread Stefan Berger
On 2/21/23 07:47, marcandre.lur...@redhat.com wrote: From: Marc-André Lureau Until now, a win32 SOCKET handle is often cast to an int file descriptor, as this is what other OS use for sockets. When necessary, QEMU eventually queries whether it's a socket with the help of fd_is_socket().

Re: [PATCH v3 13/16] slirp: open-code qemu_socket_(un)select()

2023-03-06 Thread Stefan Berger
On 2/21/23 07:47, marcandre.lur...@redhat.com wrote: From: Marc-André Lureau We are about to make the QEMU socket API use file-descriptor space only, but libslirp gives us SOCKET as fd, still. Signed-off-by: Marc-André Lureau --- net/slirp.c | 10 +++--- 1 file changed, 7

Re: [Libguestfs] [PATCH] docs: Prefer 'cookie' over 'handle'

2023-03-06 Thread Eric Blake
On Sun, Mar 05, 2023 at 10:53:38AM +0200, Wouter Verhelst wrote: > On Sat, Mar 04, 2023 at 10:03:46PM +0200, Nir Soffer wrote: > > On Sat, Mar 4, 2023 at 12:15 AM Eric Blake wrote: > > > Makes no difference to implementations (other than older code > > > still using 'handle' may be slightly

Re: [Libguestfs] [PATCH v2 1/6] spec: Recommend cap on NBD_REPLY_TYPE_BLOCK_STATUS length

2023-03-06 Thread Nir Soffer
On Sun, Mar 5, 2023 at 10:42 AM Wouter Verhelst wrote: > > On Fri, Mar 03, 2023 at 04:17:40PM -0600, Eric Blake wrote: > > On Fri, Dec 16, 2022 at 10:32:01PM +0300, Vladimir Sementsov-Ogievskiy > > wrote: > > > s-o-b line missed. > > > > I'm not sure if the NBD project has a strict policy on

Re: [PATCH v3 13/16] slirp: open-code qemu_socket_(un)select()

2023-03-06 Thread Marc-André Lureau
Hi On Mon, Mar 6, 2023 at 5:59 PM Stefan Berger wrote: > > > On 2/21/23 07:47, marcandre.lur...@redhat.com wrote: > > From: Marc-André Lureau > > > > We are about to make the QEMU socket API use file-descriptor space only, > > but libslirp gives us SOCKET as fd, still. > > > > Signed-off-by:

Re: [PATCH v3 0/5] Support Flexible Data Placement (FDP)

2023-03-06 Thread Klaus Jensen
On Feb 20 12:59, Jesper Devantier wrote: > From: Jesper Wendel Devantier > > Flexible Data Placement (FDP) is a newly introduced enhancement > of the NVM command set introduced by the NVM Express, Inc. > organization as TP 4146. FDP aims to extend the NVM command set > to enable host-guided data

migrate-bitmaps-postcopy-test failure

2023-03-06 Thread Thomas Huth
Hi, I've just seen this migrate-bitmaps-postcopy-test failure while running "make check -j5 SPEED=slow" on my laptop: @@ -1,5 +1,13 @@ -... +..F +== +FAIL: test_postcopy_success (__main__.TestDirtyBitmapPostcopyMigration)

Re: test-blockjob: intermittent CI failures in msys2-64bit job

2023-03-06 Thread Peter Maydell
On Fri, 3 Mar 2023 at 18:36, Peter Maydell wrote: > > I've noticed that test-blockjob seems to fail intermittently > on the msys2-64bit job: > > https://gitlab.com/qemu-project/qemu/-/jobs/3872508803 > https://gitlab.com/qemu-project/qemu/-/jobs/3871061024 >

Re: [PATCH v3 00/16] win32: do not mix SOCKET and fd space

2023-03-06 Thread Paolo Bonzini
On 3/6/23 09:08, Marc-André Lureau wrote: Great, thanks! (I suppose you'll drop "RFC: build-sys: add slirp.wrap", and perhaps queue the other meson/wrap series instead) I don't have time to test the dtc fallback in CI, so I'll queue only the first three patches and note it as experimental in

Re: [Libguestfs] [PATCH v2 1/6] spec: Recommend cap on NBD_REPLY_TYPE_BLOCK_STATUS length

2023-03-06 Thread Laszlo Ersek
On 3/5/23 09:41, Wouter Verhelst wrote: > On Fri, Mar 03, 2023 at 04:17:40PM -0600, Eric Blake wrote: >> On Fri, Dec 16, 2022 at 10:32:01PM +0300, Vladimir Sementsov-Ogievskiy wrote: >>> s-o-b line missed. >> >> I'm not sure if the NBD project has a strict policy on including one, >> but I don't

Re: [PATCH v3 00/16] win32: do not mix SOCKET and fd space

2023-03-06 Thread Marc-André Lureau
Hi Paolo On Mon, Mar 6, 2023 at 12:05 PM Paolo Bonzini wrote: > On 3/2/23 15:09, Marc-André Lureau wrote: > > > > > > v3: > > - fix closesocket() to prevent CloseHandle() from close() > > - fix direct closesocket() usage (#undef closesocket before) > > - add a test for _warn > >

Re: [PATCH v3 00/16] win32: do not mix SOCKET and fd space

2023-03-06 Thread Paolo Bonzini
On 3/2/23 15:09, Marc-André Lureau wrote: v3: - fix closesocket() to prevent CloseHandle() from close() - fix direct closesocket() usage (#undef closesocket before) - add a test for _warn - add r-b tags ping  (I am missing reviews, thanks) I'm going to queue this series