Re: [PATCH v2 1/5] system/cpus: rename qemu_mutex_lock_iothread() to bql_lock()

2023-12-12 Thread Akihiko Odaki
On 2023/12/13 0:39, Stefan Hajnoczi wrote: The Big QEMU Lock (BQL) has many names and they are confusing. The actual QemuMutex variable is called qemu_global_mutex but it's commonly referred to as the BQL in discussions and some code comments. The locking APIs, however, are called

Re: [PATCH 2/2] arm: xlnx-versal-virt: Add machine property ospi-flash

2023-12-12 Thread Peter Maydell
On Tue, 5 Dec 2023 at 09:52, Sai Pavan Boddu wrote: > > This property allows users to change flash model on command line as > below. > >ex: "-M xlnx-versal-virt,ospi-flash=mt35xu02gbba" > > Signed-off-by: Sai Pavan Boddu > --- > hw/arm/xlnx-versal-virt.c | 31 ++-

Re: [PATCH 1/1] xlnx-versal-ospi: disable reentrancy detection for iomem_dac

2023-12-12 Thread Peter Maydell
On Tue, 5 Dec 2023 at 10:08, Sai Pavan Boddu wrote: > > The OSPI DMA reads flash data through the OSPI linear address space (the > iomem_dac region), because of this the reentrancy guard introduced in > commit a2e1753b ("memory: prevent dma-reentracy issues") is disabled for > the memory region.

[PATCH v2 5/5] Rename "QEMU global mutex" to "BQL" in comments and docs

2023-12-12 Thread Stefan Hajnoczi
The term "QEMU global mutex" is identical to the more widely used Big QEMU Lock ("BQL"). Update the code comments and documentation to use "BQL" instead of "QEMU global mutex". Signed-off-by: Stefan Hajnoczi Acked-by: Markus Armbruster Reviewed-by: Philippe Mathieu-Daudé ---

[PATCH v2 2/5] qemu/main-loop: rename QEMU_IOTHREAD_LOCK_GUARD to BQL_LOCK_GUARD

2023-12-12 Thread Stefan Hajnoczi
The name "iothread" is overloaded. Use the term Big QEMU Lock (BQL) instead, it is already widely used and unambiguous. Signed-off-by: Stefan Hajnoczi Reviewed-by: Paul Durrant Acked-by: David Woodhouse Reviewed-by: Cédric Le Goater Acked-by: Ilya Leoshkevich --- include/qemu/main-loop.h |

[PATCH v2 4/5] Replace "iothread lock" with "BQL" in comments

2023-12-12 Thread Stefan Hajnoczi
The term "iothread lock" is obsolete. The APIs use Big QEMU Lock (BQL) in their names. Update the code comments to use "BQL" instead of "iothread lock". Signed-off-by: Stefan Hajnoczi Reviewed-by: Philippe Mathieu-Daudé --- docs/devel/reset.rst | 2 +- hw/display/qxl.h

[PATCH v2 1/5] system/cpus: rename qemu_mutex_lock_iothread() to bql_lock()

2023-12-12 Thread Stefan Hajnoczi
The Big QEMU Lock (BQL) has many names and they are confusing. The actual QemuMutex variable is called qemu_global_mutex but it's commonly referred to as the BQL in discussions and some code comments. The locking APIs, however, are called qemu_mutex_lock_iothread() and

[PATCH v2 3/5] qemu/main-loop: rename qemu_cond_wait_iothread() to qemu_cond_wait_bql()

2023-12-12 Thread Stefan Hajnoczi
The name "iothread" is overloaded. Use the term Big QEMU Lock (BQL) instead, it is already widely used and unambiguous. Signed-off-by: Stefan Hajnoczi Reviewed-by: Cédric Le Goater Reviewed-by: Philippe Mathieu-Daudé --- include/qemu/main-loop.h | 10 +-

[PATCH v2 0/5] Make Big QEMU Lock naming consistent

2023-12-12 Thread Stefan Hajnoczi
v2: - Rename APIs bql_*() [PeterX] - Spell out "Big QEMU Lock (BQL)" in doc comments [PeterX] - Rename "iolock" variables in hw/remote/mpqemu-link.c [Harsh] - Fix bql_auto_lock() indentation in Patch 2 [Ilya] - "with BQL taken" -> "with the BQL taken" [Philippe] - "under BQL" -> "under the BQL"

Re: [PATCH v2 1/2] qdev: add IOThreadVirtQueueMappingList property type

2023-12-12 Thread Stefan Hajnoczi
On Mon, Dec 11, 2023 at 04:32:06PM +0100, Markus Armbruster wrote: > Kevin Wolf writes: > > > Am 18.09.2023 um 18:16 hat Stefan Hajnoczi geschrieben: > >> virtio-blk and virtio-scsi devices will need a way to specify the > >> mapping between IOThreads and virtqueues. At the moment all virtqueues

Re: [PATCH RFC v2 05/12] hw/qdev: Remove opts member

2023-12-12 Thread Akihiko Odaki
On 2023/12/12 19:04, Philippe Mathieu-Daudé wrote: On 10/12/23 05:05, Akihiko Odaki wrote: It is no longer used. Since commit f3558b1b76 ("qdev: Base object creation on QDict rather than QemuOpts")? One usage still remains and it will be removed with an earlier patch, "[PATCH RFC v2 04/12]

Re: [PATCH RFC v2 05/12] hw/qdev: Remove opts member

2023-12-12 Thread Philippe Mathieu-Daudé
On 10/12/23 05:05, Akihiko Odaki wrote: It is no longer used. Since commit f3558b1b76 ("qdev: Base object creation on QDict rather than QemuOpts")? Reviewed-by: Philippe Mathieu-Daudé Signed-off-by: Akihiko Odaki --- include/hw/qdev-core.h | 4 hw/core/qdev.c | 1 -

Re: [PATCH RFC v2 01/12] hw/pci: Initialize PCI multifunction after realization

2023-12-12 Thread Philippe Mathieu-Daudé
On 10/12/23 05:05, Akihiko Odaki wrote: The device realization code may enable PCI multifunction for SR-IOV. Signed-off-by: Akihiko Odaki --- hw/pci/pci.c | 17 + 1 file changed, 9 insertions(+), 8 deletions(-) Reviewed-by: Philippe Mathieu-Daudé

Re: [PATCH v2 1/2] qdev: add IOThreadVirtQueueMappingList property type

2023-12-12 Thread Kevin Wolf
Am 11.12.2023 um 16:32 hat Markus Armbruster geschrieben: > Kevin Wolf writes: > > > Am 18.09.2023 um 18:16 hat Stefan Hajnoczi geschrieben: > >> virtio-blk and virtio-scsi devices will need a way to specify the > >> mapping between IOThreads and virtqueues. At the moment all virtqueues > >> are

Re: [PATCH RFC v2 00/12] virtio-net: add support for SR-IOV emulation

2023-12-12 Thread Akihiko Odaki
On 2023/12/12 13:12, Jason Wang wrote: On Mon, Dec 11, 2023 at 4:29 PM Akihiko Odaki wrote: On 2023/12/11 16:26, Jason Wang wrote: On Mon, Dec 11, 2023 at 1:30 PM Akihiko Odaki wrote: On 2023/12/11 11:52, Jason Wang wrote: On Sun, Dec 10, 2023 at 12:06 PM Akihiko Odaki wrote: