Re: [PATCH v2 9/9] gitlab-ci: Add alpine to pipeline

2021-01-18 Thread Jiaxun Yang
On Mon, Jan 18, 2021, at 6:11 PM, Daniel P. Berrangé wrote: > On Mon, Jan 18, 2021 at 02:38:08PM +0800, Jiaxun Yang wrote: > > We only run build test and check-acceptance as their are too many > > failures in checks due to minor string mismatch. > > Can you give real exam

[PATCH v2 8/9] tests/docker: Add dockerfile for Alpine Linux

2021-01-17 Thread Jiaxun Yang
Alpine Linux[1] is a security-oriented, lightweight Linux distribution based on musl libc and busybox. It it popular among Docker guests and embedded applications. Adding it to test against different libc. [1]: https://alpinelinux.org/ Signed-off-by: Jiaxun Yang --- tests/docker/dockerfiles

[PATCH v2 7/9] accel/kvm: avoid using predefined PAGE_SIZE

2021-01-17 Thread Jiaxun Yang
9/xsh/limits.h.html Signed-off-by: Jiaxun Yang --- accel/kvm/kvm-all.c | 3 +++ 1 file changed, 3 insertions(+) diff --git a/accel/kvm/kvm-all.c b/accel/kvm/kvm-all.c index 389eaace72..3feb17d965 100644 --- a/accel/kvm/kvm-all.c +++ b/accel/kvm/kvm-all.c @@ -58,6 +58,9 @@ /* KVM uses PAGE_SI

[PATCH v2 9/9] gitlab-ci: Add alpine to pipeline

2021-01-17 Thread Jiaxun Yang
We only run build test and check-acceptance as their are too many failures in checks due to minor string mismatch. Signed-off-by: Jiaxun Yang --- .gitlab-ci.d/containers.yml | 5 + .gitlab-ci.yml | 23 +++ 2 files changed, 28 insertions(+) diff --git a

[PATCH v2 6/9] tests: Rename PAGE_SIZE definitions

2021-01-17 Thread Jiaxun Yang
Signed-off-by: Jiaxun Yang Reviewed-by: Thomas Huth --- tests/migration/stress.c| 10 ++--- tests/qtest/libqos/malloc-pc.c | 4 +- tests/qtest/libqos/malloc-spapr.c | 4 +- tests/qtest/m25p80-test.c | 54 +++--- tests/tcg/multiarch/system/memory.c | 6

[PATCH v2 5/9] elf2dmp: Rename PAGE_SIZE to ELF2DMP_PAGE_SIZE

2021-01-17 Thread Jiaxun Yang
As per POSIX specification of limits.h [1], OS libc may define PAGE_SIZE in limits.h. To prevent collosion of definition, we rename PAGE_SIZE here. [1]: https://pubs.opengroup.org/onlinepubs/7908799/xsh/limits.h.html Signed-off-by: Jiaxun Yang Reviewed-by: Thomas Huth --- contrib/elf2dmp

[PATCH v2 4/9] hw/block/nand: Rename PAGE_SIZE to NAND_PAGE_SIZE

2021-01-17 Thread Jiaxun Yang
As per POSIX specification of limits.h [1], OS libc may define PAGE_SIZE in limits.h. To prevent collosion of definition, we rename PAGE_SIZE here. [1]: https://pubs.opengroup.org/onlinepubs/7908799/xsh/limits.h.html Signed-off-by: Jiaxun Yang Reviewed-by: Thomas Huth --- hw/block/nand.c

[PATCH v2 3/9] osdep.h: Remove include

2021-01-17 Thread Jiaxun Yang
forms like Haiku lack it completely, just remove it. Tested building on OpenBSD after removing this include. Signed-off-by: Michael Forney Reviewed-by: Eric Blake [jiaxun.y...@flygoat.com: Move to meson] Signed-off-by: Jiaxun Yang --- meson.build | 1 - include/qemu/osdep.h | 4 ---

[PATCH v2 2/9] libvhost-user: Include poll.h instead of sys/poll.h

2021-01-17 Thread Jiaxun Yang
h:1:2: error: #warning redirecting incorrect #include to [-Werror=cpp] 1 | #warning redirecting incorrect #include to | ^~~ Signed-off-by: Jiaxun Yang Reviewed-by: Thomas Huth --- subprojects/libvhost-user/libvhost-user.h | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-)

[PATCH v2 1/9] configure: Add sys/timex.h to probe clock_adjtime

2021-01-17 Thread Jiaxun Yang
It is not a part of standard time.h. Glibc put it under time.h however musl treat it as a sys timex extension. Signed-off-by: Jiaxun Yang Reviewed-by: Thomas Huth --- configure | 1 + 1 file changed, 1 insertion(+) diff --git a/configure b/configure index 155dda124c..1a9e1afa39 100755 --- a

[PATCH v2 0/9] Alpine Linux build fix and CI pipeline

2021-01-17 Thread Jiaxun Yang
le (Wainer) - Pickup proper signal.h fix (PMM) - Correct clock_adjtime title (Thomas Huth) - Collect review tags Jiaxun Yang (8): configure: Add sys/timex.h to probe clock_adjtime libvhost-user: Include poll.h instead of sys/poll.h hw/block/nand: Rename PAGE_SIZE to NAND_PAGE_SIZE elf2d

Re: [PATCH 7/9] accel/kvm: avoid using predefined PAGE_SIZE

2021-01-13 Thread Jiaxun Yang
On Wed, Jan 13, 2021, at 3:19 PM, Thomas Huth wrote: > On 21/12/2020 01.53, Jiaxun Yang wrote: > > As per POSIX specification of limits.h [1], OS libc may define > > PAGE_SIZE in limits.h. > > > > To prevent collosion of definition, we discard PAGE_SIZE from > >

Re: [PATCH 0/9] Alpine Linux build fix and CI pipeline

2020-12-22 Thread Jiaxun Yang
On Wed, Dec 23, 2020, at 2:41 AM, Wainer dos Santos Moschetta wrote: > Hi, > > On 12/21/20 5:25 AM, Jiaxun Yang wrote: > > > > On Mon, Dec 21, 2020, at 9:06 AM, no-re...@patchew.org wrote: > >> Patchew URL: > >> https://patchew.org/QEMU/2020122

Re: [PATCH 0/9] Alpine Linux build fix and CI pipeline

2020-12-21 Thread Jiaxun Yang
On Mon, Dec 21, 2020, at 9:06 AM, no-re...@patchew.org wrote: > Patchew URL: > https://patchew.org/QEMU/20201221005318.11866-1-jiaxun.y...@flygoat.com/ > > > > Hi, > > This series seems to have some coding style problems. See output below for > more information: > > Type: series > Message-

[PATCH 6/9] hw/block/nand: Rename PAGE_SIZE to NAND_PAGE_SIZE

2020-12-20 Thread Jiaxun Yang
As per POSIX specification of limits.h [1], OS libc may define PAGE_SIZE in limits.h. To prevent collosion of definition, we rename PAGE_SIZE here. [1]: https://pubs.opengroup.org/onlinepubs/7908799/xsh/limits.h.html Signed-off-by: Jiaxun Yang --- hw/block/nand.c | 40

[PATCH 4/9] libvhost-user: Include poll.h instead of sys/poll.h

2020-12-20 Thread Jiaxun Yang
h:1:2: error: #warning redirecting incorrect #include to [-Werror=cpp] 1 | #warning redirecting incorrect #include to | ^~~ Signed-off-by: Jiaxun Yang --- subprojects/libvhost-user/libvhost-user.h | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/subprojects/lib

[PATCH 7/9] accel/kvm: avoid using predefined PAGE_SIZE

2020-12-20 Thread Jiaxun Yang
As per POSIX specification of limits.h [1], OS libc may define PAGE_SIZE in limits.h. To prevent collosion of definition, we discard PAGE_SIZE from defined by libc and take QEMU's variable. [1]: https://pubs.opengroup.org/onlinepubs/7908799/xsh/limits.h.html Signed-off-by: Jiaxun

[PATCH 9/9] gitlab-ci: Add alpine to pipeline

2020-12-20 Thread Jiaxun Yang
We only run build test and check-acceptance as their are too many failures in checks due to minor string mismatch. Signed-off-by: Jiaxun Yang --- .gitlab-ci.d/containers.yml | 5 + .gitlab-ci.yml | 23 +++ 2 files changed, 28 insertions(+) diff --git a

[PATCH 5/9] elf2dmp: Rename PAGE_SIZE to ELF2DMP_PAGE_SIZE

2020-12-20 Thread Jiaxun Yang
As per POSIX specification of limits.h [1], OS libc may define PAGE_SIZE in limits.h. To prevent collosion of definition, we rename PAGE_SIZE here. [1]: https://pubs.opengroup.org/onlinepubs/7908799/xsh/limits.h.html Signed-off-by: Jiaxun Yang --- contrib/elf2dmp/addrspace.c | 4

[PATCH 2/9] configure: Add sys/timex.h to probe clk_adjtime

2020-12-20 Thread Jiaxun Yang
It is not a part of standard time.h. Glibc put it under time.h however musl treat it as a sys timex extension. Signed-off-by: Jiaxun Yang --- configure | 1 + 1 file changed, 1 insertion(+) diff --git a/configure b/configure index c228f7c21e..990f37e123 100755 --- a/configure +++ b/configure

[PATCH 8/9] tests: Rename PAGE_SIZE definitions

2020-12-20 Thread Jiaxun Yang
Signed-off-by: Jiaxun Yang --- tests/migration/stress.c| 10 ++--- tests/qtest/libqos/malloc-pc.c | 4 +- tests/qtest/libqos/malloc-spapr.c | 4 +- tests/qtest/m25p80-test.c | 54 +++--- tests/tcg/multiarch/system/memory.c | 6 +-- tests/test-xbzrle.c

[PATCH 1/9] tests/docker: Add dockerfile for Alpine Linux

2020-12-20 Thread Jiaxun Yang
Alpine Linux[1] is a security-oriented, lightweight Linux distribution based on musl libc and busybox. It it popular among Docker guests and embedded applications. Adding it to test against different libc. [1]: https://alpinelinux.org/ Signed-off-by: Jiaxun Yang --- tests/docker/dockerfiles

[PATCH 0/9] Alpine Linux build fix and CI pipeline

2020-12-20 Thread Jiaxun Yang
/alpine_linux_v1 Jiaxun Yang (9): tests/docker: Add dockerfile for Alpine Linux configure: Add sys/timex.h to probe clk_adjtime configure/meson: Only check sys/signal.h on non-Linux libvhost-user: Include poll.h instead of sys/poll.h elf2dmp: Rename PAGE_SIZE to ELF2DMP_PAGE_SIZE hw/block

[PATCH 3/9] configure/meson: Only check sys/signal.h on non-Linux

2020-12-20 Thread Jiaxun Yang
incorrect #include to [-Werror=cpp] 1 | #warning redirecting incorrect #include to | ^~~ Signed-off-by: Jiaxun Yang --- meson.build | 5 - 1 file changed, 4 insertions(+), 1 deletion(-) diff --git a/meson.build b/meson.build index 372576f82c..1ef8722b3a 100644 --- a