Hi,

This series has been reviewed by Alberto, can someone review / merge this?

On 6/27/23 15:24, zhenwei pi wrote:
v1 -> v2:
- rename 'ThrottleTimerType' to 'ThrottleType'
- add assertion to throttle_schedule_timer

Something remained:
- 'bool is_write' is no longer appropriate, the related functions
   need to use 'ThrottleType throttle' instead. To avoid changes from
   other subsystems in this series, do this work in a followup series
   after there patches apply.


v1:
- introduce enum ThrottleTimerType instead of timers[0], timer[1]...
- support read-only and write-only for throttle
- adapt related test codes
- cryptodev uses a write-only throttle timer

Zhenwei Pi (5):
   throttle: introduce enum ThrottleType
   test-throttle: use enum ThrottleType
   throttle: support read-only and write-only
   test-throttle: test read only and write only
   cryptodev: use NULL throttle timer cb for read direction

  backends/cryptodev.c       |  3 +-
  include/qemu/throttle.h    | 11 ++++--
  tests/unit/test-throttle.c | 72 ++++++++++++++++++++++++++++++++++++--
  util/throttle.c            | 36 +++++++++++++------
  4 files changed, 103 insertions(+), 19 deletions(-)


--
zhenwei pi

Reply via email to