[Qemu-devel] [PATCH] pc-bios: Remove execute flag from BIOS files

2013-12-27 Thread Stefan Weil
BIOS files are not directly executable, so they don't need this flag. All other BIOS files don't use the execute flag. Signed-off-by: Stefan Weil --- pc-bios/kvmvapic.bin | Bin 9216 -> 9216 bytes pc-bios/multiboot.bin | Bin 1024 -> 1024 bytes pc-bios/sgabios.bin | Bin 4096 -> 4096 bytes

Re: [Qemu-devel] [PATCH 1/2] net: Fix lan9118 TX "CMD A" handling

2013-12-27 Thread Peter Crosthwaite
On Sat, Dec 21, 2013 at 4:26 AM, Roy Franz wrote: > The 9118 ethernet controller supports transmission of multi-buffer packets > with arbitrary byte alignment of the start and end bytes. All writes to > the packet fifo are 32 bits, so the controller discards bytes at the beginning > and end of ea

Re: [Qemu-devel] [PATCH 2/2] net: Fix lan9118 buffer length handling

2013-12-27 Thread Peter Crosthwaite
On Sat, Dec 21, 2013 at 4:26 AM, Roy Franz wrote: > The 9118 ethernet controller supports transmission of multi-buffer packets > with arbitrary byte alignment of the start and end bytes. All writes to > the packet fifo are 32 bits, so the controller discards bytes at the beginning > and end of ea

Re: [Qemu-devel] [PATCH] rbd: switch from pipe to QEMUBH completion notification

2013-12-27 Thread Josh Durgin
On 12/05/2013 07:38 AM, Stefan Hajnoczi wrote: rbd callbacks are called from non-QEMU threads. Up until now a pipe was used to signal completion back to the QEMU iothread. The pipe writer code handles EAGAIN using select(2). The select(2) API is not scalable since fd_set size is static. FD_SE

Re: [Qemu-devel] [V3 PATCH 02/14] target-ppc: Add ISA2.06 bpermd Instruction

2013-12-27 Thread Scott Wood
On Wed, 2013-12-18 at 14:48 -0600, Tom Musta wrote: > This patch adds the Bit Permute Doubleword (bpermd) instruction, > which was introduced in Power ISA 2.06 as part of the base 64-bit > architecture. Technically it's "Category: Embedded.Phased-in, Server" rather than "Category: Base". e5500 do

Re: [Qemu-devel] [Qemu-ppc] [V3 PATCH 03/14] target-ppc: Add ISA2.06 divdeu[o] Instructions

2013-12-27 Thread Scott Wood
On Wed, 2013-12-18 at 14:48 -0600, Tom Musta wrote: > This patch adds the Divide Doubleword Extended Unsigned > instructions. This instruction requires dividing a 128-bit > value by a 64 bit value. Since 128 bit integer division is > not supported in TCG, a helper is used, providing a > repeated

Re: [Qemu-devel] [PATCH 09/11] ACPI: move PRST OperationRegion into SSDT

2013-12-27 Thread Igor Mammedov
On Mon, 23 Dec 2013 17:52:03 +0100 Laszlo Ersek wrote: > On 12/23/13 17:24, Igor Mammedov wrote: > > On Mon, 23 Dec 2013 16:48:49 +0200 > > "Michael S. Tsirkin" wrote: > > > >> On Mon, Dec 23, 2013 at 02:06:27PM +0100, Igor Mammedov wrote: > >>> On Mon, 23 Dec 2013 13:26:37 +0200 > >>> "Michael

Re: [Qemu-devel] [V3 PATCH 02/14] target-ppc: Add ISA2.06 bpermd Instruction

2013-12-27 Thread Scott Wood
On Tue, 2013-12-24 at 07:17 -0800, Richard Henderson wrote: > On 12/18/2013 12:48 PM, Tom Musta wrote: > > +DEF_HELPER_3(bpermd, i64, env, i64, i64) > > Should be DEF_HELPER_FLAGS_2(bpermd, TCG_CALL_NO_RWG_SE, i64, i64, i64) > > > +uint64_t helper_bpermd(CPUPPCState *env, uint64_t rs, uint64_t rb

[Qemu-devel] [PULL 13/17] doc: Mention chardev:id in available devices for -serial

2013-12-27 Thread Michael Tokarev
From: Ingo van Lil It is possible to pre-define a character device with the -chardev option and reference its id as serial device. The man page does not mention this feature. Use case: Use stdio as serial, but do not terminate VM on Ctrl-C -chardev stdio,id=mystdio,signal=off -serial c

[Qemu-devel] [PULL 10/17] target-m68k: Replace qemu_assert by hw_error

2013-12-27 Thread Michael Tokarev
From: Stefan Weil hw_error is already used for target-arm and target-s390x. Using it for target-m68k fixes this compiler warning with Darwin because hw_error is declared with QEMU_NORETURN: target-m68k/translate.c:671:13: warning: variable 'offset' is used uninitialized whenever switch default

[Qemu-devel] [PULL 17/17] acpi unit-test: Remove temporary disk after test

2013-12-27 Thread Michael Tokarev
From: Fam Zheng Signed-off-by: Fam Zheng Signed-off-by: Michael Tokarev --- tests/acpi-test.c |5 - 1 file changed, 4 insertions(+), 1 deletion(-) diff --git a/tests/acpi-test.c b/tests/acpi-test.c index ca83b1d..df1af83 100644 --- a/tests/acpi-test.c +++ b/tests/acpi-test.c @@ -382,6

[Qemu-devel] [PULL 16/17] mainstone: Fix duplicate array values for key 'space'

2013-12-27 Thread Michael Tokarev
From: Stefan Weil cgcc reported a duplicate initialisation. Mainstone includes a matrix keyboard where two different positions map to 'space'. QEMU uses the reversed mapping and does not map 'space' to two different matrix positions. Some other keys are either missing or might be mapped wrongly

[Qemu-devel] [PULL 04/17] ui/cocoa: Use macro ARRAY_SIZE where possible

2013-12-27 Thread Michael Tokarev
From: Stefan Weil This improves readability and simplifies the code. Cc: Andreas Färber Cc: Anthony Liguori Signed-off-by: Stefan Weil Reviewed-by: Peter Maydell Signed-off-by: Michael Tokarev --- ui/cocoa.m |5 ++--- 1 file changed, 2 insertions(+), 3 deletions(-) diff --git a/ui/coc

[Qemu-devel] [PULL 14/17] pxa27x: Reduce size of keyboard matrix mapping

2013-12-27 Thread Michael Tokarev
From: Stefan Weil The row and column values use only a very limited range (-1 ... 7), so a byte value is sufficient. Signed-off-by: Stefan Weil Reviewed-by: Peter Maydell Signed-off-by: Michael Tokarev --- include/hw/arm/pxa.h |4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) dif

[Qemu-devel] [PULL 09/17] fix -boot strict regressed in commit 6ef4716

2013-12-27 Thread Michael Tokarev
From: Amos Kong Commit 6ef4716 cleaned up parsing of -boot option argument, but accidentally dropped parameter strict. It should have been updated exactly like parameter menu. Do that. Signed-off-by: Amos Kong Reviewed-by: Markus Armbruster Signed-off-by: Michael Tokarev --- vl.c |3 ++-

[Qemu-devel] [PULL 12/17] configure: Python tests must be done before help message

2013-12-27 Thread Michael Tokarev
From: Stefan Weil The help message uses $python and displays its value, so that macro should be tested and set early. With this modification, configure --help displays the correct value (usually python -B) and no longer creates several *.pyc files. Signed-off-by: Stefan Weil Signed-off-by: Mic

[Qemu-devel] [PULL 06/17] linux-user: Use macro TARGET_NSIG_WORDS where possible

2013-12-27 Thread Michael Tokarev
From: Stefan Weil This improves readability and simplifies the code. Cc: Riku Voipio Signed-off-by: Stefan Weil Reviewed-by: Peter Maydell Signed-off-by: Michael Tokarev --- linux-user/signal.c |8 1 file changed, 4 insertions(+), 4 deletions(-) diff --git a/linux-user/signal.

[Qemu-devel] [PULL 11/17] configure: Rewrite code for help message

2013-12-27 Thread Michael Tokarev
From: Stefan Weil In the new form most lines of the code now look like the final output: there is no leading echo command and the lines are shorter. The resulting output is nearly identical: the only difference is a blank character which was deliberately removed: @@ -8,7 +8,7 @@ --interp-pre

[Qemu-devel] [PULL 08/17] vl: make boot_strict variable static (not used outside vl.c)

2013-12-27 Thread Michael Tokarev
Signed-off-by: Michael Tokarev Reviewed-by: Amos Kong --- vl.c |2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/vl.c b/vl.c index 7511e70..ed8debb 100644 --- a/vl.c +++ b/vl.c @@ -230,7 +230,7 @@ int ctrl_grab = 0; unsigned int nb_prom_envs = 0; const char *prom_envs[MAX_

[Qemu-devel] [PULL 15/17] pxa27x: Add 'const' attribute to keyboard maps

2013-12-27 Thread Michael Tokarev
From: Stefan Weil The mapping is a hardware feature, so it is relatively constant. Signed-off-by: Stefan Weil Reviewed-by: Peter Maydell Signed-off-by: Michael Tokarev --- hw/arm/mainstone.c |2 +- hw/arm/z2.c |2 +- hw/input/pxa2xx_keypad.c |6 +++--- include/

[Qemu-devel] [PULL 07/17] x86: only allow real mode to access 32bit without LMA

2013-12-27 Thread Michael Tokarev
From: Alexander Graf When we're running in non-64bit mode with qemu-system-x86_64 we can still end up with virtual addresses that are above the 32bit boundary if a segment offset is set up. GNU Hurd does exactly that. It sets the segment offset to 0x8000 and puts its EIP value to 0x8xxx

[Qemu-devel] [PULL 00/17] trivial patches for 2013-12-27

2013-12-27 Thread Michael Tokarev
Here are collected trivial patches for more than 2 weeks. There's nothing exciting here, most stuff is really trivial, including a few simple bugfixes. Except of one patch by Stefan Weil, which basically re-writes help text code in ./configure to be much simpler and shorter and easier to read and

[Qemu-devel] [PULL 02/17] openrisc: Fix spelling in comment (transaltion -> translation)

2013-12-27 Thread Michael Tokarev
From: Stefan Weil I also removed two hyphens in the same comment. Signed-off-by: Stefan Weil Reviewed-by: Jia Liu Signed-off-by: Michael Tokarev --- target-openrisc/translate.c |2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/target-openrisc/translate.c b/target-openris

[Qemu-devel] [PULL 05/17] exynos4210: Use macro ARRAY_SIZE where possible

2013-12-27 Thread Michael Tokarev
From: Stefan Weil This improves readability and simplifies the code. Cc: Dmitry Solodkiy Cc: Evgeny Voevodin Cc: Igor Mitsyanko Cc: Maksim Kozlov Signed-off-by: Stefan Weil Reviewed-by: Peter Maydell Signed-off-by: Michael Tokarev --- hw/char/exynos4210_uart.c |6 ++ hw/misc/exyn

[Qemu-devel] [PULL 01/17] hw/arm/highbank: Simplify code (memory region in device state)

2013-12-27 Thread Michael Tokarev
From: Stefan Weil The memory region can be included by value instead of by reference in the device state. Signed-off-by: Stefan Weil Reviewed-by: Peter Maydell Reviewed-by: Peter Crosthwaite Signed-off-by: Michael Tokarev --- hw/arm/highbank.c |7 +++ 1 file changed, 3 insertions(+)

[Qemu-devel] [PULL 03/17] misc: Use macro ARRAY_SIZE where possible

2013-12-27 Thread Michael Tokarev
From: Stefan Weil This improves readability and simplifies the code. Cc: Anthony Liguori Cc: Gerd Hoffmann Cc: Stefan Hajnoczi Signed-off-by: Stefan Weil Reviewed-by: Peter Maydell Signed-off-by: Michael Tokarev --- hw/audio/intel-hda.c |4 ++-- net/net.c|2 +- qemu-ch

Re: [Qemu-devel] [Qemu-trivial] [PATCH] acpi unit-test: Remove temporary disk after test

2013-12-27 Thread Michael Tokarev
26.12.2013 08:53, Fam Zheng write: > --- > tests/acpi-test.c | 5 - Thanks, applied to the trivial-patches queue. /mjt

Re: [Qemu-devel] [PATCH v2 41/60] target-i386: Create gen_lea_v_seg

2013-12-27 Thread Peter Maydell
On 27 December 2013 14:49, Richard Henderson wrote: > On 12/26/2013 01:27 PM, Peter Maydell wrote: >>> The only time s->addseg will be false in 16-bit mode is during translation >>> of >>> LEA. I do need the addseg check there for LEA cleanup, but this change >>> should >>> not affect gen_strin

Re: [Qemu-devel] [PATCH v2 56/60] target-i386: Tidy gen_add_A0_im

2013-12-27 Thread Peter Maydell
On 27 December 2013 15:17, Richard Henderson wrote: > On 12/26/2013 02:34 PM, Peter Maydell wrote: >> Looking a bit more closely, is it even possible for code64 to be >> 1 if we're in real or vm86 mode? If not, then the behaviour here >> is unchanged (ie still always zero extends). > > No, real or

Re: [Qemu-devel] [PATCH v2 56/60] target-i386: Tidy gen_add_A0_im

2013-12-27 Thread Richard Henderson
On 12/26/2013 02:34 PM, Peter Maydell wrote: > Looking a bit more closely, is it even possible for code64 to be > 1 if we're in real or vm86 mode? If not, then the behaviour here > is unchanged (ie still always zero extends). No, real or vm86 mode implies 16-bit. r~

[Qemu-devel] fail to live migration is related to virtio-console

2013-12-27 Thread yue-kvm
hi,all this error occured when live migration windows os, log of that vm is: features 0x1e unsupported allowed features 0x7102 qemu warning error while loading state for instance 0x0 of device ':00:04.4/virtio-console' do you have some idea about that? thanks

Re: [Qemu-devel] [PATCH v2 41/60] target-i386: Create gen_lea_v_seg

2013-12-27 Thread Richard Henderson
On 12/26/2013 01:27 PM, Peter Maydell wrote: >> The only time s->addseg will be false in 16-bit mode is during translation of >> LEA. I do need the addseg check there for LEA cleanup, but this change >> should >> not affect gen_string_movl. > > Oh, is that the bit that does: > > val = s

Re: [Qemu-devel] [PATCH resend 0/7] acpi unit-test: new features

2013-12-27 Thread Alex Bennée
marce...@redhat.com writes: > This resend includes the following: > > Compare resulting aml vs expected aml: > - runs only if iasl is installed on the host machine. > > configure| 4 + > scripts/create_config| 4 + Did I miss som