Re: [PATCH v2 2/2] gdbstub: do not split gdb_monitor_write payload

2019-12-12 Thread Damien Hedde
On 12/11/19 7:59 PM, Alex Bennée wrote: > > Damien Hedde writes: > >> Since we can now send packets of arbitrary length: >> simplify gdb_monitor_write() and send the whole payload >> in one packet. > > Do we know gdb won't barf on us. Does the negotiated max packet size > only apply to data

[PATCH] qcow2: Use offset_into_cluster()

2019-12-12 Thread Alberto Garcia
There's a couple of places left in the qcow2 code that still do the calculation manually, so let's replace them. Signed-off-by: Alberto Garcia --- block/qcow2.c | 8 +++- 1 file changed, 3 insertions(+), 5 deletions(-) diff --git a/block/qcow2.c b/block/qcow2.c index 7c18721741..3866b47946

Re: [PATCH 28/28] cputlb: Expand cpu_ldst_template.h in cputlb.c

2019-12-12 Thread Aleksandar Markovic
On Thu, Dec 12, 2019 at 5:22 AM Richard Henderson wrote: > > Reduce the amount of preprocessor obfuscation by expanding > the text of each of the functions generated. The result is > only slightly smaller than the original. > I am not sure what you meant by "The result is only slightly smaller

Re: [PATCH 23/28] target/m68k: Use cpu_*_mmuidx_ra instead of MMU_MODE{0, 1}_SUFFIX

2019-12-12 Thread Laurent Vivier
Le 12/12/2019 à 05:00, Richard Henderson a écrit : > The generated *_user functions are unused. The *_kernel functions > have a couple of users in op_helper.c; use *_mmuidx_ra instead, > with MMU_KERNEL_IDX. > > Cc: Laurent Vivier > Signed-off-by: Richard Henderson > --- > target/m68k/cpu.h

Re: [virtio-dev] Re: guest / host buffer sharing ...

2019-12-12 Thread Gerd Hoffmann
Hi, > > First the addressing is non-trivial, especially with the "transport > > specific device address" in the tuple. > > There is complexity here, but I think it would also be present in the > buffer sharing device case. With a buffer sharing device, the same > identifying information would

Re: [PATCH v2 2/2] gdbstub: do not split gdb_monitor_write payload

2019-12-12 Thread Damien Hedde
On 12/11/19 7:58 PM, Philippe Mathieu-Daudé wrote: > On 12/11/19 5:05 PM, Damien Hedde wrote: >> Since we can now send packets of arbitrary length: >> simplify gdb_monitor_write() and send the whole payload >> in one packet. > > While we can send arbitrary length on the wire, we advertise >

Re: [PATCH 06/28] cputlb: Rename helper_ret_ld*_cmmu to cpu_ld*_code

2019-12-12 Thread Aleksandar Markovic
On Thu, Dec 12, 2019 at 5:07 AM Richard Henderson wrote: > > There are no uses of the *_cmmu names other than the bare wrapping > within the *_code inlines. Therefore rename the functions so we > can drop the inlines. > > Use abi_ptr instead of target_ulong in preparation for user-only; > the

Re: [PATCH 24/28] target/mips: Use cpu_*_mmuidx_ra instead of MMU_MODE*_SUFFIX

2019-12-12 Thread Aleksandar Markovic
On Thu, Dec 12, 2019 at 5:21 AM Richard Henderson wrote: > > The separate suffixed functions were used to construct > some do_##insn function switched on mmu_idx. The interface > is exactly identical to the *_mmuidx_ra functions. Replace > them directly and remove the constructions. > > Cc:

Re: [PATCH v38 11/22] target/avr: Add instruction disassembly function

2019-12-12 Thread Aleksandar Markovic
On Tue, Dec 10, 2019 at 8:18 AM Michael Rolnik wrote: > > You are right. See at the bottom of the file. There is a comment about it > Sorry, what file? I also see that you disassemble instructions regardless of what AVR CPU the current executable is built for, don't you? OK, not a very big

Re: [PATCH v2 ppc-for-5.0 2/2] ppc/spapr: Support reboot of secure pseries guest

2019-12-12 Thread Bharata B Rao
On Thu, Dec 12, 2019 at 08:34:57AM +0100, Cédric Le Goater wrote: > Hello Bharata, > > > On 12/12/2019 06:50, Bharata B Rao wrote: > > A pseries guest can be run as a secure guest on Ultravisor-enabled > > POWER platforms. When such a secure guest is reset, we need to > > release/reset a few

Re: [PATCH 23/28] target/m68k: Use cpu_*_mmuidx_ra instead of MMU_MODE{0,1}_SUFFIX

2019-12-12 Thread Laurent Vivier
Le 12/12/2019 à 05:00, Richard Henderson a écrit : > The generated *_user functions are unused. The *_kernel functions > have a couple of users in op_helper.c; use *_mmuidx_ra instead, > with MMU_KERNEL_IDX. > > Cc: Laurent Vivier > Signed-off-by: Richard Henderson > --- > target/m68k/cpu.h

Re: [PATCH v3 2/3] spapr: Add NVDIMM device support

2019-12-12 Thread Shivaprasad G Bhat
On 12/11/2019 01:35 PM, Igor Mammedov wrote: On Wed, 11 Dec 2019 09:44:11 +0530 Shivaprasad G Bhat wrote: On 12/06/2019 07:22 AM, David Gibson wrote: On Wed, Nov 27, 2019 at 09:50:54AM +0530, Bharata B Rao wrote: On Fri, Nov 22, 2019 at 10:42 AM David Gibson wrote: Ok. A number of

[PATCH v3 0/1] Fix bochs memory leak

2019-12-12 Thread Cameron Esfahani via
Fix a small memory leak in the Bochs display driver. Each frame would leak about 304 bytes. v2: Add missing signed-off-by line. v3: Add reviewed-by and fixes lines. Cameron Esfahani (1): display/bochs-display: fix memory leak hw/display/bochs-display.c | 2 ++ 1 file changed, 2

[PATCH v3 1/1] display/bochs-display: fix memory leak

2019-12-12 Thread Cameron Esfahani via
Fix memory leak in bochs_display_update(). Leaks 304 bytes per frame. Fixes: 33ebad54056 Signed-off-by: Cameron Esfahani Reviewed-by: Philippe Mathieu-Daudé --- hw/display/bochs-display.c | 2 ++ 1 file changed, 2 insertions(+) diff --git a/hw/display/bochs-display.c

Re: [PATCH v3 12/20] target/arm: generate xml description of our SVE registers

2019-12-12 Thread Alex Bennée
Richard Henderson writes: > On 12/11/19 9:05 AM, Alex Bennée wrote: >> +static struct TypeSize vec_lanes[] = { > > const. > >> +case 51: >> +return gdb_get_reg64(buf, (cpu->env.vfp.zcr_el[1] & 0xf) + 1); > > You need to use sve_zcr_len_for_el to get the effective vq. > Also, I

Re: [PATCH] object: Improve documentation of interfaces

2019-12-12 Thread Paolo Bonzini
On 11/12/19 14:32, Greg Kurz wrote: > QOM interfaces allow a limited form of multiple inheritance, at the > condition of being stateless. That is, they cannot be instantiated > and a pointer to an interface shouldn't be dereferenceable in any way. > This is achieved by making the QOM instance type

Re: [PATCH 18/28] target/i386: Remove MMU_MODE{0,1,2}_SUFFIX

2019-12-12 Thread Paolo Bonzini
On 12/12/19 05:00, Richard Henderson wrote: > The functions generated by these macros are unused. > > Cc: Paolo Bonzini > Cc: Eduardo Habkost > Signed-off-by: Richard Henderson > --- > target/i386/cpu.h | 3 --- > 1 file changed, 3 deletions(-) > > diff --git a/target/i386/cpu.h

<    1   2   3   4   5